Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-27 Thread Segher Boessenkool
+ soc { + #address-cells = 1; + #size-cells = 1; + #interrupt-cells = 1; This isn't an interrupt controller, don't put #interrupt-cells here. Isn't this needed to define what is to be expected in the interrupts properties of the child nodes?

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-27 Thread Segher Boessenkool
Similarly, it is better to use a compatible value of something like: compatible = nintendo,flipper-immr; (instead of nintendo,flipper) because your describing just the internal bus, not the entire chip. I would just call the nodes flipper and hollywood. Either that, or not have these omnibus

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-26 Thread Segher Boessenkool
If you have only one interrupt controller, like here, you don't need to refer to it _at all_ :-) I think Linux requires that you do though. It might be a mistake on our part but heh ... Linux doesn't require it; (old) Macs are like this, for example, and that works fine. Oh and all Maple

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-26 Thread Segher Boessenkool
+ xfb-start = 0x01698000; /* end-of-ram - xfb-size */ + xfb-size = 0x168000; XFB address isn't fixed on the hardware, and the kernel might want to move it, and you can easily probe for it anyway. Remove these last two properties please. Ok but you

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-26 Thread Segher Boessenkool
+ soc { It would be better to rename this as IMMR or the bus type. This node doesn't actually describe the entire chip, but describes the internal memory mapped registers. I would really just call it flipper :-) Yeah, I came to the same conclusion. Since you're only doing 1:1

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-26 Thread Benjamin Herrenschmidt
On Thu, 2009-11-26 at 23:15 +0100, Segher Boessenkool wrote: If you have only one interrupt controller, like here, you don't need to refer to it _at all_ :-) I think Linux requires that you do though. It might be a mistake on our part but heh ... Linux doesn't require it; (old)

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-26 Thread Segher Boessenkool
If you have only one interrupt controller, like here, you don't need to refer to it _at all_ :-) I think Linux requires that you do though. It might be a mistake on our part but heh ... Linux doesn't require it; (old) Macs are like this, for example, and that works fine. Oh and all Maple

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Segher Boessenkool
+ memory { + device_type = memory; + /* 24M minus framebuffer memory area (640*576*2*2) */ + reg = 0x 0x01698000; Put the whole 24MB here, probe the framebuffer address and size in the platform code? + soc { + #address-cells =

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Albert Herranz
Segher Boessenkool wrote: +memory { +device_type = memory; +/* 24M minus framebuffer memory area (640*576*2*2) */ +reg = 0x 0x01698000; Put the whole 24MB here, probe the framebuffer address and size in the platform code? Yes, I'll do

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Benjamin Herrenschmidt
On Sun, 2009-11-22 at 16:02 -0700, Grant Likely wrote: + /* devices contained int the flipper chipset */ + soc { It would be better to rename this as IMMR or the bus type. This node doesn't actually describe the entire chip, but describes the internal memory mapped

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Benjamin Herrenschmidt
On Mon, 2009-11-23 at 13:19 -0700, Grant Likely wrote: so the node really is describing the internal bus, not the entire SoC. On some chips it is documented as the internally memory mapped registers, or IMMR. So, it is better to name this node in a way that reflects what it is (an internal

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Benjamin Herrenschmidt
On Tue, 2009-11-24 at 23:36 +0100, Segher Boessenkool wrote: If you have only one interrupt controller, like here, you don't need to refer to it _at all_ :-) I think Linux requires that you do though. It might be a mistake on our part but heh ... Cheers, Ben.

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Benjamin Herrenschmidt
On Wed, 2009-11-25 at 19:00 +0100, Segher Boessenkool wrote: + memory { + device_type = memory; + /* 24M minus framebuffer memory area (640*576*2*2) */ + reg = 0x 0x01698000; Put the whole 24MB here, probe the framebuffer address and size in the

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Grant Likely
On Wed, Nov 25, 2009 at 9:21 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Sun, 2009-11-22 at 16:02 -0700, Grant Likely wrote: + +               vi...@0c002000 { +                       compatible = nintendo,flipper-video; +                       reg = 0x0c002000 0x100;

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Benjamin Herrenschmidt
On Wed, 2009-11-25 at 21:38 -0700, Grant Likely wrote: But this isn't real OF. Real OF can generate its own valid tree. This is a flat tree, and it is valid according to all users of the flat tree. Besides, the last time we talked about this, you told me that moving it to the root was a

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-25 Thread Grant Likely
On Wed, Nov 25, 2009 at 10:29 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Wed, 2009-11-25 at 21:38 -0700, Grant Likely wrote: But this isn't real OF.  Real OF can generate its own valid tree. This is a flat tree, and it is valid according to all users of the flat tree.  

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-24 Thread Segher Boessenkool
+ model = NintendoGameCube; + compatible = nintendo,gamecube; To date, we've been using the same form for both the model and compatible properties. Specifically the vendor,model form to maintain the namespace. That, however, is a) useless; and b) not totally correct. The model

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-24 Thread Segher Boessenkool
The soc node here tries to represent the big multi-function chip that integrates most of the devices of the video game consoles (Flipper on the Nintendo GameCube and Hollywood on the Wii). Right. Much like many other SoCs. It isn't a SoC, it's really just a memory bridge / I/O bridge like

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-23 Thread Albert Herranz
Grant Likely wrote: On Sun, Nov 22, 2009 at 3:01 PM, Albert Herranz albert_herr...@yahoo.es wrote: Add a device tree source file for the Nintendo GameCube video game console. Signed-off-by: Albert Herranz albert_herr...@yahoo.es Mostly looks good. A few comments below. Biggest comment

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-23 Thread Grant Likely
On Mon, Nov 23, 2009 at 12:44 PM, Albert Herranz albert_herr...@yahoo.es wrote: Grant Likely wrote: On Sun, Nov 22, 2009 at 3:01 PM, Albert Herranz albert_herr...@yahoo.es wrote: +       /* devices contained int the flipper chipset */ +       soc { It would be better to rename this as IMMR

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-23 Thread Albert Herranz
Grant Likely wrote: On Mon, Nov 23, 2009 at 12:44 PM, Albert Herranz Can you please elaborate more on this or point me to documentation? The soc node here tries to represent the big multi-function chip that integrates most of the devices of the video game consoles (Flipper on the Nintendo

[RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-22 Thread Albert Herranz
Add a device tree source file for the Nintendo GameCube video game console. Signed-off-by: Albert Herranz albert_herr...@yahoo.es --- arch/powerpc/boot/dts/gamecube.dts | 135 1 files changed, 135 insertions(+), 0 deletions(-) create mode 100644

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-22 Thread Grant Likely
On Sun, Nov 22, 2009 at 3:01 PM, Albert Herranz albert_herr...@yahoo.es wrote: Add a device tree source file for the Nintendo GameCube video game console. Signed-off-by: Albert Herranz albert_herr...@yahoo.es Mostly looks good. A few comments below. Biggest comment is you need to add a brief