Re: [PATCH 1/4] powerpc: Dynamic DMA zone limits

2014-10-13 Thread Anton Blanchard
Hi Scott, Platform code can call limit_zone_pfn() to set appropriate limits for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will select a suitable zone based on a device's mask and the pfn limits that platform code has configured. This patch breaks my POWER8 box: ipr

Re: [PATCH 1/4] powerpc: Dynamic DMA zone limits

2014-10-13 Thread Benjamin Herrenschmidt
On Mon, 2014-10-13 at 18:14 +1100, Anton Blanchard wrote: Hi Scott, Platform code can call limit_zone_pfn() to set appropriate limits for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will select a suitable zone based on a device's mask and the pfn limits that platform code

[PATCH 1/3] powerpc: Reimplement __get_SP() as a function not a define

2014-10-13 Thread Anton Blanchard
Li Zhong points out an issue with our current __get_SP() implementation. If ftrace function tracing is enabled (ie -pg profiling using _mcount) we spill a stack frame on 64bit all the time. If a function calls __get_SP() and later calls a function that is tail call optimised, we will pop the

[PATCH 2/3] powerpc: Rename __get_SP() to current_stack_pointer()

2014-10-13 Thread Anton Blanchard
Michael points out that __get_SP() is a pretty horrible function name. Let's give it a better name. Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/include/asm/perf_event.h | 2 +- arch/powerpc/include/asm/reg.h| 2 +- arch/powerpc/kernel/irq.c | 2 +-

[PATCH 3/3] powerpc/pseries: Use dump_stack instead of show_stack

2014-10-13 Thread Anton Blanchard
We can use the simpler dump_stack() instead of show_stack(current, __get_SP()) Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/platforms/pseries/iommu.c | 11 +-- 1 file changed, 5 insertions(+), 6 deletions(-) diff --git a/arch/powerpc/platforms/pseries/iommu.c

Re: [PATCH 1/4] powerpc: Dynamic DMA zone limits

2014-10-13 Thread Michael Ellerman
On Mon, 2014-10-13 at 18:14 +1100, Anton Blanchard wrote: Hi Scott, Platform code can call limit_zone_pfn() to set appropriate limits for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will select a suitable zone based on a device's mask and the pfn limits that platform code

[PATCH 1/2] ipr: Convert to generic DMA API

2014-10-13 Thread Anton Blanchard
Even though the ipr driver is only used on PCI, convert it to use the generic DMA API. Signed-off-by: Anton Blanchard an...@samba.org --- drivers/scsi/ipr.c | 101 +++-- drivers/scsi/ipr.h | 2 +- 2 files changed, 53 insertions(+), 50

[PATCH 2/2] ipr: set coherent DMA mask

2014-10-13 Thread Anton Blanchard
Use dma_set_mask_and_coherent() to set both the DMA and coherent DMA mask. Signed-off-by: Anton Blanchard an...@samba.org --- drivers/scsi/ipr.c | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/drivers/scsi/ipr.c b/drivers/scsi/ipr.c index 3aa28bd..15f4575 100644

[PATCH] powerpc: sync pseries_le_defconfig with pseries_defconfig

2014-10-13 Thread Anton Blanchard
Now KVM is working on LE, enable it. Also enable transarent hugepage which has already been enabled on BE. Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/configs/pseries_le_defconfig | 7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git

[PATCH] powerpc: Add printk levels to setup_system output

2014-10-13 Thread Anton Blanchard
Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/kernel/setup_64.c | 32 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/arch/powerpc/kernel/setup_64.c b/arch/powerpc/kernel/setup_64.c index cd07d79..4f3cfe1 100644 ---

[PATCH] powerpc: Use probe_kernel_address in show_instructions

2014-10-13 Thread Anton Blanchard
We really don't want to take a pagefault in show_instructions, so use probe_kernel_address instead of __get_user. Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/kernel/process.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git

Re: powerpc32: add support for csum_add()

2014-10-13 Thread leroy christophe
Le 12/10/2014 18:22, Jochen Rollwagen a écrit : This patch https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html only compiles after putting an #ifndef ARCH_HAS_CSUM_ADD around the definition in include/net/checksum.h This is missing from the patch This is already

[PATCH v2 04/20] powerpc/52xx/efika: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/52xx/efika.c | 3 ++- 1 file changed, 2 insertions(+), 1

[PATCH v2 02/20] powerpc/xmon: Support either ppc_md.power_off or pm_power_off

2014-10-13 Thread Alexander Graf
Xmon can manually turn off the machine. We now have 2 code paths for this: 1) ppc_md.power_off 2) pm_power_off This patch allows xmon to support both and makes sure it graciously allows a path to not be implemented. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/xmon/xmon.c |

[PATCH v2 00/20] powerpc: Convert power off logic to pm_power_off

2014-10-13 Thread Alexander Graf
The generic Linux framework to power off the machine is a function pointer called pm_power_off. The trick about this pointer is that device drivers can potentially implement it rather than board files. Today on PowerPC we set pm_power_off to invoke our generic full machine power off logic which

[PATCH v2 08/20] powerpc/celleb: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/cell/celleb_setup.c | 4 ++-- 1 file changed, 2

[PATCH v2 03/20] powerpc/47x: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - fix typo --- arch/powerpc/platforms/44x/ppc476.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH v2 07/20] powerpc/85xx/sgy_cts1000: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/platforms/85xx/sgy_cts1000.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2 13/20] powerpc/6xx/linkstation: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/embedded6xx/linkstation.c | 4 +++- 1 file changed, 3

[PATCH v2 05/20] powerpc/mpc8349emitx: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/platforms/83xx/mcu_mpc8349emitx.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[PATCH v2 01/20] powerpc: Support override of pm_power_off

2014-10-13 Thread Alexander Graf
The pm_power_off callback is what drivers are supposed to modify when they implement power off support for the system. Support a modified callback on powerpc. That way power off support code can now either override ppc_md.power_off or pm_power_off. Signed-off-by: Alexander Graf ag...@suse.de ---

[PATCH v2 06/20] powerpc/corenet: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/platforms/85xx/corenet_generic.c | 2 +- arch/powerpc/sysdev/fsl_soc.c | 2 +- 2 files changed, 2

[PATCH v2 09/20] powerpc/cell/qpace: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/cell/qpace_setup.c | 2 +- 1 file changed, 1

[PATCH v2 20/20] powerpc: Remove ppc_md.power_off

2014-10-13 Thread Alexander Graf
Now that we have all implementations of ppc_md.power_off converted to pm_power_off we can remove the ppc_md variant. While at it, also set the default for pm_power_off to NULL so that non machine drivers can implement overrides. Signed-off-by: Alexander Graf ag...@suse.de ---

[PATCH v2 12/20] powerpc/6xx/gamecube: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/platforms/embedded6xx/gamecube.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

[PATCH v2 14/20] powerpc/6xx/wii: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/embedded6xx/wii.c | 3 ++- 1 file changed, 2

[PATCH v2 16/20] powerpc/powermac: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/powermac/setup.c | 147

[PATCH v2 11/20] powerpc/chrp: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/chrp/setup.c | 3 ++- 1 file changed, 2 insertions(+), 1

[PATCH v2 17/20] powerpc/powernv: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- arch/powerpc/platforms/powernv/setup.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2 15/20] powerpc/maple: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/maple/setup.c | 4 ++-- 1 file changed, 2 insertions(+),

[PATCH v2 10/20] powerpc/cell: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/cell/setup.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH v2 19/20] powerpc/pseries: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/pseries/setup.c | 59 +-

[PATCH v2 18/20] powerpc/ps3: Use pm_power_off rather than ppc_md.power_off

2014-10-13 Thread Alexander Graf
The generic power off callback is pm_power_off. Use that one rather than the powerpc specific ppc_md.power_off. Signed-off-by: Alexander Graf ag...@suse.de --- v1 - v2: - write pm_power_off in probe function --- arch/powerpc/platforms/ps3/setup.c | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH v2 00/20] powerpc: Convert power off logic to pm_power_off

2014-10-13 Thread Guenter Roeck
On 10/13/2014 07:01 AM, Alexander Graf wrote: The generic Linux framework to power off the machine is a function pointer called pm_power_off. The trick about this pointer is that device drivers can potentially implement it rather than board files. Today on PowerPC we set pm_power_off to invoke

Re: [PATCH v2 00/20] powerpc: Convert power off logic to pm_power_off

2014-10-13 Thread Guenter Roeck
On 10/13/2014 07:01 AM, Alexander Graf wrote: The generic Linux framework to power off the machine is a function pointer called pm_power_off. The trick about this pointer is that device drivers can potentially implement it rather than board files. Today on PowerPC we set pm_power_off to invoke

Re: [PATCH 1/3] qe-uart: modify qe-uart to adapt both powerpc and arm

2014-10-13 Thread Timur Tabi
On Fri, Oct 10, 2014 at 1:05 PM, Scott Wood scottw...@freescale.com wrote: There are many changes in here that ought to be separate patches with separate justification. Also, some of the QE changes seem to be reasonable cleanup, but not related to making the code work on ARM. I agree with

Re: [PATCH v3 00/21] powerpc/8xx: Optimise MMU TLB handling and add support of 16k pages

2014-10-13 Thread leroy christophe
Le 17/09/2014 22:34, Scott Wood a écrit : On Wed, 2014-09-17 at 22:33 +0200, christophe leroy wrote: Le 17/09/2014 18:40, Scott Wood a écrit : On Wed, 2014-09-17 at 18:36 +0200, Christophe Leroy wrote: This patchset: 1) provides several MMU TLB handling optimisation on MPC8xx. 2) adds

[PATCHv9 2/5] ppc/cell: trivial: replace get_unused_fd() by get_unused_fd_flags(0)

2014-10-13 Thread Yann Droneaud
This patch replaces calls to get_unused_fd() with equivalent call to get_unused_fd_flags(0) to preserve current behavor for existing code. In a further patch, get_unused_fd() will be removed so that new code start using get_unused_fd_flags(), with the hope O_CLOEXEC could be used, either by

[PATCHv9 0/5] Getting rid of get_unused_fd()

2014-10-13 Thread Yann Droneaud
Hi, Please find the 9th revision of my patchset to remove get_unused_fd() macro. In linux-next, tag next-20141013, they're currently: - 33 calls to fd_install() with one call part of anon_inode_getfd() - 27 calls to get_unused_fd_flags() with one call part of anon_inode_getfd

Re: [PATCH v3 4/7] sound/radeon: Add quirk for broken 64-bit MSI

2014-10-13 Thread Benjamin Herrenschmidt
On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote: Further discussion with the hw teams have revealed that this is still an issue on newer asics so I think your original patch is correct after all. Just disable 64 bit MSIs on all AMD audio PCI ids. Allright, I won't resend

Re: [PATCH v3 4/7] sound/radeon: Add quirk for broken 64-bit MSI

2014-10-13 Thread Alex Deucher
On Mon, Oct 13, 2014 at 4:11 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote: Further discussion with the hw teams have revealed that this is still an issue on newer asics so I think your original patch is correct

Re: [PATCH v3 4/7] sound/radeon: Add quirk for broken 64-bit MSI

2014-10-13 Thread Bjorn Helgaas
On Mon, Oct 13, 2014 at 2:11 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote: Further discussion with the hw teams have revealed that this is still an issue on newer asics so I think your original patch is correct

Re: powerpc32: add support for csum_add()

2014-10-13 Thread Jochen Rollwagen
Am 13.10.2014 um 13:17 schrieb leroy christophe: Le 12/10/2014 18:22, Jochen Rollwagen a écrit : This patch https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html only compiles after putting an #ifndef ARCH_HAS_CSUM_ADD around the definition in include/net/checksum.h

[PATCH] powerpc/pci: Quieten unset I/O resource warning

2014-10-13 Thread Anton Blanchard
Newer POWER designs do not implement PCI I/O space, so we expect to see a number of these. Reduce the severity of the warning so it doesn't mask other real issues. Signed-off-by: Anton Blanchard an...@samba.org --- Index: b/arch/powerpc/kernel/pci-common.c

[PATCH] powerpc: Remove ppc_md.remove_memory

2014-10-13 Thread Anton Blanchard
We have an extra level of indirection on memory hot remove which is not matched on memory hot add. Memory hotplug is book3s only, so there is no need for it. This also enables means remove_memory() (ie memory hot unplug) works on powernv. Signed-off-by: Anton Blanchard an...@samba.org ---

[PATCH] powerpc: Remove ppc64_boot_msg

2014-10-13 Thread Anton Blanchard
ppc64_boot_msg is meant to be a boot debug aid, but is only used in one spot. Get rid of it, and save ourseleves a couple of lines in the kernel log buffer. Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/include/asm/machdep.h | 10 -- arch/powerpc/kernel/setup_64.c |

Re: [PATCHv9 2/5] ppc/cell: trivial: replace get_unused_fd() by get_unused_fd_flags(0)

2014-10-13 Thread Michael Ellerman
On Mon, 2014-10-13 at 21:30 +0200, Yann Droneaud wrote: This patch replaces calls to get_unused_fd() with equivalent call to get_unused_fd_flags(0) to preserve current behavor for existing code. In a further patch, get_unused_fd() will be removed so that new code start using

Re: [RFC PATCH v3 1/3] powerpc: Fix warning reported by verify_cpu_node_mapping()

2014-10-13 Thread Li Zhong
On 二, 2014-10-07 at 08:33 -0700, Nishanth Aravamudan wrote: On 07.10.2014 [17:28:38 +1100], Michael Ellerman wrote: On Fri, 2014-10-03 at 16:26 -0700, Nishanth Aravamudan wrote: On 03.10.2014 [10:50:20 +1000], Michael Ellerman wrote: On Thu, 2014-10-02 at 14:13 -0700, Nishanth Aravamudan

Re: [RFC PATCH v3 1/3] powerpc: Fix warning reported by verify_cpu_node_mapping()

2014-10-13 Thread Michael Ellerman
On Tue, 2014-10-14 at 10:39 +0800, Li Zhong wrote: On 二, 2014-10-07 at 08:33 -0700, Nishanth Aravamudan wrote: On 07.10.2014 [17:28:38 +1100], Michael Ellerman wrote: On Fri, 2014-10-03 at 16:26 -0700, Nishanth Aravamudan wrote: On 03.10.2014 [10:50:20 +1000], Michael Ellerman wrote:

Re: [PATCH 08/44] kernel: Move pm_power_off to common code

2014-10-13 Thread Hirokazu TAKATA
From: Guenter Roeck li...@roeck-us.net arch/m32r/kernel/process.c | 8 Acked-by: Hirokazu Takata tak...@linux-m32r.org Thank you. -- takata ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org