Re: powerpc: mm: numa: Suppress "VPHN is not supported. Disabling polling" prints

2018-11-15 Thread Michael Ellerman
On Thu, 2018-11-08 at 05:17:56 UTC, sathn...@linux.vnet.ibm.com wrote: > From: Satheesh Rajendran > > When VPHN function is not supported and during cpu hotplug event, kernel > prints message 'VPHN function not supported. Disabling polling...'. > Currently it prints on every hotplug event, it

Re: [v2] selftests/powerpc: Adjust wild_bctr to build with old gcc

2018-11-15 Thread Michael Ellerman
On Thu, 2018-11-15 at 02:33:30 UTC, Gustavo Romero wrote: > Currently the selftest wild_bctr can fail to build when an old gcc is used, > notably on gcc using a binutils version <= 2.27, because the assembler does > not support the integer suffix UL. > > This patch adjusts the wild_bctr test so

Re: [PATCH] powerpc/numa: fix hot-added CPU on memory-less node

2018-11-15 Thread Laurent Vivier
On 15/11/2018 10:19, Satheesh Rajendran wrote: > On Wed, Nov 14, 2018 at 06:03:19PM +0100, Laurent Vivier wrote: >> Trying to hotplug a CPU on an empty NUMA node (without >> memory or CPU) crashes the kernel when the CPU is onlined. >> >> During the onlining process, the kernel calls

Re: powerpc/64: Fix kernel stack 16-byte alignment

2018-11-15 Thread Michael Ellerman
On Thu, 2018-11-15 at 02:34:27 UTC, Nicholas Piggin wrote: > Commit 4c2de74cc869 ("powerpc/64: Interrupts save PPR on stack rather > than thread_struct") changed sizeof(struct pt_regs) % 16 from 0 to 8, > which causes the interrupt frame allocation on kernel entry to put the > kernel stack out of

Re: [mainline][ppc][bnx2x] watchdog: CPU 80 self-detected hard LOCKUP @ opal_interrupt+0x28/0x70 when module load/unload

2018-11-15 Thread Abdul Haleem
On Thu, 2018-11-15 at 16:40 +0530, Abdul Haleem wrote: > On Mon, 2018-09-24 at 15:49 +0530, Abdul Haleem wrote: > > On Mon, 2018-09-24 at 19:35 +1000, Oliver wrote: > > > On Mon, Sep 24, 2018 at 6:56 PM, Abdul Haleem > > > wrote: > > > > Greeting's > > > > > > > > bnx2x module load/unload test

Re: [PATCH] arch/powerpc: Use dma_zalloc_coherent

2018-11-15 Thread Joe Perches
On Thu, 2018-11-15 at 23:29 +0530, Sabyasachi Gupta wrote: > On Mon, Nov 5, 2018 at 8:58 AM Sabyasachi Gupta > wrote: > > Replaced dma_alloc_coherent + memset with dma_zalloc_coherent > > > > Signed-off-by: Sabyasachi Gupta > > Any comment on this patch? It's obviously correct. You might

[PATCH 8/9] rapidio: consolidate RAPIDIO config entry in drivers/rapidio

2018-11-15 Thread Christoph Hellwig
There is no good reason to duplicate the RAPIDIO menu in various architectures. Instead provide a selectable HAVE_RAPIDIO symbol that indicates native availability of RAPIDIO support and the handle the rest in drivers/pci. This also means we now provide support for PCI(e) to Rapidio bridges for

[PATCH 9/9] eisa: consolidate EISA Kconfig entry in drivers/eisa

2018-11-15 Thread Christoph Hellwig
Let architectures opt into EISA support by selecting HAS_EISA and handle everything else in drivers/eisa. Signed-off-by: Christoph Hellwig Acked-by: Thomas Gleixner --- arch/alpha/Kconfig | 15 --- arch/mips/Kconfig | 31 +--

[PATCH 6/9] PCI: consolidate the PCI_SYSCALL symbol

2018-11-15 Thread Christoph Hellwig
Let architectures select the syscall support instead of duplicating the kconfig entry. Signed-off-by: Christoph Hellwig --- arch/alpha/Kconfig | 4 +--- arch/arc/Kconfig| 4 +--- arch/arm/Kconfig| 4 +--- arch/arm64/Kconfig | 4 +--- arch/ia64/Kconfig | 4 +---

[PATCH 7/9] pcmcia: allow PCMCIA support independent of the architecture

2018-11-15 Thread Christoph Hellwig
There is nothing architecture specific in the PCMCIA core, so allow building it everywhere. The actual host controllers will depend on ISA, PCI or a specific SOC. Signed-off-by: Christoph Hellwig Acked-by: Dominik Brodowski Acked-by: Thomas Gleixner --- arch/alpha/Kconfig | 2 --

Re: [PATCH] arch/powerpc: Use dma_zalloc_coherent

2018-11-15 Thread Sabyasachi Gupta
On Mon, Nov 5, 2018 at 8:58 AM Sabyasachi Gupta wrote: > > Replaced dma_alloc_coherent + memset with dma_zalloc_coherent > > Signed-off-by: Sabyasachi Gupta Any comment on this patch? > --- > arch/powerpc/platforms/pasemi/dma_lib.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) >

move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v4

2018-11-15 Thread Christoph Hellwig
Hi all, currently every architecture that wants to provide on of the common periphal busses needs to add some boilerplate code and include the right Kconfig files. This series instead just selects the presence (when needed) and then handles everything in the bus-specific Kconfig file under

[PATCH 4/9] PCI: consolidate PCI config entry in drivers/pci

2018-11-15 Thread Christoph Hellwig
There is no good reason to duplicate the PCI menu in every architecture. Instead provide a selectable HAVE_PCI symbol that indicates availability of PCI support, and a FORCE_PCI symbol to for PCI on and the handle the rest in drivers/pci. Signed-off-by: Christoph Hellwig Reviewed-by: Palmer

[PATCH 3/9] MIPS: remove the HT_PCI config option

2018-11-15 Thread Christoph Hellwig
This option is always selected from LOONGSON_MACH3X. Switch to just seleting PCI from that option and definining LOONGSON_PCIIO_BASE based on CONFIG_LOONGSON_MACH3X. Signed-off-by: Christoph Hellwig --- arch/mips/Kconfig| 11 ---

[PATCH 5/9] PCI: consolidate the PCI_DOMAINS and PCI_DOMAINS_GENERIC config options

2018-11-15 Thread Christoph Hellwig
Move the definitions to drivers/pci and let the architectures select them. Two small differences to before: PCI_DOMAINS_GENERIC now selects PCI_DOMAINS, cutting down the churn for modern architectures. As the only architectured arm did previously also offer PCI_DOMAINS as a user visible choice

[PATCH 2/9] alpha: force PCI on for non-jensen configs

2018-11-15 Thread Christoph Hellwig
Without PCI support the kernel won't even compile, so force it on. Signed-off-by: Christoph Hellwig --- arch/alpha/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/arch/alpha/Kconfig b/arch/alpha/Kconfig index 5b4f88363453..65f6d0bf69d4 100644 --- a/arch/alpha/Kconfig +++

[PATCH 1/2] PCI/AER: Do not use APEI/HEST to disable AER services globally

2018-11-15 Thread Alexandru Gagniuc
HEST is used to describe the meaning of errors received as part of ACPI Platform Error Interfaces (APEI). HEST is tightly coupled to ownership of AER, however the correct way to determine AER ownership is the _OSC method. _OSC is negotiated per root bus. It's possible to have one HEST descriptor

[PATCH 2/2] PCI/AER: Determine AER ownership based on _OSC instead of HEST

2018-11-15 Thread Alexandru Gagniuc
HEST is used to describe the meaning of errors received as part of ACPI Platform Error Interfaces (APEI), however the correct way to determine AER ownership is the _OSC method. pci_dev->__aer_firmware_first is used to prevent modification of AER registers when firmware owns AER. This is

[PATCH] net/ibmnvic: Fix deadlock problem in reset

2018-11-15 Thread Juliet Kim
Subject: [PATCH] net/ibmnvic: Fix deadlock problem in reset From: Juliet Kim This patch changes to use rtnl_lock only during a reset to avoid deadlock that could occur when a thread operating close is holding rtnl_lock and waiting for reset_lock acquired by another thread, which is waiting for

[PATCH 0/2] PCI/AER: Consistently use _OSC to determine who owns AER

2018-11-15 Thread Alexandru Gagniuc
Thanks to Keith for pointing out that it doesn't make sense to disable AER services when only one device has a FIRMWARE_FIRST HEST. AER ownership is an interesting issue brought in by FFS (firmware-first) model. In a nutshell if FFS handles AER, then OS should not touch any of the AER bits. FW

Re: [PATCH 2/2] PCI/AER: Determine AER ownership based on _OSC instead of HEST

2018-11-15 Thread Keith Busch
On Thu, Nov 15, 2018 at 05:16:03PM -0600, Alexandru Gagniuc wrote: > static void aer_set_firmware_first(struct pci_dev *pci_dev) > { > - int rc; > - struct aer_hest_parse_info info = { > - .pci_dev= pci_dev, > - .firmware_first = 0, > - }; > +

Re: [PATCH v2] PCI/MSI: Don't touch MSI bits when the PCI device is disconnected

2018-11-15 Thread Alex_Gagniuc
+ Borislav (ACPI guy, maybe he can answer more about HEST) On 11/15/2018 12:24 AM, Bjorn Helgaas wrote: > On Wed, Nov 14, 2018 at 07:22:04PM +, alex_gagn...@dellteam.com wrote: >> On 11/14/2018 12:00 AM, Bjorn Helgaas wrote: >>> On Tue, Nov 13, 2018 at 10:39:15PM +,

Re: [PATCH 0/2] PCI/AER: Consistently use _OSC to determine who owns AER

2018-11-15 Thread Sinan Kaya
On 11/15/2018 3:16 PM, Alexandru Gagniuc wrote: I've asked around a few people at Dell and they unanimously agree that _OSC is the correct way to determine ownership of AER. In linux, we use the result of _OSC to enable AER services, but we use HEST to determine AER ownership. That's

Re: [PATCHv2 2/6] ARM: dts: ls1021a: Add the status property disable PCIe

2018-11-15 Thread Shawn Guo
On Mon, Nov 05, 2018 at 04:46:49PM +0800, Xiaowei Bao wrote: > Add the status property disable the PCIe, the property will be enable > by bootloader. > > Signed-off-by: Xiaowei Bao Applied, thanks.

Re: [mainline][ppc][bnx2x] watchdog: CPU 80 self-detected hard LOCKUP @ opal_interrupt+0x28/0x70 when module load/unload

2018-11-15 Thread Michael Ellerman
Abdul Haleem writes: > On Thu, 2018-11-15 at 16:40 +0530, Abdul Haleem wrote: >> On Mon, 2018-09-24 at 15:49 +0530, Abdul Haleem wrote: >> > On Mon, 2018-09-24 at 19:35 +1000, Oliver wrote: >> > > On Mon, Sep 24, 2018 at 6:56 PM, Abdul Haleem >> > > wrote: >> > > > Greeting's >> > > > >> > > >

subscribe

2018-11-15 Thread Stephen Davies
subscribe

Re: [PATCHv2 1/6] arm64: dts: Add the status property disable PCIe

2018-11-15 Thread Shawn Guo
On Mon, Nov 05, 2018 at 04:46:48PM +0800, Xiaowei Bao wrote: > From: Bao Xiaowei > > Add the status property disable the PCIe, the property will be enable > by bootloader. > > Signed-off-by: Bao Xiaowei Changed prefix to 'arm64: dts: fsl: ...' and applied the patch. Shawn

Re: [PATCH kernel v3 04/22] powerpc/vfio/iommu/kvm: Do not pin device memory

2018-11-15 Thread David Gibson
On Tue, Nov 13, 2018 at 07:28:05PM +1100, Alexey Kardashevskiy wrote: > This new memory does not have page structs as it is not plugged to > the host so gup() will fail anyway. > > This adds 2 helpers: > - mm_iommu_newdev() to preregister the "memory device" memory so > the rest of API can still

Re: [PATCH] powerpc/64: Fix kernel stack 16-byte alignment

2018-11-15 Thread Abdul Haleem
On Thu, 2018-11-15 at 12:34 +1000, Nicholas Piggin wrote: > Commit 4c2de74cc869 ("powerpc/64: Interrupts save PPR on stack rather > than thread_struct") changed sizeof(struct pt_regs) % 16 from 0 to 8, > which causes the interrupt frame allocation on kernel entry to put the > kernel stack out of

Re: [PATCH kernel v3 11/22] powerpc/pseries/npu: Enable platform support

2018-11-15 Thread David Gibson
On Tue, Nov 13, 2018 at 07:28:12PM +1100, Alexey Kardashevskiy wrote: > We already changed NPU API for GPUs to not to call OPAL and the remaining > bit is initializing NPU structures. > > This uses a new QEMU capability which marks NPU-enabled vPHBs as > "IBM,npu-vphb" and initializes an NPU

RE: [PATCHv2 2/6] ARM: dts: ls1021a: Add the status property disable PCIe

2018-11-15 Thread Xiaowei Bao
Hi Shanwn, Thanks a lot. Best regards Xiaowei -Original Message- From: Shawn Guo Sent: 2018年11月16日 10:51 To: Xiaowei Bao Cc: bhelg...@google.com; robh...@kernel.org; mark.rutl...@arm.com; Leo Li ; kis...@ti.com; lorenzo.pieral...@arm.com; a...@arndb.de; gre...@linuxfoundation.org;

Re: [PATCH kernel v3 09/22] powerpc/pseries/iommu: Force default DMA window removal

2018-11-15 Thread David Gibson
On Tue, Nov 13, 2018 at 07:28:10PM +1100, Alexey Kardashevskiy wrote: > It is quite common for a device to support more than 32bit but less than > 64bit for DMA, for example, GPUs often support 42..50bits. However > the pseries platform only allows huge DMA window (the one which allows > the use

Re: [mainline][ppc][bnx2x] watchdog: CPU 80 self-detected hard LOCKUP @ opal_interrupt+0x28/0x70 when module load/unload

2018-11-15 Thread Abdul Haleem
On Fri, 2018-11-16 at 15:44 +1100, Michael Ellerman wrote: > Abdul Haleem writes: > > On Thu, 2018-11-15 at 16:40 +0530, Abdul Haleem wrote: > >> On Mon, 2018-09-24 at 15:49 +0530, Abdul Haleem wrote: > >> > On Mon, 2018-09-24 at 19:35 +1000, Oliver wrote: > >> > > On Mon, Sep 24, 2018 at 6:56

Re: [PATCH kernel v3 10/22] powerpc/pseries/iommu: Use memory@ nodes in max RAM address calculation

2018-11-15 Thread David Gibson
On Tue, Nov 13, 2018 at 07:28:11PM +1100, Alexey Kardashevskiy wrote: > We might have memory@ nodes with "linux,usable-memory" set to zero > (for example, to replicate powernv's behaviour for GPU coherent memory) > which means that the memory needs an extra initialization but since > it can be

Re: [PATCH] arch/powerpc: Use dma_zalloc_coherent

2018-11-15 Thread Sabyasachi Gupta
On Mon, Nov 5, 2018 at 7:52 AM Sabyasachi Gupta wrote: > > Replaced dma_alloc_coherent + memset with dma_zalloc_coherent > > Signed-off-by: Sabyasachi Gupta Any comment on this patch? > --- > arch/powerpc/sysdev/fsl_rmu.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff

[PATCH 1/9] arm: remove EISA kconfig option

2018-11-15 Thread Christoph Hellwig
No arm config enables EISA, and arm does not include drivers/eisa/Kconfig which provides support for things like PCI to EISA bridges, so it is most likely dead. Suggested-by: Masahiro Yamada Signed-off-by: Christoph Hellwig --- arch/arm/Kconfig | 15 --- 1 file changed, 15

Re: [PATCH] powerpc/numa: fix hot-added CPU on memory-less node

2018-11-15 Thread Satheesh Rajendran
On Wed, Nov 14, 2018 at 06:03:19PM +0100, Laurent Vivier wrote: > Trying to hotplug a CPU on an empty NUMA node (without > memory or CPU) crashes the kernel when the CPU is onlined. > > During the onlining process, the kernel calls start_secondary() > that ends by calling >

Re: [PATCH kernel v3 03/22] powerpc/mm/iommu: Make mm_iommu_new() fail on existing regions

2018-11-15 Thread David Gibson
On Tue, Nov 13, 2018 at 07:28:04PM +1100, Alexey Kardashevskiy wrote: > Since we are going to have 2 different preregistering helpers, let's > make it clear that mm_iommu_new() is only for the normal memory > (i.e.not device memory) and for existing areas mm_iommu_get() should be > used instead. >

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-15 Thread LABBE Corentin
On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > On Wed, Oct 24, 2018 at 07:35:46AM +, Corentin Labbe wrote: > > This patchset adds a new set of functions which are open-coded in lot of > > place. > > Basicly the pattern is always the same, "read, modify a bit,

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-15 Thread Russell King - ARM Linux
On Thu, Nov 15, 2018 at 10:30:34AM +0100, LABBE Corentin wrote: > On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > > On Wed, Oct 24, 2018 at 07:35:46AM +, Corentin Labbe wrote: > > > This patchset adds a new set of functions which are open-coded in lot of > > >

Unexpectedly dma_ops is NULL in struct device

2018-11-15 Thread Alexander Fomichev
Hello, I tried to use Switchtec NTB on PowerPC platform and faced a strange behaviour. In ntb_hw_switchtec module's initialization section the "struct device" has uninitialized field dma_ops (NULL). Meanwhile the same NTB hardware on x86 platform get correct dma_ops in this driver. It looks

Re: [mainline][ppc][bnx2x] watchdog: CPU 80 self-detected hard LOCKUP @ opal_interrupt+0x28/0x70 when module load/unload

2018-11-15 Thread Abdul Haleem
On Mon, 2018-09-24 at 15:49 +0530, Abdul Haleem wrote: > On Mon, 2018-09-24 at 19:35 +1000, Oliver wrote: > > On Mon, Sep 24, 2018 at 6:56 PM, Abdul Haleem > > wrote: > > > Greeting's > > > > > > bnx2x module load/unload test results in continuous hard LOCKUP trace on > > > my powerpc bare-metal

Re: [PATCH kernel] powerpc/powernv/ioda: Reduce a number of hooks in pnv_phb

2018-11-15 Thread Michael Ellerman
Sam Bobroff writes: > On Tue, Oct 16, 2018 at 01:34:09PM +1100, Alexey Kardashevskiy wrote: >> fixup_phb() is never used, this removes it. >> >> pick_m64_pe() and reserve_m64_pe() are always defined for all powernv >> PHBs: they are initialized by pnv_ioda_parse_m64_window() which is >> called

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-15 Thread LABBE Corentin
On Thu, Nov 15, 2018 at 09:33:48AM +, Russell King - ARM Linux wrote: > On Thu, Nov 15, 2018 at 10:30:34AM +0100, LABBE Corentin wrote: > > On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > > > On Wed, Oct 24, 2018 at 07:35:46AM +, Corentin Labbe wrote: > > > >

Re: [PATCH] powerpc/mm: dump block address translation on book3s/32

2018-11-15 Thread Michael Ellerman
Christophe Leroy writes: > This patch adds a debugfs file to dump block address translation: > > ~# cat /sys/kernel/debug/block_address_translation My instinct is it should be in /sys/kernel/debug/powerpc. But I guess the other page table dump files are not. > Instruction Block Address

Re: [PATCH] powerpc/mm: dump block address translation on book3s/32

2018-11-15 Thread Christophe LEROY
Le 15/11/2018 à 12:46, Michael Ellerman a écrit : Christophe Leroy writes: This patch adds a debugfs file to dump block address translation: ~# cat /sys/kernel/debug/block_address_translation My instinct is it should be in /sys/kernel/debug/powerpc. But I guess the other page table dump

[PATCH -next] powerpc/platforms/85xx: drop pointless static qualifier

2018-11-15 Thread YueHaibing
From: Yue Haibing There is no need to have the 'void __iomem *cpld_base' variable static since new value always be assigned before use it. Signed-off-by: Yue Haibing --- arch/powerpc/platforms/85xx/t1042rdb_diu.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH] Powerpc/perf: Wire up PMI throttling

2018-11-15 Thread Michael Ellerman
Ravi Bangoria writes: > Commit 14c63f17b1fde ("perf: Drop sample rate when sampling is too > slow") introduced a way to throttle PMU interrupts if we're spending > too much time just processing those. Wire up powerpc PMI handler to > use this infrastructure. To be clear we have throttling of

Re: [PATCH] powerpc/powernv: Remove PCI_MSI ifdef checks

2018-11-15 Thread Michael Ellerman
Joel Stanley writes: > On Wed, 14 Nov 2018 at 16:50, Oliver O'Halloran wrote: >> >> CONFIG_PCI_MSI was made mandatory by commit a311e738b6d8 >> ("powerpc/powernv: Make PCI non-optional") so the #ifdef >> checks around CONFIG_PCI_MSI here can be removed entirely. >> >> Signed-off-by: Oliver

Re: [PATCH] powerpc/32: Include .branch_lt in data section

2018-11-15 Thread Michael Ellerman
Alan Modra writes: > On Wed, Nov 14, 2018 at 01:32:18PM +1030, Joel Stanley wrote: >> When building a 32 bit powerpc kernel with Binutils 2.31.1 this warning >> is emitted: >> >> powerpc-linux-gnu-ld: warning: orphan section `.branch_lt' from >> `arch/powerpc/kernel/head_44x.o' being placed