Re: [PATCH V5 0/4] powerpc/perf: Add support for perf extended regs in powerpc

2020-07-30 Thread Athira Rajeev
> On 27-Jul-2020, at 10:46 PM, Athira Rajeev > wrote: > > Patch set to add support for perf extended register capability in > powerpc. The capability flag PERF_PMU_CAP_EXTENDED_REGS, is used to > indicate the PMU which support extended registers. The generic code > define the mask of

[powerpc:merge] BUILD SUCCESS 10a81441d89aa02486b3e710aa4761cb1cfcaf46

2020-07-30 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git merge branch HEAD: 10a81441d89aa02486b3e710aa4761cb1cfcaf46 Automatic merge of 'master', 'next' and 'fixes' (2020-07-28 13:16) elapsed time: 3105m configs tested: 60 configs skipped: 1 The following configs have

Re: [RESEND PATCH v5 00/11] ppc64: enable kdump support for kexec_file_load syscall

2020-07-30 Thread Hari Bathini
On 28/07/20 8:02 am, piliu wrote: On 07/27/2020 03:36 AM, Hari Bathini wrote: Sorry! There was a gateway issue on my system while posting v5, due to which some patches did not make it through. Resending... This patch series enables kdump support for kexec_file_load system call (kexec -s

[PATCH v3 2/2] powerpc/papr_scm: Add support for fetching nvdimm 'fuel-gauge' metric

2020-07-30 Thread Vaibhav Jain
We add support for reporting 'fuel-gauge' NVDIMM metric via PAPR_PDSM_HEALTH pdsm payload. 'fuel-gauge' metric indicates the usage life remaining of a papr-scm compatible NVDIMM. PHYP exposes this metric via the H_SCM_PERFORMANCE_STATS. The metric value is returned from the pdsm by extending the

Re: [PATCH 1/2] spi: mpc512x-psc: Use the framework .set_cs()

2020-07-30 Thread Mark Brown
On Wed, Jul 29, 2020 at 11:48:16PM +0200, Linus Walleij wrote: > The mpc512x-psc is rolling its own chip select control code, > but the SPI master framework can handle this. It was also > evaluating the CS status for each transfer but the CS change > should be per-message not per-transfer. No, CS

Re: [PATCH] powerpc: fix function annotations to avoid section mismatch warnings with gcc-10

2020-07-30 Thread Michael Ellerman
Segher Boessenkool writes: > On Wed, Jul 29, 2020 at 03:44:56PM -0400, Vladis Dronov wrote: >> > > Certain warnings are emitted for powerpc code when building with a gcc-10 >> > > toolset: >> > > >> > > WARNING: modpost: vmlinux.o(.text.unlikely+0x377c): Section mismatch >> > > in >> > >

[PATCH v3 1/2] powerpc/papr_scm: Fetch nvdimm performance stats from PHYP

2020-07-30 Thread Vaibhav Jain
Update papr_scm.c to query dimm performance statistics from PHYP via H_SCM_PERFORMANCE_STATS hcall and export them to user-space as PAPR specific NVDIMM attribute 'perf_stats' in sysfs. The patch also provide a sysfs ABI documentation for the stats being reported and their meanings. During NVDIMM

question about work on CMA integration into DMA

2020-07-30 Thread Maksym Kokhan
Hello! I am working on some driver, which needs to allocate a big contiguous memory block (~10 MB) and has to work on multiple platforms (x86, arm, arm64, mips, powerpc). CMA - is the most appropriate way in this case, but I have faced an unexpected problem - the fact that the CMA subsystem is

[PATCH v3 0/2] powerpc/papr_scm: add support for reporting NVDIMM 'life_used_percentage' metric

2020-07-30 Thread Vaibhav Jain
Changes since v2[1]: * Updated drc_pmem_query_stats() to reduce the number of input args to the function based suggestions from Aneesh. [1] https://lore.kernel.org/linux-nvdimm/20200726122030.31529-1-vaib...@linux.ibm.com --- This small patchset implements kernel side support for reporting

Documentation/powerpc: Ultravisor API

2020-07-30 Thread Julia Lawall
The file Documentation/powerpc/ultravisor.rst contains: Only valid value(s) in ``flags`` are: * H_PAGE_IN_SHARED which indicates that the page is to be shared with the Ultravisor. * H_PAGE_IN_NONSHARED indicates that the UV is not anymore interested in

Re: [PATCH 04/15] arm64: numa: simplify dummy_numa_init()

2020-07-30 Thread Catalin Marinas
On Tue, Jul 28, 2020 at 08:11:42AM +0300, Mike Rapoport wrote: > From: Mike Rapoport > > dummy_numa_init() loops over memblock.memory and passes nid=0 to > numa_add_memblk() which essentially wraps memblock_set_node(). However, > memblock_set_node() can cope with entire memory span itself, so

Re: [PATCH 06/15] powerpc: fadamp: simplify fadump_reserve_crash_area()

2020-07-30 Thread Michael Ellerman
Mike Rapoport writes: > From: Mike Rapoport > > fadump_reserve_crash_area() reserves memory from a specified base address > till the end of the RAM. > > Replace iteration through the memblock.memory with a single call to > memblock_reserve() with appropriate that will take care of proper memory

[PATCH] KVM: PPC: Book3S HV: fix a oops in kvmppc_uvmem_page_free()

2020-07-30 Thread Ram Pai
Observed the following oops while stress-testing, using multiple secureVM on a distro kernel. However this issue theoritically exists in 5.5 kernel and later. This issue occurs when the total number of requested device-PFNs exceed the total-number of available device-PFNs. PFN migration fails to

Re: OF: Can't handle multiple dma-ranges with different offsets

2020-07-30 Thread Chris Packham
On 23/07/20 10:11 am, Chris Packham wrote: > > On 22/07/20 4:19 pm, Chris Packham wrote: >> Hi, >> >> I've just fired up linux kernel v5.7 on a p2040 based system and I'm >> getting the following new warning >> >> OF: Can't handle multiple dma-ranges with different offsets on >>

Re: [PATCH v2] powerpc/vio: drop bus_type from parent device

2020-07-30 Thread Michael Ellerman
Greg KH writes: > On Thu, Jul 30, 2020 at 11:28:38AM +1000, Michael Ellerman wrote: >> [ Added Peter & Greg to Cc ] >> >> Thadeu Lima de Souza Cascardo writes: >> > Commit df44b479654f62b478c18ee4d8bc4e9f897a9844 ("kobject: return error >> > code if writing /sys/.../uevent fails") started

Re: [PATCH 1/2 v2] powerpc/dma: Define map/unmap mmio resource callbacks

2020-07-30 Thread Oliver O'Halloran
On Thu, Apr 30, 2020 at 11:15 PM Max Gurtovoy wrote: > > Define the map_resource/unmap_resource callbacks for the dma_iommu_ops > used by several powerpc platforms. The map_resource callback is called > when trying to map a mmio resource through the dma_map_resource() > driver API. > > For now,

Re: [PATCH v4 09/10] Powerpc/smp: Create coregroup domain

2020-07-30 Thread Valentin Schneider
(+Cc Morten) On 29/07/20 07:13, Srikar Dronamraju wrote: > * Valentin Schneider [2020-07-28 16:03:11]: > > Hi Valentin, > > Thanks for looking into the patches. > >> On 27/07/20 06:32, Srikar Dronamraju wrote: >> > Add percpu coregroup maps and masks to create coregroup domain. >> > If a

[powerpc:fixes-test] BUILD SUCCESS 909adfc66b9a1db21b5e8733e9ebfa6cd5135d74

2020-07-30 Thread kernel test robot
i386 randconfig-a015-20200727 i386 randconfig-a011-20200727 i386 randconfig-a014-20200727 i386 randconfig-a016-20200730 i386 randconfig-a012-20200730 i386 randconfig-a014-20200730 i386

Re: [PATCH] powerpc: fix function annotations to avoid section mismatch warnings with gcc-10

2020-07-30 Thread Vladis Dronov
Hello, Michael, - Original Message - > From: "Michael Ellerman" > Subject: Re: [PATCH] powerpc: fix function annotations to avoid section > mismatch warnings with gcc-10 > ... > >> > So what changed? These functions were inlined with older compilers, but > >> > not anymore? > >> > >>

Re: [PATCH v2] powerpc/vio: drop bus_type from parent device

2020-07-30 Thread Thadeu Lima de Souza Cascardo
On Thu, Jul 30, 2020 at 07:37:16AM +0200, Greg KH wrote: > On Thu, Jul 30, 2020 at 11:28:38AM +1000, Michael Ellerman wrote: > > [ Added Peter & Greg to Cc ] > > > > Thadeu Lima de Souza Cascardo writes: > > > Commit df44b479654f62b478c18ee4d8bc4e9f897a9844 ("kobject: return error > > > code if

[powerpc:next] BUILD SUCCESS cf1ae052e073c7ef6cf1a783a6427f7228253bd3

2020-07-30 Thread kernel test robot
allnoconfig i386 randconfig-a016-20200730 i386 randconfig-a012-20200730 i386 randconfig-a014-20200730 i386 randconfig-a015-20200730 i386 randconfig-a011-20200730 i386 randconfig-a013-20200730 riscv

Re: [PATCH -next] PCI: rpadlpar: Make some functions static

2020-07-30 Thread Bjorn Helgaas
On Tue, Jul 21, 2020 at 11:17:35PM +0800, Wei Yongjun wrote: > The sparse tool report build warnings as follows: > > drivers/pci/hotplug/rpadlpar_core.c:355:5: warning: > symbol 'dlpar_remove_pci_slot' was not declared. Should it be static? > drivers/pci/hotplug/rpadlpar_core.c:461:12: warning:

Re: [PATCH v4 00/10] Coregroup support on Powerpc

2020-07-30 Thread Srikar Dronamraju
* Srikar Dronamraju [2020-07-27 11:02:20]: > Changelog v3 ->v4: > v3: > https://lore.kernel.org/lkml/20200723085116.4731-1-sri...@linux.vnet.ibm.com/t/#u > Here is a summary of some of the testing done with coregroup v4 patchsets. It includes ebizzy, schbench, perf bench sched pipe and

Re: Documentation/powerpc: Ultravisor API

2020-07-30 Thread Ram Pai
On Thu, Jul 30, 2020 at 12:35:38PM +0200, Julia Lawall wrote: > The file Documentation/powerpc/ultravisor.rst contains: > > Only valid value(s) in ``flags`` are: > > * H_PAGE_IN_SHARED which indicates that the page is to be shared > with the Ultravisor. > > *

Re: [PATCH 1/9] powerpc/configs: Drop old symbols from ppc6xx_defconfig

2020-07-30 Thread Michael Ellerman
On Fri, 24 Jul 2020 23:17:20 +1000, Michael Ellerman wrote: > ppc6xx_defconfig refers to quite a few symbols that no longer exist, > as reported by scripts/checkkconfigsymbols.py, remove them. Applied to powerpc/next. [1/9] powerpc/configs: Drop old symbols from ppc6xx_defconfig

[PATCHv4 2/2] powerpc/pseries: update device tree before ejecting hotplug uevents

2020-07-30 Thread Pingfan Liu
A bug is observed on pseries by taking the following steps on rhel: -1. drmgr -c mem -r -q 5 -2. echo c > /proc/sysrq-trigger And then, the failure looks like: kdump: saving to /sysroot//var/crash/127.0.0.1-2020-01-16-02:06:14/ kdump: saving vmcore-dmesg.txt kdump: saving vmcore-dmesg.txt

[powerpc:next-test] BUILD SUCCESS 2e6bd221d96fcfd9bd1eed5cd9c008e7959daed7

2020-07-30 Thread kernel test robot
allnoconfig i386 randconfig-a016-20200730 i386 randconfig-a012-20200730 i386 randconfig-a014-20200730 i386 randconfig-a015-20200730 riscvallyesconfig riscv allnoconfig riscv

Re: [PATCH] powerpc/pseries: explicitly reschedule during drmem_lmb list traversal

2020-07-30 Thread Nathan Lynch
Michael Ellerman writes: > Nathan Lynch writes: >> Laurent Dufour writes: >>> Le 28/07/2020 à 19:37, Nathan Lynch a écrit : The drmem lmb list can have hundreds of thousands of entries, and unfortunately lookups take the form of linear searches. As long as this is the case,

Re: [PATCH] powerpc/mm: Limit resize_hpt_for_hotplug() call to hash guests only

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 15:27:04 +0530, Bharata B Rao wrote: > During memory hotplug and unplug, resize_hpt_for_hotplug() gets called > for both hash and radix guests but it should be called only for hash > guests. Though the call does nothing in the radix guest case, it is > cleaner to push this call

Re: [PATCH] selftests/powerpc: Squash spurious errors due to device removal

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 11:01:27 +1000, Oliver O'Halloran wrote: > For drivers that don't have the error handling callbacks we implement > recovery by removing the device and re-probing it. This causes the sysfs > directory for the PCI device to be removed which causes the following > spurious error

Re: [PATCH] powerpc/fadump: Fix build error with CONFIG_PRESERVE_FA_DUMP=y

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 17:03:41 +1000, Michael Ellerman wrote: > skiroot_defconfig fails: > > arch/powerpc/kernel/fadump.c:48:17: error: ‘cpus_in_fadump’ defined but > not used >48 | static atomic_t cpus_in_fadump; > > Fix it by moving the definition into the #ifdef where it's used.

Re: [PATCH v3] powerpc xmon: use `dcbf` inplace of `dcbi` instruction for 64bit Book3S

2020-07-30 Thread Michael Ellerman
On Mon, 30 Mar 2020 13:29:54 +0530, Balamuruhan S wrote: > Data Cache Block Invalidate (dcbi) instruction implemented back in > PowerPC architecture version 2.03. But as per Power Processor Users Manual > it is obsolete and not supported by POWER8/POWER9 core. Attempt to use of > this illegal

Re: [PATCH -next] powerpc: use for_each_child_of_node() macro

2020-07-30 Thread Michael Ellerman
On Tue, 28 Jul 2020 10:28:07 +0800, Qinglang Miao wrote: > Use for_each_child_of_node() macro instead of open coding it. Applied to powerpc/next. [1/1] powerpc: use for_each_child_of_node() macro https://git.kernel.org/powerpc/c/b6ac59d39a348af29477d7bfdc3ba23526e3f4ea cheers

Re: [PATCH v3 0/3] powerpc/pseries: IPI doorbell improvements

2020-07-30 Thread Michael Ellerman
On Sun, 26 Jul 2020 13:51:52 +1000, Nicholas Piggin wrote: > Since v2: > - Fixed ppc32 compile error > - Tested-by from Cedric > > Nicholas Piggin (3): > powerpc: inline doorbell sending functions > powerpc/pseries: Use doorbells even if XIVE is available > powerpc/pseries: Add KVM guest

Re: [PATCH v2 0/6] Improvements to pkey tests

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 09:30:34 +0530, Sandipan Das wrote: > Based on recent bugs found in the pkey infrastructure, this > improves the test for execute-disabled pkeys and adds a new > test for detecting inconsistencies with the pkey reported by > the signal information upon getting a fault. > >

[PATCHv4 1/2] powerpc/pseries: group lmb operation and memblock's

2020-07-30 Thread Pingfan Liu
This patch prepares for the incoming patch which swaps the order of KOBJ_ADD/REMOVE uevent and dt's updating. The dt updating should come after lmb operations, and before __remove_memory()/__add_memory(). Accordingly, grouping all lmb operations before the memblock's. Signed-off-by: Pingfan Liu

Re: [PATCH v2] powerpc/book3s64/radix: Add kernel command line option to disable radix GTSE

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 14:29:08 +0530, Aneesh Kumar K.V wrote: > This adds a kernel command line option that can be used to disable GTSE > support. > Disabling GTSE implies kernel will make hcalls to invalidate TLB entries. > > This was done so that we can do VM migration between configs that >

Re: [PATCH 1/2] powerpc/hugetlb/cma: Allocate gigantic hugetlb pages using CMA

2020-07-30 Thread Michael Ellerman
On Mon, 13 Jul 2020 20:37:48 +0530, Aneesh Kumar K.V wrote: > commit: cf11e85fc08c ("mm: hugetlb: optionally allocate gigantic hugepages > using cma") > added support for allocating gigantic hugepages using CMA. This patch > enables the same for powerpc Applied to powerpc/next. [1/2]

Re: [PATCH v2 1/5] selftests/powerpc: Add test of stack expansion logic

2020-07-30 Thread Michael Ellerman
On Fri, 24 Jul 2020 19:25:24 +1000, Michael Ellerman wrote: > We have custom stack expansion checks that it turns out are extremely > badly tested and contain bugs, surprise. So add some tests that > exercise the code and capture the current boundary conditions. > > The signal test currently

[PATCH] soc: fsl: Remove bogus packed attributes from qman.h

2020-07-30 Thread Herbert Xu
There are two __packed attributes in qman.h that are both unnecessary and causing compiler warnings because they're conflicting with explicit alignment requirements set on members within the structure. This patch removes them both. Signed-off-by: Herbert Xu diff --git a/include/soc/fsl/qman.h

Re: [PATCH] powerpc: Fix MMCRA_BHRB_DISABLE define to work with binutils version < 2.28

2020-07-30 Thread Michael Ellerman
On Wed, 29 Jul 2020 00:16:54 -0400, Athira Rajeev wrote: > commit 9908c826d5ed ("powerpc/perf: Add Power10 PMU feature to > DT CPU features") defines MMCRA_BHRB_DISABLE as `0x20UL`. > Binutils version less than 2.28 doesn't support UL suffix. > >

Re: [PATCH][next] powerpc: Use fallthrough pseudo-keyword

2020-07-30 Thread Michael Ellerman
On Mon, 27 Jul 2020 17:42:01 -0500, Gustavo A. R. Silva wrote: > Replace the existing /* fall through */ comments and its variants with > the new pseudo-keyword macro fallthrough[1]. Also, remove unnecessary > fall-through markings when it is the case. > > [1] >

Re: [PATCH] powerpc/build: vdso linker warning for orphan sections

2020-07-30 Thread Michael Ellerman
On Tue, 3 Mar 2020 11:27:48 +1000, Nicholas Piggin wrote: > Applied to powerpc/next. [1/1] powerpc/build: vdso linker warning for orphan sections https://git.kernel.org/powerpc/c/f2af201002a8bc22500c04cc474ea480bf361351 cheers

Re: [PATCH -next] powerpc/powernv/sriov: Remove unused but set variable 'phb'

2020-07-30 Thread Michael Ellerman
On Tue, 28 Jul 2020 01:11:12 +0800, Wei Yongjun wrote: > Gcc report warning as follows: > > arch/powerpc/platforms/powernv/pci-sriov.c:602:25: warning: > variable 'phb' set but not used [-Wunused-but-set-variable] > 602 | struct pnv_phb*phb; > | ^~~ > >

Re: [PATCH V5 0/4] powerpc/perf: Add support for perf extended regs in powerpc

2020-07-30 Thread Jiri Olsa
On Thu, Jul 30, 2020 at 01:24:40PM +0530, Athira Rajeev wrote: > > > > On 27-Jul-2020, at 10:46 PM, Athira Rajeev > > wrote: > > > > Patch set to add support for perf extended register capability in > > powerpc. The capability flag PERF_PMU_CAP_EXTENDED_REGS, is used to > > indicate the PMU

Re: [PATCH] KVM: PPC: Book3S HV: Define H_PAGE_IN_NONSHARED for H_SVM_PAGE_IN hcall

2020-07-30 Thread Bharata B Rao
On Thu, Jul 30, 2020 at 04:21:01PM -0700, Ram Pai wrote: > H_SVM_PAGE_IN hcall takes a flag parameter. This parameter specifies the > way in which a page will be treated. H_PAGE_IN_NONSHARED indicates > that the page will be shared with the Secure VM, and H_PAGE_IN_SHARED > indicates that the

Re: [PATCH] KVM: PPC: Book3S HV: fix a oops in kvmppc_uvmem_page_free()

2020-07-30 Thread Bharata B Rao
On Thu, Jul 30, 2020 at 04:25:26PM -0700, Ram Pai wrote: > Observed the following oops while stress-testing, using multiple > secureVM on a distro kernel. However this issue theoritically exists in > 5.5 kernel and later. > > This issue occurs when the total number of requested device-PFNs exceed

[PATCH] KVM: PPC: Book3S HV: Define H_PAGE_IN_NONSHARED for H_SVM_PAGE_IN hcall

2020-07-30 Thread Ram Pai
H_SVM_PAGE_IN hcall takes a flag parameter. This parameter specifies the way in which a page will be treated. H_PAGE_IN_NONSHARED indicates that the page will be shared with the Secure VM, and H_PAGE_IN_SHARED indicates that the page will not be shared but its contents will be copied. However