Re: [PATCH 2/7] PowerPC: add unlikely() to BUG_ON()

2011-01-28 Thread Coly Li
or not using unlikely() inside BUG_ON(), it depends on the implementation of BUG_ON(), including arch implementation. So from current feed back, doing unlikely() optimization here doesn't make anything better. Thanks for all of your feed back :-) -- Coly Li

Re: [PATCH RFC PKS/PMEM 48/58] drivers/md: Utilize new kmap_thread()

2020-10-12 Thread Coly Li
On 2020/10/12 13:28, Ira Weiny wrote: > On Sat, Oct 10, 2020 at 10:20:34AM +0800, Coly Li wrote: >> On 2020/10/10 03:50, ira.we...@intel.com wrote: >>> From: Ira Weiny >>> >>> These kmap() calls are localized to a single thread. To avoid the over >>

Re: [PATCH RFC PKS/PMEM 48/58] drivers/md: Utilize new kmap_thread()

2020-10-09 Thread Coly Li
ive to option 2) introduce a flag to kmap(), then we won't forget the new thread-localized kmap method, and people won't ask why a _thread() function is called but no kthread created. Thanks. Coly Li > Cc: Coly Li (maintainer:BCACHE (BLOCK LAYER CACHE)) > Cc: Kent Overstreet (maintainer:B

Re: [PATCH 09/20] bcache: stop setting ->queuedata

2020-07-02 Thread Coly Li
On 2020/7/1 16:59, Christoph Hellwig wrote: > Nothing in bcache actually uses the ->queuedata field. > > Signed-off-by: Christoph Hellwig Acked-by: Coly Li > --- > drivers/md/bcache/super.c | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/drivers/md/bcache/

Re: [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations

2020-07-02 Thread Coly Li
Also remove the request_queue argument to it, as > the queue can be derived pretty trivially from the bio. > > Signed-off-by: Christoph Hellwig For the bcache part, Acked-by: Coly Li > --- > Documentation/block/biodoc.rst| 2 +- > .../block/writeback_

Re: [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct

2020-07-02 Thread Coly Li
ic_make_request(). Anyway, if it is decided, for bcache part, Acked-by: Coly Li > --- > Documentation/block/biodoc.rst| 2 +- > .../fault-injection/fault-injection.rst | 2 +- > Documentation/trace/ftrace.rst| 4 +-- > block/bio.c

Re: [PATCH 12/26] bcache: convert to blk_alloc_disk/blk_cleanup_disk

2021-05-21 Thread Coly Li
"bcache: fix refcount underflow in bcache_device_free()"). Maybe add a parameter to blk_cleanup_disk() or checking (disk->flags & GENHD_FL_UP) inside blk_cleanup_disk() ? Coly Li > } > > bioset_exit(>bio_split); > @@ -946,7 +942,7 @@ static int bcache_device_init(s

Re: [PATCH 12/26] bcache: convert to blk_alloc_disk/blk_cleanup_disk

2021-05-23 Thread Coly Li
On 5/21/21 1:51 PM, Christoph Hellwig wrote: > Convert the bcache driver to use the blk_alloc_disk and blk_cleanup_disk > helpers to simplify gendisk and request_queue allocation. > > Signed-off-by: Christoph Hellwig Acked-by: Coly Li Thanks. Coly Li > --- > drivers/md/b