[Linuxwacom-devel] [PATCH 6/6] Remove STYLUS_DEVICE_ID and friends.

2011-03-28 Thread Peter Hutterer
Their values don't have a specific meaning, so we can just use STYLUS_ID and friends instead. Signed-off-by: Peter Hutterer --- src/wcmConfig.c | 10 +- src/wcmISDV4.c | 12 ++-- src/wcmUSB.c| 28 ++-- src/xf86WacomDefs.h |8 +---

[Linuxwacom-devel] [PATCH 5/6] Remove discard_first field from DeviceStateRec

2011-03-28 Thread Peter Hutterer
Obsolete since the removal of old serial devices. Signed-off-by: Peter Hutterer --- src/wcmCommon.c |4 ++-- src/xf86WacomDefs.h |1 - 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/src/wcmCommon.c b/src/wcmCommon.c index 56b7f90..3ca8be9 100644 --- a/src/wcmCommon.c

[Linuxwacom-devel] [PATCH 4/6] usb: print invalid max value if we get one.

2011-03-28 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/wcmUSB.c |6 -- 1 files changed, 4 insertions(+), 2 deletions(-) diff --git a/src/wcmUSB.c b/src/wcmUSB.c index aadafd0..e40a671 100644 --- a/src/wcmUSB.c +++ b/src/wcmUSB.c @@ -499,7 +499,8 @@ int usbWcmGetRanges(InputInfoPtr pInfo) if (ab

[Linuxwacom-devel] [PATCH 2/6] usb: remove to superfluous linebreaks.

2011-03-28 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/wcmUSB.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) diff --git a/src/wcmUSB.c b/src/wcmUSB.c index d64e114..fc9795c 100644 --- a/src/wcmUSB.c +++ b/src/wcmUSB.c @@ -404,8 +404,7 @@ static void usbInitProtocol5(WacomCommonPtr common, cons

[Linuxwacom-devel] [PATCH 3/6] usb: swap two checks.

2011-03-28 Thread Peter Hutterer
If the absbit isn't set, don't bother with the EV_ABS ioctl. Signed-off-by: Peter Hutterer --- src/wcmUSB.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/src/wcmUSB.c b/src/wcmUSB.c index fc9795c..aadafd0 100644 --- a/src/wcmUSB.c +++ b/src/wcmUSB.c @@ -477,14 +47

[Linuxwacom-devel] [PATCH 1/6] usb: count the number of buttons instead of hardcoding them.

2011-03-28 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- src/wcmUSB.c | 35 ++- test/Makefile.am |4 ++- test/usb-tests.c | 97 ++ 3 files changed, 125 insertions(+), 11 deletions(-) create mode 100644 test/usb-tests.c diff --git a/src/wc

[Linuxwacom-devel] [PATCH v2] Resolve the oldHwProx puzzle

2011-03-28 Thread Ping Cheng
Change oldHwProx to oldCursorHwProx to better reflect its use. oldCursorHwProx keeps the hardware in/out prox state so we can set the MaxCursorDist for the next round of relative cursor movement when tool first comes in prox. For Protocol 5 devices, distance is reported as the maximum when tool i

Re: [Linuxwacom-devel] [PATCH v2] ISDV4: use libudev instead of manual syspath creation.

2011-03-28 Thread Ping Cheng
Acked-by: Ping Cheng Ping On Sun, Mar 27, 2011 at 11:10 PM, Peter Hutterer wrote: > Signed-off-by: Peter Hutterer > --- > Changes to v1: > - check for libudev, not udev > - link test case with libudev > - use udev_device_get_syspath to get full /sys path > - typo fix (Optain → Obtain) > > test

Re: [Linuxwacom-devel] Area Option Relative

2011-03-28 Thread Jason Gerecke
On Sun, Mar 27, 2011 at 1:56 AM, Cedric Sodhi wrote: > I'm not sure whether Area has a different effect than (Top|Bottom)(X|Y) > used to have, as I don't have the old version to compare. Again the > problem: > > If I set the same "Area" on two different screen sizes, it has two > different effects

[Linuxwacom-devel] [PATCH] Change hardcoded string to already-defined constant

2011-03-28 Thread Jason Gerecke
WACOM_PROP_BUTTON_ACTIONS is already defined in wacom-properties.h Lets use it instead of all those magic constants. Signed-off-by: Jason Gerecke --- tools/xsetwacom.c |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff --git a/tools/xsetwacom.c b/tools/xsetwacom.c index 9df0403

Re: [Linuxwacom-devel] [PATCH 2/4] Make parse error more helpful

2011-03-28 Thread Jason Gerecke
On Sun, Mar 27, 2011 at 10:25 PM, Peter Hutterer wrote: > On Thu, Mar 24, 2011 at 06:02:54PM -0700, Jason Gerecke wrote: >> When a set of arguments cannot be parsed, knowing the word that >> did not make sense doesn't help if you've used it more than once. >> >> Signed-off-by: Jason Gerecke >> --