Re: [pfSense] Very slow traffic from other VM's through pfSense on XenServer

2014-12-27 Thread Morten Christensen


Den 22-12-2014 kl. 20:43 skrev Morten Christensen:


Den 20-12-2014 23:33, Morten Christensen skrev:
I have 2 XenServers, 1 with XenServer 6.2 and one with Xenserver 
Creedence beta 3.


Both have a pfSense 2.2 RC as router/firewall and a couple of Ubuntu 
Linux VM's and a windows-VM.


Traffic through both the physical xenserver-box and the virtual 
pfSense firewall goes at expected speeds.
But traffic from the other VM's on the same server through the 
pfSense out on wan/internet goes very, very slow.

It goes so bad they cannot update themselve with apt-get.

When I try with iperf from a linux VM through the pfSense's WAN the 
speed is 3,82 KBits/sec.
The VM's and pfSense are connected with an internal single-server 
network (as OPT1), and tests to iperf server run on pfSense from a 
linux VM shows gigabit-speed.


One of the pfSense' has xen-tools installed. The other has not. I 
cannot se improvements with the tools installed.


One of my XenServers can get several public IP'numbers. On that I now 
have installed VM's with both an IPCop firewall and a Zentyal firewall.
When one of those new firewall-VMs' is default gateway for the 
ordinary VM's on the XenServer, theirm...@moseboelle.dk is normal.


So it must be a configuration-problem om pfSense.

Still no ideas how to find the problem ?


Tried to install a pfSense 2.1.5 as VM.
With 2.1.5 as default gateway other VM's on the Xenserver have normal 
wan/internet-speed.


But very slow speeed through 2.2RC continues.

--
Morten Christensen
___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list


[pfSense] Very slow traffic from other VM's through pfSense on XenServer

2014-12-22 Thread Morten Christensen


Den 20-12-2014 23:33, Morten Christensen skrev:
I have 2 XenServers, 1 with XenServer 6.2 and one with Xenserver 
Creedence beta 3.


Both have a pfSense 2.2 RC as router/firewall and a couple of Ubuntu 
Linux VM's and a windows-VM.


Traffic through both the physical xenserver-box and the virtual 
pfSense firewall goes at expected speeds.
But traffic from the other VM's on the same server through the pfSense 
out on wan/internet goes very, very slow.

It goes so bad they cannot update themselve with apt-get.

When I try with iperf from a linux VM through the pfSense's WAN the 
speed is 3,82 KBits/sec.
The VM's and pfSense are connected with an internal single-server 
network (as OPT1), and tests to iperf server run on pfSense from a 
linux VM shows gigabit-speed.


One of the pfSense' has xen-tools installed. The other has not. I 
cannot se improvements with the tools installed.


One of my XenServers can get several public IP'numbers. On that I now 
have installed VM's with both an IPCop firewall and a Zentyal firewall.
When one of those new firewall-VMs' is default gateway for the ordinary 
VM's on the XenServer, their wan/internet-speed is normal.


So it must be a configuration-problem om pfSense.

Still no ideas how to find the problem ?


--
Morten Christensen
___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list


[pfSense] Very slow traffic from other VM's through pfSense on XenServer

2014-12-20 Thread Morten Christensen
I have 2 XenServers, 1 with XenServer 6.2 and one with Xenserver 
Creedence beta 3.


Both have a pfSense 2.2 RC as router/firewall and a couple of Ubuntu 
Linux VM's and a windows-VM.


Traffic through both the physical xenserver-box and the virtual pfSense 
firewall goes at expected speeds.
But traffic from the other VM's on the same server through the pfSense 
out on wan/internet goes very, very slow.

It goes so bad they cannot update themselve with apt-get.

When I try with iperf from a linux VM through the pfSense's WAN the 
speed is 3,82 KBits/sec.
The VM's and pfSense are connected with an internal single-server 
network (as OPT1), and tests to iperf server run on pfSense from a linux 
VM shows gigabit-speed.


One of the pfSense' has xen-tools installed. The other has not. I cannot 
se improvements with the tools installed.


Anobody with experience on pfSence and XenServer, that can give me in a 
direction to experiment in?



--
Morten Christensen
___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list