Re: [pfSense] Dependencies on older packages?

2014-06-15 Thread Volker Kuhlmann
On Wed 11 Jun 2014 22:41:55 NZST +1200, Brian Candler wrote:

 pkg_add: warning: package 'libidn-1.22' requires
 'libiconv-1.13.1_2', but 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'libidn-1.22' requires 'gettext-0.18.1.1',
 but 'gettext-0.18.3' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires
 'libiconv-1.13.1_2', but 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires
 'gettext-0.18.1.1', but 'gettext-0.18.3' is installed

There are several other packages (and/or pfsense packages?) that trigger
the same warnings.

Volker

-- 
Volker Kuhlmann is list0570 with the domain in header.
http://volker.top.geek.nz/  Please do not CC list postings to me.
___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list


Re: [pfSense] Dependencies on older packages?

2014-06-11 Thread Moshe Katz
On Wed, Jun 11, 2014 at 6:41 AM, Brian Candler b.cand...@pobox.com wrote:

  I went to install wget on a pfsense ( *2.1-RELEASE*) box, and I got this:

 # pkg_add -r wget
 Fetching
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/Latest/wget.tbz...
 Done.
 Fetching
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/All/pkg-config-0.25_1.tbz...
 Done.
 Fetching
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/All/libidn-1.22.tbz...
 Done.
 pkg_add: warning: package 'libidn-1.22' requires 'libiconv-1.13.1_2', but
 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'libidn-1.22' requires 'gettext-0.18.1.1', but
 'gettext-0.18.3' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires 'libiconv-1.13.1_2',
 but 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires 'gettext-0.18.1.1', but
 'gettext-0.18.3' is installed

 It seems that the wget package is out of date, as it depends on older
 versions of packages than the ones already installed. Is this to be
 expected?

 The only other package I had installed was iperf (via the GUI).

 Thanks,

 Brian.


I'm not sure that it's a big deal, at least for wget.  On my pfSense test
machine which is currently running 2.1, I get those warnings, but wget
works just fine afterwards despite them.

Moshe

--
Moshe Katz
-- mo...@ymkatz.net
-- +1(301)867-3732
___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list

Re: [pfSense] Dependencies on older packages?

2014-06-11 Thread Renato Botelho
On Jun 11, 2014, at 7:41, Brian Candler b.cand...@pobox.com wrote:
 
 I went to install wget on a pfsense ( 2.1-RELEASE) box, and I got this:
 
 # pkg_add -r wget
 Fetching 
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/Latest/wget.tbz...
  Done.
 Fetching 
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/All/pkg-config-0.25_1.tbz...
  Done.
 Fetching 
 ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.3-release/All/libidn-1.22.tbz...
  Done.
 pkg_add: warning: package 'libidn-1.22' requires 'libiconv-1.13.1_2', but 
 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'libidn-1.22' requires 'gettext-0.18.1.1', but 
 'gettext-0.18.3' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires 'libiconv-1.13.1_2', but 
 'libiconv-1.14_1' is installed
 pkg_add: warning: package 'wget-1.13.4_1' requires 'gettext-0.18.1.1', but 
 'gettext-0.18.3' is installed
 
 It seems that the wget package is out of date, as it depends on older 
 versions of packages than the ones already installed. Is this to be expected?
 
 The only other package I had installed was iperf (via the GUI).

Yes, it’s expected. You are using a FreeBSD repo made when 8.3 was released, 
after that, ports tree received tons of updates. You can try to set PACKAGESITE 
env var pointing to 8.4-release packages or even to 8-stable and see if it 
helps. It’s just good to remember that it’s not an officially way to install 
things on pfSense.

--
Renato Botelho
http://people.freebsd.org/~garga/pubkey.asc




___
List mailing list
List@lists.pfsense.org
https://lists.pfsense.org/mailman/listinfo/list