Re: [Lldb-commits] [PATCH] D13028: [RFC] Merge dsym and dwarf test cases

2015-09-21 Thread Zachary Turner via lldb-commits
zturner added a subscriber: zturner. zturner added a comment. This is great, I've been thinking about implementing the exact same thing myself. Is it possible to remove the need to call self.build()? It seems like the the wrapped_run function could do it before invoking the actual test method.

[Lldb-commits] [PATCH] D13039: Rename clang_type_t to opaque_t.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem created this revision. brucem added a reviewer: clayborg. brucem added a subscriber: lldb-commits. This is no longer related to Clang and is just an opaque pointer to data for a compiler type. http://reviews.llvm.org/D13039 Files: include/lldb/Expression/ASTDumper.h

[Lldb-commits] [lldb] r248228 - test framework: parallel test runner sends terminate to formatter before printing to stdout

2015-09-21 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Mon Sep 21 19:15:50 2015 New Revision: 248228 URL: http://llvm.org/viewvc/llvm-project?rev=248228=rev Log: test framework: parallel test runner sends terminate to formatter before printing to stdout The parallel test runner now sends the terminate event to the formatter (if

[Lldb-commits] [PATCH] D13018: Further reduction of Clang-related header inclusion.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem created this revision. brucem added a reviewer: clayborg. brucem added a subscriber: lldb-commits. http://reviews.llvm.org/D13018 Files: include/lldb/Expression/DWARFExpression.h include/lldb/Expression/Expression.h include/lldb/Expression/ExpressionParser.h

Re: [Lldb-commits] [PATCH] D12976: Fix TestChangeProcessGroup to properly step out of sleep.

2015-09-21 Thread Tamas Berghammer via lldb-commits
tberghammer added a subscriber: tberghammer. tberghammer added a comment. I committed in the fix mentioned by Pavel as http://reviews.llvm.org/rL248146 http://reviews.llvm.org/D12976 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Vasileios Kalintiris via lldb-commits
vkalintiris created this revision. vkalintiris added a reviewer: clayborg. vkalintiris added a subscriber: lldb-commits. Normally, these macros are defined in . However, GLIBC exposes their definition through too. This change allows us to compile LLDB with non-GLIBC C libraries.

[Lldb-commits] [lldb] r248146 - Use ClangASTContext for compile units with language eLanguageTypeMipsAssembler

2015-09-21 Thread Tamas Berghammer via lldb-commits
Author: tberghammer Date: Mon Sep 21 05:08:49 2015 New Revision: 248146 URL: http://llvm.org/viewvc/llvm-project?rev=248146=rev Log: Use ClangASTContext for compile units with language eLanguageTypeMipsAssembler Both GNU AS and LLVM emits language type DW_LANG_Mips_Assembler for all assembly

Re: [Lldb-commits] [PATCH] D12954: Reduce inclusion of clang headers.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem added a comment. I downloaded a build of IWYU over the weekend, but haven't had the time to look at using it yet! I did find a couple of places where we can alter the included headers though (patch coming this week) to include less and IWYU wouldn't catch those, so I'll still do some

[Lldb-commits] [lldb] r248236 - Remove expectedFailureFreeBSD from passing test_expr_null_with_dwarf

2015-09-21 Thread Ed Maste via lldb-commits
Author: emaste Date: Mon Sep 21 20:36:21 2015 New Revision: 248236 URL: http://llvm.org/viewvc/llvm-project?rev=248236=rev Log: Remove expectedFailureFreeBSD from passing test_expr_null_with_dwarf llvm.org/pr21550 Modified: lldb/trunk/test/lang/c/anonymous/TestAnonymous.py Modified:

Re: [Lldb-commits] [PATCH] D13039: Rename clang_type_t to opaque_t.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem updated this revision to Diff 35339. brucem added a comment. Rename to opaque_compiler_type_t instead. http://reviews.llvm.org/D13039 Files: include/lldb/Expression/ASTDumper.h include/lldb/Symbol/ClangASTImporter.h include/lldb/lldb-types.h

Re: [Lldb-commits] [PATCH] D13026: Fix typos.

2015-09-21 Thread Bruce Mitchener via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL248243: Fix typos. (authored by brucem). Changed prior to commit: http://reviews.llvm.org/D13026?vs=35275=35343#toc Repository: rL LLVM http://reviews.llvm.org/D13026 Files:

[Lldb-commits] [lldb] r248243 - Fix typos.

2015-09-21 Thread Bruce Mitchener via lldb-commits
Author: brucem Date: Tue Sep 22 00:07:56 2015 New Revision: 248243 URL: http://llvm.org/viewvc/llvm-project?rev=248243=rev Log: Fix typos. Summary: Another round of minor typo fixes. Reviewers: clayborg Subscribers: lldb-commits Differential Revision: http://reviews.llvm.org/D13026 Modified:

[Lldb-commits] [PATCH] D13019: Do not use pthread_{get, set}name_np() if we don't have GLIBC.

2015-09-21 Thread Vasileios Kalintiris via lldb-commits
vkalintiris created this revision. vkalintiris added reviewers: clayborg, ovyalov. vkalintiris added a subscriber: lldb-commits. pthread_{get,set}name_np() are nonstandard GNU extensions which are included only when _GNU_SOURCE is defined under GLIBC. http://reviews.llvm.org/D13019 Files:

Re: [Lldb-commits] [PATCH] D12964: [lldb-server] No need to add pthread twice.

2015-09-21 Thread Daniel Sanders via lldb-commits
dsanders added a comment. Thanks. I've acquired a new link failure (this time on lldb-mi) since my last build so I'll commit this once I have a temporary fix in place for that and can run the tests again. http://reviews.llvm.org/D12964 ___

Re: [Lldb-commits] [PATCH] D13019: Do not use pthread_{get, set}name_np() if we don't have GLIBC.

2015-09-21 Thread Pavel Labath via lldb-commits
labath added a subscriber: labath. Comment at: source/Host/linux/HostThreadLinux.cpp:44 @@ -38,2 +43,3 @@ { +#if defined(__GLIBC__) && defined(_GNU_SOURCE) // Read /proc/$TID/comm file. While the pthread functions is a glibc extension, the presence of the

Re: [Lldb-commits] [PATCH] D13019: Do not use pthread_{get, set}name_np() if we don't have GLIBC.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem added a subscriber: brucem. brucem added a comment. This would break this feature on Android, no? http://reviews.llvm.org/D13019 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Ed Maste via lldb-commits
emaste added a comment. Yes, updated change LGTM. http://reviews.llvm.org/D13022 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D12976: Fix TestChangeProcessGroup to properly step out of sleep.

2015-09-21 Thread Chaoren Lin via lldb-commits
chaoren added a comment. Do we still need the original stepInstruction? http://reviews.llvm.org/D12976 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [lldb] r248175 - Rename GetChildClangTypeAtIndex to GetChildCompilerTypeAtIndex

2015-09-21 Thread Bruce Mitchener via lldb-commits
Author: brucem Date: Mon Sep 21 11:48:48 2015 New Revision: 248175 URL: http://llvm.org/viewvc/llvm-project?rev=248175=rev Log: Rename GetChildClangTypeAtIndex to GetChildCompilerTypeAtIndex Reviewers: clayborg Subscribers: lldb-commits Differential Revision: http://reviews.llvm.org/D13020

Re: [Lldb-commits] [PATCH] D13027: [lldb-mi] Fix unresolved reference to llvm_regcomp and llvm_regfree.

2015-09-21 Thread Daniel Sanders via lldb-commits
dsanders added a comment. It seems I spoke too soon when I said the link error went away after a clean build. This patch fixes it. http://reviews.llvm.org/D13027 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D12977: LLDB MI addition for getting process stopped at first instruction right after launch via -exec-run

2015-09-21 Thread Kirill Lapshin via lldb-commits
KLapshin added a comment. In http://reviews.llvm.org/D12977#249437, @enlight wrote: > According to the GDB-MI spec the exec-run > > command already has a **start** option. Support for the

[Lldb-commits] [lldb] r248177 - [lldb-server] No need to add pthread twice.

2015-09-21 Thread Daniel Sanders via lldb-commits
Author: dsanders Date: Mon Sep 21 12:23:22 2015 New Revision: 248177 URL: http://llvm.org/viewvc/llvm-project?rev=248177=rev Log: [lldb-server] No need to add pthread twice. Summary: Following on from r247991: pthread is in LLDB_SYSTEM_LIBS so there's no need to explicitly add it to the link.

Re: [Lldb-commits] [PATCH] D12964: [lldb-server] No need to add pthread twice.

2015-09-21 Thread Daniel Sanders via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL248177: [lldb-server] No need to add pthread twice. (authored by dsanders). Changed prior to commit: http://reviews.llvm.org/D12964?vs=35086=35277#toc Repository: rL LLVM

Re: [Lldb-commits] [PATCH] D12977: LLDB MI addition for getting process stopped at first instruction right after launch via -exec-run

2015-09-21 Thread Kirill Lapshin via lldb-commits
KLapshin added inline comments. Comment at: tools/lldb-mi/MICmdCmdExec.cpp:92 @@ +91,3 @@ +const char *pCmd = bProcessMustStopAtEntry ? "process launch -s" : "process launch"; +const lldb::ReturnStatus rtn =

[Lldb-commits] [lldb] r248179 - Fixed up the curses test results formatter to:

2015-09-21 Thread Greg Clayton via lldb-commits
Author: gclayton Date: Mon Sep 21 12:25:01 2015 New Revision: 248179 URL: http://llvm.org/viewvc/llvm-project?rev=248179=rev Log: Fixed up the curses test results formatter to: - rename "Failures" window to "Completed Tests" - Remove the extra lock that I incorrectly added to the ResultsFormatter

Re: [Lldb-commits] [PATCH] D13027: [lldb-mi] Fix unresolved reference to llvm_regcomp and llvm_regfree.

2015-09-21 Thread Kamil Rytarowski via lldb-commits
krytarowski added a comment. Thanks http://reviews.llvm.org/D13027 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Kamil Rytarowski via lldb-commits
krytarowski added a subscriber: krytarowski. krytarowski accepted this revision. krytarowski added a reviewer: krytarowski. krytarowski added a comment. You mean `O_RDWR`, not `O_RDRW`. The patch is correct on NetBSD. http://reviews.llvm.org/D13022

Re: [Lldb-commits] [PATCH] D13020: Rename GetChildClangTypeAtIndex to GetChildCompilerTypeAtIndex

2015-09-21 Thread Bruce Mitchener via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL248175: Rename GetChildClangTypeAtIndex to GetChildCompilerTypeAtIndex (authored by brucem). Changed prior to commit: http://reviews.llvm.org/D13020?vs=35252=35271#toc Repository: rL LLVM

[Lldb-commits] [PATCH] D13026: Fix typos.

2015-09-21 Thread Bruce Mitchener via lldb-commits
brucem created this revision. brucem added a reviewer: clayborg. brucem added a subscriber: lldb-commits. Another round of minor typo fixes. http://reviews.llvm.org/D13026 Files: examples/python/symbolication.py examples/summaries/cocoa/CFArray.py examples/synthetic/gnu_libstdcpp.py

Re: [Lldb-commits] [PATCH] D13018: Further reduction of Clang-related header inclusion.

2015-09-21 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. http://reviews.llvm.org/D13018 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D12964: [lldb-server] No need to add pthread twice.

2015-09-21 Thread Daniel Sanders via lldb-commits
dsanders added a comment. 'ninja clean' seems to have made the lldb-mi link failure go away. Presumably something didn't rebuild when the references to llvm_regcomp and llvm_regfree were added. I'll run the lldb tests and then commit this. http://reviews.llvm.org/D12964

Re: [Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. Looks good. http://reviews.llvm.org/D13022 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D13020: Rename GetChildClangTypeAtIndex to GetChildCompilerTypeAtIndex

2015-09-21 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. http://reviews.llvm.org/D13020 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [lldb] r248176 - Further reduction of Clang-related header inclusion.

2015-09-21 Thread Bruce Mitchener via lldb-commits
Author: brucem Date: Mon Sep 21 11:56:08 2015 New Revision: 248176 URL: http://llvm.org/viewvc/llvm-project?rev=248176=rev Log: Further reduction of Clang-related header inclusion. Reviewers: clayborg Subscribers: lldb-commits Differential Revision: http://reviews.llvm.org/D13018 Modified:

Re: [Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Vasileios Kalintiris via lldb-commits
vkalintiris updated this revision to Diff 35258. vkalintiris updated the summary for this revision. vkalintiris added a comment. Use fcntl.h instead of sys/fcntl.h. http://reviews.llvm.org/D13022 Files: source/Core/ConnectionSharedMemory.cpp Index: source/Core/ConnectionSharedMemory.cpp

Re: [Lldb-commits] [PATCH] D13022: Use fcntl.h to retrieve the O_CREAT and O_RDRW constants.

2015-09-21 Thread Vasileios Kalintiris via lldb-commits
vkalintiris added a comment. In http://reviews.llvm.org/D13022#249823, @emaste wrote: > Although it ought to remain on the same line, no? It shouldn't matter in this case. I just followed the order of the headers in the synopsis section of shm_open(3) on my system. However, I noticed that we

Re: [Lldb-commits] [PATCH] D13028: [RFC] Merge dsym and dwarf test cases

2015-09-21 Thread Ed Maste via lldb-commits
emaste added a comment. Haven't reviewed in depth yet but in general I really like this idea. Comment at: test/lldbtest.py:524 @@ +523,3 @@ +def no_debug_info_test(func): +"""Decorate the item as a test what don't use any debug info. If this annotation is specified +

Re: [Lldb-commits] [PATCH] D13028: [RFC] Merge dsym and dwarf test cases

2015-09-21 Thread Greg Clayton via lldb-commits
clayborg added a comment. I like the idea. One question I have is if tests should opt in to multi-debug, or if tests should opt out. This solution does the opt out method. Would it be better to opt in? With something like: @debug_info_test def test_stuff(self): # ... I am fine with

Re: [Lldb-commits] [PATCH] D13028: [RFC] Merge dsym and dwarf test cases

2015-09-21 Thread Greg Clayton via lldb-commits
clayborg added a comment. Also if the compiler doesn't support the different modes do we avoid mutating the classes? Or if we disable the extra DWARF in .o file mode (be it DWO or Apple) do we avoid mutating the classes? http://reviews.llvm.org/D13028

Re: [Lldb-commits] [PATCH] D12936: Groundwork for better tracking of renderscript allocations and scripts.

2015-09-21 Thread Ewan Crawford via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL248149: Groundwork for better tracking of renderscript allocations and scripts (authored by EwanCrawford). Changed prior to commit: http://reviews.llvm.org/D12936?vs=34996=35224#toc Repository: rL

[Lldb-commits] [lldb] r248149 - Groundwork for better tracking of renderscript allocations and scripts

2015-09-21 Thread Ewan Crawford via lldb-commits
Author: ewancrawford Date: Mon Sep 21 05:53:18 2015 New Revision: 248149 URL: http://llvm.org/viewvc/llvm-project?rev=248149=rev Log: Groundwork for better tracking of renderscript allocations and scripts This patch adds some of the groundwork required for tracking the lifetime of scripts and

Re: [Lldb-commits] [PATCH] D12809: Better scheme to lookup alternate mangled name when looking up function address.

2015-09-21 Thread Siva Chandra via lldb-commits
sivachandra added a comment. Ping. The patch in its current state will require a rebase. However, any suggestions on how to take this forward would be great. I can rebase and make modifications together. http://reviews.llvm.org/D12809 ___