Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Zachary Turner via lldb-commits
Here is the example I was thinking of: https://reviews.llvm.org/D24013 It didn't yet get submitted, so you can see the current code by looking at GDBRemoteCommunicationClient.cpp lines 381-420. The shortened code is in the above patch. But here they are for reference: Before: // Look for

[Lldb-commits] [lldb] r281291 - Reduce the number of simultaneous debug sessions to 10 and remove

2016-09-12 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Mon Sep 12 21:45:45 2016 New Revision: 281291 URL: http://llvm.org/viewvc/llvm-project?rev=281291=rev Log: Reduce the number of simultaneous debug sessions to 10 and remove the expectedFlakeyDarwin annotation. I've been running this test in isolation on my macOS Sierra

Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Zachary Turner via lldb-commits
The StringRef does in fact store a length. So if you write this: std::string S("This is a test"); StringRef R(S); Then R internally contains const char *Ptr = "This is a test" size_t Len = 14 This makes repeated operations on StringRefs really fast (and efficient), because there's no copying

[Lldb-commits] [lldb] r281288 - Add a few const's (thanks Zachary) and return shared or unique pointers

2016-09-12 Thread Jim Ingham via lldb-commits
Author: jingham Date: Mon Sep 12 20:58:08 2016 New Revision: 281288 URL: http://llvm.org/viewvc/llvm-project?rev=281288=rev Log: Add a few const's (thanks Zachary) and return shared or unique pointers in places where they help prevent leaks. Modified:

Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Jim Ingham via lldb-commits
BTW, I was going over these, and this does not seem to me like a case where you want to do an early return. The logic is: Add some stuff to data See if I found the UserSource key, if so add some more stuff Then return data It would not be clearer to do: Add some stuff to data See if I found

Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Jim Ingham via lldb-commits
I see the whole content, but I'll reply to this one so the reply doesn't get truncated on your end... > On Sep 12, 2016, at 6:03 PM, Zachary Turner wrote: > > > Immediately, very little. A small amount of performance, since comparing > StringRefs is faster than comparing

Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Zachary Turner via lldb-commits
> > > Immediately, very little. A small amount of performance, since comparing > StringRefs is faster than comparing null terminated stings, since the > length is stored with the string it can use memcmp instead of strcmp. > > From a big picture perspective, quite a lot IMO. StringRef has

Re: [Lldb-commits] [lldb] r281273 - This is the main part of a change to add breakpoint save and restore to lldb.

2016-09-12 Thread Jim Ingham via lldb-commits
> On Sep 12, 2016, at 4:57 PM, Zachary Turner wrote: > > > > On Mon, Sep 12, 2016 at 4:19 PM Jim Ingham via lldb-commits > wrote: > Author: jingham > Date: Mon Sep 12 18:10:56 2016 > New Revision: 281273 > > URL:

[Lldb-commits] [lldb] r281282 - Fix an issue where LLDB was not masking enough bits off of objc classes data() pointers, effectively rendering us unable to generate descriptors for some classes

2016-09-12 Thread Enrico Granata via lldb-commits
Author: enrico Date: Mon Sep 12 19:22:49 2016 New Revision: 281282 URL: http://llvm.org/viewvc/llvm-project?rev=281282=rev Log: Fix an issue where LLDB was not masking enough bits off of objc classes data() pointers, effectively rendering us unable to generate descriptors for some classes

[Lldb-commits] [lldb] r281251 - xfail TestQueues.py and TestDarwinLogFilterMatchMessage.py

2016-09-12 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Mon Sep 12 15:23:13 2016 New Revision: 281251 URL: http://llvm.org/viewvc/llvm-project?rev=281251=rev Log: xfail TestQueues.py and TestDarwinLogFilterMatchMessage.py It looks like the message-content-retrieval aspect of DarwinLog support is flaky, not just the regex match

Re: [Lldb-commits] [PATCH] D24202: [lldb-mi] Fix parsing expressions to evaluate with spaces and optional args

2016-09-12 Thread Ed Munoz via lldb-commits
edmunoz added a comment. In https://reviews.llvm.org/D24202#539629, @ki.stfu wrote: > lgtm > > @edmunoz, good job. Thank you! Would you like me to commit? Thanks! Yes, go ahead. Repository: rL LLVM https://reviews.llvm.org/D24202 ___

[Lldb-commits] [lldb] r281243 - fix Xcode build after r281226

2016-09-12 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Mon Sep 12 13:49:22 2016 New Revision: 281243 URL: http://llvm.org/viewvc/llvm-project?rev=281243=rev Log: fix Xcode build after r281226 Modified: lldb/trunk/tools/debugserver/debugserver.xcodeproj/project.pbxproj Modified:

Re: [Lldb-commits] [PATCH] D23883: Remove MIUtilParse (no longer used)

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu accepted this revision. ki.stfu added a comment. This revision is now accepted and ready to land. lgtm https://reviews.llvm.org/D23883 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D20835: Mark the current column when displaying the context of the current breakpoint on the terminal.

2016-09-12 Thread Todd Fiala via lldb-commits
tfiala added a comment. This will unfortunately get a little messy due to the code reformatting. My first patch up for it will be to get the existing impl refreshed for the code reformatting. https://reviews.llvm.org/D20835 ___ lldb-commits

Re: [Lldb-commits] [PATCH] D20835: Mark the current column when displaying the context of the current breakpoint on the terminal.

2016-09-12 Thread Todd Fiala via lldb-commits
tfiala reclaimed this revision. tfiala added a comment. This revision is now accepted and ready to land. Reclaiming. I'll be working on this now. https://reviews.llvm.org/D20835 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D23747: Fix broken macOS LLDB build from r279314

2016-09-12 Thread Todd Fiala via lldb-commits
tfiala closed this revision. tfiala added a comment. Closing - this was submitted a few weeks ago. https://reviews.llvm.org/D23747 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Re: [Lldb-commits] [PATCH] D23747: Fix broken macOS LLDB build from r279314

2016-09-12 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a reviewer: tfiala. tfiala added a comment. This revision is now accepted and ready to land. Accepting so this can be closed. https://reviews.llvm.org/D23747 ___ lldb-commits mailing list

Re: [Lldb-commits] [PATCH] D23883: Remove MIUtilParse (no longer used)

2016-09-12 Thread Jim Ingham via lldb-commits
> On Sep 10, 2016, at 11:26 PM, Zachary Turner via lldb-commits > wrote: > > I don't think requiring user install of six would work, lldb should just work > out of the box. Renaming it to lldb_six might work. > > Also yes using llvm regex everywhere would be

Re: [Lldb-commits] [PATCH] D24385: MinidumpParsing: pid, modules, exceptions

2016-09-12 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: source/Plugins/Process/minidump/MinidumpParser.cpp:222 @@ -154,1 +221,2 @@ + return MinidumpExceptionStream::Parse(data); } dvlahovski wrote: > Now that I return an ArrayRef, which is basically a reinterpret > cast of

Re: [Lldb-commits] [PATCH] D24385: MinidumpParsing: pid, modules, exceptions

2016-09-12 Thread Dimitar Vlahovski via lldb-commits
dvlahovski added inline comments. Comment at: source/Plugins/Process/minidump/MinidumpParser.cpp:222 @@ -154,1 +221,2 @@ + return MinidumpExceptionStream::Parse(data); } Now that I return an ArrayRef, which is basically a reinterpret cast of a piece of memory

Re: [Lldb-commits] [PATCH] D24385: MinidumpParsing: pid, modules, exceptions

2016-09-12 Thread Dimitar Vlahovski via lldb-commits
dvlahovski updated this revision to Diff 71026. dvlahovski marked 17 inline comments as done. dvlahovski added a comment. Herald added subscribers: mgorny, srhines, danalbert, tberghammer. Changes regarding all of the comments. Removed llvm::Optionals where it was unneeded. Parsing also the OS

[Lldb-commits] [lldb] r281226 - Move StdStringExtractor to tools/debugserver

2016-09-12 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Sep 12 11:13:05 2016 New Revision: 281226 URL: http://llvm.org/viewvc/llvm-project?rev=281226=rev Log: Move StdStringExtractor to tools/debugserver The class is only used in the debugserver. The rest of lldb has the StringExtractor class. Xcode project will need to be

Re: [Lldb-commits] [PATCH] D24385: MinidumpParsing: pid, modules, exceptions

2016-09-12 Thread Adrian McCarthy via lldb-commits
> Even if it's length prefixed, the logic here basically just consumes the entire buffer, which doesn't seem right Yes, agreed. On Fri, Sep 9, 2016 at 5:45 PM, Zachary Turner wrote: > Even if it's length prefixed, the logic here basically just consumes the > entire buffer,

Re: [Lldb-commits] [PATCH] D23883: Remove MIUtilParse (no longer used)

2016-09-12 Thread Michał Górny via lldb-commits
mgorny added a comment. In https://reviews.llvm.org/D23883#539611, @ki.stfu wrote: > You forgot to remove its header file Thanks for noticing. Fixed now. https://reviews.llvm.org/D23883 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D23883: Remove MIUtilParse (no longer used)

2016-09-12 Thread Pavel Labath via lldb-commits
labath added a comment. @mgorny: The change should be reviewed by an lldb-mi maintainer (i.e., @ki.stfu). It helps is you explicitly specify the reviewer, as otherwise the person may not notice the patch. In https://reviews.llvm.org/D23883#539471, @mgorny wrote: > In

Re: [Lldb-commits] [PATCH] D23883: Remove MIUtilParse (no longer used)

2016-09-12 Thread Michał Górny via lldb-commits
mgorny updated this revision to Diff 70997. Herald added subscribers: mgorny, beanz. https://reviews.llvm.org/D23883 Files: tools/lldb-mi/CMakeLists.txt tools/lldb-mi/MIUtilParse.cpp tools/lldb-mi/MIUtilParse.h Index: tools/lldb-mi/MIUtilParse.h

[Lldb-commits] [lldb] r281199 - Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI)

2016-09-12 Thread Ilia K via lldb-commits
Author: ki.stfu Date: Mon Sep 12 02:14:51 2016 New Revision: 281199 URL: http://llvm.org/viewvc/llvm-project?rev=281199=rev Log: Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI) Summary: This patch adds a new test and fixes extra new-line before exit Reviewers: abidh Subscribers:

Re: [Lldb-commits] [PATCH] D9740: Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI)

2016-09-12 Thread Ilia K via lldb-commits
This revision was automatically updated to reflect the committed changes. ki.stfu marked an inline comment as done. Closed by commit rL281199: Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI) (authored by ki.stfu). Changed prior to commit:

Re: [Lldb-commits] [PATCH] D9740: Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI)

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu updated this revision to Diff 70979. ki.stfu marked 6 inline comments as done. ki.stfu added a comment. Rebase against ToT; Apply autopep8 https://reviews.llvm.org/D9740 Files: packages/Python/lldbsuite/test/tools/lldb-mi/syntax/TestMiSyntax.py tools/lldb-mi/MIDriver.cpp Index:

Re: [Lldb-commits] [PATCH] D9740: Add MiSyntaxTestCase.test_lldbmi_output_grammar test (MI)

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu updated this revision to Diff 70977. ki.stfu added a comment. Herald added a subscriber: ki.stfu. Rebase against ToT https://reviews.llvm.org/D9740 Files: packages/Python/lldbsuite/test/tools/lldb-mi/syntax/TestMiSyntax.py tools/lldb-mi/MIDriver.cpp Index:

Re: [Lldb-commits] [PATCH] D24202: [lldb-mi] Fix parsing expressions to evaluate with spaces and optional args

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu accepted this revision. ki.stfu added a comment. This revision is now accepted and ready to land. lgtm @edmunoz, good job. Thank you! Would you like me to commit? Repository: rL LLVM https://reviews.llvm.org/D24202 ___ lldb-commits

Re: [Lldb-commits] [PATCH] D23026: [LLDB-MI] removing requirement of a parameter for -break-insert's -f flag

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu added a comment. PS: I think it will look like: Index: tools/lldb-mi/MICmdCmdBreak.cpp === --- tools/lldb-mi/MICmdCmdBreak.cpp (revision 281191) +++ tools/lldb-mi/MICmdCmdBreak.cpp (working copy) @@ -84,8 +84,7

Re: [Lldb-commits] [PATCH] D23026: [LLDB-MI] removing requirement of a parameter for -break-insert's -f flag

2016-09-12 Thread Ilia K via lldb-commits
ki.stfu requested changes to this revision. ki.stfu added a comment. This revision now requires changes to proceed. Hi @pieandcakes! I'm sorry for the delay, have a lot of work. Please folllow my inline comments, rebase against ToT and update CL's summary. Comment at: