[Lldb-commits] [PATCH] D52689: [LLDB] - Add support for DW_FORM_implicit_const.

2018-10-02 Thread Vedant Kumar via Phabricator via lldb-commits
vsk added a comment. Could you describe how the test exercises DW_FORM_implicit_const support? It's not immediately clear to me. https://reviews.llvm.org/D52689 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [lldb] r343624 - Remove unnecessary field

2018-10-02 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Tue Oct 2 13:14:12 2018 New Revision: 343624 URL: http://llvm.org/viewvc/llvm-project?rev=343624=rev Log: Remove unnecessary field Modified: lldb/trunk/packages/Python/lldbsuite/test/functionalities/target_var/globals.ll Modified:

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz added a comment. Is it ok to have so many TestEchoXY.test files? I tried to get them all in one, but so far it didn't work out. Comment at: source/Interpreter/CommandInterpreter.cpp:2733 + + const char *k_space_characters = "\t\n\v\f\r "; + size_t first_non_space

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz marked an inline comment as done. sgraenitz added inline comments. Comment at: source/Interpreter/CommandInterpreter.cpp:2733 + + const char *k_space_characters = "\t\n\v\f\r "; + size_t first_non_space = line.find_first_not_of(k_space_characters);

[Lldb-commits] [PATCH] D50478: Add support for artificial tail call frames

2018-10-02 Thread Vedant Kumar via Phabricator via lldb-commits
vsk added a comment. Friendly ping. https://reviews.llvm.org/D50478 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [PATCH] D52618: [Windows] A basic implementation of memory allocations in a debuggee process

2018-10-02 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. In https://reviews.llvm.org/D52618#1252372, @labath wrote: > In https://reviews.llvm.org/D52618#1250909, @zturner wrote: > > > One idea would be to define some lit substitutions like %debuginfo. It’s > > true you can produce a gcc style command line that will be

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz updated this revision to Diff 167995. sgraenitz added a comment. Add tests, address some of the feedback from Jim and Shafik https://reviews.llvm.org/D52788 Files: include/lldb/API/SBCommandInterpreter.h include/lldb/Interpreter/CommandInterpreter.h

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added inline comments. Comment at: source/Interpreter/CommandInterpreter.cpp:96 +{"echo-comment-commands", OptionValue::eTypeBoolean, true, true, nullptr, + {}, "If true, LLDB will print a command even if it is a pure comment " + "line."}};

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added inline comments. Comment at: source/Interpreter/CommandInterpreter.cpp:2733 + + const char *k_space_characters = "\t\n\v\f\r "; + size_t first_non_space = line.find_first_not_of(k_space_characters); This looks like duplicate code from from

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. The StopOnCrash logic is slightly different. Because the outer if is "GetStopOnCrash()" you will only set stop on crash if it is set at this level and was set in the previously pushed flag set. That forces StopOnCrash to be set from the top all the way down. For

[Lldb-commits] [PATCH] D52678: DWARFExpression: Resolve file addresses in the linked module

2018-10-02 Thread Phabricator via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rLLDB343612: DWARFExpression: Resolve file addresses in the linked module (authored by adrian, committed by ). Herald added a subscriber: teemperor. Changed prior to commit:

[Lldb-commits] [lldb] r343612 - DWARFExpression: Resolve file addresses in the linked module

2018-10-02 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Tue Oct 2 10:50:42 2018 New Revision: 343612 URL: http://llvm.org/viewvc/llvm-project?rev=343612=rev Log: DWARFExpression: Resolve file addresses in the linked module This is a follow-up to https://reviews.llvm.org/D46362. When evaluating a complex expression in

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz added inline comments. Comment at: include/lldb/Interpreter/CommandInterpreter.h:105 - bool GetStopOnError() const { return DefaultToNo(m_stop_on_continue); } + bool GetStopOnError() const { return DefaultToNo(m_stop_on_error); } Unrelated fix

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz updated this revision to Diff 167976. sgraenitz added a comment. Fix CommandInterpreterRunOptions::GetStopOnError() https://reviews.llvm.org/D52788 Files: include/lldb/API/SBCommandInterpreter.h include/lldb/Interpreter/CommandInterpreter.h source/API/SBCommandInterpreter.cpp

[Lldb-commits] [lldb] r343609 - Remove GetPythonDir declaration from HostInfoBase class

2018-10-02 Thread Tatyana Krasnukha via lldb-commits
Author: tkrasnukha Date: Tue Oct 2 10:24:58 2018 New Revision: 343609 URL: http://llvm.org/viewvc/llvm-project?rev=343609=rev Log: Remove GetPythonDir declaration from HostInfoBase class Modified: lldb/trunk/include/lldb/Host/HostInfoBase.h Modified:

[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

2018-10-02 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz created this revision. sgraenitz added reviewers: aprantl, jasonmolenda, JDevlieghere. sgraenitz added a subscriber: LLDB. Add settings to control command echoing: (lldb) settings set interpreter.echo-commands true (lldb) settings set interpreter.echo-comment-commands true Both

[Lldb-commits] [PATCH] D52678: DWARFExpression: Resolve file addresses in the linked module

2018-10-02 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. I was thinking more like if it's possible to figure out that a given module has a debug_map parent, "SetModule" could automatically redirect to the that module. Then all clients have to do is SetModule with the module they have to hand and it would get the right

[Lldb-commits] [PATCH] D52772: [Settings] Make "settings set" without a value equivalent to "settings clear"

2018-10-02 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. Would it be possible for the exporter to notice empty settings and write "settings clear" instead? I'm worried that if you have a complicated setting, and the you do: (lldb) settings set target.some-complex-setting and decide you are wrong, you don't want to change

[Lldb-commits] [PATCH] D52678: DWARFExpression: Resolve file addresses in the linked module

2018-10-02 Thread Greg Clayton via Phabricator via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Jim: we are already linking the address for the DW_OP_addr using the debug map and no .o files are currently expected to be able to link an unlinked address into a file address as nothing

[Lldb-commits] [lldb] r343598 - Delete /lldb/tmp directory created in r324484.

2018-10-02 Thread James Y Knight via lldb-commits
Author: jyknight Date: Tue Oct 2 08:41:00 2018 New Revision: 343598 URL: http://llvm.org/viewvc/llvm-project?rev=343598=rev Log: Delete /lldb/tmp directory created in r324484. Was checked into a wrong place in the depot, and untouched since. Likely created by accident. Removed: lldb/tmp/

[Lldb-commits] [PATCH] D52678: DWARFExpression: Resolve file addresses in the linked module

2018-10-02 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added a comment. I could move it further up in the same function if that is what you mean? Then it would also apply to (hypothetical local variables that refer to a DW_OP_addr). I could imagine that this might be useful in some languages that want to refer to some static type metadata.

[Lldb-commits] [PATCH] D52618: [Windows] A basic implementation of memory allocations in a debuggee process

2018-10-02 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In https://reviews.llvm.org/D52618#1250909, @zturner wrote: > One idea would be to define some lit substitutions like %debuginfo. It’s > true you can produce a gcc style command line that will be equivalent to a > clang-cl invocation but it won’t be easy. eg you’ll

[Lldb-commits] [PATCH] D52651: Add functionality to export settings

2018-10-02 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 167892. JDevlieghere marked 2 inline comments as done. JDevlieghere added a comment. Split off `settings set` change into separate review: https://reviews.llvm.org/D52772 https://reviews.llvm.org/D52651 Files: include/lldb/Interpreter/OptionValue.h

[Lldb-commits] [PATCH] D52772: [Settings] Make "settings set" without a value equivalent to "settings clear"

2018-10-02 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added a reviewer: LLDB. I want to make providing no value to `setting set ` equivalent to clearing that setting: `settings clear `. The motivation is https://reviews.llvm.org/D52651 that allows settings to be written to and read from a file. Not

[Lldb-commits] [PATCH] D52651: Add functionality to export settings

2018-10-02 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 167889. JDevlieghere added a comment. Thanks a lot for the feedback! I clearly overlooked some stuff when inspiring myself on the other CommandObject code. I've updated the diff: - Rename functionality to read and write for consistency with