[Lldb-commits] [PATCH] D65129: Test load unloading of modules with libraries-svr4

2019-07-22 Thread António Afonso via Phabricator via lldb-commits
aadsm created this revision. aadsm added reviewers: labath, clayborg, xiaobai. Herald added subscribers: lldb-commits, srhines. Herald added a project: LLDB. This doubles the 3 tests running right now on linux by also executing each test with libraries-svr4 enabled. Not sure if there's a better

[Lldb-commits] [PATCH] D64013: Correctly use GetLoadedModuleList to take advantage of libraries-svr4

2019-07-22 Thread António Afonso via Phabricator via lldb-commits
aadsm updated this revision to Diff 211241. aadsm added a comment. Handle error returned by GetLoadedModuleList Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64013/new/ https://reviews.llvm.org/D64013 Files: lldb/include/lldb/Target/Process.h

[Lldb-commits] [PATCH] D65128: [Logging] Replace Log::Printf with LLDB_LOG macro (NFC)

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In D65128#1596809 , @jingham wrote: > Actually, I don't want this change as is. Some logs - like the expression > and step logs - are laid out for readability, and LLDB_LOG automatically adds > the file & function which

[Lldb-commits] [PATCH] D65128: [Logging] Replace Log::Printf with LLDB_LOG macro (NFC)

2019-07-22 Thread Jim Ingham via Phabricator via lldb-commits
jingham requested changes to this revision. jingham added a comment. This revision now requires changes to proceed. Actually, I don't want this change as is. Some logs - like the expression and step logs - are laid out for readability, and LLDB_LOG automatically adds the file & function which

[Lldb-commits] [PATCH] D65128: [Logging] Replace Log::Printf with LLDB_LOG macro (NFC)

2019-07-22 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. IIUC, LLDB_LOG already adds the file and function. A bunch of these logs are also adding __FUNCTION__, so that's probably going to come out twice now. You should probably remove the duplicates. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D65128: [Logging] Replace Log::Printf with LLDB_LOG macro (NFC)

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: jasonmolenda, jingham, labath. Herald added subscribers: teemperor, atanasyan, MaskRay, kbarton, fedor.sergeev, arichardson, javed.absar, nemanjai, sdardis, emaste, srhines. Herald added a reviewer: martong. Herald added a

[Lldb-commits] [PATCH] D64583: [lldb][test_suite] Fix skipIfTargetAndroid decorator

2019-07-22 Thread Alex Langford via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL366771: [lldb][test_suite] Fix skipIfTargetAndroid decorator (authored by xiaobai, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit:

[Lldb-commits] [lldb] r366771 - [lldb][test_suite] Fix skipIfTargetAndroid decorator

2019-07-22 Thread Alex Langford via lldb-commits
Author: xiaobai Date: Mon Jul 22 17:41:00 2019 New Revision: 366771 URL: http://llvm.org/viewvc/llvm-project?rev=366771=rev Log: [lldb][test_suite] Fix skipIfTargetAndroid decorator Summary: Delete the duplicate func `skipIfTargetAndroid` Fix the old one. It didn't work for missing an argument

[Lldb-commits] [PATCH] D64771: [lldb][test_suite] skip tests of `libstdcpp` on Android and clean up

2019-07-22 Thread Alex Langford via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL366770: [lldb][test_suite] skip tests of `libstdcpp` on Android and clean up (authored by xiaobai, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to

[Lldb-commits] [lldb] r366770 - [lldb][test_suite] skip tests of `libstdcpp` on Android and clean up

2019-07-22 Thread Alex Langford via lldb-commits
Author: xiaobai Date: Mon Jul 22 17:28:26 2019 New Revision: 366770 URL: http://llvm.org/viewvc/llvm-project?rev=366770=rev Log: [lldb][test_suite] skip tests of `libstdcpp` on Android and clean up Summary: Delete the android target from `libstdcpp` test category, since android no longer

[Lldb-commits] [lldb] r366768 - [Logging] Replace LogIfAnyCategoriesSet with LLDB_LOG.

2019-07-22 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jul 22 16:48:01 2019 New Revision: 366768 URL: http://llvm.org/viewvc/llvm-project?rev=366768=rev Log: [Logging] Replace LogIfAnyCategoriesSet with LLDB_LOG. This patch removes any remaining instances of LogIfAnyCategoriesSet and replaces them with the LLDB_LOG

[Lldb-commits] [PATCH] D65122: [Symbol] Use llvm::Expected when getting TypeSystems

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: source/Breakpoint/Watchpoint.cpp:45 + if (log) +log->Printf( +"Watchpoint::Watchpoint(): Failed to set type.\nReason: %s",

[Lldb-commits] [PATCH] D64881: [Cmake] Use the modern way to find Python when possible

2019-07-22 Thread Hans Wennborg via Phabricator via lldb-commits
hans added a comment. In D64881#1590204 , @amccarth wrote: > An aside ... > > I'm still trying to get back to a buildable state the earlier changes, like > the one that tries to enforce version consistency between the libs and the > interpreter. I'm

[Lldb-commits] [PATCH] D65123: Restore tests for lldb-server and lldb-vscode removed at rL366590

2019-07-22 Thread Alex Langford via Phabricator via lldb-commits
xiaobai accepted this revision. xiaobai added a comment. This revision is now accepted and ready to land. Thanks for restoring them. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D65123/new/ https://reviews.llvm.org/D65123

[Lldb-commits] [PATCH] D64995: [lldb] Fix crash when tab-completing in multi-line expr

2019-07-22 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added a comment. Also once we get one test going then it should be easy to add coverage for all sorts of scenarios. Who knows maybe we will find more bugs. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64995/new/ https://reviews.llvm.org/D64995

[Lldb-commits] [PATCH] D64992: [lldb][NFC] Cleanup mentions and code related to lldb-mi

2019-07-22 Thread António Afonso via Phabricator via lldb-commits
aadsm added a comment. @teemperor This diff deleted all lldb-server and lldb-vscode tests :( Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64992/new/ https://reviews.llvm.org/D64992 ___ lldb-commits

[Lldb-commits] [PATCH] D65122: [Symbol] Use llvm::Expected when getting TypeSystems

2019-07-22 Thread Alex Langford via Phabricator via lldb-commits
xiaobai created this revision. xiaobai added reviewers: JDevlieghere, davide, compnerd. Herald added a subscriber: jdoerfert. This commit achieves the following: - Functions used to return a `TypeSystem *` return an `llvm::Expected` now. This means that the result of a call is always checked,

[Lldb-commits] [lldb] r366745 - Remove Xcode project remnants

2019-07-22 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jul 22 14:51:04 2019 New Revision: 366745 URL: http://llvm.org/viewvc/llvm-project?rev=366745=rev Log: Remove Xcode project remnants Removed: lldb/trunk/scripts/generate-vers.pl Modified: lldb/trunk/tools/debugserver/source/CMakeLists.txt Removed:

[Lldb-commits] [lldb] r366742 - Remove INSTALL.txt file

2019-07-22 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jul 22 14:33:43 2019 New Revision: 366742 URL: http://llvm.org/viewvc/llvm-project?rev=366742=rev Log: Remove INSTALL.txt file Its contents are stale and much better documentation can be found either online or in the docs directory. Removed:

[Lldb-commits] [lldb] r366741 - [Docs] Remove stale documentation

2019-07-22 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jul 22 14:26:50 2019 New Revision: 366741 URL: http://llvm.org/viewvc/llvm-project?rev=366741=rev Log: [Docs] Remove stale documentation This removes a stale piece of documentation about building LLDB with the Xcode project. Modified:

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL366739: [LLDB] Remove the Xcode project (authored by JDevlieghere, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit:

[Lldb-commits] [lldb] r366739 - [LLDB] Remove the Xcode project

2019-07-22 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jul 22 14:20:23 2019 New Revision: 366739 URL: http://llvm.org/viewvc/llvm-project?rev=366739=rev Log: [LLDB] Remove the Xcode project Finally, after a lot of hard work from a bunch of people, we're in a state where we can unify LLDB's build system. This patch

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. Let's move the discussion about the script to D65114 . Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D65109/new/ https://reviews.llvm.org/D65109 ___

[Lldb-commits] [PATCH] D65114: [LLDB] Add utility to streamline Xcode project generation.

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: lanza, clayborg, sgraenitz, jasonmolenda. Herald added a subscriber: teemperor. Herald added a project: LLDB. JDevlieghere added a comment. Currently outstanding questions are: @clayborg > Not sure why we need two different build

[Lldb-commits] [PATCH] D65114: [LLDB] Add utility to streamline Xcode project generation.

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. Currently outstanding questions are: @clayborg > Not sure why we need two different build directories? Can we just use the > mono-repo style build and use "cmake -G Xcode"? Or is this just to appease > the Apple build process? @lanza > This could probably be

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda accepted this revision. jasonmolenda added a comment. This revision is now accepted and ready to land. LGTM. scripts/sort-pbxproj.rb can go too. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D65109/new/ https://reviews.llvm.org/D65109

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Nathan Lanza via Phabricator via lldb-commits
lanza added inline comments. Comment at: lldb/utils/xcode.py:1 +#!/usr/bin/env python + This could probably be just a 10 line `make` file that you just `make -f lldb/utils/xcode.mk`. Not sure if you guys are a fan of this method, but we tend to find it to be

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In D65109#1596294 , @clayborg wrote: > I am fine with removing the Xcode project. Others should ok it too. > > > I've included a new script to streamline the process: it creates two build > > directories in the current

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. I am fine with removing the Xcode project. Others should ok it too. > I've included a new script to streamline the process: it creates two build > directories in the current directory. The first directory is for LLVM and > Clang which uses Ninja to build. The second

[Lldb-commits] [PATCH] D64042: [Symbol] Improve Variable::GetLanguage

2019-07-22 Thread Alex Langford via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL366733: [Symbol] Improve Variable::GetLanguage (authored by xiaobai, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit:

[Lldb-commits] [lldb] r366733 - [Symbol] Improve Variable::GetLanguage

2019-07-22 Thread Alex Langford via lldb-commits
Author: xiaobai Date: Mon Jul 22 13:14:18 2019 New Revision: 366733 URL: http://llvm.org/viewvc/llvm-project?rev=366733=rev Log: [Symbol] Improve Variable::GetLanguage Summary: When trying to ascertain what language a variable belongs to, just checking the compilation unit is often not enough.

[Lldb-commits] [PATCH] D65109: [LLDB] Remove the Xcode project

2019-07-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: jingham, jasonmolenda, clayborg, sgraenitz. JDevlieghere added a project: LLDB. Herald added subscribers: teemperor, jfb, srhines. Finally, after a lot of hard work from a bunch of people, we're in a state where we can unify

[Lldb-commits] [PATCH] D64013: Correctly use GetLoadedModuleList to take advantage of libraries-svr4

2019-07-22 Thread António Afonso via Phabricator via lldb-commits
aadsm updated this revision to Diff 211141. aadsm added a comment. Address comments, also checks the LoadModules return on DynamicLoaderWindowsDYLD Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64013/new/ https://reviews.llvm.org/D64013 Files:

[Lldb-commits] [PATCH] D64042: [Symbol] Improve Variable::GetLanguage

2019-07-22 Thread Jim Ingham via Phabricator via lldb-commits
jingham accepted this revision. jingham added a comment. This revision is now accepted and ready to land. Sounds reasonable. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64042/new/ https://reviews.llvm.org/D64042 ___ lldb-commits mailing

[Lldb-commits] [PATCH] D62183: [Windows] Fix race condition between state changes

2019-07-22 Thread Adrian McCarthy via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL366703: [Windows] Fix race condition between state changes (authored by amccarth, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit:

[Lldb-commits] [lldb] r366703 - [Windows] Fix race condition between state changes

2019-07-22 Thread Adrian McCarthy via lldb-commits
Author: amccarth Date: Mon Jul 22 10:03:20 2019 New Revision: 366703 URL: http://llvm.org/viewvc/llvm-project?rev=366703=rev Log: [Windows] Fix race condition between state changes Patch by Martin Andersson (martin.anders...@evoma.se) If the process is resumed before the state is changed to

[Lldb-commits] [PATCH] D62183: [Windows] Fix race condition between state changes

2019-07-22 Thread Adrian McCarthy via Phabricator via lldb-commits
amccarth added a comment. Yes, I can submit it for you, probably in the next hour or two. Thanks for the patch! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62183/new/ https://reviews.llvm.org/D62183 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D64251: Don't depend on psutil on AIX

2019-07-22 Thread David Tenty via Phabricator via lldb-commits
daltenty updated this revision to Diff 211104. daltenty added a comment. - Fix typo in comment Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64251/new/ https://reviews.llvm.org/D64251 Files: libcxx/utils/libcxx/util.py lldb/lit/lit.cfg.py

[Lldb-commits] [lldb] r366692 - ELF: Fix a "memset clearing object of non-trivial type" warning

2019-07-22 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Jul 22 07:29:29 2019 New Revision: 366692 URL: http://llvm.org/viewvc/llvm-project?rev=366692=rev Log: ELF: Fix a "memset clearing object of non-trivial type" warning Just delete the memset as the ELFHeader constructor already zero-initializes the object. Also clean up

[Lldb-commits] [PATCH] D65025: [Symbol] Improve TypeSystemMap mutex safety

2019-07-22 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. I fear this will deadlock again now. The original reason for the m_clear_in_progress was: > r260624 | jingham | 2016-02-11 16:03:19 -0800 (Thu, 11 Feb 2016) | 14 lines > > When calling TypeSystemMap::Clear, objects being destroyed in the process of > clearing the

[Lldb-commits] [PATCH] D65089: SymbolVendor: Move compile unit handling into the SymbolFile class

2019-07-22 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. Looks good. Just one question about caching the calculated number of compile units. Comment at: source/Symbol/SymbolFile.cpp:174-182 +uint32_t SymbolFile::GetNumCompileUnits() { + std::lock_guard guard(GetModuleMutex()); + if

[Lldb-commits] [PATCH] D65089: SymbolVendor: Move compile unit handling into the SymbolFile class

2019-07-22 Thread Pavel Labath via Phabricator via lldb-commits
labath created this revision. labath added reviewers: clayborg, jingham, JDevlieghere. Herald added a subscriber: jdoerfert. SymbolFile classes are responsible for creating CompileUnit instances and they already need to have a notion of the id<->CompileUnit mapping (because of APIs like

[Lldb-commits] [lldb] r366673 - [lldb][NFC] Tablegenify breakpoint

2019-07-22 Thread Raphael Isemann via lldb-commits
Author: teemperor Date: Mon Jul 22 03:02:09 2019 New Revision: 366673 URL: http://llvm.org/viewvc/llvm-project?rev=366673=rev Log: [lldb][NFC] Tablegenify breakpoint Modified: lldb/trunk/source/Commands/CommandObjectBreakpoint.cpp