[Lldb-commits] [PATCH] D69320: [lldb] [Python] Do not attempt to flush() a read-only fd

2019-10-22 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. Same here, I cannot commit. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D69320/new/ https://reviews.llvm.org/D69320 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D69320: [lldb] [Python] Do not attempt to flush() a read-only fd

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. In D69320#1718288 , @mgorny wrote: > Could you push this for me? It seems that I have missed the GitHub migration > and I didn't get commit access to the new repository. looks like i've got the same problem CHANGES

[Lldb-commits] [PATCH] D69320: [lldb] [Python] Do not attempt to flush() a read-only fd

2019-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. Could you push this for me? It seems that I have missed the GitHub migration and I didn't get commit access to the new repository. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D69320/new/ https://reviews.llvm.org/D69320

[Lldb-commits] [PATCH] D69320: [lldb] [Python] Do not attempt to flush() a read-only fd

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna accepted this revision. lawrence_danna added a comment. This revision is now accepted and ready to land. LGTM CHANGES SINCE LAST ACTION https://reviews.llvm.org/D69320/new/ https://reviews.llvm.org/D69320 ___ lldb-commits mailing

[Lldb-commits] [PATCH] D69320: [lldb] [Python] Do not attempt to flush() a read-only fd

2019-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny created this revision. mgorny added reviewers: lawrence_danna, labath, krytarowski. When creating a FileSP object, do not flush() the underlying file unless it is open for writing. Attempting to flush() a read-only fd results in EBADF on NetBSD. https://reviews.llvm.org/D69320 Files:

[Lldb-commits] [PATCH] D67793: new api class: SBFile

2019-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. While looking at the other bug, I noticed something suspicious here. Comment at: lldb/trunk/source/Host/common/File.cpp:74 + .Case("r", File::eOpenOptionRead) + .Case("w", File::eOpenOptionWrite) + .Case("a", File::eOpenOptionWrite |

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. In D68856#1718240 , @mgorny wrote: > In the meantime, I found the root issue. It's in `PythonDataObjects.cpp`, > `PythonFile::ConvertToFile(bool borrowed)`. The function unconditionally > calls `flush()` on the fd.

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In the meantime, I found the root issue. It's in `PythonDataObjects.cpp`, `PythonFile::ConvertToFile(bool borrowed)`. The function unconditionally calls `flush()` on the fd. However, it's invalid to call `flush()` on stdin or — more generally — on file open only for

[Lldb-commits] [PATCH] D69230: RFC: specialized Optional for T that can represent its own invalid state

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. Seems like there's a consensus that if we have something like this it should be called `DenseOptional`, and changes to `Optional` should only make it more like `std::optional` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [lldb] 0bff9bd - [lldb] Adjust for the new class_rw_t layout.

2019-10-22 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2019-10-22T10:22:06-07:00 New Revision: 0bff9bd26e3d8b424f96f66b4297a73a873c4e53 URL: https://github.com/llvm/llvm-project/commit/0bff9bd26e3d8b424f96f66b4297a73a873c4e53 DIFF:

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. In D68856#1718096 , @lawrence_danna wrote: > now I'm stuck on this trying to install cmake. > > pkg_add: no pkg found for 'libunistring>=0.9.4', sorry. > pkg_add: Can't install dependency libunistring>=0.9.4 >

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. now I'm stuck on this trying to install cmake. pkg_add: no pkg found for 'libunistring>=0.9.4', sorry. pkg_add: Can't install dependency libunistring>=0.9.4 pkg_add: 1 package addition failed *** Error code 1 Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. In D68856#1717767 , @krytarowski wrote: > In D68856#1717683 , @lawrence_danna > wrote: > > > @mgorny > > > > I can't get anything to work. I've tried running a local VM with > >

[Lldb-commits] [PATCH] D69309: Support template instantiation in the expression evaluator

2019-10-22 Thread Jaroslav Sevcik via Phabricator via lldb-commits
jarin created this revision. Herald added subscribers: lldb-commits, arphaman, aprantl. Herald added a project: LLDB. WORK IN PROGRESS This change is mostly for discussion, it is messy and likely wrong as I am new to the lldb codebase. The goal of this exercise is to support expressions

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. For the git part you will need to install mozilla-rootcerts and follow post-install instructions, as otherwise `https://` won't work nicely. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68856/new/

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. In D68856#1717683 , @lawrence_danna wrote: > @mgorny > > I can't get anything to work. I've tried running a local VM with > virtualbox but it's networking driver crashes my kernel. I've tried a local > VM with VMware

[Lldb-commits] [PATCH] D69230: RFC: specialized Optional for T that can represent its own invalid state

2019-10-22 Thread serge via Phabricator via lldb-commits
serge-sans-paille added inline comments. Comment at: llvm/include/llvm/ADT/Optional.h:216 + OptionalStorage =(T const ) { +assert(Info::is_valid(y)); +value = y; Slight note (borrowed from [this

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. That's dedication. I wasn't able to get it to run on qemu-kvm either. Regular qemu works bit the performance is terrible. I ended installing it as a second system on my laptop. I'll try to figure it out myself. If you could suggest roughly what syscalls are involved,

[Lldb-commits] [PATCH] D68856: convert SBDebugger::***FileHandle() wrappers to native files.

2019-10-22 Thread Lawrence D'Anna via Phabricator via lldb-commits
lawrence_danna added a comment. @mgorny I can't get anything to work. I've tried running a local VM with virtualbox but it's networking driver crashes my kernel. I've tried a local VM with VMware but it won't boot netbsd. I've tried AWS but they only have netbsd 7, which is too old.

[Lldb-commits] [PATCH] D69230: RFC: specialized Optional for T that can represent its own invalid state

2019-10-22 Thread David Blaikie via Phabricator via lldb-commits
dblaikie added a comment. In D69230#1717675 , @serge-sans-paille wrote: > On a personal note, as much as I like the idea (and I really do like it), I'd > rather have llvm::optional sticking to std::optional interface. (short-ish reply, while busy with

[Lldb-commits] [PATCH] D69230: RFC: specialized Optional for T that can represent its own invalid state

2019-10-22 Thread serge via Phabricator via lldb-commits
serge-sans-paille added a comment. (keeping the ball rolling) lYou want to exploit the presence of a sentinel in the domain of values of a given type. Maybe make that explicit through the method naming instead of using the `isValid` theme. Some bibliography on the subject: