[Lldb-commits] [PATCH] D97524: [lldb] Add deref support to libc++ unique_ptr synthetic

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97524/new/ https://reviews.llvm.org/D97524

[Lldb-commits] [PATCH] D97524: [lldb] Add deref support to libc++ unique_ptr synthetic

2021-02-25 Thread Dave Lee via Phabricator via lldb-commits
kastiglione added a comment. There's pretty much nothing new here compared D97165 . Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97524/new/ https://reviews.llvm.org/D97524

[Lldb-commits] [PATCH] D97524: [lldb] Add deref support to libc++ unique_ptr synthetic

2021-02-25 Thread Dave Lee via Phabricator via lldb-commits
kastiglione created this revision. kastiglione added reviewers: teemperor, jingham, JDevlieghere. kastiglione requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Add frame variable dereference suppport to libc++ `std::unique_ptr`. This change

[Lldb-commits] [PATCH] D50299: Migrate to llvm::unique_function instead of static member functions for callbacks

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. Thanks Neal. Can you run clang-format again and upload the diff with context (`git diff -U`). Overall this looks pretty good. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D50299/new/

[Lldb-commits] [PATCH] D50299: Migrate to llvm::unique_function instead of static member functions for callbacks

2021-02-25 Thread Neal via Phabricator via lldb-commits
nealsid updated this revision to Diff 326553. nealsid added a comment. Herald added a project: LLDB. I'm updating this very old patch that I forgot about in 2018. This one removes the use of batons in the edit line callbacks, replaces typedefs with using declarations, and uses unique_function

[Lldb-commits] [PATCH] D97498: [LLDB] Support GDB remote g packet partial read

2021-02-25 Thread Muhammad Omair Javaid via Phabricator via lldb-commits
omjavaid created this revision. omjavaid added a reviewer: labath. omjavaid requested review of this revision. GDB remote protocol does not specify length of g packet for register read. It depends on remote to include all or exclude certain registers from g packet. In case a register or set of

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Med Ismail Bennani via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGb889ef4214bc: [lldb/Core] Change large function threshold variable into a setting. (authored by mib). Repository: rG LLVM Github Monorepo

[Lldb-commits] [lldb] b889ef4 - [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Med Ismail Bennani via lldb-commits
Author: Med Ismail Bennani Date: 2021-02-25T22:35:04+01:00 New Revision: b889ef4214bc6dc8880fdd4badc0dcd9a3197753 URL: https://github.com/llvm/llvm-project/commit/b889ef4214bc6dc8880fdd4badc0dcd9a3197753 DIFF:

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM. Thanks for bearing with me! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97486/new/ https://reviews.llvm.org/D97486

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 326478. mib edited the summary of this revision. mib added a comment. Address @JDevlieghere comments. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97486/new/ https://reviews.llvm.org/D97486 Files:

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: lldb/source/Core/CoreProperties.td:31 Desc<"The default frame format string to use when displaying stack frame information for threads.">; + def StopDisassemblySize: Property<"stop-disassembly-size", "UInt64">, +Global,

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 326450. mib added a comment. Renamed setting to `stop-disassembly-size`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97486/new/ https://reviews.llvm.org/D97486 Files: lldb/include/lldb/Core/Debugger.h

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: lldb/include/lldb/Core/Debugger.h:249 + uint32_t GetLargeFunctionThreshold() const; + This seems like it could have a better name, how about `DisassemblyTreshold`? If this only used when stopped (like

[Lldb-commits] [PATCH] D97486: [lldb/Core] Change large function threshold variable into a setting.

2021-02-25 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added reviewers: teemperor, JDevlieghere. mib added a project: LLDB. mib requested review of this revision. Herald added a subscriber: lldb-commits. This patch replaces the static large function threshold variable by a global debugger setting. The default threshold

[Lldb-commits] [lldb] 86c2672 - [lldb][NFC] Document ClangASTImporter

2021-02-25 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-02-25T13:25:34+01:00 New Revision: 86c267233f51c36d71c12a93d661c4195f150f05 URL: https://github.com/llvm/llvm-project/commit/86c267233f51c36d71c12a93d661c4195f150f05 DIFF:

[Lldb-commits] [lldb] 2d6b767 - [lldb][NFC] Remove some obsolete comments in ClangASTImporter.cpp

2021-02-25 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-02-25T11:44:19+01:00 New Revision: 2d6b767c1d15ec736b409370da33009de57de7f2 URL: https://github.com/llvm/llvm-project/commit/2d6b767c1d15ec736b409370da33009de57de7f2 DIFF:

[Lldb-commits] [lldb] 7cfa6e1 - [lldb] Let ClangASTImporter assert that the target AST has an external source

2021-02-25 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-02-25T11:42:14+01:00 New Revision: 7cfa6e1cc64bc41e644cfc4a43bc122790896569 URL: https://github.com/llvm/llvm-project/commit/7cfa6e1cc64bc41e644cfc4a43bc122790896569 DIFF:

[Lldb-commits] [lldb] a54f160 - Prefer /usr/bin/env xxx over /usr/bin/xxx where xxx = perl, python, awk

2021-02-25 Thread Raphael Isemann via lldb-commits
Author: Harmen Stoppels Date: 2021-02-25T11:32:27+01:00 New Revision: a54f160b3a98b91cd241a555d904a6b6453affc4 URL: https://github.com/llvm/llvm-project/commit/a54f160b3a98b91cd241a555d904a6b6453affc4 DIFF:

[Lldb-commits] [PATCH] D97449: [Diagnose] Unify MCContext and LLVMContext diagnosing

2021-02-25 Thread Yuanfang Chen via Phabricator via lldb-commits
ychen created this revision. ychen added reviewers: MaskRay, rnk, tejohnson, qcolombet, anemet. Herald added subscribers: dexonsmith, kerbowa, hiraditya, nhaehnle, jvesely. ychen requested review of this revision. Herald added projects: clang, LLDB, LLVM. Herald added subscribers: llvm-commits,

[Lldb-commits] [PATCH] D95119: Prefer /usr/bin/env xxx over /usr/bin/xxx where xxx = perl, python, awk

2021-02-25 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In D95119#2584709 , @haampie wrote: > Should this be merged? Do you have commit access? If not I can land this for you. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95119/new/ https://reviews.llvm.org/D95119

[Lldb-commits] [PATCH] D95119: Prefer /usr/bin/env xxx over /usr/bin/xxx where xxx = perl, python, awk

2021-02-25 Thread Harmen Stoppels via Phabricator via lldb-commits
haampie added a comment. I don't have commit access, would be great if you could do that for me! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95119/new/ https://reviews.llvm.org/D95119 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D95119: Prefer /usr/bin/env xxx over /usr/bin/xxx where xxx = perl, python, awk

2021-02-25 Thread Harmen Stoppels via Phabricator via lldb-commits
haampie added a comment. Should this be merged? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95119/new/ https://reviews.llvm.org/D95119 ___ lldb-commits mailing list lldb-commits@lists.llvm.org