[Lldb-commits] [PATCH] D98914: Make target.process.stop-on-sharedlibrary-events setting work

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. A few nits but the change itself looks sound. Comment at: lldb/source/Breakpoint/BreakpointOptions.cpp:457 + // If a synchronous callback is called at async

[Lldb-commits] [PATCH] D97739: Add a progress class that can track and report long running operations that happen in LLDB.

2021-03-18 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. Thanks for doing this! The event version looks pretty clean to me. I think we should go that way. I don't think we should have two ways, that seems confusing and still leaves us calling unknown user code in the middle of symbol updates... Repository: rG LLVM

[Lldb-commits] [PATCH] D98914: Make target.process.stop-on-sharedlibrary-events setting work

2021-03-18 Thread Jim Ingham via Phabricator via lldb-commits
jingham created this revision. jingham added a reviewer: JDevlieghere. jingham requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This setting is supposed to make us stop when we hit a shared library event. The shared library event

[Lldb-commits] [PATCH] D97739: Add a progress class that can track and report long running operations that happen in LLDB.

2021-03-18 Thread Greg Clayton via Phabricator via lldb-commits
clayborg updated this revision to Diff 331739. clayborg added a comment. Added support for getting progress events via SBEvent delivery. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97739/new/ https://reviews.llvm.org/D97739 Files:

[Lldb-commits] [lldb] 71c4da8 - Don't assume that stepping out of a function will land on the next line.

2021-03-18 Thread Jim Ingham via lldb-commits
Author: Jim Ingham Date: 2021-03-18T17:44:17-07:00 New Revision: 71c4da83b67a485f0cfacbce8b46eaa497df900e URL: https://github.com/llvm/llvm-project/commit/71c4da83b67a485f0cfacbce8b46eaa497df900e DIFF: https://github.com/llvm/llvm-project/commit/71c4da83b67a485f0cfacbce8b46eaa497df900e.diff

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Vedant Kumar via Phabricator via lldb-commits
vsk updated this revision to Diff 331695. vsk added a comment. - Make the test generic (not Darwin-specific) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98879/new/ https://reviews.llvm.org/D98879 Files:

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Vedant Kumar via Phabricator via lldb-commits
vsk updated this revision to Diff 331694. vsk added a comment. - Add a test. It's Darwin-specific as I couldn't work out how to pass the .dylib path to the linker in a platform-agnostic way. - Trim the comment. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 331688. mgorny added a comment. Actually wait for two signals. Store the extra info on parent signal, and use it when handling the fork. For now, the handler just detaches the child and resumes the parent. CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Michał Górny via Phabricator via lldb-commits
mgorny added inline comments. Comment at: lldb/include/lldb/Host/common/NativeProcessProtocol.h:401-404 + struct Extension { +static constexpr uint32_t fork = 1; +static constexpr uint32_t vfork = 2; + }; labath wrote: > The llvm way to do this is via

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In D98822#2635647 , @labath wrote: > Seems mostly ok. The getPidForTid business does not seem completely ideal, > though. I think it may be cleaner to keep the threads for which we have > received the creation event in some kind

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. This and the proposed test sound reasonable to me. Comment at: lldb/source/Plugins/Platform/POSIX/PlatformPOSIX.cpp:581 + // version symbol is checked. (Previously, LLDB used RTLD_NOW=2, which made + // it impossible to load such libraries (e.g.

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Vedant Kumar via Phabricator via lldb-commits
vsk added a comment. The best way I can think of to test this is to: - Make a library, T1, out of: % cat t1.c extern void use(); void f1() {} void f2() { use(); } - Make a library, T2, out of: % cat t2.c void use() {} - Link T1.dylib against T2.dylib, so that the reference to

[Lldb-commits] [PATCH] D98880: [lldb] Move Apple simulators test targets under API

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG36335fe75369: [lldb] Move Apple simulators test targets under API (authored by JDevlieghere). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [lldb] 36335fe - [lldb] Move Apple simulators test targets under API

2021-03-18 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2021-03-18T13:55:37-07:00 New Revision: 36335fe753690c20c73a48a168d4b11feb3810a8 URL: https://github.com/llvm/llvm-project/commit/36335fe753690c20c73a48a168d4b11feb3810a8 DIFF:

[Lldb-commits] [PATCH] D98880: [lldb] Move Apple simulators test targets under API

2021-03-18 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor accepted this revision. teemperor added a comment. This revision is now accepted and ready to land. LGTM, thanks! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98880/new/ https://reviews.llvm.org/D98880 ___ lldb-commits mailing

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added a comment. Thank you for adding the commentary on what `RTLD_LAZY` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98879/new/ https://reviews.llvm.org/D98879 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Seems mostly ok. The getPidForTid business does not seem completely ideal, though. I think it may be cleaner to keep the threads for which we have received the creation event in some kind of a purgatory list until we receive the corresponding parent event (which will

[Lldb-commits] [lldb] 0c208d1 - [lldb] Fix flakyness in TestGdbRemote_vContThreads

2021-03-18 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2021-03-18T20:41:55+01:00 New Revision: 0c208d1f42be3fcbca37729cafcab5e97ce0a8e2 URL: https://github.com/llvm/llvm-project/commit/0c208d1f42be3fcbca37729cafcab5e97ce0a8e2 DIFF: https://github.com/llvm/llvm-project/commit/0c208d1f42be3fcbca37729cafcab5e97ce0a8e2.diff

[Lldb-commits] [PATCH] D98886: Strip pointer authentication codes from MacOSX arc pc.

2021-03-18 Thread Justin Cohen via Phabricator via lldb-commits
justincohen created this revision. justincohen requested review of this revision. Herald added projects: LLDB, LLVM. Herald added subscribers: llvm-commits, lldb-commits. Repository: rG LLVM Github Monorepo https://reviews.llvm.org/D98886 Files: lldb/include/lldb/Target/Process.h

[Lldb-commits] [PATCH] D91679: [trace][intel-pt] Implement trace start and trace stop

2021-03-18 Thread walter erquinigo via Phabricator via lldb-commits
wallace reclaimed this revision. wallace added a comment. Changed my mind :) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D91679/new/ https://reviews.llvm.org/D91679 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D98880: [lldb] Move Apple simulators test targets under API

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 331634. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98880/new/ https://reviews.llvm.org/D98880 Files: lldb/test/API/CMakeLists.txt lldb/test/CMakeLists.txt Index: lldb/test/CMakeLists.txt

[Lldb-commits] [PATCH] D98880: [lldb] Move Apple simulators test targets under API

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added a reviewer: teemperor. Herald added a subscriber: mgorny. JDevlieghere requested review of this revision. Move the Apple simulators test targets as they only matter for the API tests. https://reviews.llvm.org/D98880 Files:

[Lldb-commits] [PATCH] D91679: [trace][intel-pt] Implement trace start and trace stop

2021-03-18 Thread walter erquinigo via Phabricator via lldb-commits
wallace abandoned this revision. wallace marked 7 inline comments as done. wallace added a comment. I'll redo this diff in smaller diffs Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D91679/new/ https://reviews.llvm.org/D91679

[Lldb-commits] [PATCH] D98842: [lldb] Make the api, shell and unit tests independent lit test suites

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 331630. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98842/new/ https://reviews.llvm.org/D98842 Files: lldb/test/API/CMakeLists.txt lldb/test/CMakeLists.txt lldb/test/Shell/CMakeLists.txt lldb/test/Unit/CMakeLists.txt

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Vedant Kumar via Phabricator via lldb-commits
vsk planned changes to this revision. vsk added a comment. Herald added a subscriber: JDevlieghere. This needs a test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98879/new/ https://reviews.llvm.org/D98879

[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY

2021-03-18 Thread Vedant Kumar via Phabricator via lldb-commits
vsk created this revision. vsk added a reviewer: jingham. Herald added a subscriber: emaste. vsk requested review of this revision. Herald added a project: LLDB. In general, it seems like the debugger should allow programs to load & run with libraries as far as possible, instead of defaulting to

[Lldb-commits] [PATCH] D98842: [lldb] Make the api, shell and unit tests independent lit test suites

2021-03-18 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 331627. JDevlieghere added a comment. Add `EXCLUDE_FROM_CHECK_ALL` to the new targets to avoid tests getting added twice. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98842/new/ https://reviews.llvm.org/D98842 Files:

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Michał Górny via Phabricator via lldb-commits
mgorny added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeProcessLinux.cpp:456 + LLDB_LOG(log, "tid {0} belongs to a different tgid {1}, assuming child", + pid, tgid.getValue()); + MonitorFork(pid, false, 0); For

[Lldb-commits] [PATCH] D98822: [lldb] follow-fork/vfork support [WIP]

2021-03-18 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 331609. mgorny added a comment. Add a helper function to get PID (TGID) from TID. Recognize fork notifications from parent (SIGTRAP) and from child (SIGSTOP with a TGID != `GetID()`) and call a helper for them. The helper doesn't do anything except for

[Lldb-commits] [PATCH] D98842: [lldb] Make the api, shell and unit tests independent lit test suites

2021-03-18 Thread Stella Stamenova via Phabricator via lldb-commits
stella.stamenova added a comment. In D98842#2634902 , @teemperor wrote: > Just gonna post a comment to point out that this apparently adds all tests > twice to `check-all` which makes the tests go kaputt (but I only messaged > Jonas directly about that,

[Lldb-commits] [PATCH] D98842: [lldb] Make the api, shell and unit tests independent lit test suites

2021-03-18 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor requested changes to this revision. teemperor added a comment. This revision now requires changes to proceed. Just gonna post a comment to point out that this apparently adds all tests twice to `check-all` which makes the tests go kaputt (but I only messaged Jonas directly about that,

[Lldb-commits] [PATCH] D98842: [lldb] Make the api, shell and unit tests independent lit test suites

2021-03-18 Thread Stella Stamenova via Phabricator via lldb-commits
stella.stamenova accepted this revision. stella.stamenova added a comment. This revision is now accepted and ready to land. Looks good as long as it doesn't break windows :O CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98842/new/ https://reviews.llvm.org/D98842

[Lldb-commits] [lldb] 68bb51a - [lldb] Fix TestAutoInstallMainExecutable.py

2021-03-18 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2021-03-18T15:20:44+01:00 New Revision: 68bb51acd572735d80d20adb2c2fc51a5cbbd88e URL: https://github.com/llvm/llvm-project/commit/68bb51acd572735d80d20adb2c2fc51a5cbbd88e DIFF: https://github.com/llvm/llvm-project/commit/68bb51acd572735d80d20adb2c2fc51a5cbbd88e.diff

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-18 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh marked an inline comment as done. kimanh added a comment. Thanks a lot for the review Pavel! I've updated the test. If it looks fine like this, could you help me to commit this change? Comment at: lldb/test/Shell/SymbolFile/DWARF/dwarf5-debug_line-file-index.s:98 +

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-18 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 331547. kimanh added a comment. Removing subprogram and base_type tags (as they are not needed for the test) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98619/new/ https://reviews.llvm.org/D98619 Files: