[Lldb-commits] [PATCH] D107470: [llvm+lldb] Remove dead-code in DWARFListTableHeader::extract modifying DWARFDataExtractor

2021-08-16 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. `DWARFDebugInfo.TestRnglistsAddressSize`, `DWARFListTableHeader.AddressSize64Offset`, and `DWARFListTableHeader.AddressSize32Offset` pass without applying the patch. Why adding them? Comment at:

[Lldb-commits] [PATCH] D106466: [llvm+lldb] Fix#2 of DW_AT_ranges DW_FORM_sec_offset not using DW_AT_rnglists_base (used by GCC)

2021-08-16 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. The code looks good, but please improve the comments and wait for approval from a more LLDB-knowledgeable person than me, Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp:441 + if (offset == 0) { +// Caller must not use this default

[Lldb-commits] [PATCH] D107470: 2/3: [llvm+lldb] Remove dead-code in DWARFListTableHeader::extract modifying DWARFDataExtractor

2021-08-13 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added inline comments. Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFListTable.h:289-291 if (Header.length()) Data = DWARFDataExtractor(Data, getHeaderOffset() + Header.length()); + Data.setAddressSize(getAddrSize()); if `Header.Length` is

[Lldb-commits] [PATCH] D106466: 3/3: [llvm+lldb] Fix#2 of DW_AT_ranges DW_FORM_sec_offset not using DW_AT_rnglists_base (used by GCC)

2021-08-11 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. In D106466#2926185 , @jankratochvil wrote: > In D106466#2922549 , @ikudrin wrote: > >> As far as I understand it, you need a specially constructed >> `llvm::DWARFDebugRnglistTable`

[Lldb-commits] [PATCH] D107470: 2/3: [llvm+lldb] Remove dead-code in DWARFListTableHeader::extract modifying DWARFDataExtractor

2021-08-11 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added inline comments. Comment at: llvm/unittests/DebugInfo/DWARF/DWARFListTableTest.cpp:128 + EXPECT_EQ(Table.getAddrSize(), 8U); + Extractor.setAddressSize(Table.getAddrSize()); + Expected List = Table.findList(Extractor, Offset); This looks odd.

[Lldb-commits] [PATCH] D106466: [llvm+lldb] 2/2: Fix#2 of DW_AT_ranges DW_FORM_sec_offset not using DW_AT_rnglists_base (used by GCC)

2021-08-03 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. As far as I understand it, you need a specially constructed `llvm::DWARFDebugRnglistTable` object so that `DWARFUnit::FindRnglistFromOffset()` can call its `findList()` method and get a list of records located at a specific offset. It looks like a newly created

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-04-06 Thread Igor Kudrin via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG714324b79ae2: [DebugInfo] Support DWARFv5 index sections. (authored by ikudrin). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75929/new/

[Lldb-commits] [PATCH] D77141: [DebugInfo] Rename section identifiers which are deprecated in DWARFv5. NFC.

2020-04-06 Thread Igor Kudrin via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGa0249fe91c7b: [DebugInfo] Rename section identifiers which are deprecated in DWARFv5. NFC. (authored by ikudrin). Changed prior to commit: https://reviews.llvm.org/D77141?vs=254802=255232#toc

[Lldb-commits] [PATCH] D77302: [DebugInfo] Rename getOffset() to getContribution(). NFC.

2020-04-05 Thread Igor Kudrin via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGf13ce15d4410: [DebugInfo] Rename getOffset() to getContribution(). NFC. (authored by ikudrin). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D77302/new/

[Lldb-commits] [PATCH] D77141: [DebugInfo] Rename section identifiers which are deprecated in DWARFv5. NFC.

2020-04-05 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 254802. ikudrin added a comment. - Rebased to the tip. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D77141/new/ https://reviews.llvm.org/D77141 Files: lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugInfo.cpp

[Lldb-commits] [PATCH] D77302: [DebugInfo] Rename getOffset() to getContribution(). NFC.

2020-04-02 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin created this revision. ikudrin added reviewers: jhenderson, dblaikie, probinson, aprantl. ikudrin added projects: LLVM, debug-info. Herald added subscribers: lldb-commits, arphaman, hiraditya. Herald added a project: LLDB. The old name was a bit misleading because the functions actually

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-04-01 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 254207. ikudrin marked an inline comment as done. ikudrin added a comment. Thanks, @jhenderson, @labath! - Added a helper function `isKnownV5SectionID()`. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75929/new/ https://reviews.llvm.org/D75929

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-31 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 253874. ikudrin marked 4 inline comments as done. ikudrin added a comment. - Updated the comment for `DWARFSectionKind`. - Simplified the storing of raw section identifiers. - Moved independent changes into separate patches. CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D77141: [DebugInfo] Rename section identifiers which are deprecated in DWARFv5. NFC.

2020-03-31 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin created this revision. ikudrin added reviewers: dblaikie, jhenderson, probinson, aprantl. ikudrin added projects: LLVM, debug-info. Herald added subscribers: lldb-commits, arphaman, hiraditya. Herald added a project: LLDB. ikudrin added a parent revision: D76067: [llvm-dwp] Refactor

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-31 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 253879. ikudrin added a comment. - Removed `DWARFUnitIndex::getVersion()` as it is related to the other patch. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75929/new/ https://reviews.llvm.org/D75929 Files:

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-19 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin marked 2 inline comments as done. ikudrin added inline comments. Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFUnitIndex.h:47-48 +// For pre-standard ones, which correspond to sections being deprecated in +// DWARFv5, the values are chosen more or less arbitrary and

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-19 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin marked 3 inline comments as done. ikudrin added a comment. In D75929#1926834 , @labath wrote: > (btw, is there a test case for the "unknown column" code path?) Yes, it is checked in `llvm/test/DebugInfo/X86/debug-cu-index-unknown-section.s`,

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-17 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 250731. ikudrin marked 8 inline comments as done. ikudrin added a comment. - Fixed messages in `llvm-dwp.cpp`. - Fixed comments in the tests. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75929/new/ https://reviews.llvm.org/D75929 Files:

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-17 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added inline comments. Comment at: llvm/tools/llvm-dwp/llvm-dwp.cpp:614 +if (CUIndex.getVersion() != 2) + return make_error("Unsupported cu_index version"); jhenderson wrote: > jhenderson wrote: > > I see the above error message starts with a

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-16 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 250537. ikudrin marked 10 inline comments as done. ikudrin added a comment. @jhenderson, thank you for the comments! - Made comments for `DWARFSectionKind`, `serializeSectionKind()` and `deserializeSectionKind()` in doxygen style. - Renamed function. -

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-16 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added inline comments. Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFUnitIndex.h:116 + // This is a parallel array of raw section IDs for columns of unknown kinds. + // This array is created only if there are items in columns ColumnKinds with + //

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-13 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. In D75929#1920691 , @dblaikie wrote: > > This is almost what you are doing right now -- the only difference is that > > the "internal" enum would no longer be internal -- it would actually match > > the on-disk format of a v5

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-12 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin updated this revision to Diff 249939. ikudrin added a comment. - Use values for clashing identifiers proposed by @dblaikie. - Convert all unknown section identifiers into a special value, `DW_SECT_EXT_unknown`; Use an optional parallel array to keep the raw values of unknown

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-11 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. In D75929#1916466 , @labath wrote: > In D75929#1916127 , @ikudrin wrote: > > > I believe that this patch is more or less compatible with any approach > > which might be taken. The idea is

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-11 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added a comment. Thanks for the links! What a coincidence... I believe that this patch is more or less compatible with any approach which might be taken. The idea is that there is a set of constants for internal use and functions to translate them to/from external representation and

[Lldb-commits] [PATCH] D75929: [DebugInfo] Support DWARFv5 index sections.

2020-03-10 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin created this revision. ikudrin added reviewers: dblaikie, probinson, jhenderson, aprantl, labath. ikudrin added projects: LLVM, debug-info. Herald added subscribers: lldb-commits, arphaman, hiraditya. Herald added a project: LLDB. DWARFv5 defines index sections in package files in a

[Lldb-commits] [PATCH] D59381: Change CompileUnit and ARanges interfaces to propagate errors

2019-12-24 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin added inline comments. Comment at: lldb/trunk/source/Plugins/SymbolFile/DWARF/DWARFDebugAranges.cpp:60 +llvm::Error error = set.extract(debug_aranges_data, ); +if (!error) + return error; @zturner, this probably should be ``` if (error)

[Lldb-commits] [PATCH] D65640: Update LLDB to follow changes in llvm::DWARFDebugNames::NameIndex (4/5)

2019-08-06 Thread Igor Kudrin via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL368033: Update LLDB to follow changes in llvm::DWARFDebugNames::NameIndex (4/5) (authored by ikudrin, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior

[Lldb-commits] [PATCH] D65640: Update LLDB to follow changes in llvm::DWARFDebugNames::NameIndex (4/5)

2019-08-02 Thread Igor Kudrin via Phabricator via lldb-commits
ikudrin created this revision. ikudrin added reviewers: dblaikie, probinson, aprantl, clayborg, labath. ikudrin added a project: LLDB. Herald added a subscriber: arphaman. ikudrin added a parent revision: D65638: Switch LLVM to use 64-bit offsets (2/5). Repository: rLLDB LLDB