Re: [Lldb-commits] [lldb] r320242 - Change uses of strncpy in debugserver to strlcpy

2017-12-11 Thread Joerg Sonnenberger via lldb-commits
On Sat, Dec 09, 2017 at 03:37:09AM -, Jason Molenda via lldb-commits wrote: > Log: > Change uses of strncpy in debugserver to strlcpy > for better safety. I don't think this is an improvement really. Many of those should be plain memcpy or protected against truncation. Joerg

Re: [Lldb-commits] [PATCH] D31367: Expression: add missing linkage to RuntimeDyld component

2017-03-30 Thread Joerg Sonnenberger via lldb-commits
On Thu, Mar 30, 2017 at 10:47:39PM +0200, Michał Górny wrote: > On czw, 2017-03-30 at 21:37 +0200, Joerg Sonnenberger wrote: > > On Thu, Mar 30, 2017 at 06:00:15PM +, Chris Bieneman via Phabricator > > wrote: > > > ExecutionEngine headers directly reference symbols from RuntimeDyld, > > > so

Re: [Lldb-commits] [PATCH] D31367: Expression: add missing linkage to RuntimeDyld component

2017-03-30 Thread Joerg Sonnenberger via lldb-commits
On Thu, Mar 30, 2017 at 06:00:15PM +, Chris Bieneman via Phabricator wrote: > ExecutionEngine headers directly reference symbols from RuntimeDyld, > so we should enforce a requirement that anyone using ExeuctionEngine > also link RuntimeDyld. This works today as expected for static archive >

[Lldb-commits] [PATCH] D25750: When invoking Terminal, don't assume the default shell

2016-10-18 Thread Joerg Sonnenberger via lldb-commits
joerg added a comment. OK, this is OSX specific, but I still think that hardcoding bash is a bad idea. Does it need anything not in `/bin/sh`? https://reviews.llvm.org/D25750 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D25750: When invoking Terminal, don't assume the default shell

2016-10-18 Thread Joerg Sonnenberger via lldb-commits
joerg added a comment. Hard-coding `/bin/bash` is not an improvement in my opinion. There are quite a few systems where this is plainly breaking things. https://reviews.llvm.org/D25750 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D23830: Add cmake option to choose whether to use the builtin demangler

2016-08-25 Thread Joerg Sonnenberger via lldb-commits
joerg accepted this revision. joerg added a reviewer: joerg. joerg added a comment. This revision is now accepted and ready to land. LGTM https://reviews.llvm.org/D23830 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [lldb] r263333 - Let's not convert from UINT32_MAX to the std::numeric_limits version.

2016-03-19 Thread Joerg Sonnenberger via lldb-commits
On Tue, Mar 15, 2016 at 09:20:17PM +, Zachary Turner via lldb-commits wrote: > Is the stdint version better somehow? I thought C++ numeric_limits were > actually preferred over the C macros. It's quite a bit shorter and more readable? That sounds like a good reason to me. Joerg

Re: [Lldb-commits] [lldb] r259611 - The compiler may use "line number 0" to indicate compiler generated goo that it can't

2016-02-04 Thread Joerg Sonnenberger via lldb-commits
On Wed, Feb 03, 2016 at 12:14:52AM +, Zachary Turner via lldb-commits wrote: > Shouldn't it be possible to force clang to generate code like this? If so > couldn't you write a test for this by stepping over a function call which > has this kind of code in it? Doesn't global inline assembler

Re: [Lldb-commits] [lldb] r258546 - Silence -Wreturn-type warnings

2016-01-23 Thread Joerg Sonnenberger via lldb-commits
On Fri, Jan 22, 2016 at 08:26:30PM -, Saleem Abdulrasool via lldb-commits wrote: > Author: compnerd > Date: Fri Jan 22 14:26:30 2016 > New Revision: 258546 > > URL: http://llvm.org/viewvc/llvm-project?rev=258546=rev > Log: > Silence -Wreturn-type warnings > > Address a couple of instances

Re: [Lldb-commits] [PATCH] D16508: NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-01-23 Thread Joerg Sonnenberger via lldb-commits
On Sat, Jan 23, 2016 at 04:02:19PM +, Kamil Rytarowski via lldb-commits wrote: > Add basic support, i386 version will be added later. I think you want to keep at least the mc_tlsbase field as well. Access to __thread variables will need it. Joerg

Re: [Lldb-commits] [lldb] r258199 - [Process] Remove dead code. All the switch cases are already covered.

2016-01-19 Thread Joerg Sonnenberger via lldb-commits
On Tue, Jan 19, 2016 at 10:11:48PM +, Zachary Turner via lldb-commits wrote: > What about this: > > switch (m_private_state.GetValue()) > { > case eStateConnected: > case eStateAttaching: > case eStateLaunching: > case eStateStopped: > case

Re: [Lldb-commits] [PATCH] D15482: Welcome to NetBSD signals

2015-12-14 Thread Joerg Sonnenberger via lldb-commits
joerg accepted this revision. joerg added a comment. This revision is now accepted and ready to land. LGTM Repository: rL LLVM http://reviews.llvm.org/D15482 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D15374: Add NetBSD support in the buildDriver and buildLibrary routines

2015-12-09 Thread Joerg Sonnenberger via lldb-commits
joerg added inline comments. Comment at: packages/Python/lldbsuite/test/lldbtest.py:2100 @@ -2099,3 +2099,3 @@ } -elif sys.platform.startswith('freebsd') or sys.platform.startswith("linux") or os.environ.get('LLDB_BUILD_TYPE') == 'Makefile': +

Re: [Lldb-commits] [PATCH] D15262: Add initial NetBSD support in lldbsuite/test/lldbtest.py

2015-12-06 Thread Joerg Sonnenberger via lldb-commits
joerg added a comment. Two small cleanups, otherwise LGTM. Comment at: packages/Python/lldbsuite/test/lldbtest.py:1328 @@ -1313,3 +1327,3 @@ cls.platformContext = _PlatformContext('DYLD_LIBRARY_PATH', 'lib', 'dylib') -elif getPlatform() == "linux" or

Re: [Lldb-commits] [PATCH] D14689: Embed libpanel(3) for NetBSD-7.0

2015-11-16 Thread Joerg Sonnenberger via lldb-commits
joerg added a comment. I'd settle for requiring ncurses for 7.0 and get libpanel into 7.1. Repository: rL LLVM http://reviews.llvm.org/D14689 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D14042: Add more NetBSD platform glue for lldb

2015-11-06 Thread Joerg Sonnenberger via lldb-commits
joerg accepted this revision. joerg added a reviewer: joerg. joerg added a comment. This revision is now accepted and ready to land. LGTM Repository: rL LLVM http://reviews.llvm.org/D14042 ___ lldb-commits mailing list

Re: [Lldb-commits] [lldb] r251107 - Disable the strict-aliasing warnings produced by gcc

2015-10-23 Thread Joerg Sonnenberger via lldb-commits
On Fri, Oct 23, 2015 at 10:34:54AM -, Tamas Berghammer via lldb-commits wrote: > Author: tberghammer > Date: Fri Oct 23 05:34:53 2015 > New Revision: 251107 > > URL: http://llvm.org/viewvc/llvm-project?rev=251107=rev > Log: > Disable the strict-aliasing warnings produced by gcc > > GCC

Re: [Lldb-commits] [PATCH] D13866: Remove more gcc warnings.

2015-10-19 Thread Joerg Sonnenberger via lldb-commits
On Mon, Oct 19, 2015 at 12:59:25PM +, Hafiz Abid Qadeer via lldb-commits wrote: > I saw following gcc warnings in 3 places and they seem to make sense. > > "comparison of unsigned expression >= 0 is always true [-Wtype-limits]" > > To fix the warnings, I have removed the offending checks.

Re: [Lldb-commits] [PATCH] D13334: Preliminary NetBSD support

2015-10-01 Thread Joerg Sonnenberger via lldb-commits
On Thu, Oct 01, 2015 at 10:41:46AM +, Pavel Labath via lldb-commits wrote: > This platform code looks like it was copy-pasted from PlatformFreeBSD. > Do you anticipate making significant changes here? > > If not, it might be a good idea to share this code with FreeBSD in some > way (in fact

Re: [Lldb-commits] [PATCH] D12746: The pipe2(2) call is supported on NetBSD

2015-09-09 Thread Joerg Sonnenberger via lldb-commits
On Thu, Sep 10, 2015 at 01:15:43AM +, Kamil Rytarowski wrote: > Linux and NetBSD versions are compatible, modulo flag values: > - O_CLOEXEC and O_NONBLOCK are the same, > - O_NOSIGPIPE on NetBSD, > - O_DIRECT on Linux. I wonder why we don't just detect this via appropiate build test. There

Re: [Lldb-commits] [PATCH] D12661: NetBSD doesn't provide struct statfs, make use of struct statvfs

2015-09-05 Thread Joerg Sonnenberger via lldb-commits
joerg added a comment. One good question is whether using statvfs(3) shouldn't be the default as it is the POSIX interface. Repository: rL LLVM http://reviews.llvm.org/D12661 ___ lldb-commits mailing list lldb-commits@lists.llvm.org