[Lldb-commits] [PATCH] D109231: [lldb] Improve error handling around GetRngListData()

2021-09-23 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added inline comments. Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp:522 +entry->getContribution(llvm::DW_SECT_RNGLISTS)) { + Offset = contribution->Offset; return DWARFDataExtractor(data, contribution->Offset,

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-09-03 Thread Kim-Anh Tran via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGec671f3ea00b: [lldb] Support .debug_rnglists.dwo sections in dwp file (authored by kimanh). Repository: rG LLVM Github Monorepo CHANGES SINCE

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-09-03 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. I've split up the code that addresses the .debug_rnglists from the code that takes care of better error handling (https://reviews.llvm.org/D109231). I'll commit the reviewed part (this). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D109231: [lldb] Improve error handling around GetRngListData()

2021-09-03 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. kimanh added a reviewer: jankratochvil. kimanh published this revision for review. kimanh added a comment. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. I've split up the other CL (https://reviews.llvm.org/D107456) into the part that was

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-09-03 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 370562. kimanh added a comment. - splitting up new code (for error handling) into a different CL - keep code that was already accepted Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107456/new/

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added inline comments. Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp:556 + " (ranges list base: 0x%" PRIx64 "): %s", + offset, m_ranges_base, toString(table_or_error.takeError()).c_str()); } jankratochvil wrote: >

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 369547. kimanh added a comment. - Updating error messages Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107456/new/ https://reviews.llvm.org/D107456 Files: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp

[Lldb-commits] [PATCH] D108816: [lldb] Return all line entries matchign a line if no column is specified

2021-08-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Thanks for the review! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108816/new/ https://reviews.llvm.org/D108816 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D108816: [lldb] Return all line entries matchign a line if no column is specified

2021-08-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG3973d8b29e24: [lldb] Return all line entries matchign a line if no column is specified (authored by kimanh). Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-27 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Friendly ping! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107456/new/ https://reviews.llvm.org/D107456 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D108816: [lldb] Return all line entries matchign a line if no column is specified

2021-08-27 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. kimanh added reviewers: mib, JDevlieghere. kimanh published this revision for review. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Previously, if no column was specified, ResolveSymbolContext would take the first match returned by

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-20 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Thanks a lot for the review! Very sorry for my late update, I was out on vacation and then had to catch up with mails. Updated the revision now. Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp:537 +if (const

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-20 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 367758. kimanh marked 2 inline comments as done. kimanh added a comment. - Incorporating Jan's patch - Adding error message Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107456/new/

[Lldb-commits] [PATCH] D107659: [nfc] [lldb] Assertions for D106270 - [DWARF5] Fix offset check when using .debug_names

2021-08-09 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh accepted this revision. kimanh added a comment. This revision is now accepted and ready to land. LGTM, I also support that assertions are added. This gives confidence in what's expected and also makes it easier to read/understand whether it's a skeleton/non-skeleton unit that we are

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-08-09 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Thanks for the review! Landing now. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106270/new/ https://reviews.llvm.org/D106270 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-08-09 Thread Kim-Anh Tran via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG0dda5425318a: [DWARF5] Fix offset check when using .debug_names (authored by kimanh). Changed prior to commit:

[Lldb-commits] [PATCH] D107456: [lldb] Support .debug_rnglists.dwo sections in dwp file

2021-08-05 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. kimanh updated this revision to Diff 364081. kimanh added a comment. kimanh updated this revision to Diff 364364. kimanh added reviewers: labath, jankratochvil. kimanh published this revision for review. Herald added a project: LLDB. Herald added a subscriber:

[Lldb-commits] [PATCH] D107161: [lldb] Fix lookup of .debug_loclists with split-dwarf

2021-08-04 Thread Kim-Anh Tran via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG0092dbcd80f2: [lldb] Fix lookup of .debug_loclists with split-dwarf (authored by kimanh). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST

[Lldb-commits] [PATCH] D107161: [lldb] Fix lookup of .debug_loclists with split-dwarf

2021-08-02 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 363407. kimanh marked 7 inline comments as done. kimanh added a comment. Address reviews: - remove unused tmp label - remove invalid offsets - add ReportError when no loclist contribution was found - adapt ReportError logging to include offset and loclist

[Lldb-commits] [PATCH] D107161: [lldb] Fix lookup of .debug_loclists with split-dwarf

2021-07-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. kimanh edited the summary of this revision. kimanh added reviewers: labath, jankratochvil. kimanh published this revision for review. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This patch fixes the lookup of locations in .debug_loclists,

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-30 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. In D106355#2913605 , @jankratochvil wrote: > You can also consider coding `lldb-add-index` for better performance as that > is too much for my available time. I don't think that I'll get to it either. But we'll also evaluate

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-28 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh marked an inline comment as not done. kimanh added a comment. Thanks once more for reviewing! If I should rename the variable (or anything else), let me know! Otherwise, could you help me to land this change (since I do not have committer rights)? Comment at:

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-28 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 362287. kimanh marked an inline comment as done. kimanh added a comment. Remove braces. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106355/new/ https://reviews.llvm.org/D106355 Files:

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-07-27 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added inline comments. Comment at: lldb/source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.cpp:3024 -m_index->GetGlobalVariables( -dwarf_cu->GetNonSkeletonUnit(), [&](DWARFDIE die) { - VariableSP var_sp( shafik wrote: > So is

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-07-26 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Ping on this thread, any comment/guidance on this would help us a lot! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106270/new/ https://reviews.llvm.org/D106270 ___ lldb-commits

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-26 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. > If you do not want to debug those libraries cannot you just strip debug info > from them (`llvm-strip -g`)? Oh, stripping debug info may work. We're on the Chrome DevTools team and we're working on a DWARF-based debugging extension for C/C++. Ideally we'd like to

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-22 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Thanks for having a look at the CL! In D106355#2893959 , @jankratochvil wrote: > Is it really just a microoptimization or can you measure any improvement? > That `ManualDWARFIndex::Index` will be called is expected. But there

[Lldb-commits] [PATCH] D106355: [DWARF5] Only fallback to manual index if no entry was found

2021-07-20 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. Herald added a subscriber: arphaman. kimanh updated this revision to Diff 360084. kimanh added a comment. kimanh retitled this revision from "[Index] Only fallback to manual index if no entry was found" to "[DWARF5] Only fallback to manual index if no entry was

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-07-20 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added inline comments. Comment at: lldb/source/Plugins/SymbolFile/DWARF/AppleDWARFIndex.cpp:82 + const DWARFUnit _skeleton_cu = cu.GetNonSkeletonUnit(); DWARFMappedHash::DIEInfoArray hash_data; JDevlieghere wrote: > I assume the `const` of the

[Lldb-commits] [PATCH] D106270: [DWARF5] Fix offset check when using .debug_names

2021-07-19 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. Herald added a subscriber: arphaman. kimanh added a subscriber: pfaffe. kimanh edited the summary of this revision. kimanh added a reviewer: labath. kimanh published this revision for review. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. When

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-22 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. I'm very sorry for the incorrect reduction, and thanks for fixing this! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98619/new/ https://reviews.llvm.org/D98619 ___ lldb-commits

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-22 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. It seems as if it's the same for windows (I don't have windows unfortunately to check): https://lab.llvm.org/buildbot/#/builders/83/builds/4884 Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98619/new/

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-22 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh added a comment. Thanks for having a look, and for the explanation! Please let me know if I can do anything to help debugging this! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98619/new/ https://reviews.llvm.org/D98619

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-22 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh marked an inline comment as done. kimanh added a comment. Unfortunately the test seems to run and fail on the ARM. I thoughty adding REQUIRES: x85 would skip no x86 ones, but maybe I did something wrong. Comment at:

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-18 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh marked an inline comment as done. kimanh added a comment. Thanks a lot for the review Pavel! I've updated the test. If it looks fine like this, could you help me to commit this change? Comment at: lldb/test/Shell/SymbolFile/DWARF/dwarf5-debug_line-file-index.s:98 +

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-18 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh updated this revision to Diff 331547. kimanh added a comment. Removing subprogram and base_type tags (as they are not needed for the test) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98619/new/ https://reviews.llvm.org/D98619 Files:

[Lldb-commits] [PATCH] D98619: [lldb] Use CompileUnit::ResolveSymbolContext in SymbolFileDWARF

2021-03-15 Thread Kim-Anh Tran via Phabricator via lldb-commits
kimanh created this revision. kimanh added reviewers: labath, jasonmolenda. kimanh added a project: LLDB. Herald added subscribers: JDevlieghere, arphaman. kimanh requested review of this revision. Herald added a reviewer: jdoerfert. Herald added subscribers: lldb-commits, sstefan1.