Re: [Lldb-commits] [lldb] r331415 - [NSDictionary] Simplify the formatter. NFCI.

2018-05-02 Thread Jason Molenda via lldb-commits
> On May 2, 2018, at 4:58 PM, Davide Italiano wrote: > > On Wed, May 2, 2018 at 4:56 PM, Davide Italiano wrote: >> On Wed, May 2, 2018 at 4:51 PM, Jason Molenda via lldb-commits >> wrote: >>> Is this really simpler?

Re: [Lldb-commits] [lldb] r331415 - [NSDictionary] Simplify the formatter. NFCI.

2018-05-02 Thread Davide Italiano via lldb-commits
On Wed, May 2, 2018 at 4:56 PM, Davide Italiano wrote: > On Wed, May 2, 2018 at 4:51 PM, Jason Molenda via lldb-commits > wrote: >> Is this really simpler? We could write it >> >> if (name == g_zero) >> return 0; >> else >> return

Re: [Lldb-commits] [lldb] r331415 - [NSDictionary] Simplify the formatter. NFCI.

2018-05-02 Thread Davide Italiano via lldb-commits
On Wed, May 2, 2018 at 4:51 PM, Jason Molenda via lldb-commits wrote: > Is this really simpler? We could write it > > if (name == g_zero) > return 0; > else > return UINT32_MAX; > > or we could do it that way, or it could be done the way it was originally >

Re: [Lldb-commits] [lldb] r331415 - [NSDictionary] Simplify the formatter. NFCI.

2018-05-02 Thread Jason Molenda via lldb-commits
Is this really simpler? We could write it if (name == g_zero) return 0; else return UINT32_MAX; or we could do it that way, or it could be done the way it was originally written. tbh it seems like a style choice, and whoever wrote it originally may have preferred it being expressed that

[Lldb-commits] [lldb] r331415 - [NSDictionary] Simplify the formatter. NFCI.

2018-05-02 Thread Davide Italiano via lldb-commits
Author: davide Date: Wed May 2 16:36:07 2018 New Revision: 331415 URL: http://llvm.org/viewvc/llvm-project?rev=331415=rev Log: [NSDictionary] Simplify the formatter. NFCI. Modified: lldb/trunk/source/Plugins/Language/ObjC/NSDictionary.cpp Modified: