Re: [Lldb-commits] [PATCH] D15355: Add failure paths to a few JSONNumber members

2015-12-09 Thread Tamas Berghammer via lldb-commits
tberghammer requested changes to this revision. tberghammer added a comment. This revision now requires changes to proceed. These GetAs{...} functions should never fail in their current implementation as we have only 3 different data type and all of them are handled. The new function signatures

[Lldb-commits] [lldb] r255105 - XFAIL TestReturnValue for remote Windows->Android tests

2015-12-09 Thread Pavel Labath via lldb-commits
Author: labath Date: Wed Dec 9 04:54:18 2015 New Revision: 255105 URL: http://llvm.org/viewvc/llvm-project?rev=255105=rev Log: XFAIL TestReturnValue for remote Windows->Android tests this also adds the ability to match the host platform to the expectedFailureAll decorator. Modified:

Re: [Lldb-commits] [PATCH] D15357: Update code to silent some ARM/ARM64 specific compiler warnings

2015-12-09 Thread Tamas Berghammer via lldb-commits
tberghammer requested changes to this revision. tberghammer added a comment. This revision now requires changes to proceed. We discussed the same change recently (http://reviews.llvm.org/D13866) and the general opinion was that the original code have the right semantics and we don't want to

Re: [Lldb-commits] [PATCH] D15355: Add failure paths to a few JSONNumber members

2015-12-09 Thread Pavel Labath via lldb-commits
labath added a subscriber: labath. labath added a comment. btw, if you use `llvm_unreachable("text")`, then you don't need the return after that. http://reviews.llvm.org/D15355 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D15374: Add NetBSD support in the buildDriver and buildLibrary routines

2015-12-09 Thread Kamil Rytarowski via lldb-commits
krytarowski created this revision. krytarowski added reviewers: emaste, joerg, clay.chang, tfiala. krytarowski added a subscriber: lldb-commits. krytarowski set the repository for this revision to rL LLVM. Herald added a subscriber: emaste. NetBSD is like FreeBSD and Linux in these routines.

[Lldb-commits] [lldb] r255108 - [LLDB][MIPS] Adding call to IsMSAAvailable() while creating RegisterInfoInterface

2015-12-09 Thread Sagar Thakur via lldb-commits
Author: slthakur Date: Wed Dec 9 06:31:01 2015 New Revision: 255108 URL: http://llvm.org/viewvc/llvm-project?rev=255108=rev Log: [LLDB][MIPS] Adding call to IsMSAAvailable() while creating RegisterInfoInterface This patch will fix the test case

[Lldb-commits] [PATCH] D15379: Switch to gold linker on android x86, x86_64, arm

2015-12-09 Thread Tamas Berghammer via lldb-commits
tberghammer created this revision. tberghammer added reviewers: labath, ovyalov. tberghammer added a subscriber: lldb-commits. Herald added subscribers: srhines, danalbert, tberghammer, rengolin, aemerson. Switch to gold linker on android x86, x86_64, arm These architectures already using the

Re: [Lldb-commits] [PATCH] D15374: Add NetBSD support in the buildDriver and buildLibrary routines

2015-12-09 Thread Joerg Sonnenberger via lldb-commits
joerg added inline comments. Comment at: packages/Python/lldbsuite/test/lldbtest.py:2100 @@ -2099,3 +2099,3 @@ } -elif sys.platform.startswith('freebsd') or sys.platform.startswith("linux") or os.environ.get('LLDB_BUILD_TYPE') == 'Makefile': +

Re: [Lldb-commits] [PATCH] D15379: Switch to gold linker on android x86, x86_64, arm

2015-12-09 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. looks good http://reviews.llvm.org/D15379 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [lldb] r255118 - Correctly XFAIL TestReturnValue

2015-12-09 Thread Pavel Labath via lldb-commits
Author: labath Date: Wed Dec 9 09:49:40 2015 New Revision: 255118 URL: http://llvm.org/viewvc/llvm-project?rev=255118=rev Log: Correctly XFAIL TestReturnValue android is not an "os", use the target triple to match it. Modified:

[Lldb-commits] [lldb] r255121 - [RenderScript] Add hook for destroyed allocations

2015-12-09 Thread Ewan Crawford via lldb-commits
Author: ewancrawford Date: Wed Dec 9 10:01:58 2015 New Revision: 255121 URL: http://llvm.org/viewvc/llvm-project?rev=255121=rev Log: [RenderScript] Add hook for destroyed allocations New hook for rsdAllocationDestroy() which is called when allocations are deleted. LLDB should be aware of this

Re: [Lldb-commits] [PATCH] D15333: Enable half2float() on windows.

2015-12-09 Thread Zachary Turner via lldb-commits
zturner accepted this revision. zturner added a comment. This revision is now accepted and ready to land. Yea, sorry. In the future if someone says "lgtm" that's as good as hitting the accept button in phabricator. Repository: rL LLVM http://reviews.llvm.org/D15333

[Lldb-commits] [lldb] r255130 - Turn on new test summary results by default.

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 12:01:14 2015 New Revision: 255130 URL: http://llvm.org/viewvc/llvm-project?rev=255130=rev Log: Turn on new test summary results by default. Modified: lldb/trunk/packages/Python/lldbsuite/test/dotest.py

[Lldb-commits] [lldb] r255131 - create 3 issues for testbots: FAIL, ERROR (exceptional), and TIMEOUT

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 12:01:19 2015 New Revision: 255131 URL: http://llvm.org/viewvc/llvm-project?rev=255131=rev Log: create 3 issues for testbots: FAIL, ERROR (exceptional), and TIMEOUT This change is a trial balloon to verify that the default test summary output sends the right

[Lldb-commits] [lldb] r255138 - Fix new summary to include exceptional exit count in determining exit value

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 13:05:44 2015 New Revision: 255138 URL: http://llvm.org/viewvc/llvm-project?rev=255138=rev Log: Fix new summary to include exceptional exit count in determining exit value The main dotest.py should exit with a system return code of 1 on any issue. This change

[Lldb-commits] [lldb] r255134 - Disable the issue verification tests.

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 12:24:47 2015 New Revision: 255134 URL: http://llvm.org/viewvc/llvm-project?rev=255134=rev Log: Disable the issue verification tests. Added: lldb/trunk/packages/Python/lldbsuite/test/issue_verification/TestFail.py.park - copied, changed from r255131,

Re: [Lldb-commits] [PATCH] D15379: Switch to gold linker on android x86, x86_64, arm

2015-12-09 Thread Oleksiy Vyalov via lldb-commits
ovyalov accepted this revision. ovyalov added a comment. LGTM Comment at: cmake/platforms/Android.cmake:124 @@ -123,1 +123,3 @@ +# Use gold linker and enable safe ICF in case of x86, x86_64 and arm +if ( ANDROID_ABI STREQUAL "x86"OR Just out of curiosity

Re: [Lldb-commits] [PATCH] D15326: Rework breakpoint language filtering to use the symbol context's language.

2015-12-09 Thread Jim Ingham via lldb-commits
jingham added a comment. "cstring_is_mangled" does NOT mean that the string is a C++ mangled string, it means it is ANY kind of mangled string - you can tell because it is used to determine whether to populate the m_mangled and m_demangled components of the Mangled structure, which it should

[Lldb-commits] [lldb] r255153 - Remove the -P option from dotest.py

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 14:48:59 2015 New Revision: 255153 URL: http://llvm.org/viewvc/llvm-project?rev=255153=rev Log: Remove the -P option from dotest.py This was an option to display a graphical progress bar. Nobody is using this, and it doesn't work correctly anyway with the new

[Lldb-commits] [lldb] r255151 - Remove the -i command line option from dotest.py.

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 14:48:31 2015 New Revision: 255151 URL: http://llvm.org/viewvc/llvm-project?rev=255151=rev Log: Remove the -i command line option from dotest.py. This is part of a larger effort to remove unused command line options from dotest.py. Modified:

[Lldb-commits] [lldb] r255150 - Delete the -F command line option from dotest.py.

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 14:48:19 2015 New Revision: 255150 URL: http://llvm.org/viewvc/llvm-project?rev=255150=rev Log: Delete the -F command line option from dotest.py. This removes the failfast command line option as part of an effort to simplify dotest and remove unused command line

[Lldb-commits] [lldb] r255159 - Put progress.py back, apparently this can't be deleted.

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 15:32:28 2015 New Revision: 255159 URL: http://llvm.org/viewvc/llvm-project?rev=255159=rev Log: Put progress.py back, apparently this can't be deleted. Added: lldb/trunk/third_party/Python/module/progress/progress.py Added:

[Lldb-commits] [lldb] r255161 - enable timeout/exceptional exit support for xUnit formatter

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 16:02:31 2015 New Revision: 255161 URL: http://llvm.org/viewvc/llvm-project?rev=255161=rev Log: enable timeout/exceptional exit support for xUnit formatter Also adds enable.py/disable.py script to simplify turning on and off the issue_verification tests helpful

Re: [Lldb-commits] [PATCH] D15312: Fix scope-based lookup when more than one function is found.

2015-12-09 Thread Greg Clayton via lldb-commits
clayborg added a comment. Above I meant to say I don't understand what the "else if (find_name)" does. I understand the rest of it. So in the "else if (find_name)" we are looking for any decl, regardless of wether it matches "opaque_find_decl_ctx" as long as the name and type are correct?

Re: [Lldb-commits] [PATCH] D15374: Add NetBSD support in the buildDriver and buildLibrary routines

2015-12-09 Thread Kamil Rytarowski via lldb-commits
krytarowski updated this revision to Diff 42372. krytarowski added a comment. Strip zero character from platform name Repository: rL LLVM http://reviews.llvm.org/D15374 Files: packages/Python/lldbsuite/test/lldbtest.py Index: packages/Python/lldbsuite/test/lldbtest.py

Re: [Lldb-commits] [PATCH] D15312: Fix scope-based lookup when more than one function is found.

2015-12-09 Thread Dawn Perchik via lldb-commits
dawn updated this revision to Diff 42385. dawn added a comment. This version of the patch is the API "generic" version of the patch. Please choose to review which ever is preferred, and I will submit another patch based on that version if needed. BTW Greg, thanks for the suggestion of

Re: [Lldb-commits] [PATCH] D15312: Fix scope-based lookup when more than one function is found.

2015-12-09 Thread Dawn Perchik via lldb-commits
dawn marked 3 inline comments as done. dawn added a comment. > It seems like you combined "find this decl instance within a decl context" > with "find a decl by name in the CompilerDeclContext and optionally get the > type". It it exactly "find this decl instance within a decl context". > I

[Lldb-commits] [lldb] r255139 - Move XunitFormatter into its own xunit_formatter.py file.

2015-12-09 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Dec 9 13:32:14 2015 New Revision: 255139 URL: http://llvm.org/viewvc/llvm-project?rev=255139=rev Log: Move XunitFormatter into its own xunit_formatter.py file. Added: lldb/trunk/packages/Python/lldbsuite/test/xunit_formatter.py Modified:

Re: [Lldb-commits] [PATCH] D15312: Fix scope-based lookup when more than one function is found.

2015-12-09 Thread Dawn Perchik via lldb-commits
dawn marked 6 inline comments as done. dawn added a comment. Hi Greg, I'm working on a new revision to change the patch as you suggest (thanks for your review - you had some great suggestions!). Sorry, if I'm missing something obviously here, but there's still some things I don't understand:

[Lldb-commits] [lldb] r255143 - Remove -k command line option from dotest.py.

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 13:45:51 2015 New Revision: 255143 URL: http://llvm.org/viewvc/llvm-project?rev=255143=rev Log: Remove -k command line option from dotest.py. This is part of an effort to remove unused command line options. Removed:

[Lldb-commits] [lldb] r255141 - Remove -libcxx option from dotest.py

2015-12-09 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Dec 9 13:45:16 2015 New Revision: 255141 URL: http://llvm.org/viewvc/llvm-project?rev=255141=rev Log: Remove -libcxx option from dotest.py Nobody was using this, and plus it can be achieved just as well by using -E to set an environment variable. Modified:

Re: [Lldb-commits] [PATCH] D15333: Enable half2float() on windows.

2015-12-09 Thread Aidan Dodds via lldb-commits
ADodds added a comment. If there are no objections, are you happy to accept this? Repository: rL LLVM http://reviews.llvm.org/D15333 ___ lldb-commits mailing list lldb-commits@lists.llvm.org