Re: [Lldb-commits] [PATCH] D15175: Fix breakpoint language filtering for other C variants (like C99) and Pascal.

2015-12-03 Thread Dawn Perchik via lldb-commits
dawn added a comment. Jim, this patch doesn't attempt to fix the issue I raised in my comment - it just fixes the oversight of other C variants (clang picks C99 for example) and renames your function to a more meaningful name (and matches Mangled::GuessLanguage which is also uses the name to

Re: [Lldb-commits] [PATCH] D14944: [LLDB][MIPS] Marking some expected failures

2015-12-03 Thread Mohit Bhakkad via lldb-commits
mohit.bhakkad updated this revision to Diff 41843. mohit.bhakkad added a comment. Addressed comments Repository: rL LLVM http://reviews.llvm.org/D14944 Files: packages/Python/lldbsuite/test/functionalities/watchpoint/hello_watchlocation/TestWatchLocation.py

Re: [Lldb-commits] [PATCH] D15182: [MIPS] Fix TestCrashDuringStep.py for MIPS

2015-12-03 Thread Jaydeep Patil via lldb-commits
jaydeep updated this revision to Diff 41840. jaydeep added a comment. Marked as XFAIL Repository: rL LLVM http://reviews.llvm.org/D15182 Files: packages/Python/lldbsuite/test/functionalities/thread/crash_during_step/TestCrashDuringStep.py Index:

Re: [Lldb-commits] [PATCH] D15065: Define new builder_netbsd

2015-12-03 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a comment. This revision is now accepted and ready to land. I'm not sure exactly how these were divided up initially, but I'd suspect a substantial amount of it is similar along the vein of POSIX vs. non-POSIX, probably with some diffs for OS X

Re: [Lldb-commits] [PATCH] D15209: Fix script import --allow-reload on Python 3

2015-12-03 Thread Todd Fiala via lldb-commits
tfiala added a comment. Doesn't look like I can hit this until the morning. But it'll be first thing on my list. http://reviews.llvm.org/D15209 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D12809: Better scheme to lookup alternate mangled name when looking up function address.

2015-12-03 Thread Dawn Perchik via lldb-commits
dawn accepted this revision. dawn added a comment. lgtm. Patch was applied locally and tested with no regressions. Thanks for fixing the patch. http://reviews.llvm.org/D12809 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D15172: Fix in-memory section loading for JIT-ed code.

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer accepted this revision. tberghammer added a comment. This revision is now accepted and ready to land. LGTM http://reviews.llvm.org/D15172 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D15183: Remove some duplicated code from PlatformPOSIX/Android

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer created this revision. tberghammer added a reviewer: labath. tberghammer added a subscriber: lldb-commits. Herald added subscribers: srhines, danalbert, tberghammer, emaste. Remove some duplicated code from PlatformPOSIX/Android The code was duplicated to handle the custom symbol

Re: [Lldb-commits] [PATCH] D15152: Change Platform::LoadImage to copy the file to the remote platform

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. What is the opinion about adding just a boolean flag to specify if the path provided is a local path or a remote path? In case it is a remote path (will be the default to keep current behavior) then we don't do any copying and if it is a local path then we copy the

Re: [Lldb-commits] [PATCH] D11465: Fix "process load/unload" on android

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. In http://reviews.llvm.org/D11465#300606, @labath wrote: > In http://reviews.llvm.org/D11465#300581, @jingham wrote: > > > It seems like an awful lot of logic is duplicated between the POSIX & > > Android versions of LoadImage when all that really changes is the

[Lldb-commits] [PATCH] D15182: [MIPS] Fix TestCrashDuringStep.py for MIPS

2015-12-03 Thread Jaydeep Patil via lldb-commits
jaydeep created this revision. jaydeep added a reviewer: clayborg. jaydeep added subscribers: bhushan, sagar, mohit.bhakkad, nitesh.jain, lldb-commits. jaydeep set the repository for this revision to rL LLVM. Single stepping requires setting software breakpoint at address 0x0. This results in

[Lldb-commits] [lldb] r254602 - Fix TestLoadUnload for Windows -> POSIX remote debugging

2015-12-03 Thread Tamas Berghammer via lldb-commits
Author: tberghammer Date: Thu Dec 3 05:02:10 2015 New Revision: 254602 URL: http://llvm.org/viewvc/llvm-project?rev=254602=rev Log: Fix TestLoadUnload for Windows -> POSIX remote debugging Previously we used sys.os.path for appending target pathes what failed when cased dlopen to fail on the

Re: [Lldb-commits] [PATCH] D15182: [MIPS] Fix TestCrashDuringStep.py for MIPS

2015-12-03 Thread Pavel Labath via lldb-commits
labath added a subscriber: labath. labath added a comment. I believe this defeats the purpose of the whole test, which (I think) is to check that crashes during the actual "step" operation are handled correctly. We already have other tests which test crashing after a "continue" so I don't

[Lldb-commits] [lldb] r254608 - Remove some duplicated code from PlatformPOSIX/Android

2015-12-03 Thread Tamas Berghammer via lldb-commits
Author: tberghammer Date: Thu Dec 3 06:58:03 2015 New Revision: 254608 URL: http://llvm.org/viewvc/llvm-project?rev=254608=rev Log: Remove some duplicated code from PlatformPOSIX/Android The code was duplicated to handle the custom symbol name for functions in libdl.so for android. This change

[Lldb-commits] [lldb] r254593 - [Fix] fix build failure due to rL254588

2015-12-03 Thread Mohit K. Bhakkad via lldb-commits
Author: mohit.bhakkad Date: Thu Dec 3 02:44:33 2015 New Revision: 254593 URL: http://llvm.org/viewvc/llvm-project?rev=254593=rev Log: [Fix] fix build failure due to rL254588 Modified: lldb/trunk/include/lldb/Core/Debugger.h Modified: lldb/trunk/include/lldb/Core/Debugger.h URL:

Re: [Lldb-commits] [PATCH] D15183: Remove some duplicated code from PlatformPOSIX/Android

2015-12-03 Thread Tamas Berghammer via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL254608: Remove some duplicated code from PlatformPOSIX/Android (authored by tberghammer). Changed prior to commit: http://reviews.llvm.org/D15183?vs=41735=41742#toc Repository: rL LLVM

Re: [Lldb-commits] [PATCH] D15152: Change Platform::LoadImage to copy the file to the remote platform

2015-12-03 Thread Greg Clayton via lldb-commits
clayborg added a comment. Maybe Platform::LoadImage() should keep its current arguments and the path that is specified should always be correct for the platform. Other code should do the copy over if it needs to and call Platform::LoadImage() with a path that makes sense for the platform. The

Re: [Lldb-commits] [PATCH] D15187: Improve the functionality of JSONNumber

2015-12-03 Thread Enrico Granata via lldb-commits
granata.enrico added a subscriber: granata.enrico. granata.enrico added a comment. IIU my C++ correctly, this code covers neither int64_t nor double; it covers the unsigned variety of int64 - as well as any other unsigned integer type. The main advantage (other than not relying on implicit

Re: [Lldb-commits] [PATCH] D15187: Improve the functionality of JSONNumber

2015-12-03 Thread Greg Clayton via lldb-commits
clayborg added a comment. Everything looks good, just wondering why we need the template code? See inlined comments. Comment at: include/lldb/Utility/JSON.h:102-104 @@ +101,5 @@ + +template {} && + std::is_unsigned{}>::type* =

Re: [Lldb-commits] [PATCH] D15187: Improve the functionality of JSONNumber

2015-12-03 Thread Enrico Granata via lldb-commits
IIU my C++ correctly, this code covers neither int64_t nor double; it covers the unsigned variety of int64 - as well as any other unsigned integer type. The main advantage (other than not relying on implicit promotions) would be that if someone writes their new integral data type (BigNum), and

[Lldb-commits] [lldb] r254633 - Un XFAIL some tests that are now passing on Windows.

2015-12-03 Thread Zachary Turner via lldb-commits
Author: zturner Date: Thu Dec 3 13:20:05 2015 New Revision: 254633 URL: http://llvm.org/viewvc/llvm-project?rev=254633=rev Log: Un XFAIL some tests that are now passing on Windows. Modified: lldb/trunk/packages/Python/lldbsuite/test/functionalities/conditional_break/TestConditionalBreak.py

Re: [Lldb-commits] [PATCH] D15172: Fix in-memory section loading for JIT-ed code.

2015-12-03 Thread Oleksiy Vyalov via lldb-commits
ovyalov closed this revision. ovyalov added a comment. Submitted as http://reviews.llvm.org/rL254638 http://reviews.llvm.org/D15172 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D12809: Better scheme to lookup alternate mangled name when looking up function address.

2015-12-03 Thread Siva Chandra via lldb-commits
sivachandra added a comment. @dawn: Thanks for accepting the patch. I guess I still need to wait for sign-off/comments from a CODE_OWNER. http://reviews.llvm.org/D12809 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

Re: [Lldb-commits] [PATCH] D15183: Remove some duplicated code from PlatformPOSIX/Android

2015-12-03 Thread Jim Ingham via lldb-commits
jingham added a comment. Cute! That's much nicer. Repository: rL LLVM http://reviews.llvm.org/D15183 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [PATCH] D15209: Fix script import --allow-reload on Python 3

2015-12-03 Thread Zachary Turner via lldb-commits
zturner created this revision. zturner added reviewers: granata.enrico, tfiala. zturner added a subscriber: lldb-commits. I think this patch may require some xcode changes. This is because of the `from six.moves import reload_module`. In the CMake build as part of the swig wrapper python

Re: [Lldb-commits] [PATCH] D15175: Fix breakpoint language filtering for other C variants (like C99) and Pascal.

2015-12-03 Thread Jim Ingham via lldb-commits
jingham requested changes to this revision. jingham added a comment. This revision now requires changes to proceed. If we really can't tell whether a symbol is CPP or Pascal based on the name, then GetLanguageForSymbolByName should be reworked to take a std::vector& in which to return the

Re: [Lldb-commits] [PATCH] D15218: Implement GetMemoryRegionInfo for mini dumps.

2015-12-03 Thread Adrian McCarthy via lldb-commits
amccarth updated this revision to Diff 41828. amccarth added a comment. Ran clang-format and removed initialization of a local variable that was no longer used. Note that clang-format re-ordered the include because the change added one include. http://reviews.llvm.org/D15218 Files:

[Lldb-commits] [lldb] r254666 - Add a newline at the end of this file

2015-12-03 Thread Enrico Granata via lldb-commits
Author: enrico Date: Thu Dec 3 17:53:45 2015 New Revision: 254666 URL: http://llvm.org/viewvc/llvm-project?rev=254666=rev Log: Add a newline at the end of this file Modified: lldb/trunk/source/Target/Process.cpp Modified: lldb/trunk/source/Target/Process.cpp URL:

Re: [Lldb-commits] [PATCH] D15218: Implement GetMemoryRegionInfo for mini dumps.

2015-12-03 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: source/Plugins/Process/Windows/MiniDump/ProcessWinMiniDump.cpp:312 @@ +311,3 @@ +// necessary to test for any of the bits that provide that access type. +const bool readable = +entry->Protect &

Re: [Lldb-commits] [PATCH] D15209: Fix script import --allow-reload on Python 3

2015-12-03 Thread Todd Fiala via lldb-commits
tfiala added a comment. Yep - I can make sure this works on Xcode tonight. I'll either direct send you the diff or incorporate it with what you have here. It probably won't be until much later tonight, but I'll definitely hit this. http://reviews.llvm.org/D15209

Re: [Lldb-commits] [PATCH] D15187: Improve the functionality of JSONNumber

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer added inline comments. Comment at: include/lldb/Utility/JSON.h:102-104 @@ +101,5 @@ + +template {} && + std::is_unsigned{}>::type* = nullptr> +explicit JSONNumber (T u) : clayborg wrote: > What

Re: [Lldb-commits] [PATCH] D15152: Change Platform::LoadImage to copy the file to the remote platform

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. I would like to exposed the ability to specify if we want the specified file to be copied over to the target or not both at the command line and on the SB API. To do this without duplicating the logic what do the file installation into CommandObjectProcess and

Re: [Lldb-commits] [PATCH] D15152: Change Platform::LoadImage to copy the file to the remote platform

2015-12-03 Thread Tamas Berghammer via lldb-commits
tberghammer added a comment. Sounds reasonable. The only question is that currently only PlatformPOSIX supports LoadImage. Do we want to add the DoLoadImage function now, or do we want to wait until some other platform also want to implement image loading? http://reviews.llvm.org/D15152

[Lldb-commits] [lldb] r254698 - Add a space char so step logging doesn't print things like

2015-12-03 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Thu Dec 3 20:52:49 2015 New Revision: 254698 URL: http://llvm.org/viewvc/llvm-project?rev=254698=rev Log: Add a space char so step logging doesn't print things like "Stepping out from a.out`bar at a.c:3returning to frame" Modified:

Re: [Lldb-commits] [PATCH] D15187: Improve the functionality of JSONNumber

2015-12-03 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Ok, thanks for the explanation. You might add a comment saying something like you just said above the template stuff so people can see why it is needed. http://reviews.llvm.org/D15187