[Lldb-commits] [lldb] r251522 - Fix build break on OS X from cleanup check-in.

2015-10-28 Thread Todd Fiala via lldb-commits
Author: tfiala Date: Wed Oct 28 10:24:19 2015 New Revision: 251522 URL: http://llvm.org/viewvc/llvm-project?rev=251522=rev Log: Fix build break on OS X from cleanup check-in. I'll track down why our CI is not sending out emails on build breaks. Modified: lldb/trunk/source/Core/IOHandler.cpp

Re: [Lldb-commits] [PATCH] D14136: Refactor Windows process plugin to enable sharing of code between live and post-mortem debugging

2015-10-28 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: source/Plugins/Process/Windows/Common/ProcessWindowsForward.h:20 @@ +19,1 @@ +#endif \ No newline at end of file Put a newline here Comment at:

[Lldb-commits] Buildbot e-mail notification has been changed

2015-10-28 Thread Galina Kistanova via lldb-commits
Hello everyone, I continue works to reduce buildbot noise. E-mail notification has been changed in the buildmaster. Now it should not count interrupted builds to figure out if notification should be send. So, some people might want to reconsider the notification rules for their personal

Re: [Lldb-commits] [PATCH] D14118: Changes for Bug 17384

2015-10-28 Thread Oleksiy Vyalov via lldb-commits
ovyalov added a comment. Hi, looks like TestHelloWorld and TestInferiorAssert began to fail after this change - http://lab.llvm.org:8011/builders/lldb-x86_64-ubuntu-14.04-cmake/builds/7880 Could you mark these tests as XFAILs for now? http://reviews.llvm.org/D14118

Re: [Lldb-commits] [PATCH] D14089: Avoid using `..` in paths for include dirs.

2015-10-28 Thread Stephane Sezer via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL251530: Avoid using `..` in paths for include dirs. (authored by sas). Changed prior to commit: http://reviews.llvm.org/D14089?vs=38454=38670#toc Repository: rL LLVM http://reviews.llvm.org/D14089

[Lldb-commits] [lldb] r251537 - Make core files not crash when you load a core file into LLDB with just "lldb -c core".

2015-10-28 Thread Greg Clayton via lldb-commits
Author: gclayton Date: Wed Oct 28 13:04:38 2015 New Revision: 251537 URL: http://llvm.org/viewvc/llvm-project?rev=251537=rev Log: Make core files not crash when you load a core file into LLDB with just "lldb -c core". To do this I added a few new ways to determine the OS from PT_NOTE notes in

[Lldb-commits] [lldb] r251505 - Changes for Bug 17384

2015-10-28 Thread Ravitheja Addepally via lldb-commits
Author: ravitheja Date: Wed Oct 28 04:47:29 2015 New Revision: 251505 URL: http://llvm.org/viewvc/llvm-project?rev=251505=rev Log: Changes for Bug 17384 Summary: Virtual dynamic shared objects, or vdso files were not loaded for Linux OS.In Bug 17384 the call stack could not be unwinded from

Re: [Lldb-commits] [PATCH] D14136: Refactor Windows process plugin to enable sharing of code between live and post-mortem debugging

2015-10-28 Thread Adrian McCarthy via lldb-commits
amccarth added inline comments. Comment at: source/Plugins/Process/Windows/Common/ProcessWindowsForward.h:20 @@ +19,1 @@ +#endif \ No newline at end of file zturner wrote: > Put a newline here Actually, this file is obsolete, so I'm deleting it instead. It was

[Lldb-commits] [lldb] r251550 - Removed an unecessary code-signing phase on lldb-tool.

2015-10-28 Thread Sean Callanan via lldb-commits
Author: spyffe Date: Wed Oct 28 15:07:46 2015 New Revision: 251550 URL: http://llvm.org/viewvc/llvm-project?rev=251550=rev Log: Removed an unecessary code-signing phase on lldb-tool. Modified: lldb/trunk/lldb.xcodeproj/project.pbxproj Modified: lldb/trunk/lldb.xcodeproj/project.pbxproj URL:

[Lldb-commits] [lldb] r251544 - Try to fix the linux buildbot.

2015-10-28 Thread Zachary Turner via lldb-commits
Author: zturner Date: Wed Oct 28 14:18:53 2015 New Revision: 251544 URL: http://llvm.org/viewvc/llvm-project?rev=251544=rev Log: Try to fix the linux buildbot. It's complaining that it doesn't under the "import" command, so I guess I need this hashbang at the beginning so that it knows it's a

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Looks good. argdumper should probably go to /usr/libexec, but then I guess we won't be able to find it, so that's a different story... http://reviews.llvm.org/D14169

Re: [Lldb-commits] [PATCH] D14162: Create Python library `seven` in lldbsuite.support

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala added a comment. Just one question on the python 3 return code for non-exceptional exit. Comment at: packages/Python/lldbsuite/support/seven.py:12 @@ +11,3 @@ +import subprocess +return (0, subprocess.check_output(command, shell=True)) +

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala added a comment. In http://reviews.llvm.org/D14169#277587, @tfiala wrote: > > scripts/Python/finish-swig-Python-LLDB.sh > > > Hmm I think there is a python implementation of this script that I may have > missed. Checking on that now. Yes there is. I need to adjust one other place.

Re: [Lldb-commits] [PATCH] D14162: Create Python library `seven` in lldbsuite.support

2015-10-28 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: packages/Python/lldbsuite/support/seven.py:12 @@ +11,3 @@ +import subprocess +return (0, subprocess.check_output(command, shell=True)) +except subprocess.CalledProcessError as e: tfiala

Re: [Lldb-commits] [PATCH] D14037: Reuse native curses(8) library on NetBSD

2015-10-28 Thread Kamil Rytarowski via lldb-commits
krytarowski added a comment. I have successfully compiled this patch on FreeBSD. $ uname -a FreeBSD 10.1-RELEASE-p19 FreeBSD 10.1-RELEASE-p19 #0: Sat Aug 22 03:55:09 UTC 2015 r...@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64 Repository: rL LLVM

Re: [Lldb-commits] [PATCH] D14157: Make dosep correctly invoke the top level script when doing the multiprocessing fork

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a comment. This revision is now accepted and ready to land. Looks good. We were having trouble running the script from the top level earlier and were directly calling the one that you're disabling. That'll be nice to get the top level one working

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala added a comment. > scripts/Python/finish-swig-Python-LLDB.sh Hmm I think there is a python implementation of this script that I may have missed. Checking on that now. http://reviews.llvm.org/D14169 ___ lldb-commits mailing list

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala closed this revision. tfiala added a comment. Closed by commit: $ svn commit Sendinglldb.xcodeproj/project.pbxproj Sendingscripts/Python/finish-swig-Python-LLDB.sh Sendingscripts/Python/finishSwigPythonLLDB.py Sendingsource/Host/macosx/Host.mm

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala updated this revision to Diff 38715. tfiala added a comment. Fixed up one missed spot, the python-based class completion script. I think the original clean build and test run on Linux missed this because I don't think we actually use it on Linux. It's primarily useful on OS X 10.11 and

Re: [Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala added a comment. I'm out the next couple days at the LLVM conference. I'm going to put this in. We'll revert it out if it causes any trouble on Windows and fix it up. http://reviews.llvm.org/D14169 ___ lldb-commits mailing list

Re: [Lldb-commits] [PATCH] D14042: Add more NetBSD platform glue for lldb

2015-10-28 Thread Kamil Rytarowski via lldb-commits
krytarowski added a comment. I have successfully compiled this patch on FreeBSD. $ uname -a FreeBSD 10.1-RELEASE-p19 FreeBSD 10.1-RELEASE-p19 #0: Sat Aug 22 03:55:09 UTC 2015 r...@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64 Repository: rL LLVM

[Lldb-commits] [PATCH] D14157: Make dosep correctly invoke the top level script when doing the multiprocessing fork

2015-10-28 Thread Zachary Turner via lldb-commits
zturner created this revision. zturner added a reviewer: tfiala. zturner added a subscriber: lldb-commits. This patch disables the ability to run `packages/Python/lldbsuite/test/dotest.py` as a standalone script by explicitly erroring out if it detects that to be the case. Then, it fixes up

[Lldb-commits] [lldb] r251555 - Don't crash when opening a fuzzed mach-o file that has bad dyld trie data.

2015-10-28 Thread Greg Clayton via lldb-commits
Author: gclayton Date: Wed Oct 28 15:49:34 2015 New Revision: 251555 URL: http://llvm.org/viewvc/llvm-project?rev=251555=rev Log: Don't crash when opening a fuzzed mach-o file that has bad dyld trie data. Modified: lldb/trunk/source/Plugins/ObjectFile/Mach-O/ObjectFileMachO.cpp Modified:

[Lldb-commits] [PATCH] D14159: Add a Visual Studio solution for LLDB's Python code

2015-10-28 Thread Zachary Turner via lldb-commits
zturner created this revision. zturner added a reviewer: amccarth. zturner added a subscriber: lldb-commits. Herald added subscribers: srhines, danalbert, tberghammer. If you have PTVS [https://github.com/Microsoft/PTVS] installed, you can open this solution in Visual Studio and get an

[Lldb-commits] [lldb] r251559 - Skip this test is the test suite is running in a mode where it has no WindowServer access

2015-10-28 Thread Enrico Granata via lldb-commits
Author: enrico Date: Wed Oct 28 17:08:09 2015 New Revision: 251559 URL: http://llvm.org/viewvc/llvm-project?rev=251559=rev Log: Skip this test is the test suite is running in a mode where it has no WindowServer access Modified:

[Lldb-commits] [PATCH] D14162: Create Python library `seven` in lldbsuite.support

2015-10-28 Thread Zachary Turner via lldb-commits
zturner created this revision. zturner added a reviewer: tfiala. zturner added a subscriber: lldb-commits. The purpose of this file is to fill in the gaps where `six` is lacking support for some operation that we need. Initially this just provides a replacement for the `commands` module which

Re: [Lldb-commits] [PATCH] D14163: Address another race condition running tests on Windows

2015-10-28 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: packages/Python/lldbsuite/test/lldbtest.py:1823-1830 @@ -1822,3 +1822,10 @@ -os.rename(src, dst) +try: +os.rename(src, dst) +except: +

[Lldb-commits] [lldb] r251561 - Fix Clang-tidy modernize-use-nullptr warnings in remaining files in include/lldb/Core; other minor fixes.

2015-10-28 Thread Eugene Zelenko via lldb-commits
Author: eugenezelenko Date: Wed Oct 28 17:11:25 2015 New Revision: 251561 URL: http://llvm.org/viewvc/llvm-project?rev=251561=rev Log: Fix Clang-tidy modernize-use-nullptr warnings in remaining files in include/lldb/Core; other minor fixes. Modified: lldb/trunk/include/lldb/Core/STLUtils.h

[Lldb-commits] [lldb] r251563 - Remove unused SUN_LEN macro for Android.

2015-10-28 Thread Oleksiy Vyalov via lldb-commits
Author: ovyalov Date: Wed Oct 28 17:21:02 2015 New Revision: 251563 URL: http://llvm.org/viewvc/llvm-project?rev=251563=rev Log: Remove unused SUN_LEN macro for Android. Modified: lldb/trunk/source/Host/posix/DomainSocket.cpp Modified: lldb/trunk/source/Host/posix/DomainSocket.cpp URL:

[Lldb-commits] [lldb] r251564 - Change Target::EvaluateExpression to take an ExecutionContextScope * rather than a

2015-10-28 Thread Jim Ingham via lldb-commits
Author: jingham Date: Wed Oct 28 17:23:17 2015 New Revision: 251564 URL: http://llvm.org/viewvc/llvm-project?rev=251564=rev Log: Change Target::EvaluateExpression to take an ExecutionContextScope * rather than a StackFrame * (StackFrame is an ExecutionContextScope.) That allows you to call an

[Lldb-commits] [PATCH] D14163: Address another race condition running tests on Windows

2015-10-28 Thread Adrian McCarthy via lldb-commits
amccarth created this revision. amccarth added a reviewer: zturner. amccarth added a subscriber: lldb-commits. Another case where sleep-and-retry avoids file access errors on Windows. http://reviews.llvm.org/D14163 Files: packages/Python/lldbsuite/test/lldbtest.py Index:

Re: [Lldb-commits] [PATCH] D14163: Address another race condition running tests on Windows

2015-10-28 Thread Adrian McCarthy via lldb-commits
amccarth added inline comments. Comment at: packages/Python/lldbsuite/test/lldbtest.py:1823-1830 @@ -1822,3 +1822,10 @@ -os.rename(src, dst) +try: +os.rename(src, dst) +except: +

[Lldb-commits] [lldb] r251578 - Initialize data_len to 0 in source/Plugins/Platform/Android/AdbClient.cpp

2015-10-28 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 28 18:23:44 2015 New Revision: 251578 URL: http://llvm.org/viewvc/llvm-project?rev=251578=rev Log: Initialize data_len to 0 in source/Plugins/Platform/Android/AdbClient.cpp Modified: lldb/trunk/source/Plugins/Platform/Android/AdbClient.cpp Modified:

[Lldb-commits] [lldb] r251583 - Fix potential null deref; after SymbolContextSpecifier::SymbolContextMatches

2015-10-28 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 28 18:49:55 2015 New Revision: 251583 URL: http://llvm.org/viewvc/llvm-project?rev=251583=rev Log: Fix potential null deref; after SymbolContextSpecifier::SymbolContextMatches has tested that sc.function is null, it would try to deref sc.function. It should be

[Lldb-commits] [lldb] r251585 - Explicitly cast size_t var to (uint64_t) when printf format is PRIx64.

2015-10-28 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 28 19:13:42 2015 New Revision: 251585 URL: http://llvm.org/viewvc/llvm-project?rev=251585=rev Log: Explicitly cast size_t var to (uint64_t) when printf format is PRIx64. Modified:

[Lldb-commits] [lldb] r251586 - Xcode suggested enabling a "no common blocks" warning

2015-10-28 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 28 19:21:14 2015 New Revision: 251586 URL: http://llvm.org/viewvc/llvm-project?rev=251586=rev Log: Xcode suggested enabling a "no common blocks" warning (whatever that is) and wanted to clean up some duplicated entries in the project files. Modified:

[Lldb-commits] [lldb] r251581 - Remove an unused local variable

2015-10-28 Thread Enrico Granata via lldb-commits
Author: enrico Date: Wed Oct 28 18:36:44 2015 New Revision: 251581 URL: http://llvm.org/viewvc/llvm-project?rev=251581=rev Log: Remove an unused local variable Modified: lldb/trunk/source/DataFormatters/TypeCategoryMap.cpp Modified: lldb/trunk/source/DataFormatters/TypeCategoryMap.cpp URL:

[Lldb-commits] [lldb] r251584 - Static analyzer noticed that a null get_pending_items_caller could

2015-10-28 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 28 19:08:03 2015 New Revision: 251584 URL: http://llvm.org/viewvc/llvm-project?rev=251584=rev Log: Static analyzer noticed that a null get_pending_items_caller could be used. Guard against that. Modified:

[Lldb-commits] [lldb] r251587 - Fix Clang-tidy modernize-use-nullptr warnings in include/lldb/Expression and Host; other minor fixes.

2015-10-28 Thread Eugene Zelenko via lldb-commits
Author: eugenezelenko Date: Wed Oct 28 19:27:24 2015 New Revision: 251587 URL: http://llvm.org/viewvc/llvm-project?rev=251587=rev Log: Fix Clang-tidy modernize-use-nullptr warnings in include/lldb/Expression and Host; other minor fixes. Modified:

[Lldb-commits] [PATCH] D14166: Correctly include LLVM_EXTERNAL_CLANG_SOURCE_DIR.

2015-10-28 Thread Chaoren Lin via lldb-commits
chaoren created this revision. chaoren added reviewers: sas, ovyalov. chaoren added a subscriber: lldb-commits. http://reviews.llvm.org/D14166 Files: cmake/modules/LLDBConfig.cmake Index: cmake/modules/LLDBConfig.cmake === ---

Re: [Lldb-commits] [PATCH] D14166: Correctly include LLVM_EXTERNAL_CLANG_SOURCE_DIR.

2015-10-28 Thread Chaoren Lin via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL251589: Correctly include LLVM_EXTERNAL_CLANG_SOURCE_DIR. (authored by chaoren). Changed prior to commit: http://reviews.llvm.org/D14166?vs=38700=38702#toc Repository: rL LLVM

[Lldb-commits] [PATCH] D14169: Rename argdumper to lldb-argdumper.

2015-10-28 Thread Todd Fiala via lldb-commits
tfiala created this revision. tfiala added reviewers: labath, zturner, jasonmolenda. tfiala added a subscriber: lldb-commits. Distributions that put lldb binaries in /usr/bin and whatnot are going to put argdumper in the same place. argdumper is way too generic a name. Rename to