[llvm-commits] CVS: llvm/include/llvm/Type.h

2007-05-17 Thread Dan Gohman
Changes in directory llvm/include/llvm: Type.h updated: 1.107 - 1.108 --- Log message: Correct a name in a comment. --- Diffs of the changes: (+4 -3) Type.h |7 --- 1 files changed, 4 insertions(+), 3 deletions(-) Index: llvm/include/llvm/Type.h diff -u

[llvm-commits] CVS: llvm/include/llvm/PassAnalysisSupport.h

2007-05-14 Thread Dan Gohman
Changes in directory llvm/include/llvm: PassAnalysisSupport.h updated: 1.30 - 1.31 --- Log message: Add a addRequiredTransitiveID member function, which is to addRequiredTransitive as addRequiredID is to addRequired. --- Diffs of the changes: (+8 -6) PassAnalysisSupport.h | 14

[llvm-commits] CVS: llvm/include/llvm/Support/DOTGraphTraits.h

2007-05-14 Thread Dan Gohman
Changes in directory llvm/include/llvm/Support: DOTGraphTraits.h updated: 1.15 - 1.16 --- Log message: Use templates for the GraphType for DefaultDOTGraphTraits' members instead of just using void*. This allows it to be used with graph adapters like Inverse. --- Diffs of the changes: (+12

[llvm-commits] CVS: llvm/lib/Analysis/CFGPrinter.cpp

2007-05-14 Thread Dan Gohman
Changes in directory llvm/lib/Analysis: CFGPrinter.cpp updated: 1.26 - 1.27 --- Log message: Add passes -view-cfg and -view-cfg-only that are like -print-cfg and -print-cfg-only except they use the ViewCFG function, which displays the CFG rendered with graphviz with gv. --- Diffs of the

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopUnroll.cpp

2007-05-14 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopUnroll.cpp updated: 1.47 - 1.48 --- Log message: Correct a few comments. --- Diffs of the changes: (+5 -5) LoopUnroll.cpp | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) Index:

[llvm-commits] CVS: llvm/include/llvm/CodeGen/SelectionDAGNodes.h

2007-05-14 Thread Dan Gohman
Changes in directory llvm/include/llvm/CodeGen: SelectionDAGNodes.h updated: 1.189 - 1.190 --- Log message: Correct a comment. --- Diffs of the changes: (+1 -1) SelectionDAGNodes.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

Re: [llvm-commits] beginning unroll improvements

2007-05-11 Thread Dan Gohman
Devang Patel wrote: This looks good. Have you run any llvm-test benchmarks or any other benchmarks ? I'm not currently planning to make loop-unroll unroll anything more by default than what it currently does, so I don't expect llvm-test to be affected. Dan -- Dan Gohman, Cray Inc

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopUnroll.cpp

2007-05-11 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopUnroll.cpp updated: 1.46 - 1.47 --- Log message: This patch extends the LoopUnroll pass to be able to unroll loops with unknown trip counts. This is left off by default, and a command-line option enables it. It also begins to separate loop

[llvm-commits] CVS: llvm/include/llvm/Instructions.h

2007-05-11 Thread Dan Gohman
Changes in directory llvm/include/llvm: Instructions.h updated: 1.73 - 1.74 --- Log message: Simplify BranchInst::getSuccessor, avoiding a conditional operator. --- Diffs of the changes: (+1 -2) Instructions.h |3 +-- 1 files changed, 1 insertion(+), 2 deletions(-) Index:

[llvm-commits] CVS: llvm/include/llvm/Pass.h

2007-05-11 Thread Dan Gohman
Changes in directory llvm/include/llvm: Pass.h updated: 1.90 - 1.91 --- Log message: Add explicit keywords to several constructors that now have one argument. --- Diffs of the changes: (+5 -5) Pass.h | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) Index:

[llvm-commits] CVS: llvm/include/llvm/Pass.h PassManager.h

2007-05-11 Thread Dan Gohman
Changes in directory llvm/include/llvm: Pass.h updated: 1.91 - 1.92 PassManager.h updated: 1.39 - 1.40 --- Log message: Remove forward-declarations for classes that don't exist. --- Diffs of the changes: (+0 -3) Pass.h|2 -- PassManager.h |1 - 2 files changed, 3

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/InstructionCombining.cpp LoopRotation.cpp

2007-05-11 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: InstructionCombining.cpp updated: 1.764 - 1.765 LoopRotation.cpp updated: 1.13 - 1.14 --- Log message: Fix typos. --- Diffs of the changes: (+3 -3) InstructionCombining.cpp |2 +- LoopRotation.cpp |4 ++-- 2 files changed, 3

[llvm-commits] CVS: llvm/lib/Transforms/Utils/LCSSA.cpp

2007-05-11 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Utils: LCSSA.cpp updated: 1.42 - 1.43 --- Log message: Fix typos. --- Diffs of the changes: (+1 -1) LCSSA.cpp |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/lib/Transforms/Utils/LCSSA.cpp diff -u

[llvm-commits] CVS: llvm/lib/VMCore/Instructions.cpp

2007-05-11 Thread Dan Gohman
Changes in directory llvm/lib/VMCore: Instructions.cpp updated: 1.91 - 1.92 --- Log message: Update comments to say vector instead of packed. --- Diffs of the changes: (+10 -10) Instructions.cpp | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) Index:

[llvm-commits] beginning unroll improvements

2007-05-09 Thread Dan Gohman
might be provided by other sources, for example by a pass that peels/splits the loop for this purpose. Dan -- Dan Gohman, Cray Inc. Index: test/Transforms/LoopUnroll/2007-05-09-UnknownTripCount.ll === RCS file: test/Transforms/LoopUnroll

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopUnroll.cpp

2007-05-08 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopUnroll.cpp updated: 1.44 - 1.45 --- Log message: Correct the comment for ApproximateLoopSize to reflect what it actually does. --- Diffs of the changes: (+1 -2) LoopUnroll.cpp |3 +-- 1 files changed, 1 insertion(+), 2 deletions(-)

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopUnroll.cpp

2007-05-08 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopUnroll.cpp updated: 1.45 - 1.46 --- Log message: Fix various whitespace inconsistencies. --- Diffs of the changes: (+10 -10) LoopUnroll.cpp | 20 ++-- 1 files changed, 10 insertions(+), 10 deletions(-) Index:

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp

2007-05-04 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopStrengthReduce.cpp updated: 1.135 - 1.136 --- Log message: Use IntrinsicInst to test for prefetch instructions, which is ever so slightly nicer than using CallInst with an extra check; thanks Chris. --- Diffs of the changes: (+5 -6)

[llvm-commits] CVS: llvm/lib/Target/X86/X86TargetAsmInfo.cpp

2007-05-03 Thread Dan Gohman
Changes in directory llvm/lib/Target/X86: X86TargetAsmInfo.cpp updated: 1.39 - 1.40 --- Log message: Sets the section names for fixed-size constants and use the mergeable flag for ELF on x86 so that duplicate constants can be eliminated by the linker. This matches what GCC does with its

[llvm-commits] CVS: llvm/include/llvm/Analysis/ScalarEvolution.h

2007-05-03 Thread Dan Gohman
Changes in directory llvm/include/llvm/Analysis: ScalarEvolution.h updated: 1.19 - 1.20 --- Log message: Use the explicit keyword for the SCEV class' constructor. --- Diffs of the changes: (+1 -1) ScalarEvolution.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/lib/Target/TargetAsmInfo.cpp

2007-05-03 Thread Dan Gohman
Changes in directory llvm/lib/Target: TargetAsmInfo.cpp updated: 1.25 - 1.26 --- Log message: Indent the .text, .data, and .bss directives in assembly output, so that they are consistent with the other directives. --- Diffs of the changes: (+3 -3) TargetAsmInfo.cpp |6 +++--- 1 files

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp

2007-05-03 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LoopStrengthReduce.cpp updated: 1.134 - 1.135 --- Log message: Allow strength reduction to make use of addressing modes for the address operand in a prefetch intrinsic. --- Diffs of the changes: (+10 -1) LoopStrengthReduce.cpp | 11

[llvm-commits] ELF sections in X86AsmTargetAsm.cpp

2007-05-01 Thread Dan Gohman
that don't support this? It looks like nasm/yasm wouldn't accept some of the other things that LLVM currently emits anyway.. Dan -- Dan Gohman, Cray Inc. Index: lib/Target/X86/X86TargetAsmInfo.cpp === RCS file: /var/cvs/llvm/llvm/lib/Target

[llvm-commits] CVS: llvm/include/llvm/Target/TargetData.h

2007-04-26 Thread Dan Gohman
Changes in directory llvm/include/llvm/Target: TargetData.h updated: 1.59 - 1.60 --- Log message: Fix a typo in a comment. --- Diffs of the changes: (+1 -1) TargetData.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/include/llvm/Target/TargetData.h diff -u

[llvm-commits] CVS: llvm/lib/CodeGen/SelectionDAG/ScheduleDAGRRList.cpp

2007-04-26 Thread Dan Gohman
Changes in directory llvm/lib/CodeGen/SelectionDAG: ScheduleDAGRRList.cpp updated: 1.29 - 1.30 --- Log message: Fix a typo in a comment. --- Diffs of the changes: (+1 -1) ScheduleDAGRRList.cpp |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/utils/TableGen/CodeGenIntrinsics.h

2007-04-26 Thread Dan Gohman
Changes in directory llvm/utils/TableGen: CodeGenIntrinsics.h updated: 1.12 - 1.13 --- Log message: Update a comment to reflect recent changes in the type system. --- Diffs of the changes: (+1 -1) CodeGenIntrinsics.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/test/CodeGen/X86/dollar-name.ll

2007-04-26 Thread Dan Gohman
Changes in directory llvm/test/CodeGen/X86: dollar-name.ll added (r1.1) --- Log message: testcase for PR1339: http://llvm.org/PR1339 : http://llvm.org/PR1339: http://llvm.org/PR1339 --- Diffs of the changes: (+17 -0) dollar-name.ll | 17 + 1 files changed, 17

[llvm-commits] CVS: llvm/lib/Target/X86/X86ATTAsmPrinter.cpp

2007-04-26 Thread Dan Gohman
Changes in directory llvm/lib/Target/X86: X86ATTAsmPrinter.cpp updated: 1.102 - 1.103 --- Log message: Fix PR1339: http://llvm.org/PR1339 and CodeGen/X86/dollar-name.ll --- Diffs of the changes: (+32 -3) X86ATTAsmPrinter.cpp | 35 --- 1 files changed, 32

Re: [llvm-commits] Function aliases

2007-04-19 Thread Dan Gohman
: int x = 2; extern int y __attribute__((alias(x))); Dan -- Dan Gohman, Cray Inc. ___ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits

[llvm-commits] CVS: llvm/lib/Target/X86/X86InstrSSE.td

2007-04-18 Thread Dan Gohman
Changes in directory llvm/lib/Target/X86: X86InstrSSE.td updated: 1.180 - 1.181 --- Log message: Fix the spelling of the prefetchnta instruction. --- Diffs of the changes: (+1 -1) X86InstrSSE.td |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/LICM.cpp

2007-04-17 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: LICM.cpp updated: 1.90 - 1.91 --- Log message: Spell doFinalization right, so that it is a proper virtual override and gets called. --- Diffs of the changes: (+1 -1) LICM.cpp |2 +- 1 files changed, 1 insertion(+), 1 deletion(-)

Re: [llvm-commits] CVS: llvm/test/CodeGen/X86/vec_call.ll

2007-04-16 Thread Dan Gohman
-; RUN: llvm-upgrade %s | llvm-as | llc -march=x86 -mattr=+sse2 | \ +; RUN: llvm-upgrade %s | llvm-as | llc -march=x86 -mattr=+sse2 -mtriple=powerpc-apple-darwin8 | \ Did you really mean to use a powerpc triple with -march=x86? Dan -- Dan Gohman, Cray Inc

[llvm-commits] CVS: llvm/include/llvm/Argument.h BasicBlock.h Constant.h Constants.h Function.h GlobalValue.h GlobalVariable.h InlineAsm.h Instruction.h Value.h

2007-04-13 Thread Dan Gohman
Changes in directory llvm/include/llvm: Argument.h updated: 1.14 - 1.15 BasicBlock.h updated: 1.63 - 1.64 Constant.h updated: 1.35 - 1.36 Constants.h updated: 1.145 - 1.146 Function.h updated: 1.73 - 1.74 GlobalValue.h updated: 1.34 - 1.35 GlobalVariable.h updated: 1.40 - 1.41 InlineAsm.h

[llvm-commits] CVS: llvm/include/llvm/Support/PatternMatch.h

2007-04-13 Thread Dan Gohman
Changes in directory llvm/include/llvm/Support: PatternMatch.h updated: 1.19 - 1.20 --- Log message: Rename Value::getValueType to getValueID, to avoid confusion with other things named getValueType. --- Diffs of the changes: (+3 -3) PatternMatch.h |6 +++--- 1 files changed, 3

[llvm-commits] [patch] minor instcombine+bitcast improvement

2007-04-06 Thread Dan Gohman
= bitcast i32* %s to float* I'm not yet familiar with instcombine's canonicalization style; is this a desireable change? It doesn't cause any regressions for me. Dan -- Dan Gohman, Cray Inc. Index: InstructionCombining.cpp === RCS

Re: [llvm-commits] CVS: llvm/lib/Target/X86/X86InstrInfo.cpp

2007-03-28 Thread Dan Gohman
.txt Dan -- Dan Gohman, Cray Inc. ___ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits

[llvm-commits] CVS: llvm/include/llvm/Argument.h BasicBlock.h Constants.h DerivedTypes.h Module.h PassAnalysisSupport.h PassManager.h PassManagers.h PassSupport.h Type.h

2007-03-23 Thread Dan Gohman
Changes in directory llvm/include/llvm: Argument.h updated: 1.13 - 1.14 BasicBlock.h updated: 1.62 - 1.63 Constants.h updated: 1.139 - 1.140 DerivedTypes.h updated: 1.88 - 1.89 Module.h updated: 1.84 - 1.85 PassAnalysisSupport.h updated: 1.28 - 1.29 PassManager.h updated: 1.38 - 1.39

[llvm-commits] CVS: llvm/lib/VMCore/AsmWriter.cpp Instructions.cpp

2007-03-22 Thread Dan Gohman
Changes in directory llvm/lib/VMCore: AsmWriter.cpp updated: 1.264 - 1.265 Instructions.cpp updated: 1.80 - 1.81 --- Log message: Change uses of Function::front to Function::getEntryBlock for readability. --- Diffs of the changes: (+2 -2) AsmWriter.cpp|2 +- Instructions.cpp |

[llvm-commits] CVS: llvm/lib/Transforms/Utils/CloneFunction.cpp CodeExtractor.cpp InlineFunction.cpp SimplifyCFG.cpp

2007-03-22 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Utils: CloneFunction.cpp updated: 1.43 - 1.44 CodeExtractor.cpp updated: 1.50 - 1.51 InlineFunction.cpp updated: 1.54 - 1.55 SimplifyCFG.cpp updated: 1.118 - 1.119 --- Log message: Change uses of Function::front to Function::getEntryBlock for

[llvm-commits] CVS: llvm/lib/Analysis/ProfileInfo.cpp ProfileInfoLoader.cpp

2007-03-22 Thread Dan Gohman
Changes in directory llvm/lib/Analysis: ProfileInfo.cpp updated: 1.10 - 1.11 ProfileInfoLoader.cpp updated: 1.11 - 1.12 --- Log message: Change uses of Function::front to Function::getEntryBlock for readability. --- Diffs of the changes: (+3 -2) ProfileInfo.cpp |2 +-

[llvm-commits] CVS: llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp

2007-03-22 Thread Dan Gohman
Changes in directory llvm/lib/CodeGen/SelectionDAG: SelectionDAGISel.cpp updated: 1.390 - 1.391 --- Log message: Change uses of Function::front to Function::getEntryBlock for readability. --- Diffs of the changes: (+1 -1) SelectionDAGISel.cpp |2 +- 1 files changed, 1 insertion(+), 1

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/InstructionCombining.cpp LICM.cpp ScalarReplAggregates.cpp TailRecursionElimination.cpp

2007-03-22 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Scalar: InstructionCombining.cpp updated: 1.671 - 1.672 LICM.cpp updated: 1.88 - 1.89 ScalarReplAggregates.cpp updated: 1.80 - 1.81 TailRecursionElimination.cpp updated: 1.29 - 1.30 --- Log message: Change uses of Function::front to

[llvm-commits] CVS: llvm/lib/Transforms/Utils/InlineFunction.cpp

2007-02-20 Thread Dan Gohman
Changes in directory llvm/lib/Transforms/Utils: InlineFunction.cpp updated: 1.53 - 1.54 --- Log message: Fix typos in comments. --- Diffs of the changes: (+1 -1) InlineFunction.cpp |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/lib/Target/Target.td

2007-02-20 Thread Dan Gohman
Changes in directory llvm/lib/Target: Target.td updated: 1.92 - 1.93 --- Log message: Fix typos in comments. --- Diffs of the changes: (+1 -1) Target.td |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/lib/Target/Target.td diff -u llvm/lib/Target/Target.td:1.92

[llvm-commits] CVS: llvm/CREDITS.TXT

2007-02-15 Thread Dan Gohman
/CREDITS.TXT:1.67 Sun Jan 7 21:10:00 2007 +++ llvm/CREDITS.TXTThu Feb 15 16:05:14 2007 @@ -85,6 +85,10 @@ E: [EMAIL PROTECTED] D: Callgraph class cleanups +N: Dan Gohman +E: [EMAIL PROTECTED] +D: Miscellaneous bug fixes + N: Paolo Invernizzi E: [EMAIL PROTECTED] D: Visual C

[llvm-commits] fix cases of assert(foo)

2007-02-13 Thread Dan Gohman
-- Dan Gohman, Cray Inc. [EMAIL PROTECTED] Index: lib/Bytecode/Reader/Reader.cpp === RCS file: /var/cvs/llvm/llvm/lib/Bytecode/Reader/Reader.cpp,v retrieving revision 1.238 diff -u -r1.238 Reader.cpp --- lib/Bytecode/Reader

<    1   2   3   4   5