[lng-odp] [API-NEXT PATCH v5 0/7] Multi-queue packet io APIs

2015-11-26 Thread Petri Savolainen
This patch set adds APIs for multi-queue packet IO. It does not remove or modify existing API calls, so that multi-queue can be verified first with couple of apps and implementations. Single queue APIs (e.g. odp_pktio_inq_setdef()) and potentially plain _recv() and _send() should be removed once

[lng-odp] [API-NEXT PATCH v5 3/7] api: pktio: added direct queue receive

2015-11-26 Thread Petri Savolainen
Added odp_pktio_recv_queue for direct packet receive from pktio input queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 33 - 1 file changed, 28 insertions(+), 5 deletions(-) diff --git

[lng-odp] [API-NEXT PATCH v5 1/7] api: pktio: added pktio capability struct

2015-11-26 Thread Petri Savolainen
Added capability structure and a function to query it. Capability limits are used for advanced pktio configuration, like configuration of multiple input/output queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 23 +++ 1

[lng-odp] [API-NEXT PATCH v5 5/7] api: pktio: added direct send to pktio output queue

2015-11-26 Thread Petri Savolainen
Added odp_pktio_send_queue for direct packet send to a pktio output queue. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 39 +++ 1 file changed, 31 insertions(+), 8 deletions(-) diff --git

[lng-odp] [API-NEXT PATCH v5 4/7] api: pktio: added multiple pktio output queues

2015-11-26 Thread Petri Savolainen
Added output queue configuration parameters and functions for setting up multiple output queues. Added also a function to query the number of output queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h| 71

[lng-odp] [API-NEXT PATCH v5 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-26 Thread Petri Savolainen
Implemented multi-queue API with dummy single queue support. Enables testing the API and provides stubbs for actual multi-queue implementations. Not optimized. Signed-off-by: Petri Savolainen --- .../include/odp/plat/packet_io_types.h | 14 +-

[lng-odp] [API-NEXT PATCH v5 7/7] test: l2fwd: use multi-queue pktio in direct mode

2015-11-26 Thread Petri Savolainen
Modified the application to support for multiple queues per interface. Enabled inequal worker thread counts. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 413 --- 1 file changed, 351 insertions(+), 62

Re: [lng-odp] [API-NEXT PATCH 1/3] api: thrmask: correct specification error

2015-11-26 Thread Savolainen, Petri (Nokia - FI/Espoo)
Ping. This series fixes ‘make install’. Why it has not been merged? 6 days since the review… From: EXT Bill Fischofer [mailto:bill.fischo...@linaro.org] Sent: Friday, November 20, 2015 3:43 PM To: Savolainen, Petri (Nokia - FI/Espoo) Cc: LNG ODP Mailman List Subject: Re: [lng-odp] [API-NEXT

Re: [lng-odp] [API-NEXT PATCH] api: sync: update spec and add odp_sync_loads

2015-11-26 Thread Savolainen, Petri (Nokia - FI/Espoo)
Ping. This improves current sync spec and implementation. > -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT > Petri Savolainen > Sent: Monday, October 26, 2015 6:08 PM > To: lng-odp@lists.linaro.org > Subject: [lng-odp] [API-NEXT PATCH] api:

Re: [lng-odp] [API-NEXT PATCH v3] api: atomic: added atomic_lock_free_u64

2015-11-26 Thread Savolainen, Petri (Nokia - FI/Espoo)
ping. > -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT > Petri Savolainen > Sent: Thursday, November 12, 2015 10:30 AM > To: lng-odp@lists.linaro.org > Subject: [lng-odp] [API-NEXT PATCH v3] api: atomic: added > atomic_lock_free_u64 > >

[lng-odp] api-next: make distcheck build is broken

2015-11-26 Thread Savolainen, Petri (Nokia - FI/Espoo)
In api-next branch: ./bootstrap ./configure make distcheck CC odp_barrier.lo CC odp_buffer.lo CC odp_classification.lo In file included from ../../../platform/linux-generic/include/odp/packet_io.h:35:0, from

Re: [lng-odp] [API-NEXT PATCH] api: init: allow implementation to use private ways for its own configuration

2015-11-26 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: EXT Zoltan Kiss [mailto:zoltan.k...@linaro.org] > Sent: Tuesday, November 24, 2015 4:45 PM > To: lng-odp@lists.linaro.org > Cc: bill.fischo...@linaro.org; Savolainen, Petri (Nokia - FI/Espoo); > mike.hol...@linaro.org > Subject: Re: [API-NEXT PATCH] api:

Re: [lng-odp] api-next: make distcheck build is broken

2015-11-26 Thread Maxim Uvarov
Looks like it's my fault with wrong sync master which moved includes from Makefile.am to Makefile.inc. Will fix it shortly. Maxim. On 11/26/2015 12:03, Savolainen, Petri (Nokia - FI/Espoo) wrote: In api-next branch: ./bootstrap ./configure make distcheck CC odp_barrier.lo CC

[lng-odp] [PATCH] mergefix: add mising includes to Makefile.inc

2015-11-26 Thread Maxim Uvarov
Looks like merge conflict was not cleanly fixed moving includes from Makefile.am to Makefile.inc. Adding missed. Signed-off-by: Maxim Uvarov --- platform/Makefile.inc | 4 1 file changed, 4 insertions(+) diff --git a/platform/Makefile.inc b/platform/Makefile.inc

Re: [lng-odp] [API-NEXT PATCH v3] api: atomic: added atomic_lock_free_u64

2015-11-26 Thread Maxim Uvarov
Ola, can you please review the final version? Maxim. On 11/26/2015 11:56, Savolainen, Petri (Nokia - FI/Espoo) wrote: ping. -Original Message- From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT Petri Savolainen Sent: Thursday, November 12, 2015 10:30 AM To:

[lng-odp] [API-NEXT PATCHv2] mergefix: add mising includes to Makefile.inc

2015-11-26 Thread Maxim Uvarov
Looks like merge conflict was not cleanly fixed moving includes from Makefile.am to Makefile.inc. Adding missed. Signed-off-by: Maxim Uvarov --- v2: - added missing std_clib.h (thanks Anders) - patch prefix is API-NEXT platform/Makefile.inc | 5 + 1 file

Re: [lng-odp] [API-NEXT PATCH v3] api: atomic: added atomic_lock_free_u64

2015-11-26 Thread Ola Liljedahl
Yes I will do that. On 26 November 2015 at 12:41, Maxim Uvarov wrote: > Ola, can you please review the final version? > > Maxim. > > > On 11/26/2015 11:56, Savolainen, Petri (Nokia - FI/Espoo) wrote: >> >> ping. >> >>> -Original Message- >>> From: lng-odp

Re: [lng-odp] [API-NEXT PATCH v2] helper: add cuckoo hash implementation

2015-11-26 Thread HePeng
Cuckoo Hash Table is an efficient hash table variant which has a very high utilization (load/total entries > 90%). In our tests, the utilization is around 94%. Here is a brief introduction on cuckoo hash: https://en.wikipedia.org/wiki/Cuckoo_hashing

Re: [lng-odp] [API-NEXT PATCHv2] mergefix: add mising includes to Makefile.inc

2015-11-26 Thread Anders Roxell
On 2015-11-26 15:35, Maxim Uvarov wrote: > Looks like merge conflict was not cleanly fixed moving > includes from Makefile.am to Makefile.inc. Adding > missed. > > Signed-off-by: Maxim Uvarov > --- > v2: - added missing std_clib.h (thanks Anders) > - patch prefix

Re: [lng-odp] [API-NEXT PATCH v2] helper: add cuckoo hash implementation

2015-11-26 Thread Maxim Uvarov
Peng, please find quick review bellow. The main comment is you need to split this patch on 3 patches: - "api:" patch with proposal api change; - implementation patch - validation test patch. I just wanted to move code from helper to linux-generic and reuse it for shm ipc. But now it looks

Re: [lng-odp] [API-NEXT PATCHv2] mergefix: add mising includes to Makefile.inc

2015-11-26 Thread Maxim Uvarov
Merged with reorder Thanks. On 11/26/2015 16:28, Anders Roxell wrote: On 2015-11-26 15:35, Maxim Uvarov wrote: Looks like merge conflict was not cleanly fixed moving includes from Makefile.am to Makefile.inc. Adding missed. Signed-off-by: Maxim Uvarov --- v2: -

Re: [lng-odp] [API-NEXT PATCH 1/3] api: thrmask: correct specification error

2015-11-26 Thread Maxim Uvarov
Merged, Thanks. Maxim. On 11/26/2015 11:45, Savolainen, Petri (Nokia - FI/Espoo) wrote: Ping. This series fixes ‘make install’. Why it has not been merged? 6 days since the review… Sorry, was busy with other things. *From:*EXT Bill Fischofer [mailto:bill.fischo...@linaro.org] *Sent:*

Re: [lng-odp] [API-NEXT PATCHv4 0/5] pktio statistics counters

2015-11-26 Thread Maxim Uvarov
ping. On 11/24/2015 16:10, Maxim Uvarov wrote: v4: - fix Stuarts and Mikes comments. v3: - fix netmap (ethtool = 1); v2: - try to use ethtool for statistics counters if not fall back to sysfs. ( virtual veth devices do not support sysfs, netmap does not support sysfs.) - fix

Re: [lng-odp] [API-NEXT PATCH] api: init: allow implementation to use private ways for its own configuration

2015-11-26 Thread Zoltan Kiss
On 26/11/15 09:25, Savolainen, Petri (Nokia - FI/Espoo) wrote: -Original Message- From: EXT Zoltan Kiss [mailto:zoltan.k...@linaro.org] Sent: Tuesday, November 24, 2015 4:45 PM To: lng-odp@lists.linaro.org Cc: bill.fischo...@linaro.org; Savolainen, Petri (Nokia - FI/Espoo);

Re: [lng-odp] [API-NEXT PATCH v3 0/7] api: time: update local time to be monotonic

2015-11-26 Thread Ivan Khoronzhuk
ping On 23.11.15 23:20, Ivan Khoronzhuk wrote: This series is intended to modify time API to be used as monotonic wall time in order to simplify time API usage and create prerequisites for adding global time API. Since v2: - removed patch changing type of ODP_TIME_* - added new patch: test:

Re: [lng-odp] [API-NEXT PATCH] api: sync: update spec and add odp_sync_loads

2015-11-26 Thread Ola Liljedahl
On 12 November 2015 at 11:03, Savolainen, Petri (Nokia - FI/Espoo) < petri.savolai...@nokia.com> wrote: >> > if (msg == UPDATE_FOO) { >> > // Make sure that load of “foo” is not moved before schedule() >> > odp_sync_loads(); >> >> odp_sync_acquire() would be a better name. >> >> > >> >

[lng-odp] [API-NEXT PATCH] api: pool: clarify user area initializer usage

2015-11-26 Thread Zoltan Kiss
Clarify when exactly the function should be called by a platform, and what is promised about the data modified by it. Signed-off-by: Zoltan Kiss --- Petri, please review this before 1.5. It contains the code I quoted in my answer to the original thread. This lingers

Re: [lng-odp] [API-NEXT PATCHv2 0/4] AES125-GCM support

2015-11-26 Thread Maxim Uvarov
Merged, api was reviewed by Petri, validation and implementation looks about the same as other ciphers. Maxim. On 11/24/2015 18:44, Nicolas Morey-Chaisemartin wrote: Ping On 11/17/2015 04:43 PM, Nicolas Morey-Chaisemartin wrote: I have prepared a serie to validate md5_check and