Re: [lng-odp] [API-NEXT 4/4] A scalable software scheduler

2017-03-29 Thread Brian Brooks
On 03/29 11:20:37, Savolainen, Petri (Nokia - FI/Espoo) wrote: > Couple of high level comments: > > 1) Too many #ifdefs >* Code is hard to read and maintain when every 10th line is #ifdef or #else >* Are all #ifdef combinations tested? Or meant to be supported? >* It seems that some de

[lng-odp] [Bug 2797] scheduler_main runs for long time

2017-03-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2797 Yi He changed: What|Removed |Added CC||yi...@linaro.org Resolution|---

Re: [lng-odp] [API-NEXT 4/4] A scalable software scheduler

2017-03-29 Thread Brian Brooks
On 03/29 10:39:35, Maxim Uvarov wrote: > 1. Prefix has to be "PATCH API-NEXT" not "API-NEXT" Okay. > 2. Please remove ifdefs. And compile all variants of schedules into the > library. Code needs to be compile each time. There are multiple ways to interpret this. Can you please describe the chang

[lng-odp] [Bug 2908] Packet validation test fails if implementation does not limit packet length

2017-03-29 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2908 Bill Fischofer changed: What|Removed |Added Status|IN_PROGRESS |RESOLVED Resolution|---

Re: [lng-odp] [PATCH] validation: packet: do assert on newly created pkt reference

2017-03-29 Thread Bill Fischofer
On Wed, Mar 29, 2017 at 3:15 AM, Balakrishna Garapati wrote: > Signed-off-by: Balakrishna Garapati Reviewed-by: Bill Fischofer > --- > test/common_plat/validation/api/packet/packet.c | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/test/common_plat/validation/api/packet/packet.c >

Re: [lng-odp] Sequence requirments for odp_schedule_order_lock()

2017-03-29 Thread Bill Fischofer
On Wed, Mar 29, 2017 at 7:18 AM, Radosław Biernacki wrote: > Hi all, > > The documentation for odp_schedule_order_lock(unsigned lock_index) does not > specify the sequence in which the lock_index need to be given. That's because there is no such required sequence. Each lock index is a distinct or

Re: [lng-odp] [PATCH] test: perf: fix bash syntax in odp_pktio_ordered_run.sh

2017-03-29 Thread Maxim Uvarov
in Travis this fails but passes locally. Will look more on reasons before merge it. Looks like after it began to work MAX_PPS rate should be adjusted to some number. Maxim. On 03/29/17 06:14, Bill Fischofer wrote: > > > On Tue, Mar 21, 2017 at 11:50 AM, Maxim Uvarov

[lng-odp] [Linaro/odp] 39b3a1: linux-gen: remove pktio ipc option from configure

2017-03-29 Thread GitHub
Branch: refs/heads/master Home: https://github.com/Linaro/odp Commit: 39b3a1681097638f5ba99666447553293abdef20 https://github.com/Linaro/odp/commit/39b3a1681097638f5ba99666447553293abdef20 Author: Maxim Uvarov Date: 2017-03-29 (Wed, 29 Mar 2017) Changed paths: M configu

Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control

2017-03-29 Thread Bill Fischofer
On Wed, Mar 29, 2017 at 8:38 AM, Bogdan Pricope wrote: > > What about: > > void odp_packet_out_l3_csum_override(odp_packet_t pkt, odp_bool_t compute); That's a bit of a mouthful. Since chksum insertion only makes sense on output that's implied here, so I think Petri's name choices seem clear and

Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control

2017-03-29 Thread Bogdan Pricope
What about: void odp_packet_out_l3_csum_override(odp_packet_t pkt, odp_bool_t compute); On 29 March 2017 at 16:16, Maxim Uvarov wrote: > On 03/29/17 13:10, Savolainen, Petri (Nokia - FI/Espoo) wrote: >> >> >> From: Maxim Uvarov [mailto:maxim.uva...@linaro.org] >> Sent: Wednesday, March 29, 2017

Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control

2017-03-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: Maxim Uvarov [mailto:maxim.uva...@linaro.org] > Sent: Wednesday, March 29, 2017 4:16 PM > To: Savolainen, Petri (Nokia - FI/Espoo) labs.com> > Cc: lng-odp-forward > Subject: Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet > checksum control > > O

Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control

2017-03-29 Thread Maxim Uvarov
On 03/29/17 13:10, Savolainen, Petri (Nokia - FI/Espoo) wrote: > > > From: Maxim Uvarov [mailto:maxim.uva...@linaro.org] > Sent: Wednesday, March 29, 2017 10:26 AM > To: Savolainen, Petri (Nokia - FI/Espoo) > > Cc: Bill Fischofer ; lng-odp-forward > > Subject: Re: [lng-odp] [API-NEXT PATCH]

Re: [lng-odp] [API-NEXT PATCH 1/2] validation: packet: increase test pool size

2017-03-29 Thread Elo, Matias (Nokia - FI/Espoo)
Sorry, wrong version number. Should be ignored. -Matias > On 29 Mar 2017, at 16:10, Matias Elo wrote: > > Previously packet_test_concatsplit() could fail on some pool > implementations as the pool ran out of buffers. Increase default pools size > and use capability to make sure the value is va

[lng-odp] [API-NEXT PATCH v3 1/2] validation: packet: increase test pool size

2017-03-29 Thread Matias Elo
Previously packet_test_concatsplit() could fail on some pool implementations as the pool ran out of buffers. Increase default pools size and use capability to make sure the value is valid. Signed-off-by: Matias Elo --- V3: - Increased pool size (Krishna) test/common_plat/validation/api/packet/p

[lng-odp] [API-NEXT PATCH v3 2/2] validation: packet: remove invalid check from packet_test_alloc_segmented()

2017-03-29 Thread Matias Elo
One can't assume that the packet should be segmented as this test is using a different pool with different parameters than the default test pool. Signed-off-by: Matias Elo --- test/common_plat/validation/api/packet/packet.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/test/common_plat/v

[lng-odp] [API-NEXT PATCH 1/2] validation: packet: increase test pool size

2017-03-29 Thread Matias Elo
Previously packet_test_concatsplit() could fail on some pool implementations as the pool ran out of buffers. Increase default pools size and use capability to make sure the value is valid. Signed-off-by: Matias Elo --- V3: - Increase packet pool size (Krishna) test/common_plat/validation/api/pa

[lng-odp] [API-NEXT PATCH 2/2] validation: packet: remove invalid check from packet_test_alloc_segmented()

2017-03-29 Thread Matias Elo
One can't assume that the packet should be segmented as this test is using a different pool with different parameters than the default test pool. Signed-off-by: Matias Elo --- test/common_plat/validation/api/packet/packet.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/test/common_plat/v

Re: [lng-odp] 32b support in ODP-Cloud

2017-03-29 Thread Bill Fischofer
On Wed, Mar 29, 2017 at 7:29 AM, Ola Liljedahl wrote: > > > On 29 March 2017 at 13:25, Bill Fischofer > wrote: > >> >> >> On Wed, Mar 29, 2017 at 5:47 AM, Ola Liljedahl >> wrote: >> >>> On 29 March 2017 at 10:43, Francois Ozog >>> wrote: >>> If there is a cost to get virtual address, then

Re: [lng-odp] 32b support in ODP-Cloud

2017-03-29 Thread Ola Liljedahl
On 29 March 2017 at 13:25, Bill Fischofer wrote: > > > On Wed, Mar 29, 2017 at 5:47 AM, Ola Liljedahl > wrote: > >> On 29 March 2017 at 10:43, Francois Ozog >> wrote: >> >>> If there is a cost to get virtual address, then I assume translation is >>> NOT just casting: correct? >>> >> Correct. li

[lng-odp] Sequence requirments for odp_schedule_order_lock()

2017-03-29 Thread Radosław Biernacki
Hi all, The documentation for odp_schedule_order_lock(unsigned lock_index) does not specify the sequence in which the lock_index need to be given. Shouldn't the following statements be included in description of this function? 1) All code paths calling this function (in the same synchronization c

Re: [lng-odp] [API-NEXT PATCH v2 1/2] validation: packet: increase test pool size

2017-03-29 Thread Krishna Garapati
On 29 March 2017 at 12:51, Elo, Matias (Nokia - FI/Espoo) < matias@nokia-bell-labs.com> wrote: > > > On 28 Mar 2017, at 17:21, Krishna Garapati org> wrote: > > > > This pool size is not enough with odp-dpdk. It runs out of buffers hence > the "packet_test_ref" fails. We should increase it to

Re: [lng-odp] 32b support in ODP-Cloud

2017-03-29 Thread Bill Fischofer
On Wed, Mar 29, 2017 at 5:47 AM, Ola Liljedahl wrote: > On 29 March 2017 at 10:43, Francois Ozog wrote: > >> If there is a cost to get virtual address, then I assume translation is >> NOT just casting: correct? >> > Correct. linux-generic has a number of dereferences in the code that > returns e

Re: [lng-odp] [API-NEXT 4/4] A scalable software scheduler

2017-03-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
Couple of high level comments: 1) Too many #ifdefs * Code is hard to read and maintain when every 10th line is #ifdef or #else * Are all #ifdef combinations tested? Or meant to be supported? * It seems that some design trade-offs would be needed for better code maintainability 2) Too ma

Re: [lng-odp] [API-NEXT PATCH v2 1/2] validation: packet: increase test pool size

2017-03-29 Thread Elo, Matias (Nokia - FI/Espoo)
> On 28 Mar 2017, at 17:21, Krishna Garapati > wrote: > > This pool size is not enough with odp-dpdk. It runs out of buffers hence the > "packet_test_ref" fails. We should increase it to even higher size. > /Krishna OK, if you have the reference patches merged could you verify which value wo

Re: [lng-odp] 32b support in ODP-Cloud

2017-03-29 Thread Ola Liljedahl
On 29 March 2017 at 10:43, Francois Ozog wrote: > If there is a cost to get virtual address, then I assume translation is > NOT just casting: correct? > Correct. linux-generic has a number of dereferences in the code that returns e.g. the buffer address from a buffer handle. This is not optimised

Re: [lng-odp] [API-NEXT 3/4] api: queue: Add ring_size

2017-03-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim > Uvarov > Sent: Wednesday, March 29, 2017 10:28 AM > To: Brian Brooks > Cc: lng-odp-forward > Subject: Re: [lng-odp] [API-NEXT 3/4] api: queue: Add ring_size > > isn't queue size connecte

Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control

2017-03-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
From: Maxim Uvarov [mailto:maxim.uva...@linaro.org] Sent: Wednesday, March 29, 2017 10:26 AM To: Savolainen, Petri (Nokia - FI/Espoo) Cc: Bill Fischofer ; lng-odp-forward Subject: Re: [lng-odp] [API-NEXT PATCH] api: packet: add per packet checksum control I have few questions for better und

Re: [lng-odp] [API-NEXT 4/4] A scalable software scheduler

2017-03-29 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of > Honnappa Nagarahalli > Sent: Wednesday, March 29, 2017 6:28 AM > To: Bill Fischofer ; Brian Brooks > > Cc: Ola Liljedahl ; Kevin Wang > ; lng-odp-forward > Subject: Re: [lng-odp] [API-NEXT 4/4] A

Re: [lng-odp] 32b support in ODP-Cloud

2017-03-29 Thread Francois Ozog
If there is a cost to get virtual address, then I assume translation is NOT just casting: correct? FF On 29 March 2017 at 10:00, Ola Liljedahl wrote: > So there is a choice between > A) enabling static type checking in the compiler through strong typing > => requires (syntactical) pointers i C

Re: [lng-odp] [API-NEXT 3/4] api: queue: Add ring_size

2017-03-29 Thread Ola Liljedahl
On 29 March 2017 at 03:55, Brian Brooks wrote: > On 03/28 19:18:37, Bill Fischofer wrote: >> > > It is infinitely better to do patch review in plain text rather > than HTML. I thought this was a plain text mailing list? > >> >> >>