Re: [lng-odp] [PATCH 5/8] add fbk hash table

2015-10-09 Thread Ola Liljedahl
On 9 October 2015 at 10:33, HePeng wrote: > > 在 2015年10月9日,下午4:26,Ola Liljedahl 写道: > > On 8 October 2015 at 14:43, HePeng wrote: > >> >> 在 2015年10月8日,下午8:13,Ola Liljedahl 写道: >> >> On 8 October 2015

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Ola Liljedahl
On 9 October 2015 at 09:34, Alexandru Badicioiu < alexandru.badici...@linaro.org> wrote: > The problem you raised is not strictly related to this patch. > A crypto session has an output queue (for async mode) where the results , > including the operation status, will be delivered. There is

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Alexandru Badicioiu
This was a long discussion some time ago and the result was that crypto output should be abstracted in the form of the completion event and access functions would retrieve status and output packets. Also the implementation is in charge with crypto completion event allocation and not the

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Ola Liljedahl
On 9 October 2015 at 10:37, Alexandru Badicioiu < alexandru.badici...@linaro.org> wrote: > This was a long discussion some time ago and the result was that crypto > output should be abstracted in the form of the completion event and access > functions would retrieve status and output packets.

Re: [lng-odp] [PATCH 5/8] add fbk hash table

2015-10-09 Thread Ola Liljedahl
On 8 October 2015 at 14:43, HePeng wrote: > > 在 2015年10月8日,下午8:13,Ola Liljedahl 写道: > > On 8 October 2015 at 10:02, Bill Fischofer > wrote: > >> Trying to keep the rte_ prefix would be confusing. One of the precepts >>

Re: [lng-odp] [PATCH 5/8] add fbk hash table

2015-10-09 Thread HePeng
> 在 2015年10月9日,下午4:36,Ola Liljedahl 写道: > > On 9 October 2015 at 10:33, HePeng > wrote: > >> 在 2015年10月9日,下午4:26,Ola Liljedahl > > 写道: >> >> On 8 October

Re: [lng-odp] [PATCH] checkpatch: escape left braces in regex

2015-10-09 Thread Nicolas Morey-Chaisemartin
It is actually already fixed in the Linux kernel. Shoud we import the latest checkpatch then? $ git show 4e5d56bdf892e18832a6540b63ebf709966bce2a commit 4e5d56bdf892e18832a6540b63ebf709966bce2a Author: Eddie Kovsky Date: Wed Sep 9 15:37:52 2015 -0700 checkpatch: fix

Re: [lng-odp] [PATCH 5/8] add fbk hash table

2015-10-09 Thread HePeng
> 在 2015年10月9日,下午4:26,Ola Liljedahl 写道: > > On 8 October 2015 at 14:43, HePeng > wrote: > >> 在 2015年10月8日,下午8:13,Ola Liljedahl > > 写道: >> >> On 8 October

[lng-odp] [PATCH v2 3/6] test: l2fwd: fix crash when accuracy is set to 0

2015-10-09 Thread Matias Elo
Application crashes if accuracy option is set to zero (division by zero). Disable statistics printing if accuracy <= 0. Signed-off-by: Matias Elo --- test/performance/odp_l2fwd.c | 59 +++- 1 file changed, 37 insertions(+), 22

[lng-odp] [PATCH v2 0/6] l2fwd test improvements

2015-10-09 Thread Matias Elo
Added various improvements to the l2fwd test application: - Supports using odd number of ports - Scheduler queue type can be selected - Added options for enabling/disabling eth address filling New options: -d, --dst_change <0/1>: Enable/disable changing packets' dst eth addresses -s,

Re: [lng-odp] [PATCH 2/3] linux-generic: pktio: add netmap pktio support

2015-10-09 Thread Savolainen, Petri (Nokia - FI/Espoo)
There’s no dependency to netmap unless the user requests to use it with “--with-netmap-path” configure option. So, the switch is there (in this patch). -Petri From: EXT Mike Holmes [mailto:mike.hol...@linaro.org] Sent: Thursday, October 08, 2015 9:01 PM To: Savolainen, Petri (Nokia - FI/Espoo)

Re: [lng-odp] [PATCH 2/3] linux-generic: pktio: add netmap pktio support

2015-10-09 Thread Christophe Milard
Hi Mike. I have read through this patch: I haven't dared marking it as reviewed as I am not sure about some part of it, especialy related to the build environment. The pktio part is very close to what I did when merging and looked fine to me. Also the debate regarding whether this should be

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Alexandru Badicioiu
The problem you raised is not strictly related to this patch. A crypto session has an output queue (for async mode) where the results , including the operation status, will be delivered. There is nothing in the API to prevent using a pktio output queue for crypto completion events but the pktio

[lng-odp] [API-NEXTv7 0/5] ODP_PMR_CUSTOM_FRAME support

2015-10-09 Thread Nicolas Morey-Chaisemartin
v7: - fix classiefier unit tests - split add ODP_PMR_CUSTOM_FRAME in 2 - One patch changes odp_pmr_create signature to use a struct instead of arg list - Second one only adds ODP_PMR_CUSTOM_FRAME to the api v6: - rebase on latest api-next v5: - change linux-generic

[lng-odp] [API-NEXTv7 5/5] example: classifier: implement ODP_PMR_CUSTOM_FRAME match

2015-10-09 Thread Nicolas Morey-Chaisemartin
Signed-off-by: Benoît Ganne --- example/classifier/odp_classifier.c | 86 ++--- 1 file changed, 70 insertions(+), 16 deletions(-) diff --git a/example/classifier/odp_classifier.c b/example/classifier/odp_classifier.c index 689313d..fa10809

[lng-odp] [API-NEXTv7 4/5] linux-generic: classification: implement ODP_PMR_CUSTOM_FRAME matching

2015-10-09 Thread Nicolas Morey-Chaisemartin
Signed-off-by: Benoît Ganne --- .../include/odp_classification_datamodel.h | 2 ++ .../include/odp_classification_inlines.h| 21 + platform/linux-generic/odp_classification.c | 7 +++ 3 files changed, 30 insertions(+) diff

Re: [lng-odp] [PATCH] checkpatch: escape left braces in regex

2015-10-09 Thread Nicolas Morey-Chaisemartin
I guess it should. But I'm not sure where the upstream is. It may even be fixed there. Nicolas On 10/08/2015 06:20 PM, Mike Holmes wrote: > Should this go upstream also ? > > On 8 October 2015 at 14:46, Nicolas Morey-Chaisemartin > wrote: > >> Latest Perl version marks

Re: [lng-odp] [PATCH 1/5] Add Jhash and CRC functions

2015-10-09 Thread Mike Holmes
On Oct 8, 2015 10:55 PM, "HePeng" wrote: > > We should first added a generic hash API to api-next, and then provide crc and jhash implementations? > > I am not clear about how hash functions can be added into ODP. Should we first present a proposal ? Yes, send a proposal if

[lng-odp] [API-NEXTv7 3/5] api: classification: add ODP_PMR_CUSTOM_FRAME

2015-10-09 Thread Nicolas Morey-Chaisemartin
The application can now specify a packet offset in PMR rules. This offset is absolute from the frame start. It is used to extract the PMR value. This is useful to support arbitrary backplane protocols and extensions. Signed-off-by: Benoît Ganne ---

[lng-odp] [API-NEXTv7 2/5] api: classification: use a structure instead of many args for odp_pmr_create

2015-10-09 Thread Nicolas Morey-Chaisemartin
Signed-off-by: Nicolas Morey-Chaisemartin --- example/classifier/odp_classifier.c| 12 +--- include/odp/api/classification.h | 31 +++ platform/linux-generic/odp_classification.c| 35 ++

[lng-odp] [API-NEXTv7 1/5] api: classification: move odp_pmr_match_t definition

2015-10-09 Thread Nicolas Morey-Chaisemartin
This patch move the odp_pmr_match_t structure definition to prepare the introduction of the new ODP_PMR_CUSTOM_FRAME term. Signed-off-by: Benoît Ganne --- include/odp/api/classification.h | 30 +++--- 1 file changed, 15 insertions(+), 15 deletions(-)

Re: [lng-odp] [PATCH 2/3] linux-generic: pktio: add netmap pktio support

2015-10-09 Thread Savolainen, Petri (Nokia - FI/Espoo)
This is same level of optimization than using mmap type sockets instead of basic sockets. It’s an alternative way to get packets into linux-generic. The optimization talk should start after this point (after packet receive from the network): how much we optimize SW classifier, how much SW

[lng-odp] [PATCHv9 5/8] helpers: remove odp_ prefix for tests source files

2015-10-09 Thread Maxim Uvarov
Prefixed were removed for validation test suite and to be consistent we need to do the same for helpers. Signed-off-by: Maxim Uvarov --- helper/test/.gitignore | 9 + helper/test/Makefile.am | 16

[lng-odp] [PATCHv9 8/8] linux-generic: internal ipc_pktio test

2015-10-09 Thread Maxim Uvarov
2 example ipc pktio applications create ipc pktio to each other and do packet transfer, validation magic numbers and packets sequence counters inside it. Signed-off-by: Maxim Uvarov --- platform/linux-generic/Makefile.am | 1 +

[lng-odp] [PATCHv9 1/8] helper: ring: update ring with shm proc argument

2015-10-09 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- helper/include/odp/helper/ring.h | 2 ++ helper/ring.c| 9 - 2 files changed, 10 insertions(+), 1 deletion(-) diff --git a/helper/include/odp/helper/ring.h b/helper/include/odp/helper/ring.h index

[lng-odp] [PATCHv9 2/8] linux-generic: create internal pool create function with shm flags

2015-10-09 Thread Maxim Uvarov
On init odp creates odp_sched_pool. We can not modify API to add new parameter to odp_pool_param_t and this pool should not be shared between different processes. To do that implemented internal linux-generic function with parameters to created shm. Note: create shm before and then provide it to

[lng-odp] [PATCHv9 6/8] helper: move ring test to helper

2015-10-09 Thread Maxim Uvarov
Move ring test to helper and kill not needed api_test directory. Unfortunately odp_ring_test.c had some old dirty code so I had to clean up it to to use cunit and latest helper apis. Signed-off-by: Maxim Uvarov --- configure.ac |

Re: [lng-odp] [PATCH] checkpatch: escape left braces in regex

2015-10-09 Thread Nicolas Morey-Chaisemartin
OK. Just submitted the cherry picked patch on the ML. On 10/09/2015 02:13 PM, Maxim Uvarov wrote: > On 10/09/15 12:21, Nicolas Morey-Chaisemartin wrote: >> It is actually already fixed in the Linux kernel. >> Shoud we import the latest checkpatch then? > > we should cherry-pick that change if we

[lng-odp] [PATCH] checkpatch: fix left brace warning

2015-10-09 Thread Nicolas Morey-Chaisemartin
Using checkpatch.pl with Perl 5.22.0 generates the following warning: Unescaped left brace in regex is deprecated, passed through in regex; This patch fixes the warnings by escaping occurrences of the left brace inside the regular expression. Signed-off-by: Eddie Kovsky

Re: [lng-odp] [API-NEXT PATCH 1/2] api: pktio link

2015-10-09 Thread Maxim Uvarov
On 10/08/15 15:26, Ola Liljedahl wrote: On 17 September 2015 at 18:03, Nicolas Morey-Chaisemartin > wrote: Polling the link status makes sense but isn't setting the link state a bit redundant with pktio start/stop ? On meeting we figured out

Re: [lng-odp] [API-NEXT PATCH 0/2] linux-generic: cpu: fix cycle lost while cycle counter overflow

2015-10-09 Thread Maxim Uvarov
Petri, Ola, can you please review that patches? Thank you, Maxim. On 10/05/15 15:58, Ivan Khoronzhuk wrote: This series fixes cycle lost while counter overflow. First patch move diff function in one place. Second corrects diff function. Based on api-next as it corrects new cpu cycle api.

[lng-odp] [PATCH v2 5/6] test: l2fwd: add option to disable filling eth addresses

2015-10-09 Thread Matias Elo
By default every packet's source MAC address is filled to match the output port. Add option to disable this to enable testing packet forwarding without touching the packets. Signed-off-by: Matias Elo --- test/performance/odp_l2fwd.c | 17 +++-- 1 file changed,

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Alexandru Badicioiu
So you would like inline/synchronous API mode to have a completion queue too? What would be the use for it? On 9 October 2015 at 13:01, Ola Liljedahl wrote: > On 9 October 2015 at 10:37, Alexandru Badicioiu < > alexandru.badici...@linaro.org> wrote: > >> This was a

[lng-odp] [PATCHv9 0/8] IPC (pktio)

2015-10-09 Thread Maxim Uvarov
v9: reworked patches according to Connect agreements: - linux-generic only pktio; - 2 separate symmetric apps with same init process; - does not matter which app was run first; - init process for 2 apps is the same; Maxim Uvarov (8): helper: ring: update ring with shm proc

Re: [lng-odp] [PATCH] checkpatch: escape left braces in regex

2015-10-09 Thread Maxim Uvarov
On 10/09/15 12:21, Nicolas Morey-Chaisemartin wrote: It is actually already fixed in the Linux kernel. Shoud we import the latest checkpatch then? we should cherry-pick that change if we have real problem. Other changes are optional, you can review them if there is reason to apply them.

[lng-odp] [PATCH v2 1/6] test: l2fwd: add option to change destination eth addresses

2015-10-09 Thread Matias Elo
If the application is being run on a host connected to a switch, not changing the ethernet destination may cause loops. Added an option to change the destination ethernet address. The destination addresses follow the format 02:00:00:00:00:XX where the final octet is the output port number.

[lng-odp] [PATCH v2 6/6] test: l2fwd: word copy ethernet addresses

2015-10-09 Thread Matias Elo
Optimize ethernet address filling by using word copy. Signed-off-by: Matias Elo --- test/performance/odp_l2fwd.c | 43 +++ 1 file changed, 31 insertions(+), 12 deletions(-) diff --git a/test/performance/odp_l2fwd.c

[lng-odp] [PATCHv9 3/8] move odph_pause inside linux-generic

2015-10-09 Thread Maxim Uvarov
Move odph_pause inside linux-generic. Validation test is also useless with such move. Signed-off-by: Maxim Uvarov --- helper/Makefile.am | 4 +--- helper/ring.c | 2 +-

[lng-odp] [PATCHv9 7/8] linux-generic: add ipc pktio support

2015-10-09 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- platform/linux-generic/Makefile.am | 2 + .../linux-generic/include/odp_buffer_internal.h| 3 + .../linux-generic/include/odp_packet_io_internal.h | 35 + .../include/odp_packet_io_ipc_internal.h | 51 ++

Re: [lng-odp] [PATCH] example:ipsec: Using environment varibale for pktio mode.

2015-10-09 Thread Maxim Uvarov
Merged, Maxim. On 10/07/15 13:23, nikhil.agar...@freescale.com wrote: From: Nikhil Agarwal Pktio input mode of operation should be derived from environment variable input instead of compile time flag. Signed-off-by: Nikhil Agarwal

Re: [lng-odp] [API-NEXT PATCH] api: crypto: add crypto IPSec extension

2015-10-09 Thread Ola Liljedahl
On 9 October 2015 at 12:48, Alexandru Badicioiu < alexandru.badici...@linaro.org> wrote: > So you would like inline/synchronous API mode to have a completion queue > too? What would be the use for it? > I think we are misunderstanding each other and I haven't been very detailed. The output of

Re: [lng-odp] [PATCH 5/8] add fbk hash table

2015-10-09 Thread Maxim Uvarov
Please specify git commit hash related to original code. I'm thinking how to maintain that in future. And looks like there will be no way other then walk over all new patches and modify them to our odp code. In that case reference to original git base will be helpful. Thank you, Maxim. On

Re: [lng-odp] Using config.h

2015-10-09 Thread Nicolas Morey-Chaisemartin
On 09/01/2015 02:23 PM, Maxim Uvarov wrote: > On 09/01/15 15:07, Nicolas Morey-Chaisemartin wrote: >> >> On 09/01/2015 12:39 PM, Maxim Uvarov wrote: >>> On 09/01/15 11:45, Nicolas Morey-Chaisemartin wrote: Hi, I'm having a small issue with the performance/scheduler test. It

[lng-odp] [API-NEXT PATCHv4 0/4] api: packet reference count support

2015-10-09 Thread Maxim Uvarov
v4: remove following checks from test case: /* Handles should be different */ CU_ASSERT(pkt != pkt_ref); /* Debug print also should have refcount bits */ CU_ASSERT(odp_packet_to_u64(pkt) !=

[lng-odp] [API-NEXT PATCHv4 1/4] api: packet reference count support

2015-10-09 Thread Maxim Uvarov
Add api for packet reference count support. Which is useful in case: - multicast support - TCP retransmission - traffic generator Introduced new call: newpkt = odp_packet_create_ref(pkt) which creates reference to original packet, but handles for reference packet and original are different.

[lng-odp] [API-NEXT PATCHv4 2/4] linux-generic: packet reference count support

2015-10-09 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- .../linux-generic/include/odp_buffer_internal.h| 8 ++- .../linux-generic/include/odp_packet_internal.h| 18 ++ platform/linux-generic/odp_packet.c| 65 -- 3 files changed, 85 insertions(+),

[lng-odp] [API-NEXT PATCHv4 3/4] linix-generic: _odp_pri account 64 bits

2015-10-09 Thread Maxim Uvarov
_odp_pri returns uint64_t value but actually accounts only 32 bit. In my case that lead to return the same value for printed packets with additional handle bits. Signed-off-by: Maxim Uvarov --- platform/linux-generic/include/odp/plat/strong_types.h | 2 +- 1 file

[lng-odp] [PATCH 2/2] linux-generic: netmap: sync tx queues

2015-10-09 Thread Matias Elo
Sync tx queues to recover from overload. Previously send could get permanently stuck here. Signed-off-by: Matias Elo --- platform/linux-generic/pktio/netmap.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/platform/linux-generic/pktio/netmap.c

Re: [lng-odp] [API-NEXT PATCHv4 1/4] api: packet reference count support

2015-10-09 Thread Nicolas Morey-Chaisemartin
On 10/09/2015 02:59 PM, Maxim Uvarov wrote: > Add api for packet reference count support. Which is useful in case: > - multicast support > - TCP retransmission > - traffic generator > > Introduced new call: newpkt = odp_packet_create_ref(pkt) which creates > reference to original packet, but

[lng-odp] [PATCH] configure: move all AM_CONDITIONAL to configure.ac

2015-10-09 Thread Nicolas Morey-Chaisemartin
Platform specific m4 files cannot define AM_CONDITIONAL. Even if not used outside of the platform specific file, configure will exit with an error if another platform does not set this conditional: configure: error: conditional "netmap_support" was never defined. Usually this means the macro

[lng-odp] [API-NEXT PATCHv4 4/4] validation: packet: test packet reference count

2015-10-09 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- test/validation/packet/packet.c | 31 +++ test/validation/packet/packet.h | 1 + 2 files changed, 32 insertions(+) diff --git a/test/validation/packet/packet.c b/test/validation/packet/packet.c index

[lng-odp] [PATCH 1/2] linux-generic: netmap: use default interface config

2015-10-09 Thread Matias Elo
Don't override interface default configuration options. Signed-off-by: Matias Elo --- platform/linux-generic/pktio/netmap.c | 12 1 file changed, 12 deletions(-) diff --git a/platform/linux-generic/pktio/netmap.c b/platform/linux-generic/pktio/netmap.c index