[lng-odp] [API-NEXT PATCH v2 1/2] doc: images: add traffic manager svg

2016-01-11 Thread Mike Holmes
Signed-off-by: Mike Holmes --- v2: Updated digram for the node to match text doc/images/tm_hierarchy.svg | 2418 +++ doc/images/tm_node.svg | 1178 + 2 files changed, 3596 insertions(+) create mode

Re: [lng-odp] Driver interface definition...

2016-01-11 Thread Bill Fischofer
In thinking about how ODP drivers relate to the rest of ODP it is useful to consider this from a client/server perspective. For ODP applications, the ODP API defines an interface that allows client applications to request services from an ODP implementation without either the application or ODP

[lng-odp] [API-NEXT PATCH v2 2/2] doc: users: migrate TM from API to users doc

2016-01-11 Thread Mike Holmes
Signed-off-by: Mike Holmes --- v2: Directly use svg in the documentation and dont generate a png since modern browsers can work with .svg files doc/users-guide/Makefile.am | 2 +- doc/users-guide/users-guide-tm.adoc | 264

Re: [lng-odp] Driver interface definition...

2016-01-11 Thread Mike Holmes
Anders, Christophe and I had a discussion and here are some very rough notes on what I think settled out of it. Requirements: We wanted something that scales if more interfaces to ODP are defined and openStack was suggested as the sort of east/west that may occur We want the actual driver

Re: [lng-odp] [PATCHv8] helper : Fix UDP checksum computation

2016-01-11 Thread Ilya Maximets
On 04.01.2016 15:48, ion.grig...@freescale.com wrote: > From: Grigore Ion > > This patch fixes the following problems: > - checksum computation for LE platforms > - checksum computation for packets having the UDP length not a > multiple of 2 > - checksum computation in

Re: [lng-odp] [API-NEXT RFC 01/31] api: dma: defining the dma region descriptor

2016-01-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
Since it's a driver interface file, it should be placed into new folder: odp/include/odp/driver/dma.h Under "driver" (or similar) and next to odp/include/odp/api (not under api). -Petri > -Original Message- > From: EXT Christophe Milard [mailto:christophe.mil...@linaro.org] > Sent:

[lng-odp] [PATCHv9] helper : Fix UDP checksum computation

2016-01-11 Thread ion.grigore
From: Grigore Ion This patch fixes the following problems: - checksum computation for LE platforms - checksum computation for packets having the UDP length not a multiple of 2 - checksum computation in the test and the example applications Signed-off-by: Grigore Ion

Re: [lng-odp] [PATCHv8] helper : Fix UDP checksum computation

2016-01-11 Thread Ion Grigore
Done -Original Message- From: Ilya Maximets [mailto:i.maxim...@samsung.com] Sent: Monday, January 11, 2016 10:14 AM To: ion.grig...@freescale.com; lng-odp@lists.linaro.org Cc: Maxim Uvarov Subject: Re: [PATCHv8] helper : Fix UDP checksum computation On

Re: [lng-odp] [API-NEXT RFC 02/31] api: introducing the driver api definition file

2016-01-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
CC’d the list again. From: EXT Christophe Milard [mailto:christophe.mil...@linaro.org] Sent: Monday, January 11, 2016 10:29 AM To: Savolainen, Petri (Nokia - FI/Espoo) Subject: Re: [API-NEXT RFC 02/31] api: introducing the driver api definition file On 11 January 2016 at 09:12, Savolainen,

Re: [lng-odp] [API-NEXT RFC 01/31] api: dma: defining the dma region descriptor

2016-01-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
Addition of driver interface should have minimal impact into API (it’s just another way to connect pktio into HW). E.g. application should not configure DMA directly, but maybe provide additional information through pktio or pool parameters (which can be useful to integrated pktio devices in

[lng-odp] [PATCH v3 0/3] correct limits validation

2016-01-11 Thread Ivan Khoronzhuk
This series corrects limits based on resolution. Since v2: - remove return Since v1: - no functional changes - replaceed "[lng-odp] [PATCH 1/3] validation: time: initialize resolution vars" on "validation: time: store local and global resolution" from Nicolas Ivan Khoronzhuk (2):

[lng-odp] [PATCH v3 1/3] validation: time: store local and global resolution

2016-01-11 Thread Ivan Khoronzhuk
From: Nicolas Morey-Chaisemartin Computation were done on a local variable and never stored back to the global value so both local_res and global_res were always 0. Reviewed-by: Ivan Khoronzhuk Signed-off-by: Ivan Khoronzhuk

[lng-odp] [PATCH v3 2/3] validation: time: round up resolution

2016-01-11 Thread Ivan Khoronzhuk
While division the resolution can have fractional part, so better to round it up, when it's needed. Reviewed-by: Bill Fischofer Signed-off-by: Ivan Khoronzhuk --- test/validation/time/time.c | 3 ++- 1 file changed, 2 insertions(+), 1

Re: [lng-odp] [API-NEXT RFC 01/31] api: dma: defining the dma region descriptor

2016-01-11 Thread Christophe Milard
Then I have a issue about the overlapping part of the API / DPI... Shall we have two names for each of these symbols? The approach taken here avoided that, at least. Mike has added an item to the ARCH call this afternoon... We can take that there Thx, Christophe. On 11 January 2016 at 09:22,

[lng-odp] [PATCH] doc: implementers-guide: libC version

2016-01-11 Thread Christophe Milard
Limiting the usage of the C library to the functions defined in its C99 version. Signed-off-by: Christophe Milard --- doc/implementers-guide/implementers-guide.adoc | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git

[lng-odp] [PATCH v3 3/3] validation: time: increase limit to check to 2 res

2016-01-11 Thread Ivan Khoronzhuk
In places of two conversions the error can be up to 2 resolutions, so increase validation range to 2 res. Reviewed-by: Bill Fischofer Signed-off-by: Ivan Khoronzhuk --- test/validation/time/time.c | 20 ++-- 1 file changed,

[lng-odp] [PATCH] pool:support to create pool on user's own memory

2016-01-11 Thread Zaibo Xu
As user initiates pool params with its own memory reserving and un-reserving functions, pool will be created on its own memory, or on odp share memory as before. Signed-off-by: Zaibo Xu --- include/odp/api/pool.h| 12

Re: [lng-odp] [RFC API-NEXT PATCH] api: packet: add packet segment manipulation

2016-01-11 Thread Bill Fischofer
On Mon, Jan 11, 2016 at 7:47 AM, Petri Savolainen < petri.savolai...@nokia.com> wrote: > Packet segments can be allocated/freed/multi-referenced. > Segments data pointer and length can be modified (push/pull). > Segments can be linked to packets when needed (can exist also > when not connected to

Re: [lng-odp] [PATCH] doc: images: refactor makefile

2016-01-11 Thread Maxim Uvarov
Merged, Maxim. On 01/07/2016 22:47, Bill Fischofer wrote: On Thu, Jan 7, 2016 at 1:44 PM, Mike Holmes > wrote: Drop per target rules for generic make Suggested-by: Anders Roxell Signed-off-by:

Re: [lng-odp] [PATCH] validation: possibility to inactive preconded test

2016-01-11 Thread Mike Holmes
Looks good, but maybe the implementers guide needs an update. The example is now out of date, we can have the guide automatically use the code frm in test as part of the doc if you think that helps keep it in sync On 11 January 2016 at 07:18, Christophe Milard

[lng-odp] ODP 1.5 - Crash while cleanup ODP/ODP timer pool

2016-01-11 Thread Bogdan Pricope
Hi, I am using ODP-LNG 1.5 and I am getting this crash while trying to cleanup ODP timer pool + other resources. Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 0x7fffe700 (LWP 27019)] timer_notify (sigval=sigval@entry=...) at odp_timer.c:638 638

Re: [lng-odp] [PATCH v3 0/3] correct limits validation

2016-01-11 Thread Maxim Uvarov
Merged, Maxim. On 01/11/2016 12:58, Ivan Khoronzhuk wrote: This series corrects limits based on resolution. Since v2: - remove return Since v1: - no functional changes - replaceed "[lng-odp] [PATCH 1/3] validation: time: initialize resolution vars" on "validation: time: store local and

Re: [lng-odp] [PATCHv9] helper : Fix UDP checksum computation

2016-01-11 Thread Maxim Uvarov
Merged, Thanks, Maxim. On 01/11/2016 12:48, Ilya Maximets wrote: On 11.01.2016 12:13, ion.grig...@freescale.com wrote: From: Grigore Ion This patch fixes the following problems: - checksum computation for LE platforms - checksum computation for packets having the

[lng-odp] [API-NEXT PATCH v3 2/6] linux-generic: pktio: re-organize queue config code

2016-01-11 Thread Petri Savolainen
Push generic parts of input/output queue config code to upper level (into odp_packet_io.c). Signed-off-by: Petri Savolainen --- platform/linux-generic/include/odp_packet_netmap.h | 7 +- platform/linux-generic/odp_packet_io.c | 186 ++---

[lng-odp] [API-NEXT PATCH v3 1/6] linux-generic: netmap: map rings in netmap_start

2016-01-11 Thread Petri Savolainen
From: Matias Elo This is a bug fix for old API. Map pktin/pktout queues to netmap rings in netmap_start() instead of netmap_*put_queues_config() for backward compatibility with inq_setdef API. Signed-off-by: Matias Elo ---

[lng-odp] [API-NEXT PATCH v3 0/6] Multi-queue pktio for poll mode

2016-01-11 Thread Petri Savolainen
This patch set adds support for multi-queue pktio for poll mode queues. v3: * Rebased v2: * Bug correction in patch 2/6: bad netmap initialization when using the old API. Matias Elo (1): linux-generic: netmap: map rings in netmap_start Petri Savolainen (5): linux-generic: pktio:

[lng-odp] [PATCH] validation: possibility to inactive preconded test

2016-01-11 Thread Christophe Milard
When marking a test which has a precondition as temporarly inactive, it feels better to be able to keep the precondition function: ODP_TEST_INFO_CONDITIONAL(send_failure, check_send_failure) will be marked as inactive by: ODP_TEST_INFO_INACTIVE(send_failure, check_send_failure) rather than:

[lng-odp] [API-NEXT PATCH v3 3/6] linux-generic: pktio: added poll type input queue

2016-01-11 Thread Petri Savolainen
Added support for poll type input queues. Signed-off-by: Petri Savolainen --- .../linux-generic/include/odp_queue_internal.h | 2 +- platform/linux-generic/odp_packet_io.c | 23 ++ platform/linux-generic/odp_queue.c

Re: [lng-odp] [RFC API-NEXT PATCH] Packet References and Composites

2016-01-11 Thread Bill Fischofer
Thanks. I'll do that in the next iteration. I just wanted to get the discussion going on these topics, and in particular to get feedback from the SoC vendors as to what sort of aggregation mechanism fits most naturally with their architecture and HW capabilities. Note that this is just an

[lng-odp] [API-NEXT PATCH v3 4/6] linux-generic: pktio: use multiqueue recv internally

2016-01-11 Thread Petri Savolainen
Use multiqueue recv for poll type input queues. Signed-off-by: Petri Savolainen --- platform/linux-generic/odp_packet_io.c | 11 ++- 1 file changed, 2 insertions(+), 9 deletions(-) diff --git a/platform/linux-generic/odp_packet_io.c

Re: [lng-odp] [RFC API-NEXT PATCH] Packet References and Composites

2016-01-11 Thread Bala Manoharan
This patch series could be split into two different parts as Reference and Composite since IMO the Referencing part is straight forward and might not need much discussion and could be be accepted sooner. Regarding the concept of composite packets it would be appreciable to provide some use-cases

[lng-odp] [API-NEXT PATCH v3 6/6] test: l2fwd: added poll queue mode

2016-01-11 Thread Petri Savolainen
Added poll queue mode (mode == 4), which uses poll type queues for packet input. Configuration and functionality is very similar to direct recv mode. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 188 --- 1

[lng-odp] [API-NEXT PATCH v3 5/6] test: l2fwd: re-organize functions

2016-01-11 Thread Petri Savolainen
Re-order functions to get rid off (static) function prototypes and improve code readability. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 645 +-- 1 file changed, 318 insertions(+), 327 deletions(-) diff

[lng-odp] [RFC API-NEXT PATCH] packet segmentation

2016-01-11 Thread Petri Savolainen
Pseudo code example of multi-casting a received packet - odp_packet_seg_t prepared_seg[NUM_MCAST]; void on_init(void) { int i; /* prepare a segment per multi-cast header */ for (i = 0; i < NUM_MCAST; i++) {

[lng-odp] [RFC API-NEXT PATCH] api: packet: add packet segment manipulation

2016-01-11 Thread Petri Savolainen
Packet segments can be allocated/freed/multi-referenced. Segments data pointer and length can be modified (push/pull). Segments can be linked to packets when needed (can exist also when not connected to packets). TODO: Packet pool params need tuning for segment length configuration.

[lng-odp] Driver interface definition...

2016-01-11 Thread Christophe Milard
Hi, Today the situation as I see it, is as follows: We have a single interface to ODP, the application interface, A. This interface is defined by a file which any application includes: include/odp.h includes in turn a set of platform//include/odp/. These files are given a chance to define

Re: [lng-odp] Regarding running the new traffic_mngr tests.

2016-01-11 Thread Alexandru Badicioiu
Hi Barry, thanks for all these details and explanations. Regarding enhanced API for finding HW configurations those are meant to help in creating portable HW-accelerated applications. The changes may be modest but the goal is not, I think. A high level description of these changes : - set egress

Re: [lng-odp] [PATCH] doc: implementers-guide: libC version

2016-01-11 Thread Mike Holmes
On 11 January 2016 at 04:47, Christophe Milard wrote: > Limiting the usage of the C library to the functions defined in its > C99 version. > > Signed-off-by: Christophe Milard > Reviewed-by: Mike Holmes >

Re: [lng-odp] [PATCH] doc: process: add byelaws

2016-01-11 Thread Maxim Uvarov
bellow are small notes but it's better to clean up it now. Maxim. On 01/07/2016 22:17, Mike Holmes wrote: The bylaws were only recorded as part of the website, move them to git where they can be tracked. Signed-off-by: Mike Holmes --- doc/process-guide/Makefile.am

Re: [lng-odp] [PATCH] doc: process: add byelaws

2016-01-11 Thread Mike Holmes
On 11 January 2016 at 14:31, Maxim Uvarov wrote: > bellow are small notes but it's better to clean up it now. > > Maxim. > > On 01/07/2016 22:17, Mike Holmes wrote: > >> The bylaws were only recorded as part of the website, move them to git >> where they can be tracked.