Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-28 Thread Gary Gregory
. >>>>>>> >>>>>>> On 21 July 2016 at 16:30, Ralph Goers <ralph.go...@dslextreme.com> >>>>>>> wrote: >>>>>>> >>>>>>>> The more I think about this the more I dislike it. This requires >>&

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Ralph Goers
s" for the pattern: >> >> try (final AutoCloseableLock l = LOCK.lock()) { >> return MAP.containsKey(name); >> } >> >> I could rename lock() to doLock() and a void lock() but that seems a bit >> confusing to have both metho

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Ralph Goers
>> try (final AutoCloseableLock l = LOCK.lock()) { >> return MAP.containsKey(name); >> } >> >> I could rename lock() to doLock() and a void lock() but that seems a bit >> confusing to have both methods. >> >> This is in

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Ralph Goers
; >> I could rename lock() to doLock() and a void lock() but that seems a bit >> confusing to have both methods. >> >> This is in the branch AutoCloseableLock which I'd like to merge. >> >> Thoughts? >> >> Gary >> >> On Fri, Jun 24, 2016 at 7:42 AM,

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Gary Gregory
atisfy >>>>>>> the compiler. It defeats the work Remko has been doing to make the code >>>>>>> garbage free as it is explicitly creating objects it doesn’t even use. >>>>>>> >>>>>>> Ralph >>>>>>> >

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Matt Sicker
;>> Ralph >>>>>> >>>>>> On Jul 21, 2016, at 2:12 PM, Gary Gregory <garydgreg...@gmail.com> >>>>>> wrote: >>>>>> >>>>>> Hi Matt, >>>>>> >>>>>> AutoCloseableLock canno

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Matt Sicker
t;>> Ralph >>>>> >>>>> On Jul 21, 2016, at 2:12 PM, Gary Gregory <garydgreg...@gmail.com> >>>>> wrote: >>>>> >>>>> Hi Matt, >>>>> >>>>> AutoCloseableLock cannot implement

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Gary Gregory
gt;> return MAP.containsKey(name); >>> } >>> >>> I could rename lock() to doLock() and a void lock() but that seems a bit >>> confusing to have both methods. >>> >>> This is in the branch AutoCloseableLock which I'd

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Ralph Goers
gt; confusing to have both methods. >> >> This is in the branch AutoCloseableLock which I'd like to merge. >> >> Thoughts? >> >> Gary >> >> On Fri, Jun 24, 2016 at 7:42 AM, Matt Sicker <boa...@gmail.com >> <mailto:boa...@gmail.com&g

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Gary Gregory
>>>> Hi Matt, >>>> >>>> AutoCloseableLock cannot implement Lock because lock() is void and I >>>> count on AutoCloseableLock#lock() returning "this" for the pattern: >>>> >>>> try (final AutoCloseableLock l = LOCK

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Matt Sicker
gt;>> confusing to have both methods. >>> >>> This is in the branch AutoCloseableLock which I'd like to merge. >>> >>> Thoughts? >>> >>> Gary >>> >>> On Fri, Jun 24, 2016 at 7:42 AM, Matt Sicker <boa...@gmail.com>

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Gary Gregory
s a bit >> confusing to have both methods. >> >> This is in the branch AutoCloseableLock which I'd like to merge. >> >> Thoughts? >> >> Gary >> >> On Fri, Jun 24, 2016 at 7:42 AM, Matt Sicker <boa...@gmail.com> wrote: >&

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Matt Sicker
t;> I kinda imagined AutoCloseableLock to implement both AutoCloseable and >> Lock. >> >> ------ Forwarded message -- >> From: <ggreg...@apache.org> >> Date: 24 June 2016 at 03:50 >> Subject: [1/4] logging-log4j2 git commit: Add AutoCloseable

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Ralph Goers
> -- Forwarded message -- > From: <ggreg...@apache.org <mailto:ggreg...@apache.org>> > Date: 24 June 2016 at 03:50 > Subject: [1/4] logging-log4j2 git commit: Add AutoCloseableLock. > To: comm...@logging.apache.org <mailto:comm...@logging.a

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-07-21 Thread Gary Gregory
loseable and > Lock. > > -- Forwarded message -- > From: <ggreg...@apache.org> > Date: 24 June 2016 at 03:50 > Subject: [1/4] logging-log4j2 git commit: Add AutoCloseableLock. > To: comm...@logging.apache.org > > > Repository: logging-log4j2 > U

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-06-24 Thread Matt Sicker
utoCloseable and >> Lock. >> >> -- Forwarded message -- >> From: <ggreg...@apache.org> >> Date: 24 June 2016 at 03:50 >> Subject: [1/4] logging-log4j2 git commit: Add AutoCloseableLock. >> To: comm...@logging.apache.org >> >&g

Re: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-06-24 Thread Gary Gregory
boa...@gmail.com> wrote: > I kinda imagined AutoCloseableLock to implement both AutoCloseable and > Lock. > > -- Forwarded message -- > From: <ggreg...@apache.org> > Date: 24 June 2016 at 03:50 > Subject: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

Fwd: [1/4] logging-log4j2 git commit: Add AutoCloseableLock.

2016-06-24 Thread Matt Sicker
I kinda imagined AutoCloseableLock to implement both AutoCloseable and Lock. -- Forwarded message -- From: <ggreg...@apache.org> Date: 24 June 2016 at 03:50 Subject: [1/4] logging-log4j2 git commit: Add AutoCloseableLock. To: comm...@logging.apache.org Repository: logging-