Errors Building HTML::Parser on AIX

2001-04-17 Thread dcross - David Cross

Sorry to drag the list off-topic, but I've a Perl question!

I'm having trouble building HTML::Parser on an AIX box. It's the first time
I've tried to build and install an XS module, so it's quite possible that
it's a wider issue.

The 'make' seems to go ok, but when I run 'make test' I get the same error
for each test file:

t/unbroken-text.Can't load 'blib/arch/auto/HTML/Parser/Parser.so' for
module HTML::Parser: dlopen: blib/arch/auto/HTML/Parser/Parser.so: A file or
directory in the path name does not exist. at
/usr/local/lib/perl5/5.00502/aix/DynaLoader.pm line 168.

 at t/unbroken-text.t line 2
BEGIN failed--compilation aborted at t/unbroken-text.t line 2.
dubious
Test returned status 2 (wstat 512, 0x200)


Running ls -l blib/arch/auto/HTML/Parser/Parser.so shows that the file
exists and is readable. 

The build process seems to be using IBM's own C compiler rather than gcc.

Does anyone have any clues about this?

Cheers,

Dave...

-- 


The information contained in this communication is
confidential, is intended only for the use of the recipient
named above, and may be legally privileged. If the reader 
of this message is not the intended recipient, you are
hereby notified that any dissemination, distribution or
copying of this communication is strictly prohibited.  
If you have received this communication in error, please 
re-send this communication to the sender and delete the 
original message or any copy of it from your computer
system.



Re: Errors Building HTML::Parser on AIX

2001-04-17 Thread David Cantrell

On Tue, Apr 17, 2001 at 02:12:14PM +0100, dcross - David Cross wrote:

 I'm having trouble building HTML::Parser on an AIX box. It's the first time
 I've tried to build and install an XS module, so it's quite possible that
 it's a wider issue.
 
 t/unbroken-text.Can't load 'blib/arch/auto/HTML/Parser/Parser.so' for
 module HTML::Parser: dlopen: blib/arch/auto/HTML/Parser/Parser.so: A file or
 directory in the path name does not exist. at
 /usr/local/lib/perl5/5.00502/aix/DynaLoader.pm line 168.
 
 Running ls -l blib/arch/auto/HTML/Parser/Parser.so shows that the file
 exists and is readable. 

What does file(1) tell you about that, and about a *working* loadable module
somewhere in the perl distribution?

 The build process seems to be using IBM's own C compiler rather than gcc.

Which compiler was used to build perl?  And which libraries did it use -
IBM's, or GNU's?

-- 
David Cantrell | [EMAIL PROTECTED] | http://www.cantrell.org.uk/david/

This is a signature.  There are many like it but this one is mine.

** I read encrypted mail first, so encrypt if your message is important **



RE: Errors Building HTML::Parser on AIX

2001-04-17 Thread dcross - David Cross

From: David Cantrell [EMAIL PROTECTED]
Sent: Tuesday, April 17, 2001 2:26 PM

 On Tue, Apr 17, 2001 at 02:12:14PM +0100, dcross - David Cross wrote:
 
  I'm having trouble building HTML::Parser on an AIX box. It's the first
time
  I've tried to build and install an XS module, so it's quite possible
that
  it's a wider issue.
  
  t/unbroken-text.Can't load 'blib/arch/auto/HTML/Parser/Parser.so'
for
  module HTML::Parser: dlopen: blib/arch/auto/HTML/Parser/Parser.so: A
file or
  directory in the path name does not exist. at
  /usr/local/lib/perl5/5.00502/aix/DynaLoader.pm line 168.
  
  Running ls -l blib/arch/auto/HTML/Parser/Parser.so shows that the file
  exists and is readable. 
 
 What does file(1) tell you about that, and about a *working* loadable
module
 somewhere in the perl distribution?

blib/arch/auto/HTML/Parser/Parser.so:   executable (RISC System/6000) or
object module not stripped

/usr/local/lib/perl5/5.00502/aix/auto/POSIX/POSIX.so:   executable (RISC
System/6000) or object module not stripped

  The build process seems to be using IBM's own C compiler rather than
gcc.
 
 Which compiler was used to build perl?  

perl -MConfig -e'print map { "$_ : $Config{$_}\n" } keys %Config | egrep
'^cc'

cc : cc
cccdlflags :
ccdlflags : -bE:perl.exp
ccflags : -D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=8192-- 

 And which libraries did it use - IBM's, or GNU's?

Is that this?

glibpth : /usr/shlib  /shlib /lib/pa1.1 /usr/lib/large /lib /usr/lib
/usr/lib/386 /lib/386 /lib/large /usr/lib/small /lib/small /usr/ccs/lib
/usr/ucblib /usr/local/lib

Or these?

lib_ext : .a
libc : /lib/libc.a
libperl : libperl.a
libpth : /lib /usr/lib /usr/ccs/lib
libs : -lnsl -ldbm -ldl -lld -lm -lc -lcrypt -lbsd -lPW
libswanted : sfio socket inet nsl nm ndbm gdbm dbm db malloc dl dld ld sun m
c cposix posix ndir dir crypt ucb bsd BSD PW x

Should I be worried about the 'lib_ext : a' line or 'so : a' that I've also
seen?

Dave...

-- 


The information contained in this communication is
confidential, is intended only for the use of the recipient
named above, and may be legally privileged. If the reader 
of this message is not the intended recipient, you are
hereby notified that any dissemination, distribution or
copying of this communication is strictly prohibited.  
If you have received this communication in error, please 
re-send this communication to the sender and delete the 
original message or any copy of it from your computer
system.



Re: Errors Building HTML::Parser on AIX

2001-04-17 Thread Jonathan Stowe

On Tue, 17 Apr 2001, dcross - David Cross wrote:

 Sorry to drag the list off-topic, but I've a Perl question!

 I'm having trouble building HTML::Parser on an AIX box. It's the first time
 I've tried to build and install an XS module, so it's quite possible that
 it's a wider issue.

 The 'make' seems to go ok, but when I run 'make test' I get the same error
 for each test file:

 t/unbroken-text.Can't load 'blib/arch/auto/HTML/Parser/Parser.so' for
 module HTML::Parser: dlopen: blib/arch/auto/HTML/Parser/Parser.so: A file or
 directory in the path name does not exist. at
 /usr/local/lib/perl5/5.00502/aix/DynaLoader.pm line 168.

  at t/unbroken-text.t line 2
 BEGIN failed--compilation aborted at t/unbroken-text.t line 2.
 dubious
 Test returned status 2 (wstat 512, 0x200)


 Running ls -l blib/arch/auto/HTML/Parser/Parser.so shows that the file
 exists and is readable.

 The build process seems to be using IBM's own C compiler rather than gcc.

 Does anyone have any clues about this?


Is AIX one of those OS that requires you to set LD_LIBRARY_PATH or some
equivalent to load a shared library - although this shouldnt be the case
for the binary part of a module because dynaloader searches in a bunch of
places relative to @INC ...

Is it some other .so file that Parser.so uses ? What does ldd tell you ?

/J\




Re: Errors Building HTML::Parser on AIX

2001-04-17 Thread Chris Benson

On Tue, Apr 17, 2001 at 03:21:07PM +0100, Jonathan Stowe wrote:
 
 Is AIX one of those OS that requires you to set LD_LIBRARY_PATH or some
 equivalent to load a shared library - although this shouldnt be the case
 for the binary part of a module because dynaloader searches in a bunch of
 places relative to @INC ...

export LIBPATH=colon:separated:list:of:dirs 
on planet AIX.  If that is the problem.


-- 
Chris Benson