Re: [lttng-dev] [URCU pull request review] urcu improvements

2012-12-05 Thread Mathieu Desnoyers
* Mathieu Desnoyers (mathieu.desnoy...@efficios.com) wrote: Here is a pull request to myself for my recent work on wfcqueue and urcu flavors into the userspace RCU master branch. Please let me know if you see any immediate show stoppers. FYI, after small modifications to answer the comments,

[lttng-dev] Request change name of function lookup_enum in libbabeltrace to make GDB use this lib

2012-12-05 Thread Hui Zhu
Hi, I am working on add CTF support to GDB. You can see my patch review threads in: http://sourceware.org/ml/gdb-patches/2012-11/msg00552.html http://sourceware.org/ml/gdb-patches/2012-11/msg00554.html http://sourceware.org/ml/gdb-patches/2012-11/msg00553.html

Re: [lttng-dev] [PATCH lttng-modules] Update kernel probes to more detailed match to kernel versions

2012-12-05 Thread Gabbasov, Andrew
Hi Mathieu, * Gabbasov, Andrew (andrew_gabba...@mentor.com) wrote: Hi Mathieu, * Andrew Gabbasov (andrew_gabba...@mentor.com) wrote: We have added some more ifdef's to kernel probes to more closely match the kernel tracepoints for different kernel versions. The changes cover

Re: [lttng-dev] Request change name of function lookup_enum in libbabeltrace to make GDB use this lib

2012-12-05 Thread Hui Zhu
On Wed, Dec 5, 2012 at 8:08 PM, Mathieu Desnoyers mathieu.desnoy...@efficios.com wrote: * Hui Zhu (teawa...@gmail.com) wrote: Hi, I am working on add CTF support to GDB. You can see my patch review threads in: http://sourceware.org/ml/gdb-patches/2012-11/msg00552.html

[lttng-dev] [PATCH urcu] wfstack: implement nonblocking pop and next

2012-12-05 Thread Mathieu Desnoyers
Signed-off-by: Mathieu Desnoyers mathieu.desnoy...@efficios.com --- diff --git a/urcu/static/wfstack.h b/urcu/static/wfstack.h index 018a121..9bc9519 100644 --- a/urcu/static/wfstack.h +++ b/urcu/static/wfstack.h @@ -137,7 +137,7 @@ int _cds_wfs_push(struct cds_wfs_stack *s, struct cds_wfs_node

Re: [lttng-dev] Test if tracepoint is enabled

2012-12-05 Thread David Bryant
On 05/12/12 20:49, Mathieu Desnoyers wrote: * David Bryant (david.bry...@quantum.com) wrote: So, building on your example: #define tracepoint_cond(provider, name, pre, post, ...) \ do { \ if (caa_unlikely(__tracepoint_##provider##___##name.state)) { \ pre \