Re: List of Figures

2006-04-04 Thread tceglare
Thank you very much - it works!

 Hi

 Click: Insert - short title
 and then write a shorter title after the title of the figure. In the TOC
 the short title is displayed. Also works for section titles etc. and
 works is both TOC and headers etc.

 Regards
 Christiaan




 [EMAIL PROTECTED] wrote:
hello,

i have inserted a list of figures in my document (book-komascript). the
problem is that the whole(!) description of the figures appears in the
list. i want to appear just a short title of each figure.

can anyone help me, please?

cu,

  tc







Re: Numbers of section and subsection

2006-04-04 Thread Jordi Espasa Clofent
 Since support for latex2html was discontinued a few years ago
 you could try htlatex which is still being actively developed.

Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.

¿What tex-html converter do you use or do you advice me?

Thanks a lot.

-- 
Salut,
Jordi Espasa


pgpHGADenDPNS.pgp
Description: PGP signature


Re: List of Figures

2006-04-04 Thread Wolfgang Engelmann
Am Montag, 3. April 2006 22:57 schrieb [EMAIL PROTECTED]:
 hello,

 i have inserted a list of figures in my document (book-komascript). the
 problem is that the whole(!) description of the figures appears in the
 list. i want to appear just a short title of each figure.

 can anyone help me, please?

I guess you used floatsfigure and added the legend there after 
Figure#: blabla
Go with your cursor to Figure#:here blabla
and select shorttitle in the same dropdown column where you selected floats

a red framed field marked OPT opens, where you can insert your short title 
(easiest: cut and paste your legend and shorten it afterward)

Wolfgang


Re: Numbers of section and subsection

2006-04-04 Thread Stephen Harris

Jordi Espasa Clofent wrote:

Since support for latex2html was discontinued a few years ago
you could try htlatex which is still being actively developed.


Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.


¿What tex-html converter do you use or do you advice me?

Thanks a lot.



I use htlatex. Here is a somewhat complicated conversion to html
that I did this year. What do you think? htlatex xypic.tex 
http://www.mathematik.uni-marburg.de/%7Egumm/LyX/Using_XYpic_in_LyX.htm


I had to fix spaces in Logo names like XY -pic and LaTex, fairly simple.
Yum does a good job of installing with Fedora core. Mandrive also has
something like that; another distro uses apt-get. Many distros will
include tex4ht if you do a full Tetex install. Often the Tetex database
has to be updated after adding a package or fonts and LyX reconfigured.

Perhaps someone else can help you with latex2html which is known
to be a bit unreliable. It is a helper app in the Latex bundle. LyX
uses external html converters, but doesn't do developer work on them.

Regards,
Stephen



Re: Copy and paste from Lyx

2006-04-04 Thread Griera
A Dissabte 01 Abril 2006 01:07, Charlie va escriure:
 Thank you. That is one work around and will save me building a .deb from
 the Lyx 1.4 source, which I can't even get too from the Lyx website. which
 might also be another bug.

You are welcome. Regards. 


Re: Arranging the references in alphabetic order

2006-04-04 Thread jesse mejia


On Apr 3, 2006, at 3:55 AM, Behnam Mostajeran Goortani wrote:



Hi There,
How can I put the references in alphabetic order (Authors names) in 
Lyx (under

windows)?


I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


-Jesse



Re: bookstab package and lyx

2006-04-04 Thread Charles de Miramon
Marcelo Acuña wrote:

 Hello,
  I want to use bookstab package for nices tables,
 doc of this package came with example, this example
 work in kile but in lyx I only get errors and errors
 like:
 
  You haven?t defined [EMAIL PROTECTED] yet
It is a bug when you cut and paste from LaTeX insets. Nothing to do with the
bookstab package.

Cheers,
Charles
-- 
http://www.kde-france.org



Re: Arranging the references in alphabetic order

2006-04-04 Thread Peter Bowyer

At 11:47 04/04/2006, jesse mejia wrote:
I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


Using Natbib this happened by default for me, and took a while to 
work out how to change.  I'm writing up a physics project so am using 
Numerical referencing fwiw.


Anyhow, when you insert your BibTex Generated Bibliography you have a 
large list of styles.


unsrtnat: numbers in the order the references were inserted into the 
document, and orders the bibliography in that way.
plainnat: orders the bibliography alphabetically, then wherever you 
insert the reference it numbers for the position in the ordered bibliography.


There was one other I tried as well which I forget - basically play 
with the styles until you find the one that works for you :)


Regards,
Peter

--
Maple Design - quality web design and programming
http://www.mapledesign.co.uk 



Re: \bind not working on 1.4.0

2006-04-04 Thread belahcene abdelkader


Hi,
great it is obsolete, how to switch to another
language!!!
please can you send me a correct file withc replaces
the previous lyxrc, with a correct switching and using
the F12  key for example

thank you very much
bela


--- Jean-Marc Lasgouttes
[EMAIL PROTECTED] wrote:

  belahcene == belahcene abdelkader
 [EMAIL PROTECTED] writes:
 
 belahcene Hi every body, I ve just check the 1.4.0
 version, there are
 belahcene a lot diff than 1.3.4 and bugs too. I
 wnat to switch with
 belahcene F12 to another language, say arabic, so I
 uncomment the
 belahcene arabic part in lyxrc.example and I copied
 it to lyxrc (I
 belahcene used to do it without problem since 1.1.6
 versiion), it is
 belahcene working on 1.3.4 but not 1.4.0, the \bind
 is not
 belahcene recognized. First I have to fix this pb
 before continue and
 belahcene check other things best regards bela
 thank for help
 
 It is not possible anymore to put \bind commands in
 lyxrc file. You
 should use a personal bind file to do that, like
 
 --mybindings.bind--
 \bind_file cua
 
 \bind Delete delete-backward
 
 
 The lyxrc.example file is obsolete, and should
 probably be removed.
 
 JMarc
 




__
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: LyX to OpenOffice

2006-04-04 Thread Stephen Harris

jesse mejia wrote:


Does anyone know if theres an easy way to get these scripts running on 
OSX? No big deal if not... I can just convert on a linux box if it's not 
possible. Thanks!


-Jesse



You could write to Nick Thomas and ask, see if he knows.

ncth  at safe-mail dot net {normalize email address)


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex, the
 resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:

 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}

 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone know
 how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

 I attach the lyx document.

 Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
http://www.appl-ecosys.com Voice: 503-667-4517  Fax: 503-667-8863


AGU classes...

2006-04-04 Thread Mathieu Richaud

Hello,

I am running into a problem that I can't solve... I run Lyx 1.4.0 under 
Mandriva2006. I am writing an article to be submitted to the American 
Geophysical Union (AGU). According to AGU's website, I need to download 
a .bst file for bibtex. I downloaded agufull04.bst, agufull.bst and 
agu.bst. I put them all in /usr/share/texmf/bibtex/bst/agu directory 
and ran texhash as root, and I can find them in the style window. The 
document class is AGU++ and and the class setting is agums. If I click 
on the use class default button, Natbib is automatically chosen as 
default.


However, when I want to look at my manuscript, I get the following errors...

Package natbib error: The aguplus class already includes natbib coding.
LateX error: unknow option authoryear for package natbib.
\endinput}{}
Type Return for now, but then later remove the command 
\userpackage{natbib} from the document


What can I do? I tried a bunch of things but nothing worked. Thanks for 
your help!


Mathieu

--
Mathieu Richaud
Graduate Student
Dept. of Geology
Northern Illinois University
DeKalb, IL 60115
[EMAIL PROTECTED]



Lyx 1.4.0 won'http://www.codeweavers.com/support/tickets/browse/?list=6;ticket_level=2t allow quotation marks inside ERT boxes

2006-04-04 Thread Paul Johnson
I'm writing NoWeb documents using LyX and the statistical program R.
In my Fedora Core 5 systems, I notice lyx updated to 1.4.0 from the
Fedora Extras and most things work well (thanks!).  The guide we
prepared for LyX to weave statistical results into documents still
works great.

However, LyX will not let me type double quotation marks:   inside
ERT boxes.  And that's vital for the R code.  I am allowed to copy and
paste quotation marks from ERT boxes that I wrote with LyX 1.3.7, so
that is a work around.  But I can't understand why LyX would disable
the  key altogether.

Thanks in advance.

--
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas


Re: List of Figures

2006-04-04 Thread tceglare
Thank you very much - it works!

 Hi

 Click: Insert - short title
 and then write a shorter title after the title of the figure. In the TOC
 the short title is displayed. Also works for section titles etc. and
 works is both TOC and headers etc.

 Regards
 Christiaan




 [EMAIL PROTECTED] wrote:
hello,

i have inserted a list of figures in my document (book-komascript). the
problem is that the whole(!) description of the figures appears in the
list. i want to appear just a short title of each figure.

can anyone help me, please?

cu,

  tc







Re: Numbers of section and subsection

2006-04-04 Thread Jordi Espasa Clofent
 Since support for latex2html was discontinued a few years ago
 you could try htlatex which is still being actively developed.

Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.

¿What tex-html converter do you use or do you advice me?

Thanks a lot.

-- 
Salut,
Jordi Espasa


pgpHGADenDPNS.pgp
Description: PGP signature


Re: List of Figures

2006-04-04 Thread Wolfgang Engelmann
Am Montag, 3. April 2006 22:57 schrieb [EMAIL PROTECTED]:
 hello,

 i have inserted a list of figures in my document (book-komascript). the
 problem is that the whole(!) description of the figures appears in the
 list. i want to appear just a short title of each figure.

 can anyone help me, please?

I guess you used floatsfigure and added the legend there after 
Figure#: blabla
Go with your cursor to Figure#:here blabla
and select shorttitle in the same dropdown column where you selected floats

a red framed field marked OPT opens, where you can insert your short title 
(easiest: cut and paste your legend and shorten it afterward)

Wolfgang


Re: Numbers of section and subsection

2006-04-04 Thread Stephen Harris

Jordi Espasa Clofent wrote:

Since support for latex2html was discontinued a few years ago
you could try htlatex which is still being actively developed.


Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.


¿What tex-html converter do you use or do you advice me?

Thanks a lot.



I use htlatex. Here is a somewhat complicated conversion to html
that I did this year. What do you think? htlatex xypic.tex 
http://www.mathematik.uni-marburg.de/%7Egumm/LyX/Using_XYpic_in_LyX.htm


I had to fix spaces in Logo names like XY -pic and LaTex, fairly simple.
Yum does a good job of installing with Fedora core. Mandrive also has
something like that; another distro uses apt-get. Many distros will
include tex4ht if you do a full Tetex install. Often the Tetex database
has to be updated after adding a package or fonts and LyX reconfigured.

Perhaps someone else can help you with latex2html which is known
to be a bit unreliable. It is a helper app in the Latex bundle. LyX
uses external html converters, but doesn't do developer work on them.

Regards,
Stephen



Re: Copy and paste from Lyx

2006-04-04 Thread Griera
A Dissabte 01 Abril 2006 01:07, Charlie va escriure:
 Thank you. That is one work around and will save me building a .deb from
 the Lyx 1.4 source, which I can't even get too from the Lyx website. which
 might also be another bug.

You are welcome. Regards. 


Re: Arranging the references in alphabetic order

2006-04-04 Thread jesse mejia


On Apr 3, 2006, at 3:55 AM, Behnam Mostajeran Goortani wrote:



Hi There,
How can I put the references in alphabetic order (Authors names) in 
Lyx (under

windows)?


I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


-Jesse



Re: bookstab package and lyx

2006-04-04 Thread Charles de Miramon
Marcelo Acuña wrote:

 Hello,
  I want to use bookstab package for nices tables,
 doc of this package came with example, this example
 work in kile but in lyx I only get errors and errors
 like:
 
  You haven?t defined [EMAIL PROTECTED] yet
It is a bug when you cut and paste from LaTeX insets. Nothing to do with the
bookstab package.

Cheers,
Charles
-- 
http://www.kde-france.org



Re: Arranging the references in alphabetic order

2006-04-04 Thread Peter Bowyer

At 11:47 04/04/2006, jesse mejia wrote:
I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


Using Natbib this happened by default for me, and took a while to 
work out how to change.  I'm writing up a physics project so am using 
Numerical referencing fwiw.


Anyhow, when you insert your BibTex Generated Bibliography you have a 
large list of styles.


unsrtnat: numbers in the order the references were inserted into the 
document, and orders the bibliography in that way.
plainnat: orders the bibliography alphabetically, then wherever you 
insert the reference it numbers for the position in the ordered bibliography.


There was one other I tried as well which I forget - basically play 
with the styles until you find the one that works for you :)


Regards,
Peter

--
Maple Design - quality web design and programming
http://www.mapledesign.co.uk 



Re: \bind not working on 1.4.0

2006-04-04 Thread belahcene abdelkader


Hi,
great it is obsolete, how to switch to another
language!!!
please can you send me a correct file withc replaces
the previous lyxrc, with a correct switching and using
the F12  key for example

thank you very much
bela


--- Jean-Marc Lasgouttes
[EMAIL PROTECTED] wrote:

  belahcene == belahcene abdelkader
 [EMAIL PROTECTED] writes:
 
 belahcene Hi every body, I ve just check the 1.4.0
 version, there are
 belahcene a lot diff than 1.3.4 and bugs too. I
 wnat to switch with
 belahcene F12 to another language, say arabic, so I
 uncomment the
 belahcene arabic part in lyxrc.example and I copied
 it to lyxrc (I
 belahcene used to do it without problem since 1.1.6
 versiion), it is
 belahcene working on 1.3.4 but not 1.4.0, the \bind
 is not
 belahcene recognized. First I have to fix this pb
 before continue and
 belahcene check other things best regards bela
 thank for help
 
 It is not possible anymore to put \bind commands in
 lyxrc file. You
 should use a personal bind file to do that, like
 
 --mybindings.bind--
 \bind_file cua
 
 \bind Delete delete-backward
 
 
 The lyxrc.example file is obsolete, and should
 probably be removed.
 
 JMarc
 




__
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: LyX to OpenOffice

2006-04-04 Thread Stephen Harris

jesse mejia wrote:


Does anyone know if theres an easy way to get these scripts running on 
OSX? No big deal if not... I can just convert on a linux box if it's not 
possible. Thanks!


-Jesse



You could write to Nick Thomas and ask, see if he knows.

ncth  at safe-mail dot net {normalize email address)


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex, the
 resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:

 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}

 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone know
 how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

 I attach the lyx document.

 Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
http://www.appl-ecosys.com Voice: 503-667-4517  Fax: 503-667-8863


AGU classes...

2006-04-04 Thread Mathieu Richaud

Hello,

I am running into a problem that I can't solve... I run Lyx 1.4.0 under 
Mandriva2006. I am writing an article to be submitted to the American 
Geophysical Union (AGU). According to AGU's website, I need to download 
a .bst file for bibtex. I downloaded agufull04.bst, agufull.bst and 
agu.bst. I put them all in /usr/share/texmf/bibtex/bst/agu directory 
and ran texhash as root, and I can find them in the style window. The 
document class is AGU++ and and the class setting is agums. If I click 
on the use class default button, Natbib is automatically chosen as 
default.


However, when I want to look at my manuscript, I get the following errors...

Package natbib error: The aguplus class already includes natbib coding.
LateX error: unknow option authoryear for package natbib.
\endinput}{}
Type Return for now, but then later remove the command 
\userpackage{natbib} from the document


What can I do? I tried a bunch of things but nothing worked. Thanks for 
your help!


Mathieu

--
Mathieu Richaud
Graduate Student
Dept. of Geology
Northern Illinois University
DeKalb, IL 60115
[EMAIL PROTECTED]



Lyx 1.4.0 won'http://www.codeweavers.com/support/tickets/browse/?list=6;ticket_level=2t allow quotation marks inside ERT boxes

2006-04-04 Thread Paul Johnson
I'm writing NoWeb documents using LyX and the statistical program R.
In my Fedora Core 5 systems, I notice lyx updated to 1.4.0 from the
Fedora Extras and most things work well (thanks!).  The guide we
prepared for LyX to weave statistical results into documents still
works great.

However, LyX will not let me type double quotation marks:   inside
ERT boxes.  And that's vital for the R code.  I am allowed to copy and
paste quotation marks from ERT boxes that I wrote with LyX 1.3.7, so
that is a work around.  But I can't understand why LyX would disable
the  key altogether.

Thanks in advance.

--
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas


Re: List of Figures

2006-04-04 Thread tceglare
Thank you very much - it works!

> Hi
>
> Click: Insert - short title
> and then write a shorter title after the title of the figure. In the TOC
> the short title is displayed. Also works for section titles etc. and
> works is both TOC and headers etc.
>
> Regards
> Christiaan
>
>
>
>
> [EMAIL PROTECTED] wrote:
>>hello,
>>
>>i have inserted a list of figures in my document (book-komascript). the
>>problem is that the whole(!) description of the figures appears in the
>>list. i want to appear just a short title of each figure.
>>
>>can anyone help me, please?
>>
>>cu,
>>
>>  tc
>>
>>
>
>



Re: Numbers of section and subsection

2006-04-04 Thread Jordi Espasa Clofent
> Since support for latex2html was discontinued a few years ago
> you could try htlatex which is still being actively developed.

Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.

¿What tex-html converter do you use or do you advice me?

Thanks a lot.

-- 
Salut,
Jordi Espasa


pgpHGADenDPNS.pgp
Description: PGP signature


Re: List of Figures

2006-04-04 Thread Wolfgang Engelmann
Am Montag, 3. April 2006 22:57 schrieb [EMAIL PROTECTED]:
> hello,
>
> i have inserted a list of figures in my document (book-komascript). the
> problem is that the whole(!) description of the figures appears in the
> list. i want to appear just a short title of each figure.
>
> can anyone help me, please?

I guess you used >floats>figure and added the legend there after 
Figure#: blabla
Go with your cursor to Figure#: blabla
and select >shorttitle in the same dropdown column where you selected floats

a red framed field marked OPT opens, where you can insert your short title 
(easiest: cut and paste your legend and shorten it afterward)

Wolfgang


Re: Numbers of section and subsection

2006-04-04 Thread Stephen Harris

Jordi Espasa Clofent wrote:

Since support for latex2html was discontinued a few years ago
you could try htlatex which is still being actively developed.


Hi Stephen,

I know it, but I think the usage and installation process of tex4ht (htlatex 
is included inside) is very, very tiresome. Indeed, after just an hour, I 
haven't it installed. In the other side, latex2html is sopported in a lot of 
distros and their usage is easier than tex4ht.


¿What tex-html converter do you use or do you advice me?

Thanks a lot.



I use htlatex. Here is a somewhat complicated conversion to html
that I did this year. What do you think? "htlatex xypic.tex" 
http://www.mathematik.uni-marburg.de/%7Egumm/LyX/Using_XYpic_in_LyX.htm


I had to fix spaces in Logo names like XY -pic and LaTex, fairly simple.
Yum does a good job of installing with Fedora core. Mandrive also has
something like that; another distro uses apt-get. Many distros will
include tex4ht if you do a full Tetex install. Often the Tetex database
has to be updated after adding a package or fonts and LyX reconfigured.

Perhaps someone else can help you with latex2html which is known
to be a bit unreliable. It is a helper app in the Latex bundle. LyX
uses external html converters, but doesn't do developer work on them.

Regards,
Stephen



Re: Copy and paste from Lyx

2006-04-04 Thread Griera
A Dissabte 01 Abril 2006 01:07, Charlie va escriure:
> Thank you. That is one work around and will save me building a .deb from
> the Lyx 1.4 source, which I can't even get too from the Lyx website. which
> might also be another bug.

You are welcome. Regards. 


Re: Arranging the references in alphabetic order

2006-04-04 Thread jesse mejia


On Apr 3, 2006, at 3:55 AM, Behnam Mostajeran Goortani wrote:



Hi There,
How can I put the references in alphabetic order (Authors names) in 
Lyx (under

windows)?


I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


-Jesse



Re: bookstab package and lyx

2006-04-04 Thread Charles de Miramon
Marcelo Acuña wrote:

> Hello,
>  I want to use bookstab package for nices tables,
> doc of this package came with example, this example
> work in kile but in lyx I only get errors and errors
> like:
> 
>  You haven?t defined [EMAIL PROTECTED] yet
It is a bug when you cut and paste from LaTeX insets. Nothing to do with the
bookstab package.

Cheers,
Charles
-- 
http://www.kde-france.org



Re: Arranging the references in alphabetic order

2006-04-04 Thread Peter Bowyer

At 11:47 04/04/2006, jesse mejia wrote:
I've been wondering the same thing. (not under windows...but I don't 
think that should make a difference)
Anyone know of a way to do it? Last time I had to re-arrange all my 
references manually, which led to fixing all of my footnotes! Since 
I've been careful to enter them in alphabetical order as I work, but 
there must be a way to re-order the list...


Using Natbib this happened by default for me, and took a while to 
work out how to change.  I'm writing up a physics project so am using 
Numerical referencing fwiw.


Anyhow, when you insert your BibTex Generated Bibliography you have a 
large list of styles.


unsrtnat: numbers in the order the references were inserted into the 
document, and orders the bibliography in that way.
plainnat: orders the bibliography alphabetically, then wherever you 
insert the reference it numbers for the position in the ordered bibliography.


There was one other I tried as well which I forget - basically play 
with the styles until you find the one that works for you :)


Regards,
Peter

--
Maple Design - quality web design and programming
http://www.mapledesign.co.uk 



Re: \bind not working on 1.4.0

2006-04-04 Thread belahcene abdelkader


Hi,
great it is obsolete, how to switch to another
language!!!
please can you send me a correct file withc replaces
the previous lyxrc, with a correct switching and using
the F12  key for example

thank you very much
bela


--- Jean-Marc Lasgouttes
<[EMAIL PROTECTED]> wrote:

> > "belahcene" == belahcene abdelkader
> <[EMAIL PROTECTED]> writes:
> 
> belahcene> Hi every body, I ve just check the 1.4.0
> version, there are
> belahcene> a lot diff than 1.3.4 and bugs too. I
> wnat to switch with
> belahcene> F12 to another language, say arabic, so I
> uncomment the
> belahcene> arabic part in lyxrc.example and I copied
> it to lyxrc (I
> belahcene> used to do it without problem since 1.1.6
> versiion), it is
> belahcene> working on 1.3.4 but not 1.4.0, the \bind
> is not
> belahcene> recognized. First I have to fix this pb
> before continue and
> belahcene> check other things best regards bela
> thank for help
> 
> It is not possible anymore to put \bind commands in
> lyxrc file. You
> should use a personal bind file to do that, like
> 
> --mybindings.bind--
> \bind_file cua
> 
> \bind "Delete" "delete-backward"
> 
> 
> The lyxrc.example file is obsolete, and should
> probably be removed.
> 
> JMarc
> 




__
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: LyX to OpenOffice

2006-04-04 Thread Stephen Harris

jesse mejia wrote:


Does anyone know if theres an easy way to get these scripts running on 
OSX? No big deal if not... I can just convert on a linux box if it's not 
possible. Thanks!


-Jesse



You could write to Nick Thomas and ask, see if he knows.

ncth  at safe-mail dot net {normalize email address)


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
> Hi, I have a problem related with the pdf index generation with the beamer
> class. I write a simple lyx document, and when I view it with pdflatex, the
> resulting pdf leaves the left-side navigation panel empty, even using
> section and subsection environments in the lyx document. When I export the
> file to latex to see what happen, I see two strange lines:
>
> \setcounter{secnumdepth}{-1000}
> \setcounter{tocdepth}{-1000}
>
> that in previous beamer documents had a value of 3 instead of -1000. I
> don't know why these two numbers are set to -1000, and I also don't know
> how to reset them to its original value. By setting them to a reasonable
> value, let's say 3, for instance, the index appears again. Does anyone know
> how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

> I attach the lyx document.
>
> Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
 Voice: 503-667-4517  Fax: 503-667-8863


AGU classes...

2006-04-04 Thread Mathieu Richaud

Hello,

I am running into a problem that I can't solve... I run Lyx 1.4.0 under 
Mandriva2006. I am writing an article to be submitted to the American 
Geophysical Union (AGU). According to AGU's website, I need to download 
a .bst file for bibtex. I downloaded agufull04.bst, agufull.bst and 
agu.bst. I put them all in /usr/share/texmf/bibtex/bst/ 
and ran texhash as root, and I can find them in the "style" window. The 
document class is AGU++ and and the class setting is agums. If I click 
on the "use class default" button, Natbib is automatically chosen as 
default.


However, when I want to look at my manuscript, I get the following errors...

"Package natbib error: The aguplus class already includes natbib coding."
"LateX error: unknow option "authoryear" for package "natbib."
"\endinput}{}"
"Type  for now, but then later remove the command 
\userpackage{natbib} from the document"


What can I do? I tried a bunch of things but nothing worked. Thanks for 
your help!


Mathieu

--
Mathieu Richaud
Graduate Student
Dept. of Geology
Northern Illinois University
DeKalb, IL 60115
[EMAIL PROTECTED]



Lyx 1.4.0 won'http://www.codeweavers.com/support/tickets/browse/?list=6;ticket_level=2t allow quotation marks inside ERT boxes

2006-04-04 Thread Paul Johnson
I'm writing NoWeb documents using LyX and the statistical program R.
In my Fedora Core 5 systems, I notice lyx updated to 1.4.0 from the
Fedora Extras and most things work well (thanks!).  The guide we
prepared for LyX to "weave" statistical results into documents still
works great.

However, LyX will not let me type double quotation marks: "  inside
ERT boxes.  And that's vital for the R code.  I am allowed to copy and
paste quotation marks from ERT boxes that I wrote with LyX 1.3.7, so
that is a work around.  But I can't understand why LyX would disable
the " key altogether.

Thanks in advance.

--
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas