Re: Trouble Typesetting English & Korean

2016-05-31 Thread Joel Kulesza
Sorry for the spam, but after more searching, one can enter 'mj' in
Document -> Settings -> Fonts -> CJK.  I'll leave this here in case someone
searches the archive; hopefully it will be a help.

That said, I was originally looking through the Text style dialog for this
setting (expecting that one could use different CJK fonts on different
passages within the same document).  Does it make sense to move this
setting to that dialog (or to duplicate it there to be overridden by a
global setting)?

Thank you,
Joel

On Tue, May 31, 2016 at 9:42 PM, Joel Kulesza  wrote:

> LyX Users (& Devs.),
>
> I'm having trouble typesetting some Korean within a primarily English
> document.  Please see the attached minimal .lyx file.  This was created by
> entering the following text
> 
> in a new document, setting the Document->Settings->Language->Encoding->
> Unicode (CJK) (utf8), highlighting the Korean section (include FAQ),
> selecting Text style, and changing the language to Korean.
>
> 이 FAQ 은 자주 반복되는 질문과 그에 대한 대답을 간단명료한 양식으로 모아 엮어졌습니다.
>
> This FAQ list was made to summarize some frequently asked questions and
> their answers in a convenient form.
>
>
> After attempting to render, the result is:
>
> !pdfTeX error: pdflatex (file cyberbc2): Font cyberbc2 at 600 not found
>
>
> Note that if I instead include the native Korean with a LaTeX box
> containing the \begin{CJK}...\end{CJK} found below, I can render.  So, it
> all seems to hinge on the {mj}.
>
> Can anyone tell what I've done wrong / overlooked?  Does anyone know how
> to change my CJK flags to those shown below (which I can render)?
>
> Thank you,
> Joel
>
> I am able to render this LaTeX document manually:
>
> \documentclass{article}
>
>
> \usepackage[T1]{fontenc}
>
> \usepackage{CJKutf8}
>
> \usepackage[english]{babel}
>
>
>
> \begin{document}
>
>
>
> \begin{CJK}{UTF8}{mj}
>
>
>
>   이 FAQ 은 자주 반복되는 질문과 그에 대한 대답을 간단명료한 양식으로
>
>   모아 엮어졌습니다.
>
>
>
> \end{CJK}
>
>
>
> This FAQ list was made to summarize some frequently asked questions
>
> and their answers in a convenient form.
>
>
>
> \end{document}
>
>


Trouble Typesetting English & Korean

2016-05-31 Thread Joel Kulesza
LyX Users (& Devs.),

I'm having trouble typesetting some Korean within a primarily English
document.  Please see the attached minimal .lyx file.  This was created by
entering the following text

in a new document, setting the Document->Settings->Language->Encoding->
Unicode (CJK) (utf8), highlighting the Korean section (include FAQ),
selecting Text style, and changing the language to Korean.

이 FAQ 은 자주 반복되는 질문과 그에 대한 대답을 간단명료한 양식으로 모아 엮어졌습니다.
This FAQ list was made to summarize some frequently asked questions and
their answers in a convenient form.


After attempting to render, the result is:

!pdfTeX error: pdflatex (file cyberbc2): Font cyberbc2 at 600 not found


Note that if I instead include the native Korean with a LaTeX box
containing the \begin{CJK}...\end{CJK} found below, I can render.  So, it
all seems to hinge on the {mj}.

Can anyone tell what I've done wrong / overlooked?  Does anyone know how to
change my CJK flags to those shown below (which I can render)?

Thank you,
Joel

I am able to render this LaTeX document manually:

\documentclass{article}


\usepackage[T1]{fontenc}

\usepackage{CJKutf8}

\usepackage[english]{babel}



\begin{document}



\begin{CJK}{UTF8}{mj}



  이 FAQ 은 자주 반복되는 질문과 그에 대한 대답을 간단명료한 양식으로

  모아 엮어졌습니다.



\end{CJK}



This FAQ list was made to summarize some frequently asked questions

and their answers in a convenient form.



\end{document}


korean_test_lyx_220.lyx
Description: Binary data


Re: Embedding asymptote in Lyx

2016-05-31 Thread Scott Kostyshak
On Sat, Jun 07, 2014 at 12:07:58PM +0200, Georg Baum wrote:
> Cyril wrote:
> 
> > The converter is from what initial format ? I guess the final is PDF.
> > But the initial one is LaTeX, LyX,...?
> 
> That depends. I guess you want to use pdflatex for direct pdf production. In 
> that case, use "LaTeX (pdflatex)" (code name pdflatex in the preferences 
> file), and your three commands are
> 
> pdflatex myfile.tex
> asy myfile-*
> pdflatex myfile.tex
> 
> If you use TeXLive, you can even use latexmk instead of a wrapper script 
> (from 
> http://asymptote.sourceforge.net/doc/LaTeX-usage.html):
> 
> latexmk -pdf myfile
> 
> The final format is the new PDF variant you need to define. Otherwise your 
> new converter would overwrite the default, and this would cause errors for 
> files without asymptote code. 

Hi Cyril,

Did you get this to work? We have an open enhancement request to
possibly improve support for asymptote in LyX:
http://www.lyx.org/trac/ticket/2950

But we would need your help to proceed.

Scott


signature.asc
Description: PGP signature


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Scott Kostyshak
On Tue, May 31, 2016 at 11:05:59PM +0200, Kornel Benko wrote:
> Am Dienstag, 31. Mai 2016 um 16:09:26, schrieb Scott Kostyshak 
> 
> > On Tue, May 31, 2016 at 09:38:17PM +0200, Georg Baum wrote:
> > > Scott Kostyshak wrote:
> > > 
> > > > On Tue, May 31, 2016 at 09:10:17AM +0200, Wolfgang Engelmann wrote:
> > > >> 
> > > >> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx 
> > > >> lyx22)
> > > >> side by side
> > > > 
> > > > You're on Linux right? I'm not sure of the best way to remove it. We
> > > > don't have an uninstall target (i.e. you can't do "make uninstall").
> > > 
> > > We do (at least with autotools). Simply call
> > > 
> > > make uninstall
> > > 
> > > from the rc1 build directory. If installation needed root privileges, 
> > > then 
> > > this needs root privileges as well.
> > 
> > Good to know. Sorry for the misinformation, Wolfgang. I based my answer
> > on the targets created by cmake.
> 
> But with cmake we can use packages. Uninstalling is just as easy as using 
> 'dpkg --purge' or 'rpm -e'.

That is indeed good to know.

I was blaming myself, not cmake.

Scott


signature.asc
Description: PGP signature


LyX Qt5 PPA (was: Re: Upgrading to Lyx 2.2)

2016-05-31 Thread Liviu Andronic
On Tue, May 31, 2016 at 6:58 PM, Jürgen Spitzmüller  wrote:
> Am Montag, den 30.05.2016, 11:02 +0200 schrieb UD:
>> Thanks a lot--  I have now upgraded to 2.2 without issues.  Now if I
>> could only get the Lyx icons on my Yoga 2 Pro HiDPI to be a little
>> bigger so I could actually see them, I might even be happy!
>
> Try right-click on the toolbar and select "Huge" or "Giant". (This
> should not be needed IMHO, LyX should scale the icons appropriately if
> HiDPI is detected, but this is unfortunately not the case).
>
> Note also that, with Linux, you might need to pass a specific value to
> activate Qt's HiDPI support via .profile
>
> depending on your Qt version it is either
>
> export QT_AUTO_SCREEN_SCALE_FACTOR=1
> (as of Qt 5.6)
>
> or
>
> export QT_DEVICE_PIXEL_RATIO=auto
> (Qt 5.4 and 5.5)
>

I've now prepared a "LyX Qt5 (release)" specifically for packages of
LyX built against Qt5 >=5.5.1 :
https://launchpad.net/~lyx-devel/+archive/ubuntu/release-qt5

For now only Xenial packages are available. Older Qt5 releases have
significant problems with LyX, so older Ubuntu distros are not
supported.

Those who need HiDPI support please check the packages (they will
replace your current Qt4 builds) and report on the list if you
encounter issues.

Regards,
Liviu


> HTH
> (works well for me on the same machine)
>
> Jürgen
>
>
>> Yours,
>> EK
>>
>



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Kornel Benko
Am Dienstag, 31. Mai 2016 um 16:09:26, schrieb Scott Kostyshak 

> On Tue, May 31, 2016 at 09:38:17PM +0200, Georg Baum wrote:
> > Scott Kostyshak wrote:
> > 
> > > On Tue, May 31, 2016 at 09:10:17AM +0200, Wolfgang Engelmann wrote:
> > >> 
> > >> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
> > >> side by side
> > > 
> > > You're on Linux right? I'm not sure of the best way to remove it. We
> > > don't have an uninstall target (i.e. you can't do "make uninstall").
> > 
> > We do (at least with autotools). Simply call
> > 
> > make uninstall
> > 
> > from the rc1 build directory. If installation needed root privileges, then 
> > this needs root privileges as well.
> 
> Good to know. Sorry for the misinformation, Wolfgang. I based my answer
> on the targets created by cmake.

But with cmake we can use packages. Uninstalling is just as easy as using 'dpkg 
--purge' or 'rpm -e'.


> Scott
> 
> > 
> > 
> > Georg

Kornel

signature.asc
Description: This is a digitally signed message part.


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Scott Kostyshak
On Tue, May 31, 2016 at 09:38:17PM +0200, Georg Baum wrote:
> Scott Kostyshak wrote:
> 
> > On Tue, May 31, 2016 at 09:10:17AM +0200, Wolfgang Engelmann wrote:
> >> 
> >> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
> >> side by side
> > 
> > You're on Linux right? I'm not sure of the best way to remove it. We
> > don't have an uninstall target (i.e. you can't do "make uninstall").
> 
> We do (at least with autotools). Simply call
> 
> make uninstall
> 
> from the rc1 build directory. If installation needed root privileges, then 
> this needs root privileges as well.

Good to know. Sorry for the misinformation, Wolfgang. I based my answer
on the targets created by cmake.

Scott

> 
> 
> Georg
> 


signature.asc
Description: PGP signature


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Georg Baum
Scott Kostyshak wrote:

> On Tue, May 31, 2016 at 09:10:17AM +0200, Wolfgang Engelmann wrote:
>> 
>> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
>> side by side
> 
> You're on Linux right? I'm not sure of the best way to remove it. We
> don't have an uninstall target (i.e. you can't do "make uninstall").

We do (at least with autotools). Simply call

make uninstall

from the rc1 build directory. If installation needed root privileges, then 
this needs root privileges as well.


Georg



Re: Upgrading to Lyx 2.2

2016-05-31 Thread Jürgen Spitzmüller
Am Montag, den 30.05.2016, 11:02 +0200 schrieb UD:
> Thanks a lot--  I have now upgraded to 2.2 without issues.  Now if I
> could only get the Lyx icons on my Yoga 2 Pro HiDPI to be a little
> bigger so I could actually see them, I might even be happy!

Try right-click on the toolbar and select "Huge" or "Giant". (This
should not be needed IMHO, LyX should scale the icons appropriately if
HiDPI is detected, but this is unfortunately not the case).

Note also that, with Linux, you might need to pass a specific value to
activate Qt's HiDPI support via .profile

depending on your Qt version it is either

export QT_AUTO_SCREEN_SCALE_FACTOR=1
(as of Qt 5.6)

or

export QT_DEVICE_PIXEL_RATIO=auto
(Qt 5.4 and 5.5)

HTH
(works well for me on the same machine)

Jürgen


> Yours,
> EK
> 



Consecutive numbering in KOMA-Script article

2016-05-31 Thread jezZiFeR
Hello, I have a question regarding the numeration in KOMA-script article. I
would like to have consecutive numbering starting from the beginning (with
1) in each section. Right now the numbering is consecutive throughout the
whole document. After each section it just continues, while I would like to
have to begin it with 1 in each section. I hope I have made clear, what I
want to achieve:

SECTION 2

1. Chapter
2. Chapter
…

SECTION 2

1. Chapter
2. Chapter
…

Thanks for any help
Jess


Re: No graphics preview within LyX

2016-05-31 Thread Daniel CLEMENT
Le lundi 30 mai 2016 à 13:51 +0200, Kornel Benko a écrit :
> Am Montag, 30. Mai 2016 um 13:40:16, schrieb Daniel CLEMENT 
> 
> > Le lundi 30 mai 2016 à 13:24 +0200, Kornel Benko a écrit :
> > > Am Montag, 30. Mai 2016 um 13:10:40, schrieb Daniel CLEMENT 
> > > 
> > > > Dear list members,
> > > > 
> > > > I have this issue with a PC at work: graphics are not displayed in sh:
> > > > 1: convert: not found
> > > > /usr/share/lyx/scripts/convertDefault.py ERROR
> > > > Execution of "convert" failed.the LyX window. I got this error:
> > > > 
> > > > "Error converting to readable format"
> > > > 
> > > > (I do my best to translate from French.)
> > > > 
> > > > However, the graphic file is here, and previewing the whole file (e.g.
> > > > in PDF) is fine.
> > > > 
> > > > The system is Linux Debian Stable (w/ LyX 2.1.3), it's supposed to be
> > > > the very same
> > > > setup as on my home PC (except that it's 32-bit instead of 64). My own
> > > > PC does not have this problem.
> > > > 
> > > > If I launch LyX from the command line, I get this error message in the
> > > > terminal:
> > > > 
> > > > sh: 1: convert: not found
> > > > /usr/share/lyx/scripts/convertDefault.py ERROR
> > > > Execution of "convert" failed.
> > > > 
> > > > I suppose some package is missing , but I don't know which one.
> > > > 
> > > > TIA for any advice - regards,
> > > 
> > > probably package 'imagemagick'.
> > > 
> > >   Kornel
> > Well that was my 1st thought also, but I checked, and it is there. (I
> > did not try to reinstall it though.)
> Here it is:
> # which covert
>   /usr/bin/convert
> #ls -l /usr/bin/convert
>   /usr/bin/convert -> /etc/alternatives/convert
> #ls -l  /etc/alternatives/convert
>   /etc/alternatives/convert -> /usr/bin/convert.im6
> #dpkg -S /usr/bin/convert.im6
>   imagemagick
> 
> But apparently our platforms differ.
> 
>   Kornel
I could re-check the PC at work this morning, and indeed imagemagick was
missing. (imagemagick-commom was there, but the column in synaptic was
too narrow and I did not notice the difference...)

So, of course, installing imagemagick solved the problem. I wrongly
assumed that it was a LyX dependency, but I guess it got installed
otherwise on my home PC.

Sorry about my mistake, and thanks for the help.
-- 
Daniel CLEMENT



Re: ClassicThesis

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 12:11, Michael Berger wrote:

Wolfgang,
if this is the first time to use classicthesis in Lyx then you might 
get classicthesis 4.1 first and the wait till your distributions are 
fit and complete for version 4.2 which is downwards compatible to 
version 4.1
AFAIK version 4.2 also depends on some latest coma-packages that are 
up to now not yet available/standard in most distributions.
Classicthesis 4.1 works well with me and cooperates flawlessly with 
bibtex as well as with biblatex.

I will switch to version 4.2 when my distro is ready and prepared for it.
Michael

Thanks Michael,
but the 4.2 version seems to work at least as biblatex_bibtex8.
biblatex_biber does not show the references in the pdf output, but 
perhaps somebody can point me to the cause of it.


I was going to give a talk on ClassicThesis at the Tuebix meeting on the 
10th of June (http://www.tuebix.org/) in Tuebingen, Germany. Since it is 
soon starting, I am glad I could get it working now with the help of 
this excellent list.

Wolfgang


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 11:35, Helge Hafting wrote:



Den 31. mai 2016 10:50, skrev Wolfgang Engelmann:

I used ./configure --with-version-suffix=22
and make
and #make install
so probably neither one
Wolfgang


Removing rc1 is not necessary for correct operation of lyx 2.2.0 in 
this case. The rc1 lyx you compiled is named "lyx-22", and won't 
interfere with the packaged lyx named "lyx".


You may of course still want to remove the older lyx-22 to save space 
or have a tidy filesystem. The binaries:

rm /usr/local/lyx-22*
(removes lyx-22 and lyxclient-22. You must be root or use sudo to do 
this)


Other lyx files:
rm -r /usr/local/share/lyx-22
(removes everything else, templates, scripts, document classes and so 
on. You must be root for this too.)


Check if there is anything else left:
find /usr/local/ -name "lyx-22*"
If anything is found, consider removing it. If it has "-22" in the 
name, it is only needed for lyx-22 and should be of little use for 
anything else.


Personal lyx-22 rc1 stuff:
rm -r ~/.lyx-22
(removes settings, customizations and personal templates for this 
particular lyx. If you have saved anything in here, such as your own 
templates or document classes, then you may want to copy it into the 
new .lyx/ folder first. )



The distro package system installs lyx stuff in /usr/share/lyx/, which 
is a different folder from those used by lyx-22. The distributed 
binaries should be /usr/bin/lyx and /usr/bin/lyxclient, and the 
personal folder for settings etc.  is ~/.lyx/


A lyx you install with "make install" goes in /usr/local/... so it 
won't interfere with anything from the package management system of 
the linux distribution. And when you use "--with-version-suffix=22", 
everything will be tagged with that convenient "-22". This makes 
removal easier, and allows installation of many versions of lyx 
simultaneously, which is useful for testing & development. All 
different versions should use different version-suffix.


Helge Hafting
Thanks, Helge, for explaining all this in detail which is very helpful 
for me, especially the various places for lyx.


As far as my question re ngerman is concerned, I noticed that the 
summary is also in German, which explains that it is needed.


Re: Question about development of non-linear writing project

2016-05-31 Thread Tobias
tom  gmx.at> writes:

> 
> 
> > I am worried about this issue too. No traces of this on the webpages and
> > lyx-outline which was a working fork with the corkboard developed by Rob
> > Oakes seems dead for a while now. This i a giant improvement for Lyx and it
> > would be really sad if it was abandoned!
> 
> +1 for corkboard.
> 
> Anyone heard news about the state of this project as of 2015?
> 
> 

Hey there! 

I’ve also been searching the web for quite a while and could not figure out
the current status of the project. Is it still planned to be implemented?
(as was discussed in 2014 for the 2.2 release)

Does anyone have information about this awesome project?

Re: ClassicThesis

2016-05-31 Thread Michael Berger

Wolfgang,
if this is the first time to use classicthesis in Lyx then you might get 
classicthesis 4.1 first and the wait till your distributions are fit and 
complete for version 4.2 which is downwards compatible to version 4.1
AFAIK version 4.2 also depends on some latest coma-packages that are up 
to now not yet available/standard in most distributions.
Classicthesis 4.1 works well with me and cooperates flawlessly with 
bibtex as well as with biblatex.

I will switch to version 4.2 when my distro is ready and prepared for it.
Michael


On 05/31/2016 09:49 AM, Wolfgang Engelmann wrote:

I try to use ClassicThesis under Lyx.
I unpacked this:
(classicthesis-v4.2 is a bugfix release of the classic thesis template 
that for the first time introduces BibLaTeX, a powerful package for 
formatting citations and references. Due to lacking support in LyX, 
several hacks have been applied (wiki.lyx.org/BibTeX/Biblatex) so that 
standard LyX dialogs could be used for citation input, and 
bibliography databases found during compilation. BibLaTeX is capable 
of employing several backends for bibliography management; we provide 
two: biber, the preferred and most capable one (but still immature and 
sometimes glitchy), and bibtex8. If both fail for you, revert to the 
old bibliography management with BibTeX.)

and followed this:
Test the template by opening and compiling ClassicThesis.lyx in this 
order:
1-classicthesis-LyX-v4.2_biblatex_biber/ (tested and worked with TeX 
Live 2014 on Fedora Linux 22)
2-classicthesis-LyX-v4.2_biblatex_bibtex8/ (tested and worked with 
MikTeX 2.9 on Windows as well)

3-classicthesis-LyX-v4.1_bugfix/
Note that this is the same template set up in three different ways - 
you will be using only one of the folders.


Under Kubuntu (14. ) and using Lyx2.2.0 (of 23.5.2016)
I get the following errors:
1- csquotes.sty not found
2- csquotes.sty not found
3- mparlack.sty not found

Under Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0 
(of 23.5.2016) I get the following errors:

1- biblatex.sty not found
2- biblatex.sty not found
3- beramono.sty not found

What do I have to do to get it working (especially the one under 
Kubuntu)?

Could it be a texlive issue?

Wolfgang





Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Helge Hafting



Den 31. mai 2016 10:50, skrev Wolfgang Engelmann:

I used ./configure --with-version-suffix=22
and make
and #make install
so probably neither one
Wolfgang


Removing rc1 is not necessary for correct operation of lyx 2.2.0 in this 
case. The rc1 lyx you compiled is named "lyx-22", and won't interfere 
with the packaged lyx named "lyx".


You may of course still want to remove the older lyx-22 to save space or 
have a tidy filesystem. The binaries:

rm /usr/local/lyx-22*
(removes lyx-22 and lyxclient-22. You must be root or use sudo to do this)

Other lyx files:
rm -r /usr/local/share/lyx-22
(removes everything else, templates, scripts, document classes and so 
on. You must be root for this too.)


Check if there is anything else left:
find /usr/local/ -name "lyx-22*"
If anything is found, consider removing it. If it has "-22" in the name, 
it is only needed for lyx-22 and should be of little use for anything else.


Personal lyx-22 rc1 stuff:
rm -r ~/.lyx-22
(removes settings, customizations and personal templates for this 
particular lyx. If you have saved anything in here, such as your own 
templates or document classes, then you may want to copy it into the new 
.lyx/ folder first. )



The distro package system installs lyx stuff in /usr/share/lyx/, which 
is a different folder from those used by lyx-22. The distributed 
binaries should be /usr/bin/lyx and /usr/bin/lyxclient, and the personal 
folder for settings etc.  is ~/.lyx/


A lyx you install with "make install" goes in /usr/local/... so it won't 
interfere with anything from the package management system of the linux 
distribution. And when you use "--with-version-suffix=22", everything 
will be tagged with that convenient "-22". This makes removal easier, 
and allows installation of many versions of lyx simultaneously, which is 
useful for testing & development. All different versions should use 
different version-suffix.


Helge Hafting


Re: ClassicThesis

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 10:10, Liviu Andronic wrote:

On Tue, May 31, 2016 at 9:49 AM, Wolfgang Engelmann
 wrote:

I try to use ClassicThesis under Lyx.
I unpacked this:
(classicthesis-v4.2 is a bugfix release of the classic thesis template that
for the first time introduces BibLaTeX, a powerful package for formatting
citations and references. Due to lacking support in LyX, several hacks have
been applied (wiki.lyx.org/BibTeX/Biblatex) so that standard LyX dialogs
could be used for citation input, and bibliography databases found during
compilation. BibLaTeX is capable of employing several backends for
bibliography management; we provide two: biber, the preferred and most
capable one (but still immature and sometimes glitchy), and bibtex8. If both
fail for you, revert to the old bibliography management with BibTeX.)
and followed this:
Test the template by opening and compiling ClassicThesis.lyx in this order:
1-classicthesis-LyX-v4.2_biblatex_biber/ (tested and worked with TeX Live
2014 on Fedora Linux 22)
2-classicthesis-LyX-v4.2_biblatex_bibtex8/ (tested and worked with MikTeX
2.9 on Windows as well)
3-classicthesis-LyX-v4.1_bugfix/
Note that this is the same template set up in three different ways - you
will be using only one of the folders.

Under Kubuntu (14. ) and using Lyx2.2.0 (of 23.5.2016)
I get the following errors:
1- csquotes.sty not found
2- csquotes.sty not found
3- mparlack.sty not found


Use Search the contents of packages:
http://packages.ubuntu.com/

A quick search shows you need to install texlive-latex-extra. Not sure
about mparlack.sty, though.



Under Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0 (of
23.5.2016) I get the following errors:
1- biblatex.sty not found
2- biblatex.sty not found
3- beramono.sty not found


https://www.debian.org/distrib/packages
Here it should probably be texlive-bibtex-extra and texlive-fonts-extra.

Liviu



What do I have to do to get it working (especially the one under Kubuntu)?
Could it be a texlive issue?

Wolfgang



Thanks for the suggestions. It is working now, however, there are two 
minor issues:


1-

Package biblatex Info: Trying to load language 'ngerman'...

Package biblatex Info: ... file 'ngerman.lbx' found.

(/usr/share/texlive/texmf-dist/tex/latex/biblatex/lbx/ngerman.lbx

File: ngerman.lbx 2014/06/25 v2.9a biblatex localization (PK/JW/AB)

Package biblatex Info: Trying to load language 'german'...

Package biblatex Info: ... file 'german.lbx' found.

(/usr/share/texlive/texmf-dist/tex/latex/biblatex/lbx/german.lbx

File: german.lbx 2014/06/25 v2.9a biblatex localization (PK/JW/AB)

Package biblatex Warning: No hyphenation patterns for 'german' on input 
line 47 1.



This I do not understand. Classicthesis language is set in English, why 
is ngerman demanded? If I do need it, how do I load it?


2- with biblatex_biber I do not get the bibliography in the pdf printout.
What has to be done

Thanks again
Wolfgang


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Kornel Benko
Am Dienstag, 31. Mai 2016 um 10:50:38, schrieb Wolfgang Engelmann 

> >> I compiled it from source
> > With cmake or automake help?
> > In case you used cmake, you could create a debian package. Installing and 
> > de-installing  is easy in that case.
> >
> >   Kornel
> I used ./configure --with-version-suffix=22

This is automake.

> and make
> and #make install
> so probably neither one
> Wolfgang

Kornel

signature.asc
Description: This is a digitally signed message part.


Re: Upgrading to Lyx 2.2

2016-05-31 Thread Helge Hafting



Den 31. mai 2016 01:27, skrev Paul A. Rubin:
"Complete" reinstall actually left my ~/.lyx directory intact, so it 
worked out fine.


This is as expected with Debian/Ubuntu. "apt" and "dpkg" is not supposed 
to touch anything in ~/  (/home/) at all, these utiltites only work with 
system directories. (/etc /usr /bin /var)


Helge Hafting


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 10:27, Kornel Benko wrote:

Am Dienstag, 31. Mai 2016 um 10:15:32, schrieb Wolfgang Engelmann 


On 31.05.2016 10:11, Wolfgang Engelmann wrote:


On 31.05.2016 10:06, Liviu Andronic wrote:

On Tue, May 31, 2016 at 9:10 AM, Wolfgang Engelmann
 wrote:

On 31.05.2016 08:58, Scott Kostyshak wrote:

On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:

Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
Wolfgang

No they're significantly different. I highly recommend you use the
final
2.2.0 over rc1.

Scott

Thanks, Scott.

How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx
lyx22)
side by side


How did you install them? What OS?


Liviu


Wolfgang



Liviu, Scott:

Kubuntu (14.04 trusty) and using Lyx2.2.0 (of 23.5.2016)

Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0
(of 23.5.2016)

Wolfgang


ps
I compiled it from source

With cmake or automake help?
In case you used cmake, you could create a debian package. Installing and 
de-installing  is easy in that case.

Kornel

I used ./configure --with-version-suffix=22
and make
and #make install
so probably neither one
Wolfgang


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Kornel Benko
Am Dienstag, 31. Mai 2016 um 10:15:32, schrieb Wolfgang Engelmann 

> 
> On 31.05.2016 10:11, Wolfgang Engelmann wrote:
> >
> >
> > On 31.05.2016 10:06, Liviu Andronic wrote:
> >> On Tue, May 31, 2016 at 9:10 AM, Wolfgang Engelmann
> >>  wrote:
> >>>
> >>> On 31.05.2016 08:58, Scott Kostyshak wrote:
> >>>
> >>> On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:
> >>>
> >>> Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
> >>> Wolfgang
> >>>
> >>> No they're significantly different. I highly recommend you use the 
> >>> final
> >>> 2.2.0 over rc1.
> >>>
> >>> Scott
> >>>
> >>> Thanks, Scott.
> >>>
> >>> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx 
> >>> lyx22)
> >>> side by side
> >>>
> >> How did you install them? What OS?
> >>
> >>
> >> Liviu
> >>
> >>> Wolfgang
> >>
> >>
> > Liviu, Scott:
> >
> > Kubuntu (14.04 trusty) and using Lyx2.2.0 (of 23.5.2016)
> >
> > Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0
> > (of 23.5.2016)
> >
> > Wolfgang
> >
> ps
> I compiled it from source

With cmake or automake help?
In case you used cmake, you could create a debian package. Installing and 
de-installing  is easy in that case.

Kornel

signature.asc
Description: This is a digitally signed message part.


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 10:11, Wolfgang Engelmann wrote:



On 31.05.2016 10:06, Liviu Andronic wrote:

On Tue, May 31, 2016 at 9:10 AM, Wolfgang Engelmann
 wrote:


On 31.05.2016 08:58, Scott Kostyshak wrote:

On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:

Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
Wolfgang

No they're significantly different. I highly recommend you use the 
final

2.2.0 over rc1.

Scott

Thanks, Scott.

How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx 
lyx22)

side by side


How did you install them? What OS?


Liviu


Wolfgang




Liviu, Scott:

Kubuntu (14.04 trusty) and using Lyx2.2.0 (of 23.5.2016)

Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0
(of 23.5.2016)

Wolfgang


ps
I compiled it from source


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 10:06, Liviu Andronic wrote:

On Tue, May 31, 2016 at 9:10 AM, Wolfgang Engelmann
 wrote:


On 31.05.2016 08:58, Scott Kostyshak wrote:

On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:

Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
Wolfgang

No they're significantly different. I highly recommend you use the final
2.2.0 over rc1.

Scott

Thanks, Scott.

How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
side by side


How did you install them? What OS?


Liviu


Wolfgang




Liviu, Scott:

Kubuntu (14.04 trusty) and using Lyx2.2.0 (of 23.5.2016)

Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0
(of 23.5.2016)

Wolfgang



Re: ClassicThesis

2016-05-31 Thread Liviu Andronic
On Tue, May 31, 2016 at 9:49 AM, Wolfgang Engelmann
 wrote:
> I try to use ClassicThesis under Lyx.
> I unpacked this:
> (classicthesis-v4.2 is a bugfix release of the classic thesis template that
> for the first time introduces BibLaTeX, a powerful package for formatting
> citations and references. Due to lacking support in LyX, several hacks have
> been applied (wiki.lyx.org/BibTeX/Biblatex) so that standard LyX dialogs
> could be used for citation input, and bibliography databases found during
> compilation. BibLaTeX is capable of employing several backends for
> bibliography management; we provide two: biber, the preferred and most
> capable one (but still immature and sometimes glitchy), and bibtex8. If both
> fail for you, revert to the old bibliography management with BibTeX.)
> and followed this:
> Test the template by opening and compiling ClassicThesis.lyx in this order:
> 1-classicthesis-LyX-v4.2_biblatex_biber/ (tested and worked with TeX Live
> 2014 on Fedora Linux 22)
> 2-classicthesis-LyX-v4.2_biblatex_bibtex8/ (tested and worked with MikTeX
> 2.9 on Windows as well)
> 3-classicthesis-LyX-v4.1_bugfix/
> Note that this is the same template set up in three different ways - you
> will be using only one of the folders.
>
> Under Kubuntu (14. ) and using Lyx2.2.0 (of 23.5.2016)
> I get the following errors:
> 1- csquotes.sty not found
> 2- csquotes.sty not found
> 3- mparlack.sty not found
>

Use Search the contents of packages:
http://packages.ubuntu.com/

A quick search shows you need to install texlive-latex-extra. Not sure
about mparlack.sty, though.


> Under Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0 (of
> 23.5.2016) I get the following errors:
> 1- biblatex.sty not found
> 2- biblatex.sty not found
> 3- beramono.sty not found
>

https://www.debian.org/distrib/packages
Here it should probably be texlive-bibtex-extra and texlive-fonts-extra.

Liviu


> What do I have to do to get it working (especially the one under Kubuntu)?
> Could it be a texlive issue?
>
> Wolfgang



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Liviu Andronic
On Tue, May 31, 2016 at 9:10 AM, Wolfgang Engelmann
 wrote:
>
>
> On 31.05.2016 08:58, Scott Kostyshak wrote:
>
> On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:
>
> Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
> Wolfgang
>
> No they're significantly different. I highly recommend you use the final
> 2.2.0 over rc1.
>
> Scott
>
> Thanks, Scott.
>
> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
> side by side
>
How did you install them? What OS?


Liviu

> Wolfgang



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Scott Kostyshak
On Tue, May 31, 2016 at 09:10:17AM +0200, Wolfgang Engelmann wrote:
> 
> 
> On 31.05.2016 08:58, Scott Kostyshak wrote:
> > On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:
> > > Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
> > > Wolfgang
> > No they're significantly different. I highly recommend you use the final
> > 2.2.0 over rc1.
> > 
> > Scott
> 
> Thanks, Scott.
> 
> How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22)
> side by side

You're on Linux right? I'm not sure of the best way to remove it. We
don't have an uninstall target (i.e. you can't do "make uninstall").
You could use something like checkinstall.

Scott


signature.asc
Description: PGP signature


ClassicThesis

2016-05-31 Thread Wolfgang Engelmann

I try to use ClassicThesis under Lyx.
I unpacked this:
(classicthesis-v4.2 is a bugfix release of the classic thesis template 
that for the first time introduces BibLaTeX, a powerful package for 
formatting citations and references. Due to lacking support in LyX, 
several hacks have been applied (wiki.lyx.org/BibTeX/Biblatex) so that 
standard LyX dialogs could be used for citation input, and bibliography 
databases found during compilation. BibLaTeX is capable of employing 
several backends for bibliography management; we provide two: biber, the 
preferred and most capable one (but still immature and sometimes 
glitchy), and bibtex8. If both fail for you, revert to the old 
bibliography management with BibTeX.)

and followed this:
Test the template by opening and compiling ClassicThesis.lyx in this order:
1-classicthesis-LyX-v4.2_biblatex_biber/ (tested and worked with TeX 
Live 2014 on Fedora Linux 22)
2-classicthesis-LyX-v4.2_biblatex_bibtex8/ (tested and worked with 
MikTeX 2.9 on Windows as well)

3-classicthesis-LyX-v4.1_bugfix/
Note that this is the same template set up in three different ways - you 
will be using only one of the folders.


Under Kubuntu (14. ) and using Lyx2.2.0 (of 23.5.2016)
I get the following errors:
1- csquotes.sty not found
2- csquotes.sty not found
3- mparlack.sty not found

Under Debian (GNU/Linux 8.4 (jessie) Release: 8.4) and using Lyx2.2.0 
(of 23.5.2016) I get the following errors:

1- biblatex.sty not found
2- biblatex.sty not found
3- beramono.sty not found

What do I have to do to get it working (especially the one under Kubuntu)?
Could it be a texlive issue?

Wolfgang


Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann



On 31.05.2016 08:58, Scott Kostyshak wrote:

On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:

Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
Wolfgang

No they're significantly different. I highly recommend you use the final
2.2.0 over rc1.

Scott


Thanks, Scott.

How do I effectively remove the rc1 lyx. I have it and 2.2.0 (myx lyx22) 
side by side

Wolfgang



Re: lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Scott Kostyshak
On Tue, May 31, 2016 at 08:53:06AM +0200, Wolfgang Engelmann wrote:
> Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
> Wolfgang

No they're significantly different. I highly recommend you use the final
2.2.0 over rc1.

Scott


signature.asc
Description: PGP signature


lyx2.2.0rc1 and lyx2.2.0 identical?

2016-05-31 Thread Wolfgang Engelmann

Are lyx2.2.0rc1 (11.4.16) and lyx2.2.0 (23.5.16) identical?
Wolfgang


Re: Lyx Change tracking show changes in output not working with displayed equations

2016-05-31 Thread Scott Kostyshak
On Mon, May 30, 2016 at 02:05:09PM -0500, David Halpern wrote:
> Hi,
> 
> I would like to print a hardcopy changes in output (deleted and added).
> If what I deleted does not contain a displayed equation, I can export the
> contents of my lyx file to a pdf file, and then print it out. However, if I
> delete a displayed equation, then an error message appears during the
> export to a pdf phase. I've also exported a lyx file to a plain latex file,
> with the changes in output on. In this case, again I get similar errors.
> With the changes in output off, latex does not generate errors.
> Is this a limitation of "tracking changes" or an error?
> Let me know how to get around this problem.
> Thanks.
> 

Hi David, it appears that this is a limitation of ulem.sty (which is
inherited by LyX's track changes feature). See:
http://www.lyx.org/trac/ticket/9678

I've checked with ulem's author and he said he would consider extending
the support for display math (it appears to be a tricky issue). I just
pinged him again (now a year later), so we'll see what he says.

As for the short run, I don't know of a workaround.

Best,

Scott

p.s. please respond to the list and not to me personally.


signature.asc
Description: PGP signature