Re: Problem with emf to eps convertor metafile2eps

2011-06-02 Thread Joost Verburg
a nedunuri nedun...@cs.utexas.edu wrote in message 
news:loom.20110601t085330-...@post.gmane.org...
 I need to scale it down in Lyx to about 20% of the original size to get it 
 to
 fit, and even then reader will labor for a very long time beofre 
 displaying
 the page (and sometimes omits the figure entirely).

Currently it's indeed necessary to manually define the size of your figure 
in LyX, as this is not preserved during conversion. However, the physical 
size of metafiles in general is not very well defined so this is likely to 
be needed with other metafiles as well.

The slow drawing in your PDF viewer shoudn't be affected by this. Vector 
graphics tend to render slower than bitmaps, but the speed should be about 
the same independent of what conversion tool was used. If you could send me 
a copy of the emf file, I can check whether I can reproduce the problem 
here.

Joost 





Re: Problem with emf to eps convertor metafile2eps

2011-06-02 Thread Joost Verburg
a nedunuri nedun...@cs.utexas.edu wrote in message 
news:loom.20110601t085330-...@post.gmane.org...
 I need to scale it down in Lyx to about 20% of the original size to get it 
 to
 fit, and even then reader will labor for a very long time beofre 
 displaying
 the page (and sometimes omits the figure entirely).

Currently it's indeed necessary to manually define the size of your figure 
in LyX, as this is not preserved during conversion. However, the physical 
size of metafiles in general is not very well defined so this is likely to 
be needed with other metafiles as well.

The slow drawing in your PDF viewer shoudn't be affected by this. Vector 
graphics tend to render slower than bitmaps, but the speed should be about 
the same independent of what conversion tool was used. If you could send me 
a copy of the emf file, I can check whether I can reproduce the problem 
here.

Joost 





Re: Problem with emf to eps convertor metafile2eps

2011-06-02 Thread Joost Verburg
"a nedunuri"  wrote in message 
news:loom.20110601t085330-...@post.gmane.org...
> I need to scale it down in Lyx to about 20% of the original size to get it 
> to
> fit, and even then reader will labor for a very long time beofre 
> displaying
> the page (and sometimes omits the figure entirely).

Currently it's indeed necessary to manually define the size of your figure 
in LyX, as this is not preserved during conversion. However, the physical 
size of metafiles in general is not very well defined so this is likely to 
be needed with other metafiles as well.

The slow drawing in your PDF viewer shoudn't be affected by this. Vector 
graphics tend to render slower than bitmaps, but the speed should be about 
the same independent of what conversion tool was used. If you could send me 
a copy of the emf file, I can check whether I can reproduce the problem 
here.

Joost 





Re: PDF will not reload

2011-05-18 Thread Joost Verburg
Uwe Stöhr uwesto...@web.de wrote in message 
news:4dd31d27.1010...@web.de...
 Yes, that's why we created a program to close/reopen Adobe Reader 
 automatically.

 Joost, do you have an idea why this doesn't work for Hafney?

It works fine for me with the same setup, Windows 7 + Adobe Reader 10.0.1.

Do I understand correctly that the View PDF button works but Update PDF 
does not? When happens when you click Update?

Joost 





Re: PDF will not reload

2011-05-18 Thread Joost Verburg
Uwe Stöhr uwesto...@web.de wrote in message 
news:4dd31d27.1010...@web.de...
 Yes, that's why we created a program to close/reopen Adobe Reader 
 automatically.

 Joost, do you have an idea why this doesn't work for Hafney?

It works fine for me with the same setup, Windows 7 + Adobe Reader 10.0.1.

Do I understand correctly that the View PDF button works but Update PDF 
does not? When happens when you click Update?

Joost 





Re: PDF will not reload

2011-05-18 Thread Joost Verburg
"Uwe Stöhr"  wrote in message 
news:4dd31d27.1010...@web.de...
> Yes, that's why we created a program to close/reopen Adobe Reader 
> automatically.
>
> Joost, do you have an idea why this doesn't work for Hafney?

It works fine for me with the same setup, Windows 7 + Adobe Reader 10.0.1.

Do I understand correctly that the "View PDF" button works but "Update PDF" 
does not? When happens when you click Update?

Joost 





Re: RC3 installers for windows available on ftp (Re: Lyx 2 binary installer)

2011-04-21 Thread Joost Verburg
Jim Oldfield jim_...@yahoo.co.uk wrote in message 
news:597324.81876...@web29209.mail.ird.yahoo.com...
One (open) question: why is it so big? RC2 was 20ish MB, and this one is 
70ish

MB. Is it just the addition of dictionaries?


Correct. Dictionaries + thesaurus lists.

Joost 





Re: RC3 installers for windows available on ftp (Re: Lyx 2 binary installer)

2011-04-21 Thread Joost Verburg
Jim Oldfield jim_...@yahoo.co.uk wrote in message 
news:597324.81876...@web29209.mail.ird.yahoo.com...
One (open) question: why is it so big? RC2 was 20ish MB, and this one is 
70ish

MB. Is it just the addition of dictionaries?


Correct. Dictionaries + thesaurus lists.

Joost 





Re: RC3 installers for windows available on ftp (Re: Lyx 2 binary installer)

2011-04-21 Thread Joost Verburg
"Jim Oldfield"  wrote in message 
news:597324.81876...@web29209.mail.ird.yahoo.com...
One (open) question: why is it so big? RC2 was 20ish MB, and this one is 
70ish

MB. Is it just the addition of dictionaries?


Correct. Dictionaries + thesaurus lists.

Joost 





Re: spellchecker for lyx 2.0 rc2

2011-04-16 Thread Joost Verburg
Julien Rioux jri...@physics.utoronto.ca wrote in message 
news:iod00u$hei$1...@dough.gmane.org...
You would need to make aspell visible to the configure script by putting 
the path to aspell.exe in your PATH environment variable or alternatively 
in the PATH in LyX preferences. Then reconfigure LyX, close and start LyX 
again. If it does not work after that then there is indeed a problem.


No, we don't use Aspell anymore. The problem is indeed that Hunspell 
dictionaries are missing in the installer. This will be fixed in RC3.


Joost 





Re: spellchecker for lyx 2.0 rc2

2011-04-16 Thread Joost Verburg
Julien Rioux jri...@physics.utoronto.ca wrote in message 
news:iod00u$hei$1...@dough.gmane.org...
You would need to make aspell visible to the configure script by putting 
the path to aspell.exe in your PATH environment variable or alternatively 
in the PATH in LyX preferences. Then reconfigure LyX, close and start LyX 
again. If it does not work after that then there is indeed a problem.


No, we don't use Aspell anymore. The problem is indeed that Hunspell 
dictionaries are missing in the installer. This will be fixed in RC3.


Joost 





Re: spellchecker for lyx 2.0 rc2

2011-04-16 Thread Joost Verburg
"Julien Rioux"  wrote in message 
news:iod00u$hei$1...@dough.gmane.org...
You would need to make aspell visible to the configure script by putting 
the path to aspell.exe in your PATH environment variable or alternatively 
in the PATH in LyX preferences. Then reconfigure LyX, close and start LyX 
again. If it does not work after that then there is indeed a problem.


No, we don't use Aspell anymore. The problem is indeed that Hunspell 
dictionaries are missing in the installer. This will be fixed in RC3.


Joost 





Re: ANNOUNCE: Windows installer for RC1

2011-03-22 Thread Joost Verburg
Wolfgang Keller felip...@gmx.net wrote in message 
news:20110322160249.b3332054.felip...@gmx.net...

This doesn't work with SumatraPDF(portable). It simply won't open the
viewer window when I hit the view button.


The PDF code should be identical to 1.6.9. I'll have a look.

Joost 





Re: ANNOUNCE: Windows installer for RC1

2011-03-22 Thread Joost Verburg
Wolfgang Keller felip...@gmx.net wrote in message 
news:20110322160249.b3332054.felip...@gmx.net...

This doesn't work with SumatraPDF(portable). It simply won't open the
viewer window when I hit the view button.


The PDF code should be identical to 1.6.9. I'll have a look.

Joost 





Re: ANNOUNCE: Windows installer for RC1

2011-03-22 Thread Joost Verburg
"Wolfgang Keller"  wrote in message 
news:20110322160249.b3332054.felip...@gmx.net...

This doesn't work with SumatraPDF(portable). It simply won't open the
viewer window when I hit the "view" button.


The PDF code should be identical to 1.6.9. I'll have a look.

Joost 





Re: Is LyX 1.6.8 the last version for Windows 2000? (1.6.9 installs, wont run)

2011-03-21 Thread Joost Verburg
Vilis I. Lietuvietis vi...@neti.ee wrote in message 
news:oieglijhlndkddgmplfpiehncpaa.vi...@neti.ee...
I used LyX extensively on both my Windows 2000 and XP systems until a year 
ago.  I just returned to my LyX project after 12 months today, to discover 
that LyX 1.6.9 installed on Windows 2000 without incident, but when I 
tried to run it, I got an error message (forgot to write it down)


As noted on the download page, Windows XP is the minimum requirement.

Joost 





Re: Is LyX 1.6.8 the last version for Windows 2000? (1.6.9 installs, wont run)

2011-03-21 Thread Joost Verburg
Vilis I. Lietuvietis vi...@neti.ee wrote in message 
news:oieglijhlndkddgmplfpiehncpaa.vi...@neti.ee...
I used LyX extensively on both my Windows 2000 and XP systems until a year 
ago.  I just returned to my LyX project after 12 months today, to discover 
that LyX 1.6.9 installed on Windows 2000 without incident, but when I 
tried to run it, I got an error message (forgot to write it down)


As noted on the download page, Windows XP is the minimum requirement.

Joost 





Re: Is LyX 1.6.8 the last version for Windows 2000? (1.6.9 installs, wont run)

2011-03-21 Thread Joost Verburg
"Vilis I. Lietuvietis"  wrote in message 
news:oieglijhlndkddgmplfpiehncpaa.vi...@neti.ee...
I used LyX extensively on both my Windows 2000 and XP systems until a year 
ago.  I just returned to my LyX project after 12 months today, to discover 
that LyX 1.6.9 installed on Windows 2000 without incident, but when I 
tried to run it, I got an error message (forgot to write it down)


As noted on the download page, Windows XP is the minimum requirement.

Joost 





Re: Adobe Reader X and Lyx

2011-02-22 Thread Joost Verburg
Julio Rojas jcredbe...@gmail.com wrote in message news:AANLkTinJK1T- As 
Andres says here, after Adobe Reader X installation, a PDF

generated by Lyx is not direcly open (ARX opens, but Lyx document is
nowhere to be found). One has to export it into some folder and then
manually open it. I don't know what version of Lyx he has, but I have
this problem with 2.0 Beta 3 (my installation of Lyx 1.6.5 uses
SumatraPDF). Has anybody solved this problem? Should I report it as a
bug?


This bug is already solved in LyX 1.6.9. The fix will also be included in 
the 2.0 release.


Joost 





Re: Adobe Reader X and Lyx

2011-02-22 Thread Joost Verburg
Julio Rojas jcredbe...@gmail.com wrote in message news:AANLkTinJK1T- As 
Andres says here, after Adobe Reader X installation, a PDF

generated by Lyx is not direcly open (ARX opens, but Lyx document is
nowhere to be found). One has to export it into some folder and then
manually open it. I don't know what version of Lyx he has, but I have
this problem with 2.0 Beta 3 (my installation of Lyx 1.6.5 uses
SumatraPDF). Has anybody solved this problem? Should I report it as a
bug?


This bug is already solved in LyX 1.6.9. The fix will also be included in 
the 2.0 release.


Joost 





Re: Adobe Reader X and Lyx

2011-02-22 Thread Joost Verburg
"Julio Rojas"  wrote in message news:AANLkTinJK1T-> As 
Andres says here, after Adobe Reader X installation, a PDF

generated by Lyx is not direcly open (ARX opens, but Lyx document is
nowhere to be found). One has to export it into some folder and then
manually open it. I don't know what version of Lyx he has, but I have
this problem with 2.0 Beta 3 (my installation of Lyx 1.6.5 uses
SumatraPDF). Has anybody solved this problem? Should I report it as a
bug?


This bug is already solved in LyX 1.6.9. The fix will also be included in 
the 2.0 release.


Joost 





Re: Fwd: installing lyx on windows 7

2011-02-14 Thread Joost Verburg
On Sat, 12 Feb 2011 16:32:24 -0600, Saras Saraswathi wrote:
 I tried to install the lyx. I installed under windows 7 on two laptops.
 One works ( a borrowed laptop) . But it does not work on my own laptop. I
 used the same downloaded sw on both. As discussed on the webpage, looks like
 it cannot do the configuration on start up. With very much difficulty I got
 a screen print of the error ( tried it about a 100 times to be fast enough
 to capture the screen!).. I do  not see any ../resources directory in the
 place specified.

According to the screenshots, one of the installations (the one that works)
was installed using the standard installer and the other one was installed
using the alternative installer. Reinstalling using the standard installer
will probably solve your problem.

Joost



Re: Fwd: installing lyx on windows 7

2011-02-14 Thread Joost Verburg
On Sat, 12 Feb 2011 16:32:24 -0600, Saras Saraswathi wrote:
 I tried to install the lyx. I installed under windows 7 on two laptops.
 One works ( a borrowed laptop) . But it does not work on my own laptop. I
 used the same downloaded sw on both. As discussed on the webpage, looks like
 it cannot do the configuration on start up. With very much difficulty I got
 a screen print of the error ( tried it about a 100 times to be fast enough
 to capture the screen!).. I do  not see any ../resources directory in the
 place specified.

According to the screenshots, one of the installations (the one that works)
was installed using the standard installer and the other one was installed
using the alternative installer. Reinstalling using the standard installer
will probably solve your problem.

Joost



Re: Fwd: installing lyx on windows 7

2011-02-14 Thread Joost Verburg
On Sat, 12 Feb 2011 16:32:24 -0600, Saras Saraswathi wrote:
>>> I tried to install the lyx. I installed under windows 7 on two laptops.
>>> One works ( a borrowed laptop) . But it does not work on my own laptop. I
>>> used the same downloaded sw on both. As discussed on the webpage, looks like
>>> it cannot do the configuration on start up. With very much difficulty I got
>>> a screen print of the error ( tried it about a 100 times to be fast enough
>>> to capture the screen!).. I do  not see any ../resources directory in the
>>> place specified.

According to the screenshots, one of the installations (the one that works)
was installed using the standard installer and the other one was installed
using the alternative installer. Reinstalling using the standard installer
will probably solve your problem.

Joost



Re: MikTeX 2.9 w/ LyX 1.6.8

2010-12-19 Thread Joost Verburg

On 12/19/2010 5:41 PM, Ken wrote:

How can I force LyX to use the new 2.9 installation?


You can set the MiKTeX path in:
Tools  Preferences  Paths  PATH prefix

Re-running the installer will also allow you to change the MiKTeX location.

Joost



Re: MikTeX 2.9 w/ LyX 1.6.8

2010-12-19 Thread Joost Verburg

On 12/19/2010 5:41 PM, Ken wrote:

How can I force LyX to use the new 2.9 installation?


You can set the MiKTeX path in:
Tools  Preferences  Paths  PATH prefix

Re-running the installer will also allow you to change the MiKTeX location.

Joost



Re: MikTeX 2.9 w/ LyX 1.6.8

2010-12-19 Thread Joost Verburg

On 12/19/2010 5:41 PM, Ken wrote:

How can I force LyX to use the new 2.9 installation?


You can set the MiKTeX path in:
Tools > Preferences > Paths > PATH prefix

Re-running the installer will also allow you to change the MiKTeX location.

Joost



Re: AW: Acrobat X problem

2010-12-13 Thread Joost Verburg

On 12/12/2010 9:45 AM, Andreas Rieger wrote:

Thanks, using  C:\Progra~2\Adobe\Acroba~1.0\Acrobat\acrobat.exe in field viewer 
respectively Anzeigeprogramm worked.


Because of a bug in Adobe Reader X the LyX mechanism to reload PDF files 
in an open Adobe Reader window doesn't work. If you installed LyX using 
the alternative installer, the workaround is to set the viewer to auto 
instead of pdfview. The pdfview that is included in the standard 
installer of LyX 1.6.8 does this automatically if Adobe 10.0.0 is detected.
In both cases, you'll have to close Adobe before updating the PDF. 
Hopefully Adobe will fix this in the next release and the automatic 
reloading will work again.


Joost



Re: AW: Acrobat X problem

2010-12-13 Thread Joost Verburg

On 12/12/2010 9:45 AM, Andreas Rieger wrote:

Thanks, using  C:\Progra~2\Adobe\Acroba~1.0\Acrobat\acrobat.exe in field viewer 
respectively Anzeigeprogramm worked.


Because of a bug in Adobe Reader X the LyX mechanism to reload PDF files 
in an open Adobe Reader window doesn't work. If you installed LyX using 
the alternative installer, the workaround is to set the viewer to auto 
instead of pdfview. The pdfview that is included in the standard 
installer of LyX 1.6.8 does this automatically if Adobe 10.0.0 is detected.
In both cases, you'll have to close Adobe before updating the PDF. 
Hopefully Adobe will fix this in the next release and the automatic 
reloading will work again.


Joost



Re: AW: Acrobat X problem

2010-12-13 Thread Joost Verburg

On 12/12/2010 9:45 AM, Andreas Rieger wrote:

Thanks, using " C:\Progra~2\Adobe\Acroba~1.0\Acrobat\acrobat.exe" in field "viewer" 
respectively "Anzeigeprogramm" worked.


Because of a bug in Adobe Reader X the LyX mechanism to reload PDF files 
in an open Adobe Reader window doesn't work. If you installed LyX using 
the alternative installer, the workaround is to set the viewer to auto 
instead of pdfview. The pdfview that is included in the standard 
installer of LyX 1.6.8 does this automatically if Adobe 10.0.0 is detected.
In both cases, you'll have to close Adobe before updating the PDF. 
Hopefully Adobe will fix this in the next release and the automatic 
reloading will work again.


Joost



Re: LyX 1.6.8 / 2.0beta without admin rights

2010-12-12 Thread Joost Verburg

On 12/12/2010 5:24 PM, Pavel Sanda wrote:

someone == joost at lyx.org
(the only one who is mastering this installer).
you can try to contact him.


The 1.6.8 Windows release was delayed because of an external library 
which suddenly disappeared from SourceForge (project + git repository 
was completely deleted). It took a lot of time to rewrite most of the 
missing code. The installer has now been finished and will be available 
shortly.


Joost



Re: LyX 1.6.8 / 2.0beta without admin rights

2010-12-12 Thread Joost Verburg

On 12/12/2010 5:24 PM, Pavel Sanda wrote:

someone == joost at lyx.org
(the only one who is mastering this installer).
you can try to contact him.


The 1.6.8 Windows release was delayed because of an external library 
which suddenly disappeared from SourceForge (project + git repository 
was completely deleted). It took a lot of time to rewrite most of the 
missing code. The installer has now been finished and will be available 
shortly.


Joost



Re: LyX 1.6.8 / 2.0beta without admin rights

2010-12-12 Thread Joost Verburg

On 12/12/2010 5:24 PM, Pavel Sanda wrote:

someone == joost at lyx.org
(the only one who is mastering this installer).
you can try to contact him.


The 1.6.8 Windows release was delayed because of an external library 
which suddenly disappeared from SourceForge (project + git repository 
was completely deleted). It took a lot of time to rewrite most of the 
missing code. The installer has now been finished and will be available 
shortly.


Joost



Re: query

2010-09-20 Thread Joost Verburg

On 9/20/2010 4:00 AM, Kevin Brubeck Unhammer wrote:

I am not able to download any version of the lyx. please guide me to
download it. i have already opened the site www.lyx.org/download but
as soon as i click on the link it is not working.
please help me to download


Try an alternative download location such as:
ftp://ftp.lip6.fr/pub/lyx/bin/1.6.7/

Joost



Re: query

2010-09-20 Thread Joost Verburg

On 9/20/2010 4:00 AM, Kevin Brubeck Unhammer wrote:

I am not able to download any version of the lyx. please guide me to
download it. i have already opened the site www.lyx.org/download but
as soon as i click on the link it is not working.
please help me to download


Try an alternative download location such as:
ftp://ftp.lip6.fr/pub/lyx/bin/1.6.7/

Joost



Re: query

2010-09-20 Thread Joost Verburg

On 9/20/2010 4:00 AM, Kevin Brubeck Unhammer wrote:

I am not able to download any version of the lyx. please guide me to
download it. i have already opened the site www.lyx.org/download but
as soon as i click on the link it is not working.
please help me to download


Try an alternative download location such as:
ftp://ftp.lip6.fr/pub/lyx/bin/1.6.7/

Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/4/2010 1:43 PM, Jose Augusto wrote:

This is an update and answer to myself :-) : I was able to install  and RUN on
Win 2K  the last version of the Lyx alt-installer which can be retrieved at
the link:
http://prdownload.berlios.de/lyxwininstall/LyX-167-4-25-AltInstaller-Complete.exe


The standard installer includes more recent version of external 
libraries, which have been compiled with Visual C++ 2010 and therefore 
don't run on Windows 2000. The alternative installer still uses the 
older ones.


Microsoft already stopped Windows 2000 support so there will be no more 
security updates. Therefore I don't think it makes sense to keep 
supporting it.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 2:17 PM, Jean-Marc Lasgouttes wrote:

Do we gain something by compiling with the latest toolchain? Aren't we
shuttig down windows 2000 arbitrarily?


Not arbitrarily. Windows 2000 support has already been discontinued by 
Microsoft so it's highly unsafe to use. Security issues are not being 
fixed. Most recent software doesn't support Windows 2000.


The main reason I used MSVC 2010 when porting all the new dependencies 
to Windows is because it would take a lot of time to upgrade everything 
to 2010 later. This would have been necessary soon when 2008 is no 
longer available.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:34 PM, Jean-Marc Lasgouttes wrote:

It is not our responsibility to tell people what OS to use...


Sure. I'm just saying that at some point it doesn't make sense to 
support an OS anymore. Windows 2000 is more than 10 years old and no 
longer supported by Microsoft. It's market share is close to 0%.


I understand that it's nice to support as many versions as possible, but 
I simply don't have the time to maintain all the dependencies ( 10 MSVC 
projects) for different compiler versions. I had to pick a version for 
the recent updates and considered MSVC 2010 to be the best future-proof 
option.


Joost



Re: Converted EPS figures from MS Visio are not exactly the same

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:47 PM, Özgün Yılmaz wrote:

Is this because of MS Word doesn’t show EPS files correctly or Is there
another reason for this?


Indeed. Word doesn't render EPS correctly.


Then I inserted eps files to a Lyx file and viewed them in a PDF file.
The text labels were fine. Straight vertical and horizontal lines were
fine. But the straight lines which are sloped (not horizontal or
vertical) somewhat looks thinner than horizontal or vertical lines
according to me when viewed in 100% zoom from Adobe Reader. But in 150%
zoom all lines likely have the same thickness.

Why is it so? Because of the converter? Is there a way to solve this?

And in DVI view I think every thing is alright.


I think it's just the way your PDF viewer renders the diagonal lines. 
When printing or zooming in there shouldn't be a difference.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/4/2010 1:43 PM, Jose Augusto wrote:

This is an update and answer to myself :-) : I was able to install  and RUN on
Win 2K  the last version of the Lyx alt-installer which can be retrieved at
the link:
http://prdownload.berlios.de/lyxwininstall/LyX-167-4-25-AltInstaller-Complete.exe


The standard installer includes more recent version of external 
libraries, which have been compiled with Visual C++ 2010 and therefore 
don't run on Windows 2000. The alternative installer still uses the 
older ones.


Microsoft already stopped Windows 2000 support so there will be no more 
security updates. Therefore I don't think it makes sense to keep 
supporting it.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 2:17 PM, Jean-Marc Lasgouttes wrote:

Do we gain something by compiling with the latest toolchain? Aren't we
shuttig down windows 2000 arbitrarily?


Not arbitrarily. Windows 2000 support has already been discontinued by 
Microsoft so it's highly unsafe to use. Security issues are not being 
fixed. Most recent software doesn't support Windows 2000.


The main reason I used MSVC 2010 when porting all the new dependencies 
to Windows is because it would take a lot of time to upgrade everything 
to 2010 later. This would have been necessary soon when 2008 is no 
longer available.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:34 PM, Jean-Marc Lasgouttes wrote:

It is not our responsibility to tell people what OS to use...


Sure. I'm just saying that at some point it doesn't make sense to 
support an OS anymore. Windows 2000 is more than 10 years old and no 
longer supported by Microsoft. It's market share is close to 0%.


I understand that it's nice to support as many versions as possible, but 
I simply don't have the time to maintain all the dependencies ( 10 MSVC 
projects) for different compiler versions. I had to pick a version for 
the recent updates and considered MSVC 2010 to be the best future-proof 
option.


Joost



Re: Converted EPS figures from MS Visio are not exactly the same

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:47 PM, Özgün Yılmaz wrote:

Is this because of MS Word doesn’t show EPS files correctly or Is there
another reason for this?


Indeed. Word doesn't render EPS correctly.


Then I inserted eps files to a Lyx file and viewed them in a PDF file.
The text labels were fine. Straight vertical and horizontal lines were
fine. But the straight lines which are sloped (not horizontal or
vertical) somewhat looks thinner than horizontal or vertical lines
according to me when viewed in 100% zoom from Adobe Reader. But in 150%
zoom all lines likely have the same thickness.

Why is it so? Because of the converter? Is there a way to solve this?

And in DVI view I think every thing is alright.


I think it's just the way your PDF viewer renders the diagonal lines. 
When printing or zooming in there shouldn't be a difference.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/4/2010 1:43 PM, Jose Augusto wrote:

This is an update and answer to myself :-) : I was able to install>>  and RUN on
Win 2K<<  the last version of the Lyx alt-installer which can be retrieved at
the link:
http://prdownload.berlios.de/lyxwininstall/LyX-167-4-25-AltInstaller-Complete.exe


The standard installer includes more recent version of external 
libraries, which have been compiled with Visual C++ 2010 and therefore 
don't run on Windows 2000. The alternative installer still uses the 
older ones.


Microsoft already stopped Windows 2000 support so there will be no more 
security updates. Therefore I don't think it makes sense to keep 
supporting it.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 2:17 PM, Jean-Marc Lasgouttes wrote:

Do we gain something by compiling with the latest toolchain? Aren't we
shuttig down windows 2000 arbitrarily?


Not arbitrarily. Windows 2000 support has already been discontinued by 
Microsoft so it's highly unsafe to use. Security issues are not being 
fixed. Most recent software doesn't support Windows 2000.


The main reason I used MSVC 2010 when porting all the new dependencies 
to Windows is because it would take a lot of time to upgrade everything 
to 2010 later. This would have been necessary soon when 2008 is no 
longer available.


Joost



Re: Lyx 1.6.7-3 and 1.6.7-4 don't run in Windows 2000 (aka win 2K)

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:34 PM, Jean-Marc Lasgouttes wrote:

It is not our responsibility to tell people what OS to use...


Sure. I'm just saying that at some point it doesn't make sense to 
support an OS anymore. Windows 2000 is more than 10 years old and no 
longer supported by Microsoft. It's market share is close to 0%.


I understand that it's nice to support as many versions as possible, but 
I simply don't have the time to maintain all the dependencies (> 10 MSVC 
projects) for different compiler versions. I had to pick a version for 
the recent updates and considered MSVC 2010 to be the best future-proof 
option.


Joost



Re: Converted EPS figures from MS Visio are not exactly the same

2010-08-05 Thread Joost Verburg

On 8/5/2010 3:47 PM, Özgün Yılmaz wrote:

Is this because of MS Word doesn’t show EPS files correctly or Is there
another reason for this?


Indeed. Word doesn't render EPS correctly.


Then I inserted eps files to a Lyx file and viewed them in a PDF file.
The text labels were fine. Straight vertical and horizontal lines were
fine. But the straight lines which are sloped (not horizontal or
vertical) somewhat looks thinner than horizontal or vertical lines
according to me when viewed in 100% zoom from Adobe Reader. But in 150%
zoom all lines likely have the same thickness.

Why is it so? Because of the converter? Is there a way to solve this?

And in DVI view I think every thing is alright.


I think it's just the way your PDF viewer renders the diagonal lines. 
When printing or zooming in there shouldn't be a difference.


Joost



Re: Using hunspell under Windows 7 with LyX 1.6

2010-07-06 Thread Joost Verburg

On 7/6/2010 8:56 AM, Falk Sticken wrote:

I would like to use hunspell as a spellchecker with LyX 1.6 under
Windows 7. I know it is supported by LyX 1.7, but this release is still
in alpha status. I have hunspell installed as part of MikTex 2.8.


You'll have to wait for LyX 2.0.

Joost



Re: Using hunspell under Windows 7 with LyX 1.6

2010-07-06 Thread Joost Verburg

On 7/6/2010 8:56 AM, Falk Sticken wrote:

I would like to use hunspell as a spellchecker with LyX 1.6 under
Windows 7. I know it is supported by LyX 1.7, but this release is still
in alpha status. I have hunspell installed as part of MikTex 2.8.


You'll have to wait for LyX 2.0.

Joost



Re: Using hunspell under Windows 7 with LyX 1.6

2010-07-06 Thread Joost Verburg

On 7/6/2010 8:56 AM, Falk Sticken wrote:

I would like to use hunspell as a spellchecker with LyX 1.6 under
Windows 7. I know it is supported by LyX 1.7, but this release is still
in alpha status. I have hunspell installed as part of MikTex 2.8.


You'll have to wait for LyX 2.0.

Joost



Re: Windows 7 compatibility

2010-06-10 Thread Joost Verburg

On 6/10/2010 9:13 AM, George Christodoulatos wrote:

Can anyone tell me if the 1.6.6.1 works ok with
64-bit Windows 7?


Yes, Windows 7 is fully supported.

Joost



Re: Windows 7 compatibility

2010-06-10 Thread Joost Verburg

On 6/10/2010 9:13 AM, George Christodoulatos wrote:

Can anyone tell me if the 1.6.6.1 works ok with
64-bit Windows 7?


Yes, Windows 7 is fully supported.

Joost



Re: Windows 7 compatibility

2010-06-10 Thread Joost Verburg

On 6/10/2010 9:13 AM, George Christodoulatos wrote:

Can anyone tell me if the 1.6.6.1 works ok with
64-bit Windows 7?


Yes, Windows 7 is fully supported.

Joost



Re: using of aspell libraries on windows

2009-11-04 Thread Joost Verburg

Sergey wrote:

(ftp://ftp.lyx.org/pub/lyx/contrib/lyx-windows-deps-mingw.zip), compiled Psi


This is an old file which is no longer maintained, we currently use the 
msvc version.


Joost



Re: using of aspell libraries on windows

2009-11-04 Thread Joost Verburg

Sergey wrote:

(ftp://ftp.lyx.org/pub/lyx/contrib/lyx-windows-deps-mingw.zip), compiled Psi


This is an old file which is no longer maintained, we currently use the 
msvc version.


Joost



Re: using of aspell libraries on windows

2009-11-04 Thread Joost Verburg

Sergey wrote:

(ftp://ftp.lyx.org/pub/lyx/contrib/lyx-windows-deps-mingw.zip), compiled Psi


This is an old file which is no longer maintained, we currently use the 
msvc version.


Joost



Re: Lyx 1.6.4 Spellchecker on Windows XP

2009-08-27 Thread Joost Verburg

Uwe Stöhr wrote:
The problem might be that there is only an Aspell dictionary available 
for en_US and not for en_GB. But the spellchecker should nevertheless 
start at least.


The English Aspell dictionary includes both an American and British version.

Joost



Re: Lyx 1.6.4 Spellchecker on Windows XP

2009-08-27 Thread Joost Verburg

Uwe Stöhr wrote:
The problem might be that there is only an Aspell dictionary available 
for en_US and not for en_GB. But the spellchecker should nevertheless 
start at least.


The English Aspell dictionary includes both an American and British version.

Joost



Re: Lyx 1.6.4 Spellchecker on Windows XP

2009-08-27 Thread Joost Verburg

Uwe Stöhr wrote:
The problem might be that there is only an Aspell dictionary available 
for en_US and not for en_GB. But the spellchecker should nevertheless 
start at least.


The English Aspell dictionary includes both an American and British version.

Joost



Re: Windows: Graphics preview doesn't work using Lyxlauncher.exe

2009-07-21 Thread Joost Verburg

Nick Bell wrote:
Apologies if this has been said before, but I have only ever been able 
to get graphics preview to work if I start LyX by running lyx.exe. If I 
use the default LyXlauncher.exe, I can't preview .eps, .pdf (although 
.png works).


For the new 1.6.3-2 installers I've updated the graphics conversion to
be more reliable and also faster. This issue should also be fixed.

Joost



Re: Screen font display issue (cleartype?)

2009-07-21 Thread Joost Verburg

James Oldfield wrote:

Both my home and college computers are running LyX 1.6.3 (3 June 2009)
on Windows XP, installed with the default installer. I see the following
problem only on my college computer [but I have mentioned my home PC in
a couple of places for comparison, you can ignore if you like]. This is
about fonts as they appear in the LyX edit window, *NOT* in the PDF
output (or instant preview).


Could you try to install 1.6.3-2? This updated installer includes Qt 
4.5.2 (a new version of the library that LyX uses for its interface) and 
it looks like they fixed such a font issue.


Joost



Re: Windows: Graphics preview doesn't work using Lyxlauncher.exe

2009-07-21 Thread Joost Verburg

Nick Bell wrote:
Apologies if this has been said before, but I have only ever been able 
to get graphics preview to work if I start LyX by running lyx.exe. If I 
use the default LyXlauncher.exe, I can't preview .eps, .pdf (although 
.png works).


For the new 1.6.3-2 installers I've updated the graphics conversion to
be more reliable and also faster. This issue should also be fixed.

Joost



Re: Screen font display issue (cleartype?)

2009-07-21 Thread Joost Verburg

James Oldfield wrote:

Both my home and college computers are running LyX 1.6.3 (3 June 2009)
on Windows XP, installed with the default installer. I see the following
problem only on my college computer [but I have mentioned my home PC in
a couple of places for comparison, you can ignore if you like]. This is
about fonts as they appear in the LyX edit window, *NOT* in the PDF
output (or instant preview).


Could you try to install 1.6.3-2? This updated installer includes Qt 
4.5.2 (a new version of the library that LyX uses for its interface) and 
it looks like they fixed such a font issue.


Joost



Re: Windows: Graphics preview doesn't work using Lyxlauncher.exe

2009-07-21 Thread Joost Verburg

Nick Bell wrote:
Apologies if this has been said before, but I have only ever been able 
to get graphics preview to work if I start LyX by running lyx.exe. If I 
use the default LyXlauncher.exe, I can't preview .eps, .pdf (although 
.png works).


For the new 1.6.3-2 installers I've updated the graphics conversion to
be more reliable and also faster. This issue should also be fixed.

Joost



Re: Screen font display issue (cleartype?)

2009-07-21 Thread Joost Verburg

James Oldfield wrote:

Both my home and college computers are running LyX 1.6.3 (3 June 2009)
on Windows XP, installed with the default installer. I see the following
problem only on my college computer [but I have mentioned my home PC in
a couple of places for comparison, you can ignore if you like]. This is
about fonts as they appear in the LyX edit window, *NOT* in the PDF
output (or instant preview).


Could you try to install 1.6.3-2? This updated installer includes Qt 
4.5.2 (a new version of the library that LyX uses for its interface) and 
it looks like they fixed such a font issue.


Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Robert Betz wrote:

However, I seem to have one problem. If I open my files using the standard 
double click technique the figures will not open. I get the error:
 
Error converting to loadable format.


I can't reproduce it. Did you change any path preferences? Could you 
post the contents of the PATH prefix box in Preferences  Paths?


Regards Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Vincent van Ravesteijn wrote:
When starting with LyXLauncher -dbg files, I get the attached log. And 
the images are not shown. When running lyx.exe from the command prompt, 
the output is the same up to /command and silent afterwards. Then the 
images are correctly shown on screen.


Thanks. It looks like there's a bug in the Windows installers of 
Ghostscript 8.63/8.64. I copied the new files for the installer from the 
Ghostcript directory, but apparently some of them are missing there.


I'll get the files from the Ghostscript source code instead and will 
update the installers.


Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Robert Betz wrote:

However, I seem to have one problem. If I open my files using the standard 
double click technique the figures will not open. I get the error:
 
Error converting to loadable format.


I can't reproduce it. Did you change any path preferences? Could you 
post the contents of the PATH prefix box in Preferences  Paths?


Regards Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Vincent van Ravesteijn wrote:
When starting with LyXLauncher -dbg files, I get the attached log. And 
the images are not shown. When running lyx.exe from the command prompt, 
the output is the same up to /command and silent afterwards. Then the 
images are correctly shown on screen.


Thanks. It looks like there's a bug in the Windows installers of 
Ghostscript 8.63/8.64. I copied the new files for the installer from the 
Ghostcript directory, but apparently some of them are missing there.


I'll get the files from the Ghostscript source code instead and will 
update the installers.


Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Robert Betz wrote:

However, I seem to have one problem. If I open my files using the standard 
double click technique the figures will not open. I get the error:
 
Error converting to loadable format.


I can't reproduce it. Did you change any path preferences? Could you 
post the contents of the "PATH prefix" box in Preferences > Paths?


Regards Joost



Re: Problem with LyxLauncher

2009-06-10 Thread Joost Verburg

Vincent van Ravesteijn wrote:
When starting with "LyXLauncher -dbg files", I get the attached log. And 
the images are not shown. When running lyx.exe from the command prompt, 
the output is the same up to  and silent afterwards. Then the 
images are correctly shown on screen.


Thanks. It looks like there's a bug in the Windows installers of 
Ghostscript 8.63/8.64. I copied the new files for the installer from the 
Ghostcript directory, but apparently some of them are missing there.


I'll get the files from the Ghostscript source code instead and will 
update the installers.


Joost



Re: Where is the standard installerfür Lyx 1.6.2-1?

2009-03-30 Thread Joost Verburg

Christian Ridderström wrote:
 I changed the download section of www.lyx.org so that we now only 
refer to
 the ftp site and not to special filenames. This prevents further 
problems
 when an installer is not available or a bug was fixed in the 
installer so

 that there is a new filename for it. OK with you Jürgen?

I wouldn't do that.. some people might be scared off by presenting a 
list of files with rather cryptic names and not knowing which one to 
choose.


They must just have a button or link saying: Lyx for windows.


Could we use some clever way to automatically let the web/wiki figure 
out which package is the latest?


We never had this problem before, because the page is updated after the 
files are uploaded to the FTP. But somehow the file did not appear on 
the FTP server for anonymous users and Jürgen probably didn't realize 
that when he updated the page.


I don't think the change is a good idea. We agreed before that there 
should be a link to the standard installer for users who don't know 
about the differences between the installers. Experienced LyX users can 
click the FTP link and choose which package they prefer.


Joost



Re: Where is the standard installerfür Lyx 1.6.2-1?

2009-03-30 Thread Joost Verburg

Christian Ridderström wrote:
 I changed the download section of www.lyx.org so that we now only 
refer to
 the ftp site and not to special filenames. This prevents further 
problems
 when an installer is not available or a bug was fixed in the 
installer so

 that there is a new filename for it. OK with you Jürgen?

I wouldn't do that.. some people might be scared off by presenting a 
list of files with rather cryptic names and not knowing which one to 
choose.


They must just have a button or link saying: Lyx for windows.


Could we use some clever way to automatically let the web/wiki figure 
out which package is the latest?


We never had this problem before, because the page is updated after the 
files are uploaded to the FTP. But somehow the file did not appear on 
the FTP server for anonymous users and Jürgen probably didn't realize 
that when he updated the page.


I don't think the change is a good idea. We agreed before that there 
should be a link to the standard installer for users who don't know 
about the differences between the installers. Experienced LyX users can 
click the FTP link and choose which package they prefer.


Joost



Re: Where is the standard installerfür Lyx 1.6.2-1?

2009-03-30 Thread Joost Verburg

Christian Ridderström wrote:
 I changed the download section of www.lyx.org so that we now only 
refer to
 the ftp site and not to special filenames. This prevents further 
problems
 when an installer is not available or a bug was fixed in the 
installer so

 that there is a new filename for it. OK with you Jürgen?

I wouldn't do that.. some people might be scared off by presenting a 
list of files with rather cryptic names and not knowing which one to 
choose.


They must just have a button or link saying: Lyx for windows.


Could we use some clever way to automatically let the web/wiki figure 
out which package is the latest?


We never had this problem before, because the page is updated after the 
files are uploaded to the FTP. But somehow the file did not appear on 
the FTP server for anonymous users and Jürgen probably didn't realize 
that when he updated the page.


I don't think the change is a good idea. We agreed before that there 
should be a link to the standard installer for users who don't know 
about the differences between the installers. Experienced LyX users can 
click the FTP link and choose which package they prefer.


Joost



Re: [correction] LyXWinInstaller for LyX 1.6.0

2008-12-01 Thread Joost Verburg

Abdelrazak Younes wrote:
But when I install the Lyx (both the standard version or the 
alternative installer), the installer will *automatically* change 
this option to Yes. (it seems very strange)


I hope that the installer informs you before doing this change and that 
the old config is restored back.


The standard installer doesn't change this setting. MiKTeX's default is 
Ask me first and it provides an option to change this on the window 
that is displayed when the first package is installed.


Joost



Re: [correction] LyXWinInstaller for LyX 1.6.0

2008-12-01 Thread Joost Verburg

Abdelrazak Younes wrote:
But when I install the Lyx (both the standard version or the 
alternative installer), the installer will *automatically* change 
this option to Yes. (it seems very strange)


I hope that the installer informs you before doing this change and that 
the old config is restored back.


The standard installer doesn't change this setting. MiKTeX's default is 
Ask me first and it provides an option to change this on the window 
that is displayed when the first package is installed.


Joost



Re: [correction] LyXWinInstaller for LyX 1.6.0

2008-12-01 Thread Joost Verburg

Abdelrazak Younes wrote:
But when I install the Lyx (both the standard version or the 
alternative installer), the installer will *automatically* change 
this option to "Yes". (it seems very strange)


I hope that the installer informs you before doing this change and that 
the old config is restored back.


The standard installer doesn't change this setting. MiKTeX's default is 
"Ask me first" and it provides an option to change this on the window 
that is displayed when the first package is installed.


Joost



Re: PDF Update fails, LyX 1.5.7 (WinXP)

2008-11-25 Thread Joost Verburg

David Hewitt wrote:

(2) I have always used Adobe Reader in many past versions and never
had this issue. AND, even with the format viewer changed to 'pdfview',
Adobe Reader is the viewer that is started, but DOES allow me to
update. Huh?? Basically everything just operates the way it used to,
so I presume that with the upgrade something changed the viewer from
'pdfview' to 'auto' for me, which then broke my ability to update the
PDF displayed in Adobe Reader. Overall, I am confused as to what
'pdfview' does, particularly because when I double-click the
pdfview.exe file from explorer I get an error that no PDF viewer is
installed, with a subsequent abort.


pdfview allows you to use Adobe Reader without the file locking issue. 
The error is normal because pdfview requires a valid PDF file as parameter.


Joost



Re: PDF Update fails, LyX 1.5.7 (WinXP)

2008-11-25 Thread Joost Verburg

David Hewitt wrote:

(2) I have always used Adobe Reader in many past versions and never
had this issue. AND, even with the format viewer changed to 'pdfview',
Adobe Reader is the viewer that is started, but DOES allow me to
update. Huh?? Basically everything just operates the way it used to,
so I presume that with the upgrade something changed the viewer from
'pdfview' to 'auto' for me, which then broke my ability to update the
PDF displayed in Adobe Reader. Overall, I am confused as to what
'pdfview' does, particularly because when I double-click the
pdfview.exe file from explorer I get an error that no PDF viewer is
installed, with a subsequent abort.


pdfview allows you to use Adobe Reader without the file locking issue. 
The error is normal because pdfview requires a valid PDF file as parameter.


Joost



Re: PDF Update fails, LyX 1.5.7 (WinXP)

2008-11-25 Thread Joost Verburg

David Hewitt wrote:

(2) I have always used Adobe Reader in many past versions and never
had this issue. AND, even with the format viewer changed to 'pdfview',
Adobe Reader is the viewer that is started, but DOES allow me to
update. Huh?? Basically everything just operates the way it used to,
so I presume that with the upgrade something changed the viewer from
'pdfview' to 'auto' for me, which then broke my ability to update the
PDF displayed in Adobe Reader. Overall, I am confused as to what
'pdfview' does, particularly because when I double-click the
pdfview.exe file from explorer I get an error that no PDF viewer is
installed, with a subsequent abort.


pdfview allows you to use Adobe Reader without the file locking issue. 
The error is normal because pdfview requires a valid PDF file as parameter.


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-18 Thread Joost Verburg

Thomas Steffen wrote:

1. configure fails because it cannot find python
2. LyX fails to convert an EPS to a bitmap, so there is no preview


This is because the directories in Resources\lyxrc.dist are wrong.

Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-18 Thread Joost Verburg

Thomas Steffen wrote:

1. configure fails because it cannot find python
2. LyX fails to convert an EPS to a bitmap, so there is no preview


This is because the directories in Resources\lyxrc.dist are wrong.

Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-18 Thread Joost Verburg

Thomas Steffen wrote:

1. configure fails because it cannot find python
2. LyX fails to convert an EPS to a bitmap, so there is no preview


This is because the directories in Resources\lyxrc.dist are wrong.

Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

I used texlive 2008 as my tex installation, which already provides
some portability. I follow the same basic approach as tl-portable.bat,
but add the necessary environment variables for LyX, convert and
ghostscript. Apart from one problem between the bundled convert and
the bundled ghoscript, this works really well.


The standard installer already bundles Ghostscript and ImageMagick in a 
portable way (no registry keys need to be modified).


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

The other issue was that convert would not recognise ghostscript. I
read that @PSdelegate@ in delegates.xml relies on registry keys, and
indeed replacing it with gswin32c.exe solved the issue. This was
necessary to get previews working for eps files.


The build-in ImageMagick does not rely on registry keys but uses the 
environment variables set by LyXLauncher (see the source for details) to 
get the location of the Ghostscript directories. Note that not only 
@PSdelegate@ is relevant but also the font directory etc.


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

I used texlive 2008 as my tex installation, which already provides
some portability. I follow the same basic approach as tl-portable.bat,
but add the necessary environment variables for LyX, convert and
ghostscript. Apart from one problem between the bundled convert and
the bundled ghoscript, this works really well.


The standard installer already bundles Ghostscript and ImageMagick in a 
portable way (no registry keys need to be modified).


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

The other issue was that convert would not recognise ghostscript. I
read that @PSdelegate@ in delegates.xml relies on registry keys, and
indeed replacing it with gswin32c.exe solved the issue. This was
necessary to get previews working for eps files.


The build-in ImageMagick does not rely on registry keys but uses the 
environment variables set by LyXLauncher (see the source for details) to 
get the location of the Ghostscript directories. Note that not only 
@PSdelegate@ is relevant but also the font directory etc.


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

I used texlive 2008 as my tex installation, which already provides
some portability. I follow the same basic approach as tl-portable.bat,
but add the necessary environment variables for LyX, convert and
ghostscript. Apart from one problem between the bundled convert and
the bundled ghoscript, this works really well.


The standard installer already bundles Ghostscript and ImageMagick in a 
portable way (no registry keys need to be modified).


Joost



Re: Steps towards a portable LyX installation on Windows

2008-11-17 Thread Joost Verburg

Thomas Steffen wrote:

The other issue was that convert would not recognise ghostscript. I
read that @PSdelegate@ in delegates.xml relies on registry keys, and
indeed replacing it with gswin32c.exe solved the issue. This was
necessary to get previews working for eps files.


The build-in ImageMagick does not rely on registry keys but uses the 
environment variables set by LyXLauncher (see the source for details) to 
get the location of the Ghostscript directories. Note that not only 
@PSdelegate@ is relevant but also the font directory etc.


Joost



Re: ChkTex in Windows

2008-10-30 Thread Joost Verburg

Uwe Stöhr wrote:

I think you should bundle it in he installer.


This should be delivered by the LaTeX distribution. It turned out that 
ChkTeX is available in TeXLive but not MiKTeX. The MiKTeX maintainer 
reported me once that he had problems to compile it on Windows, but this 
was long ago. I would like when you contact the MiKTeX maintainer 
(Christian Schenk cs/at\miktex*org) and ask what he needs to be able to 
compile it. I'm sure he will add ChkTeX then to MiKTeX.


Why not bundle it in the installer if MiKTeX doesn't distribute it? I 
just managed to get it to work on Windows with MSVC 2008. There is 
already MS-DOS code included which can easily be upgraded to Windows. 
Maybe we can put Windows support in the official source?


Joost



Re: Problem with spellcheck

2008-10-30 Thread Joost Verburg

Enrique Saint Pierre wrote:
I moved all files in C:\Aspell to C:\Documents and Settings\All 
Users\Datos de programa\Aspell and now it works!


Good. But your dictionary from the Aspell Windows site is probably 
outdated. I'd recommend you to download the latest one from 
http://wiki.lyx.org/Windows/Aspell6 .


Regards, Joost



Re: ChkTex in Windows

2008-10-30 Thread Joost Verburg

Uwe Stöhr wrote:

I think you should bundle it in he installer.


This should be delivered by the LaTeX distribution. It turned out that 
ChkTeX is available in TeXLive but not MiKTeX. The MiKTeX maintainer 
reported me once that he had problems to compile it on Windows, but this 
was long ago. I would like when you contact the MiKTeX maintainer 
(Christian Schenk cs/at\miktex*org) and ask what he needs to be able to 
compile it. I'm sure he will add ChkTeX then to MiKTeX.


Why not bundle it in the installer if MiKTeX doesn't distribute it? I 
just managed to get it to work on Windows with MSVC 2008. There is 
already MS-DOS code included which can easily be upgraded to Windows. 
Maybe we can put Windows support in the official source?


Joost



Re: Problem with spellcheck

2008-10-30 Thread Joost Verburg

Enrique Saint Pierre wrote:
I moved all files in C:\Aspell to C:\Documents and Settings\All 
Users\Datos de programa\Aspell and now it works!


Good. But your dictionary from the Aspell Windows site is probably 
outdated. I'd recommend you to download the latest one from 
http://wiki.lyx.org/Windows/Aspell6 .


Regards, Joost



Re: ChkTex in Windows

2008-10-30 Thread Joost Verburg

Uwe Stöhr wrote:

I think you should bundle it in he installer.


This should be delivered by the LaTeX distribution. It turned out that 
ChkTeX is available in TeXLive but not MiKTeX. The MiKTeX maintainer 
reported me once that he had problems to compile it on Windows, but this 
was long ago. I would like when you contact the MiKTeX maintainer 
(Christian Schenk cs/at\miktex*org) and ask what he needs to be able to 
compile it. I'm sure he will add ChkTeX then to MiKTeX.


Why not bundle it in the installer if MiKTeX doesn't distribute it? I 
just managed to get it to work on Windows with MSVC 2008. There is 
already MS-DOS code included which can easily be upgraded to Windows. 
Maybe we can put Windows support in the official source?


Joost



Re: Problem with spellcheck

2008-10-30 Thread Joost Verburg

Enrique Saint Pierre wrote:
I moved all files in "C:\Aspell" to "C:\Documents and Settings\All 
Users\Datos de programa\Aspell" and now it works!


Good. But your dictionary from the Aspell Windows site is probably 
outdated. I'd recommend you to download the latest one from 
http://wiki.lyx.org/Windows/Aspell6 .


Regards, Joost



Re: Problem with spellcheck

2008-10-27 Thread Joost Verburg

Enrique Saint-Pierre wrote:
Hi: I have LyX 1.5.5 running in Windows XP, but the spellchecker doesn't work. I get the message The spellchecker could not be started. no word list can be found for the Language es_ES I reinstalled Aspell-0.50.3 and aspell-es-0.50-2-3. Now it is under C:\Aspell, but this not solve the problem. Thanks in advance for any help, Enrique S.   


This is an old Aspell dictionary that won't work. You can download 
dictionaries at http://wiki.lyx.org/Windows/Aspell6


Joost



Re: Problem with spellcheck

2008-10-27 Thread Joost Verburg

Enrique Saint Pierre wrote:
In fact, in C:\Documents and Settings\All Users\Datos de 
programa\Aspell there is not a Data directory nor a *.kbd file.


This means that Aspell is not properly installed. Can you try to 
download LyX 1.5.6 and reinstall?


Joost



Re: Problem with spellcheck

2008-10-27 Thread Joost Verburg

Enrique Saint-Pierre wrote:
Hi: I have LyX 1.5.5 running in Windows XP, but the spellchecker doesn't work. I get the message The spellchecker could not be started. no word list can be found for the Language es_ES I reinstalled Aspell-0.50.3 and aspell-es-0.50-2-3. Now it is under C:\Aspell, but this not solve the problem. Thanks in advance for any help, Enrique S.   


This is an old Aspell dictionary that won't work. You can download 
dictionaries at http://wiki.lyx.org/Windows/Aspell6


Joost



Re: Problem with spellcheck

2008-10-27 Thread Joost Verburg

Enrique Saint Pierre wrote:
In fact, in C:\Documents and Settings\All Users\Datos de 
programa\Aspell there is not a Data directory nor a *.kbd file.


This means that Aspell is not properly installed. Can you try to 
download LyX 1.5.6 and reinstall?


Joost



  1   2   3   4   >