RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
Hello to all,

5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base
is known'. Sometimes, it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Can you send us your file, then we can have a look at what is wrong ?

Vincent
 



RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
 
Hello to all,

5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base is known'. 
Sometimes, it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Can you send us your file, then we can have a look at what is wrong ?


I enclosed the lyx file.
The code I used can be found on the link I sent in the first email


If you paste the code into LyX, you should use Edit-Paste
Special-Plain Text. If you do that, the newlines are preserved. In the
document you have now, there are some % characters disabling code.

See the attached.

Robert
 

Vincent



tikz.lyx
Description: tikz.lyx


Re: TikZ in LyX

2010-01-13 Thread curtis osterhoudt
I've just tried a few TikZ scripts in the 2.0.0 svn version of LyX. 

   The more complicated ones tend to fail for me (I'm not sure why; I don't 
have time to track down what is going wrong at the moment). However, the one 
here: http://www.texample.net/tikz/examples/nav1d/ works, possibly because it's 
so simple. 

  Does it work for you?

 /
Down with categorical imperative!
flutz...@yahoo.com
/





From: Robert_Schiemann robert_schiem...@freenet.de
To: lyx-users@lists.lyx.org
Sent: Wed, January 13, 2010 11:07:05 AM
Subject: TikZ in LyX

Hello to all,

I am quite new to using LaTeX and even newer to using it with LyX. However,
I tried to use the
http://www.texample.net/tikz/examples/free-body-diagrams/ TikZ package
from LyX. 

I did it the following way:
1. download the package and extract the file content to Program
Files\MikTeX\
2. Insert one of the example codes (see link above) in TeXnic Center -
works.
3. Insert the same example code as a new TeX code block ('Insert TeX code')
into LyX. When Compiling, i get a few errors, mainly 'Can be used only in
preamble' and 'Environment tikzpicture undefined', and a few others. 
4. I fixed these errors by deleting the \documentclass and \enddocument
commands. In addition, I inserted the \usepackage and the \usetikzlibrary
commands in the document settings (Document - Settings - Latex preamble).
Of course, i deleted these lines from the code.
5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base is known'. Sometimes,
it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Thank you a lot in advance for your help!


  

RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
Hello to all,

5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base
is known'. Sometimes, it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Can you send us your file, then we can have a look at what is wrong ?

Vincent
 



RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
 
Hello to all,

5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base is known'. 
Sometimes, it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Can you send us your file, then we can have a look at what is wrong ?


I enclosed the lyx file.
The code I used can be found on the link I sent in the first email


If you paste the code into LyX, you should use Edit-Paste
Special-Plain Text. If you do that, the newlines are preserved. In the
document you have now, there are some % characters disabling code.

See the attached.

Robert
 

Vincent



tikz.lyx
Description: tikz.lyx


Re: TikZ in LyX

2010-01-13 Thread curtis osterhoudt
I've just tried a few TikZ scripts in the 2.0.0 svn version of LyX. 

   The more complicated ones tend to fail for me (I'm not sure why; I don't 
have time to track down what is going wrong at the moment). However, the one 
here: http://www.texample.net/tikz/examples/nav1d/ works, possibly because it's 
so simple. 

  Does it work for you?

 /
Down with categorical imperative!
flutz...@yahoo.com
/





From: Robert_Schiemann robert_schiem...@freenet.de
To: lyx-users@lists.lyx.org
Sent: Wed, January 13, 2010 11:07:05 AM
Subject: TikZ in LyX

Hello to all,

I am quite new to using LaTeX and even newer to using it with LyX. However,
I tried to use the
http://www.texample.net/tikz/examples/free-body-diagrams/ TikZ package
from LyX. 

I did it the following way:
1. download the package and extract the file content to Program
Files\MikTeX\
2. Insert one of the example codes (see link above) in TeXnic Center -
works.
3. Insert the same example code as a new TeX code block ('Insert TeX code')
into LyX. When Compiling, i get a few errors, mainly 'Can be used only in
preamble' and 'Environment tikzpicture undefined', and a few others. 
4. I fixed these errors by deleting the \documentclass and \enddocument
commands. In addition, I inserted the \usepackage and the \usetikzlibrary
commands in the document settings (Document - Settings - Latex preamble).
Of course, i deleted these lines from the code.
5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base is known'. Sometimes,
it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Thank you a lot in advance for your help!


  

RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
>Hello to all,
>
>5. I still get errors when compiling:
>A few of them are like 'Missing } or \cr' inserted.
>The others go like 'Package error: No shape named base
>is known'. Sometimes, it says 'M' instead of 'shape'.
>
>What can i do to solve these problems? 

Can you send us your file, then we can have a look at what is wrong ?

Vincent
 



RE: TikZ in LyX

2010-01-13 Thread Vincent van Ravesteijn - TNW
 
>>>Hello to all,
>>>
>>>5. I still get errors when compiling:
>>>A few of them are like 'Missing } or \cr' inserted.
>>>The others go like 'Package error: No shape named base is known'. 
>>>Sometimes, it says 'M' instead of 'shape'.
>>>
>>>What can i do to solve these problems? 
>>
>>Can you send us your file, then we can have a look at what is wrong ?
>
>
>I enclosed the lyx file.
>The code I used can be found on the link I sent in the first email
>

If you paste the code into LyX, you should use "Edit->Paste
Special->Plain Text". If you do that, the newlines are preserved. In the
document you have now, there are some % characters disabling code.

See the attached.

>Robert
 

Vincent



tikz.lyx
Description: tikz.lyx


Re: TikZ in LyX

2010-01-13 Thread curtis osterhoudt
I've just tried a few TikZ scripts in the 2.0.0 svn version of LyX. 

   The more complicated ones tend to fail for me (I'm not sure why; I don't 
have time to track down what is going wrong at the moment). However, the one 
here: http://www.texample.net/tikz/examples/nav1d/ works, possibly because it's 
so simple. 

  Does it work for you?

 /
Down with categorical imperative!
flutz...@yahoo.com
/





From: Robert_Schiemann 
To: lyx-users@lists.lyx.org
Sent: Wed, January 13, 2010 11:07:05 AM
Subject: TikZ in LyX

Hello to all,

I am quite new to using LaTeX and even newer to using it with LyX. However,
I tried to use the
 TikZ package
from LyX. 

I did it the following way:
1. download the package and extract the file content to Program
Files\MikTeX\
2. Insert one of the example codes (see link above) in TeXnic Center -
works.
3. Insert the same example code as a new TeX code block ('Insert TeX code')
into LyX. When Compiling, i get a few errors, mainly 'Can be used only in
preamble' and 'Environment tikzpicture undefined', and a few others. 
4. I fixed these errors by deleting the \documentclass and \enddocument
commands. In addition, I inserted the \usepackage and the \usetikzlibrary
commands in the document settings (Document -> Settings -> Latex preamble).
Of course, i deleted these lines from the code.
5. I still get errors when compiling:
A few of them are like 'Missing } or \cr' inserted.
The others go like 'Package error: No shape named base is known'. Sometimes,
it says 'M' instead of 'shape'.

What can i do to solve these problems? 

Thank you a lot in advance for your help!