Sweave documents fail to compile under 2.03

2012-07-26 Thread Hobbs,Tom
Hello-- I have a mysterious problem. All of the documents that I created including Sweave code using lyx 2.0 fail to compile when I use lyx 2.03. I am running lyx using Mac OS Lion. I have several large documents with lots of Sweave code, so until I get this worked out, I won't able to

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Please read section 4 of the manual and report more information: https://github.com/downloads/yihui/lyx/sweave.pdf otherwise it is hard to know what is exactly is the failure. Regards, Yihui -- Yihui Xie xieyi...@gmail.com Phone: 515-294-2465 Web: http://yihui.name Department of Statistics, Iowa

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
You did not read Section 4 carefully. I said in the manual that you need to open View--View Messages, and check the messages there. A simple error dialogue box saying An error occured while running Rscript --verbose... is not helpful for diagnosis at all. BTW, your document compiles fine under my

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Oh, that is far in the opposite direction now -- too much debug information :) You do not need to turn on debug messages; normal messages are enough. The problem comes from: Rscript --verbose --no-save --no-restore /Applications/LyX 2.app/Contents/Resources/scripts/lyxsweave.R becomes

Sweave documents fail to compile under 2.03

2012-07-26 Thread Hobbs,Tom
Hello-- I have a mysterious problem. All of the documents that I created including Sweave code using lyx 2.0 fail to compile when I use lyx 2.03. I am running lyx using Mac OS Lion. I have several large documents with lots of Sweave code, so until I get this worked out, I won't able to

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Please read section 4 of the manual and report more information: https://github.com/downloads/yihui/lyx/sweave.pdf otherwise it is hard to know what is exactly is the failure. Regards, Yihui -- Yihui Xie xieyi...@gmail.com Phone: 515-294-2465 Web: http://yihui.name Department of Statistics, Iowa

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
You did not read Section 4 carefully. I said in the manual that you need to open View--View Messages, and check the messages there. A simple error dialogue box saying An error occured while running Rscript --verbose... is not helpful for diagnosis at all. BTW, your document compiles fine under my

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Oh, that is far in the opposite direction now -- too much debug information :) You do not need to turn on debug messages; normal messages are enough. The problem comes from: Rscript --verbose --no-save --no-restore /Applications/LyX 2.app/Contents/Resources/scripts/lyxsweave.R becomes

Sweave documents fail to compile under 2.03

2012-07-26 Thread Hobbs,Tom
Hello-- I have a mysterious problem. All of the documents that I created including Sweave code using lyx 2.0 fail to compile when I use lyx 2.03. I am running lyx using Mac OS Lion. I have several large documents with lots of Sweave code, so until I get this worked out, I won't able to

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Please read section 4 of the manual and report more information: https://github.com/downloads/yihui/lyx/sweave.pdf otherwise it is hard to know what is exactly is the "failure". Regards, Yihui -- Yihui Xie Phone: 515-294-2465 Web: http://yihui.name Department of Statistics,

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
You did not read Section 4 carefully. I said in the manual that you need to open View-->View Messages, and check the messages there. A simple error dialogue box saying "An error occured while running Rscript --verbose..." is not helpful for diagnosis at all. BTW, your document compiles fine under

Re: Sweave documents fail to compile under 2.03

2012-07-26 Thread Yihui Xie
Oh, that is far in the opposite direction now -- too much debug information :) You do not need to turn on debug messages; normal messages are enough. The problem comes from: Rscript --verbose --no-save --no-restore "/Applications/LyX 2.app/Contents/Resources/scripts/lyxsweave.R" becomes