Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine 
(the new version works great).
I have problem with Ubuntu: the ./configure command works fine, but 
when I use the command make the process gives an error after the command


CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_variatn_take_ref'

collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

Francesco


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Liviu Andronic
On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it wrote:
 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com wrote:
 On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
 menon...@eco.unibs.it wrote:
 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

 This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

 Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu
That of getdeb is a very good idea... but unfortunately it does not 
work. When I apply it, Ubuntu Software Center starts... and tells me 
that LyX has been installed today, but the version is still 2.0.1.

On the other hand, the solution proposed by Waluyo did not work either.

Francesco

--

Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail: menon...@eco.unibs.it
web: www.eco.unibs.it/~menoncin/




Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Xu Wang
On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin
menon...@eco.unibs.itwrote:

  Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

 On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com 
 landronim...@gmail.com wrote:

  On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncinmenon...@eco.unibs.it 
 menon...@eco.unibs.it wrote:

  I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)


  This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install


  If you compile for source it will take long.
 Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
 I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
 then your LyX will be updated to 2.0.2 (release 30/11/11).

 waluyo


  Liviu

   That of getdeb is a very good idea... but unfortunately it does not
 work. When I apply it, Ubuntu Software Center starts... and tells me that
 LyX has been installed today, but the version is still 2.0.1.
 On the other hand, the solution proposed by Waluyo did not work either.

 Francesco

 --
 
 Francesco Menoncin
 Università degli Studi di Brescia
 Facoltà di Economia
 Via S. Faustino, 74/B
 25122 Brescia (Italy)
 Tel: 0039-030-2988806
 Fax: 0039-030-2988837
 E-mail: menon...@eco.unibs.it
 web: www.eco.unibs.it/~menoncin/
 


Maybe posting/attaching the output of ./configure would shed some light?


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 19:16, Xu Wang ha scritto:



On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin 
menon...@eco.unibs.it mailto:menon...@eco.unibs.it wrote:


Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  
mailto:landronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  mailto:menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu

That of getdeb is a very good idea... but unfortunately it does
not work. When I apply it, Ubuntu Software Center starts... and
tells me that LyX has been installed today, but the version is
still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work
either.

Francesco

-- 


Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail:menon...@eco.unibs.it  mailto:menon...@eco.unibs.it
web:www.eco.unibs.it/~menoncin/  http://www.eco.unibs.it/%7Emenoncin/



Maybe posting/attaching the output of ./configure would shed some light?


Here is the output:

configuring LyX version 2.0.2

checking for build type... release

checking for version suffix...

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

checking what packaging should be used... posix

checking whether to enable maintainer-specific portions of Makefiles... no

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking for a Python interpreter with version = 2.3.4... python

checking for python... /usr/bin/python

checking for python version... 2.7

checking for python platform... linux2

checking for python script directory... 
${prefix}/lib/python2.7/dist-packages


checking for python extension module directory... 
${exec_prefix}/lib/python2.7/dist-packages


checking for style of include used by make... GNU

checking for gcc... gcc

checking whether the C compiler works... yes

checking for C compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking dependency style of gcc... gcc3

checking how to run the C preprocessor... gcc -E

checking for grep that handles long lines and -e... /bin/grep

checking for egrep... /bin/grep -E

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking whether byte ordering is bigendian... no

checking what frontend should be used for the GUI... qt4

checking for a good enough C++ compiler... g++

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes

checking dependency 

Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 4 December 2011 00:15, Francesco Menoncin menon...@eco.unibs.it wrote:
 Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

 On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com wrote:

 On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
 menon...@eco.unibs.it wrote:

 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

 This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install

 If you compile for source it will take long.
 Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
 I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
 then your LyX will be updated to 2.0.2 (release 30/11/11).

 waluyo

 Liviu

 That of getdeb is a very good idea... but unfortunately it does not work.
 When I apply it, Ubuntu Software Center starts... and tells me that LyX has
 been installed today, but the version is still 2.0.1.
 On the other hand, the solution proposed by Waluyo did not work either.


It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo


 Francesco

 --
 
 Francesco Menoncin
 Università degli Studi di Brescia
 Facoltà di Economia
 Via S. Faustino, 74/B
 25122 Brescia (Italy)
 Tel: 0039-030-2988806
 Fax: 0039-030-2988837
 E-mail: menon...@eco.unibs.it
 web: www.eco.unibs.it/~menoncin/
 


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 23:13, Waluyo Adi Siswanto ha scritto:

On 4 December 2011 00:15, Francesco Menoncinmenon...@eco.unibs.it  wrote:

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

Liviu

That of getdeb is a very good idea... but unfortunately it does not work.
When I apply it, Ubuntu Software Center starts... and tells me that LyX has
been installed today, but the version is still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work either.


It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo

I already did all that.
I have uninstalled my previously source-installed LyX 2.0.1 and I 
installed it newly from getdeb. Now it works :-)

thanks

Francesco


Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine 
(the new version works great).
I have problem with Ubuntu: the ./configure command works fine, but 
when I use the command make the process gives an error after the command


CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_variatn_take_ref'

collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

Francesco


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Liviu Andronic
On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it wrote:
 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com wrote:
 On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
 menon...@eco.unibs.it wrote:
 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

 This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

 Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu
That of getdeb is a very good idea... but unfortunately it does not 
work. When I apply it, Ubuntu Software Center starts... and tells me 
that LyX has been installed today, but the version is still 2.0.1.

On the other hand, the solution proposed by Waluyo did not work either.

Francesco

--

Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail: menon...@eco.unibs.it
web: www.eco.unibs.it/~menoncin/




Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Xu Wang
On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin
menon...@eco.unibs.itwrote:

  Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

 On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com 
 landronim...@gmail.com wrote:

  On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncinmenon...@eco.unibs.it 
 menon...@eco.unibs.it wrote:

  I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)


  This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install


  If you compile for source it will take long.
 Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
 I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
 then your LyX will be updated to 2.0.2 (release 30/11/11).

 waluyo


  Liviu

   That of getdeb is a very good idea... but unfortunately it does not
 work. When I apply it, Ubuntu Software Center starts... and tells me that
 LyX has been installed today, but the version is still 2.0.1.
 On the other hand, the solution proposed by Waluyo did not work either.

 Francesco

 --
 
 Francesco Menoncin
 Università degli Studi di Brescia
 Facoltà di Economia
 Via S. Faustino, 74/B
 25122 Brescia (Italy)
 Tel: 0039-030-2988806
 Fax: 0039-030-2988837
 E-mail: menon...@eco.unibs.it
 web: www.eco.unibs.it/~menoncin/
 


Maybe posting/attaching the output of ./configure would shed some light?


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 19:16, Xu Wang ha scritto:



On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin 
menon...@eco.unibs.it mailto:menon...@eco.unibs.it wrote:


Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  
mailto:landronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  mailto:menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu

That of getdeb is a very good idea... but unfortunately it does
not work. When I apply it, Ubuntu Software Center starts... and
tells me that LyX has been installed today, but the version is
still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work
either.

Francesco

-- 


Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail:menon...@eco.unibs.it  mailto:menon...@eco.unibs.it
web:www.eco.unibs.it/~menoncin/  http://www.eco.unibs.it/%7Emenoncin/



Maybe posting/attaching the output of ./configure would shed some light?


Here is the output:

configuring LyX version 2.0.2

checking for build type... release

checking for version suffix...

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

checking what packaging should be used... posix

checking whether to enable maintainer-specific portions of Makefiles... no

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking for a Python interpreter with version = 2.3.4... python

checking for python... /usr/bin/python

checking for python version... 2.7

checking for python platform... linux2

checking for python script directory... 
${prefix}/lib/python2.7/dist-packages


checking for python extension module directory... 
${exec_prefix}/lib/python2.7/dist-packages


checking for style of include used by make... GNU

checking for gcc... gcc

checking whether the C compiler works... yes

checking for C compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking dependency style of gcc... gcc3

checking how to run the C preprocessor... gcc -E

checking for grep that handles long lines and -e... /bin/grep

checking for egrep... /bin/grep -E

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking whether byte ordering is bigendian... no

checking what frontend should be used for the GUI... qt4

checking for a good enough C++ compiler... g++

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes

checking dependency 

Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 4 December 2011 00:15, Francesco Menoncin menon...@eco.unibs.it wrote:
 Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

 On 3 December 2011 18:47, Liviu Andronic landronim...@gmail.com wrote:

 On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
 menon...@eco.unibs.it wrote:

 I am working on two pc's Ubuntu 11.01 and Windows 7.
 I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
 new version works great).
 I have problem with Ubuntu: the ./configure command works fine, but when I
 use the command make the process gives an error after the command

 CXXLD lyx

 and I receive the following message

 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_datalist_get_data'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_unref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_match_info_ref'
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
 'g_variatn_take_ref'
 collect2: ld returned 1 exit status
 make[4]: *** [lyx] Error 1
 make[3]: *** [all-recursive] Error 1
 make[2]: *** [all] Error 2
 make[1]: *** [all-recursive] Error 1
 make: *** [all] Error 2

 Any help?
 Thank you so much
 (qt4 and qt4-dev are both installed - version 4.7.4)

 This may not be sufficient. Try
 apt-get build-dep lyx
 ./configure --enable-build-type=release
 make
 make install

 If you compile for source it will take long.
 Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
 I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
 then your LyX will be updated to 2.0.2 (release 30/11/11).

 waluyo

 Liviu

 That of getdeb is a very good idea... but unfortunately it does not work.
 When I apply it, Ubuntu Software Center starts... and tells me that LyX has
 been installed today, but the version is still 2.0.1.
 On the other hand, the solution proposed by Waluyo did not work either.


It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo


 Francesco

 --
 
 Francesco Menoncin
 Università degli Studi di Brescia
 Facoltà di Economia
 Via S. Faustino, 74/B
 25122 Brescia (Italy)
 Tel: 0039-030-2988806
 Fax: 0039-030-2988837
 E-mail: menon...@eco.unibs.it
 web: www.eco.unibs.it/~menoncin/
 


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 23:13, Waluyo Adi Siswanto ha scritto:

On 4 December 2011 00:15, Francesco Menoncinmenon...@eco.unibs.it  wrote:

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Androniclandronim...@gmail.com  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
menon...@eco.unibs.it  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the ./configure command works fine, but when I
use the command make the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

Liviu

That of getdeb is a very good idea... but unfortunately it does not work.
When I apply it, Ubuntu Software Center starts... and tells me that LyX has
been installed today, but the version is still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work either.


It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo

I already did all that.
I have uninstalled my previously source-installed LyX 2.0.1 and I 
installed it newly from getdeb. Now it works :-)

thanks

Francesco


Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine 
(the new version works great).
I have problem with Ubuntu: the "./configure" command works fine, but 
when I use the command "make" the process gives an error after the command


CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to 
'g_variatn_take_ref'

collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

Francesco


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Liviu Andronic
On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
 wrote:
> I am working on two pc's Ubuntu 11.01 and Windows 7.
> I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
> new version works great).
> I have problem with Ubuntu: the "./configure" command works fine, but when I
> use the command "make" the process gives an error after the command
>
> CXXLD lyx
>
> and I receive the following message
>
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_datalist_get_data'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_unref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_ref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_variatn_take_ref'
> collect2: ld returned 1 exit status
> make[4]: *** [lyx] Error 1
> make[3]: *** [all-recursive] Error 1
> make[2]: *** [all] Error 2
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
>
> Any help?
> Thank you so much
> (qt4 and qt4-dev are both installed - version 4.7.4)
>
This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 3 December 2011 18:47, Liviu Andronic  wrote:
> On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
>  wrote:
>> I am working on two pc's Ubuntu 11.01 and Windows 7.
>> I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
>> new version works great).
>> I have problem with Ubuntu: the "./configure" command works fine, but when I
>> use the command "make" the process gives an error after the command
>>
>> CXXLD lyx
>>
>> and I receive the following message
>>
>> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
>> 'g_datalist_get_data'
>> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
>> 'g_match_info_unref'
>> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
>> 'g_match_info_ref'
>> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
>> 'g_variatn_take_ref'
>> collect2: ld returned 1 exit status
>> make[4]: *** [lyx] Error 1
>> make[3]: *** [all-recursive] Error 1
>> make[2]: *** [all] Error 2
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
>>
>> Any help?
>> Thank you so much
>> (qt4 and qt4-dev are both installed - version 4.7.4)
>>
> This may not be sufficient. Try
> apt-get build-dep lyx
> ./configure --enable-build-type=release
> make
> make install
>

If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

> Liviu


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Andronic  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the "./configure" command works fine, but when I
use the command "make" the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu
That of getdeb is a very good idea... but unfortunately it does not 
work. When I apply it, Ubuntu Software Center starts... and tells me 
that LyX has been installed today, but the version is still 2.0.1.

On the other hand, the solution proposed by Waluyo did not work either.

Francesco

--

Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail: menon...@eco.unibs.it
web: www.eco.unibs.it/~menoncin/




Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Xu Wang
On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin
wrote:

>  Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:
>
> On 3 December 2011 18:47, Liviu Andronic  
>  wrote:
>
>  On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin 
>  wrote:
>
>  I am working on two pc's Ubuntu 11.01 and Windows 7.
> I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
> new version works great).
> I have problem with Ubuntu: the "./configure" command works fine, but when I
> use the command "make" the process gives an error after the command
>
> CXXLD lyx
>
> and I receive the following message
>
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_datalist_get_data'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_unref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_ref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_variatn_take_ref'
> collect2: ld returned 1 exit status
> make[4]: *** [lyx] Error 1
> make[3]: *** [all-recursive] Error 1
> make[2]: *** [all] Error 2
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
>
> Any help?
> Thank you so much
> (qt4 and qt4-dev are both installed - version 4.7.4)
>
>
>  This may not be sufficient. Try
> apt-get build-dep lyx
> ./configure --enable-build-type=release
> make
> make install
>
>
>  If you compile for source it will take long.
> Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
> I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
> then your LyX will be updated to 2.0.2 (release 30/11/11).
>
> waluyo
>
>
>  Liviu
>
>   That of getdeb is a very good idea... but unfortunately it does not
> work. When I apply it, Ubuntu Software Center starts... and tells me that
> LyX has been installed today, but the version is still 2.0.1.
> On the other hand, the solution proposed by Waluyo did not work either.
>
> Francesco
>
> --
> 
> Francesco Menoncin
> Università degli Studi di Brescia
> Facoltà di Economia
> Via S. Faustino, 74/B
> 25122 Brescia (Italy)
> Tel: 0039-030-2988806
> Fax: 0039-030-2988837
> E-mail: menon...@eco.unibs.it
> web: www.eco.unibs.it/~menoncin/
> 
>
>
Maybe posting/attaching the output of ./configure would shed some light?


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 19:16, Xu Wang ha scritto:



On Sat, Dec 3, 2011 at 11:15 AM, Francesco Menoncin 
> wrote:


Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Andronic  
  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
    wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the "./configure" command works fine, but when I
use the command "make" the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)


This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install


If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo


Liviu

That of getdeb is a very good idea... but unfortunately it does
not work. When I apply it, Ubuntu Software Center starts... and
tells me that LyX has been installed today, but the version is
still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work
either.

Francesco

-- 


Francesco Menoncin
Università degli Studi di Brescia
Facoltà di Economia
Via S. Faustino, 74/B
25122 Brescia (Italy)
Tel: 0039-030-2988806
Fax: 0039-030-2988837
E-mail:menon...@eco.unibs.it  
web:www.eco.unibs.it/~menoncin/  



Maybe posting/attaching the output of ./configure would shed some light?


Here is the output:

configuring LyX version 2.0.2

checking for build type... release

checking for version suffix...

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

checking what packaging should be used... posix

checking whether to enable maintainer-specific portions of Makefiles... no

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking for a Python interpreter with version >= 2.3.4... python

checking for python... /usr/bin/python

checking for python version... 2.7

checking for python platform... linux2

checking for python script directory... 
${prefix}/lib/python2.7/dist-packages


checking for python extension module directory... 
${exec_prefix}/lib/python2.7/dist-packages


checking for style of include used by make... GNU

checking for gcc... gcc

checking whether the C compiler works... yes

checking for C compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking dependency style of gcc... gcc3

checking how to run the C preprocessor... gcc -E

checking for grep that handles long lines and -e... /bin/grep

checking for egrep... /bin/grep -E

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking whether byte ordering is bigendian... no

checking what frontend should be used for the GUI... qt4

checking for a good enough C++ compiler... g++

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Waluyo Adi Siswanto
On 4 December 2011 00:15, Francesco Menoncin  wrote:
> Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:
>
> On 3 December 2011 18:47, Liviu Andronic  wrote:
>
> On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
>  wrote:
>
> I am working on two pc's Ubuntu 11.01 and Windows 7.
> I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
> new version works great).
> I have problem with Ubuntu: the "./configure" command works fine, but when I
> use the command "make" the process gives an error after the command
>
> CXXLD lyx
>
> and I receive the following message
>
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_datalist_get_data'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_unref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_match_info_ref'
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
> 'g_variatn_take_ref'
> collect2: ld returned 1 exit status
> make[4]: *** [lyx] Error 1
> make[3]: *** [all-recursive] Error 1
> make[2]: *** [all] Error 2
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
>
> Any help?
> Thank you so much
> (qt4 and qt4-dev are both installed - version 4.7.4)
>
> This may not be sufficient. Try
> apt-get build-dep lyx
> ./configure --enable-build-type=release
> make
> make install
>
> If you compile for source it will take long.
> Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
> I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
> then your LyX will be updated to 2.0.2 (release 30/11/11).
>
> waluyo
>
> Liviu
>
> That of getdeb is a very good idea... but unfortunately it does not work.
> When I apply it, Ubuntu Software Center starts... and tells me that LyX has
> been installed today, but the version is still 2.0.1.
> On the other hand, the solution proposed by Waluyo did not work either.
>

It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo


> Francesco
>
> --
> 
> Francesco Menoncin
> Università degli Studi di Brescia
> Facoltà di Economia
> Via S. Faustino, 74/B
> 25122 Brescia (Italy)
> Tel: 0039-030-2988806
> Fax: 0039-030-2988837
> E-mail: menon...@eco.unibs.it
> web: www.eco.unibs.it/~menoncin/
> 


Re: Ubuntu - Problem installing LyX 2.0.2

2011-12-03 Thread Francesco Menoncin

Il 03/12/2011 23:13, Waluyo Adi Siswanto ha scritto:

On 4 December 2011 00:15, Francesco Menoncin  wrote:

Il 03/12/2011 15:11, Waluyo Adi Siswanto ha scritto:

On 3 December 2011 18:47, Liviu Andronic  wrote:

On Sat, Dec 3, 2011 at 11:38 AM, Francesco Menoncin
  wrote:

I am working on two pc's Ubuntu 11.01 and Windows 7.
I have already installed LyX 2.0.2 on Windows 7 and everything is fine (the
new version works great).
I have problem with Ubuntu: the "./configure" command works fine, but when I
use the command "make" the process gives an error after the command

CXXLD lyx

and I receive the following message

/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_datalist_get_data'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_unref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_match_info_ref'
/usr/lib/i386-linux-gnu/libgobject-2.0.so.0: undefined reference to
'g_variatn_take_ref'
collect2: ld returned 1 exit status
make[4]: *** [lyx] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Any help?
Thank you so much
(qt4 and qt4-dev are both installed - version 4.7.4)

This may not be sufficient. Try
apt-get build-dep lyx
./configure --enable-build-type=release
make
make install

If you compile for source it will take long.
Alternative update lyx 2-* to the lates one,  you can use getdeb repository.
I just update my lyx in Ubuntu 11.10 from getdeb. Only download 7+ MB,
then your LyX will be updated to 2.0.2 (release 30/11/11).

waluyo

Liviu

That of getdeb is a very good idea... but unfortunately it does not work.
When I apply it, Ubuntu Software Center starts... and tells me that LyX has
been installed today, but the version is still 2.0.1.
On the other hand, the solution proposed by Waluyo did not work either.


It won't work if directly click install.

You need to install getdeb (to write the getdeb repository address),
then update repository.
http://www.getdeb.net/updates/Ubuntu/11.10#how_to_install
You need no.1 then no.5. After that just install from update manager
(will download ~7MB).

waluyo

I already did all that.
I have uninstalled my previously source-installed LyX 2.0.1 and I 
installed it newly from getdeb. Now it works :-)

thanks

Francesco