Re: Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-12 Thread knauslists
Now I have tested LyX on Mac OSX 10.6 more thoroughly and the crashes seem to 
appear only when Lyx does some autosaving of the current document 
(Automatisches Speichern des aktuellen Dokuments… is written in the bottom 
bar of the Lyx window – Should be sth. like autosaving current document… in 
the English version). It immediately crashes afterwards. So far I haven't 
recognized crashes elsewhere. It's always the 2-minute-autosaving-crash.
I also deactivated autosaving in the preferences but this strangely does not 
really deactivate it, as after a couple of minutes the bottom bar message 
reoccurs and so do the crashes. I have restarted LyX after changing the 
preferences.

Johannes




Heute schon gefreeMailt?
Jetzt kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6831



Re: Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-12 Thread knauslists
Now I have tested LyX on Mac OSX 10.6 more thoroughly and the crashes seem to 
appear only when Lyx does some autosaving of the current document 
(Automatisches Speichern des aktuellen Dokuments… is written in the bottom 
bar of the Lyx window – Should be sth. like autosaving current document… in 
the English version). It immediately crashes afterwards. So far I haven't 
recognized crashes elsewhere. It's always the 2-minute-autosaving-crash.
I also deactivated autosaving in the preferences but this strangely does not 
really deactivate it, as after a couple of minutes the bottom bar message 
reoccurs and so do the crashes. I have restarted LyX after changing the 
preferences.

Johannes




Heute schon gefreeMailt?
Jetzt kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6831



Re: Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-12 Thread knauslists
Now I have tested LyX on Mac OSX 10.6 more thoroughly and the crashes seem to 
appear only when Lyx does some autosaving of the current document 
("Automatisches Speichern des aktuellen Dokuments…" is written in the bottom 
bar of the Lyx window – Should be sth. like "autosaving current document…" in 
the English version). It immediately crashes afterwards. So far I haven't 
recognized crashes elsewhere. It's always the 2-minute-autosaving-crash.
I also deactivated autosaving in the preferences but this strangely does not 
really deactivate it, as after a couple of minutes the bottom bar message 
reoccurs and so do the crashes. I have restarted LyX after changing the 
preferences.

Johannes




Heute schon ge"freeMail"t?
Jetzt kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6831



Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-10 Thread knauslists
Here some additional information to my previous post:

I think the relevant parts of the log of my failed lyx compilation are:
...
imac:BRANCH_1_6_X jo$ ./configure 
--prefix=/Users/jo/Desktop/lyx_snowleopard/LyX.app --with-version-suffix=-1.6 
--with-qt4-dir=/Developer/Tools/Qt --with-included-gettext --enable-
...
checking for Qt 4 library name... failed
checking for moc-qt4... no
checking for moc... /usr/bin/moc
checking for uic-qt4... no
checking for uic... /usr/bin/uic
checking for rcc-qt4... no
checking for rcc... /usr/bin/rcc
...
Configuration
  Host type:i386-apple-darwin10.0.0
  Special build flags:  assertions concept-checks stdlib-debug warnings 
 use-pspell use-ispell
  C   Compiler: gcc 
  C   Compiler LyX flags:
  C   Compiler flags:   -Wextra -Wall-g -Os
  C++ Compiler: g++ (4.2.1)
  C++ Compiler LyX flags:
  C++ Compiler flags:   -Wextra -Wall-g -Os
  Linker flags: 
  Linker user flags:-framework Carbon -framework OpenGL -framework 
AGL -framework QuickTime -framework Cocoa
  Qt 4 Frontend:
  Qt 4 version: 
  Packaging:macosx
  LyX binary dir:   
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/MacOS
  LyX files dir:
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/Resources

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** qt 4 library not found !


Well, what is the correct QT path if it is not the one QT tells me?

Johannes.



Ist Ihr wunschn...@freenet.de noch frei?
Jetzt prüfen und kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6829



Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-10 Thread knauslists
Here some additional information to my previous post:

I think the relevant parts of the log of my failed lyx compilation are:
...
imac:BRANCH_1_6_X jo$ ./configure 
--prefix=/Users/jo/Desktop/lyx_snowleopard/LyX.app --with-version-suffix=-1.6 
--with-qt4-dir=/Developer/Tools/Qt --with-included-gettext --enable-
...
checking for Qt 4 library name... failed
checking for moc-qt4... no
checking for moc... /usr/bin/moc
checking for uic-qt4... no
checking for uic... /usr/bin/uic
checking for rcc-qt4... no
checking for rcc... /usr/bin/rcc
...
Configuration
  Host type:i386-apple-darwin10.0.0
  Special build flags:  assertions concept-checks stdlib-debug warnings 
 use-pspell use-ispell
  C   Compiler: gcc 
  C   Compiler LyX flags:
  C   Compiler flags:   -Wextra -Wall-g -Os
  C++ Compiler: g++ (4.2.1)
  C++ Compiler LyX flags:
  C++ Compiler flags:   -Wextra -Wall-g -Os
  Linker flags: 
  Linker user flags:-framework Carbon -framework OpenGL -framework 
AGL -framework QuickTime -framework Cocoa
  Qt 4 Frontend:
  Qt 4 version: 
  Packaging:macosx
  LyX binary dir:   
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/MacOS
  LyX files dir:
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/Resources

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** qt 4 library not found !


Well, what is the correct QT path if it is not the one QT tells me?

Johannes.



Ist Ihr wunschn...@freenet.de noch frei?
Jetzt prüfen und kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6829



Re: Re: Will Lyx run on Mac OS X 10.6?

2009-09-10 Thread knauslists
Here some additional information to my previous post:

I think the relevant parts of the log of my failed lyx compilation are:
...
imac:BRANCH_1_6_X jo$ ./configure 
--prefix=/Users/jo/Desktop/lyx_snowleopard/LyX.app --with-version-suffix=-1.6 
--with-qt4-dir=/Developer/Tools/Qt --with-included-gettext --enable-
...
checking for Qt 4 library name... failed
checking for moc-qt4... no
checking for moc... /usr/bin/moc
checking for uic-qt4... no
checking for uic... /usr/bin/uic
checking for rcc-qt4... no
checking for rcc... /usr/bin/rcc
...
Configuration
  Host type:i386-apple-darwin10.0.0
  Special build flags:  assertions concept-checks stdlib-debug warnings 
 use-pspell use-ispell
  C   Compiler: gcc 
  C   Compiler LyX flags:
  C   Compiler flags:   -Wextra -Wall-g -Os
  C++ Compiler: g++ (4.2.1)
  C++ Compiler LyX flags:
  C++ Compiler flags:   -Wextra -Wall-g -Os
  Linker flags: 
  Linker user flags:-framework Carbon -framework OpenGL -framework 
AGL -framework QuickTime -framework Cocoa
  Qt 4 Frontend:
  Qt 4 version: 
  Packaging:macosx
  LyX binary dir:   
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/MacOS
  LyX files dir:
/Users/account/Desktop/lyx_snowleopard/LyX.app/Contents/Resources

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** qt 4 library not found !


Well, what is the correct QT path if it is not the one QT tells me?

Johannes.



Ist Ihr wunschn...@freenet.de noch frei?
Jetzt prüfen und kostenlose E-Mail-Adresse sichern!
http://email.freenet.de/dienste/emailoffice/produktuebersicht/basic/mail/index.html?pid=6829



Re: Will Lyx run on Mac OS X 10.6?

2009-09-07 Thread Johannes Knaus
Somehow my last post was cut at the end, so here again the full text  
(I hope so):


So, now some interim report about me trying to compile lyx
on 10.6.

To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the archives there aim to quite empty ftp-servers
with QT3-versions on it.
So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.
Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.

I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALL.MACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.

I looked up where the 4.5.2 binary installs files:
Qt Designer, Qt Linguist: /Developer/Applications/Qt
Qt Documentation: /Developer/Documentation/Qt
Qt Examples: /Developer/Examples/Qt
Qt Plugins: /Developer/Applications/Qt/Plugins
Qt Frameworks: /Library/Frameworks
Qt Libraries: /usr/lib
qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)
Uninstall script: /Developer/Tools/uninstall-qt.py

I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.
So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:
The uninstall.py script runs fine and exits without error,
but it didn't remove anything.
As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*
I stopped here and didn't do anything, before making all
that mess bigger.
In sum I warn everbody: Don't install the Qt 4.5.2 binary.

But maybe I should give 4.5.2 another try with another
path/to/Qt, any ideas?
Or can somebody tell me, how I easily remove 4.5.2 without
the uninstall.py script?

Thanks for your help.

BTW: Should I place further posts on the developer-list?


Johannes


Re: Will Lyx run on Mac OS X 10.6?

2009-09-07 Thread Johannes Knaus
Somehow my last post was cut at the end, so here again the full text  
(I hope so):


So, now some interim report about me trying to compile lyx
on 10.6.

To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the archives there aim to quite empty ftp-servers
with QT3-versions on it.
So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.
Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.

I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALL.MACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.

I looked up where the 4.5.2 binary installs files:
Qt Designer, Qt Linguist: /Developer/Applications/Qt
Qt Documentation: /Developer/Documentation/Qt
Qt Examples: /Developer/Examples/Qt
Qt Plugins: /Developer/Applications/Qt/Plugins
Qt Frameworks: /Library/Frameworks
Qt Libraries: /usr/lib
qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)
Uninstall script: /Developer/Tools/uninstall-qt.py

I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.
So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:
The uninstall.py script runs fine and exits without error,
but it didn't remove anything.
As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*
I stopped here and didn't do anything, before making all
that mess bigger.
In sum I warn everbody: Don't install the Qt 4.5.2 binary.

But maybe I should give 4.5.2 another try with another
path/to/Qt, any ideas?
Or can somebody tell me, how I easily remove 4.5.2 without
the uninstall.py script?

Thanks for your help.

BTW: Should I place further posts on the developer-list?


Johannes


Re: Will Lyx run on Mac OS X 10.6?

2009-09-07 Thread Johannes Knaus
Somehow my last post was cut at the end, so here again the full text  
(I hope so):


So, now some interim report about me trying to compile lyx
on 10.6.

To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the "archives" there aim to quite empty ftp-servers
with QT3-versions on it.
So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.
Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.

I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALL.MACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.

I looked up where the 4.5.2 binary installs files:
Qt Designer, Qt Linguist: /Developer/Applications/Qt
Qt Documentation: /Developer/Documentation/Qt
Qt Examples: /Developer/Examples/Qt
Qt Plugins: /Developer/Applications/Qt/Plugins
Qt Frameworks: /Library/Frameworks
Qt Libraries: /usr/lib
qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)
Uninstall script: /Developer/Tools/uninstall-qt.py

I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.
So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:
The uninstall.py script runs fine and exits without error,
but it didn't remove anything.
As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*
I stopped here and didn't do anything, before making all
that mess bigger.
In sum I warn everbody: Don't install the Qt 4.5.2 binary.

But maybe I should give 4.5.2 another try with another
path/to/Qt, any ideas?
Or can somebody tell me, how I easily remove 4.5.2 without
the uninstall.py script?

Thanks for your help.

BTW: Should I place further posts on the developer-list?


Johannes


RE: RE: Will Lyx run on Mac OS X 10.6?

2009-09-06 Thread knauslists

So, now some interim report about me trying to compile lyx
on 10.6.



To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the archives there aim to quite empty ftp-servers
with QT3-versions on it.

So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.

Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.



I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALLMACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.



I looked up where the 4.5.2 binary installs files:

Qt Designer, Qt Linguist: /Developer/Applications/Qt

Qt Documentation: /Developer/Documentation/Qt

Qt Examples: /Developer/Examples/Qt

Qt Plugins: /Developer/Applications/Qt/Plugins

Qt Frameworks: /Library/Frameworks

Qt Libraries: /usr/lib

qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)

Uninstall script: /Developer/Tools/uninstall-qt.py



I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.



So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:

The uninstall.py script runs fine and exits without error,
but it didn't remove anything.



As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*

I stopped here and didn't do anything, before making all
that mess bigger

RE: RE: Will Lyx run on Mac OS X 10.6?

2009-09-06 Thread knauslists

So, now some interim report about me trying to compile lyx
on 10.6.



To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the archives there aim to quite empty ftp-servers
with QT3-versions on it.

So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.

Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.



I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALLMACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.



I looked up where the 4.5.2 binary installs files:

Qt Designer, Qt Linguist: /Developer/Applications/Qt

Qt Documentation: /Developer/Documentation/Qt

Qt Examples: /Developer/Examples/Qt

Qt Plugins: /Developer/Applications/Qt/Plugins

Qt Frameworks: /Library/Frameworks

Qt Libraries: /usr/lib

qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)

Uninstall script: /Developer/Tools/uninstall-qt.py



I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.



So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:

The uninstall.py script runs fine and exits without error,
but it didn't remove anything.



As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*

I stopped here and didn't do anything, before making all
that mess bigger

RE: RE: Will Lyx run on Mac OS X 10.6?

2009-09-06 Thread knauslists

So, now some interim report about me trying to compile lyx
on 10.6.



To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the "archives" there aim to quite empty ftp-servers
with QT3-versions on it.

So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.

Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.



I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALLMACOSX file.

Well, configuring always fails as it cannot find the
qt-directory.



I looked up where the 4.5.2 binary installs files:

Qt Designer, Qt Linguist: /Developer/Applications/Qt

Qt Documentation: /Developer/Documentation/Qt

Qt Examples: /Developer/Examples/Qt

Qt Plugins: /Developer/Applications/Qt/Plugins

Qt Frameworks: /Library/Frameworks

Qt Libraries: /usr/lib

qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)

Uninstall script: /Developer/Tools/uninstall-qt.py



I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.



So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:

The uninstall.py script runs fine and exits without error,
but it didn't remove anything.



As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*

I stopped here and didn't do anything, before making all
that mess bigger

Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus
I have 1.6.3 and Snow Leopard on my Mac. Unfortunately the same  
problems appear as reported for 1.6.4.


Johannes

Am 03.09.2009 um 16:15 schrieb Julio Rojas:


Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Brayb...@math.umemat.maine.edu 
 wrote:
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release.
(I got the binary from the Lyx server before it was taken off; it  
does have
the problem that Preferences is grayed out as a menu choice, but  
can be
opened using keys CMD + , . I have not noticed any other problems  
with Lyx

1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it  
sit. After
about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My
console report looks alot like the one in the bug report (link  
below).
However, Lyx did not actually crash. After choosing Ignore, Lyx was  
still

running and I could continue to type, save, edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to  
the

autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up  
as yet

(we are about 15 minutes in at this point.

This is just a follow up to the question of Knaus. I am going to  
continue to

use Lyx under Snow Leopard and see where it takes me.

Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent





--

Sometimes I lie awake at night, and ask, Where have I gone wrong?
Then a voice says to me, This is going to take more than one  
night. (Charlie Brown)





Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Julio Rojas
Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Brayb...@math.umemat.maine.edu wrote:
 I am currently testing Lyx 1.6.4 under Snow Leopard, the official release.
 (I got the binary from the Lyx server before it was taken off; it does have
 the problem that Preferences is grayed out as a menu choice, but can be
 opened using keys CMD + , . I have not noticed any other problems with Lyx
 1.6.4?)
 I created a generic Lyx file, typed a bunch of stuff and let it sit. After
 about 5 minutes, a pop up window appeared reporting that Lyx crashed. My
 console report looks alot like the one in the bug report (link below).
 However, Lyx did not actually crash. After choosing Ignore, Lyx was still
 running and I could continue to type, save, edit, etc, the file.
 The crash reoccurs about every 5 minutes, which does correspond to the
 autosave time set in preferences.
 I turned off autosave and Lyx has not sent up another crash pop up as yet
 (we are about 15 minutes in at this point.

 This is just a follow up to the question of Knaus. I am going to continue to
 use Lyx under Snow Leopard and see where it takes me.

 Bill

 On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:

 Hello,

 I ordered the new Mac OS Snowleopard this week and I wonder
 if any of the Lyx-(Mac)-Developers has already tested Lyx
 under a Developer- Version of Snowleopard?

 Will the Lyx-Binary run on Snowleopard?
 Anyway, I'll test it and post it here.

 Johannes.


 We are a bit short on Mac developers, so I doubt that you'll get an
 authorative answer.

 But, the good news is that I've heard of someone running LyX on
 Snowleopard, the bad news is that I heard this by means of a bug report:

 http://www.lyx.org/trac/ticket/6168.

 So, it'll be interesting whether this crash actually has to do something
 with Snowleopard or not.

 Vincent




Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus

Now I found time to install Snow Leopard on my Mac.
I can confirm the behaviour reported here:

Lyx (1.6.3) starts up and as long as I just watch my document it keeps  
running without any errors.
When I type something and wait for the autosave to come into action, a  
pop up window appears with an error message that LyX crashed.
However if I simply click on ignore, I can work with my LyX document,  
as LyX itself still is running. So it might only be some subprocess  
which is crashed.
I can save changes via the save button. Although after pressing the  
button the pop up telling my that LyX crashed appears again.
When I insert a table, the mentioned popup window appears, too. So it  
seems that as soon as you start something which calls up a new menubar  
this process crashes, too.


All these crashes seem to have to with the fork() without exit() thing  
reported on trac, see the crashlog-excerpts below.


So is it useful if I try to compile Lyx on my own on 10.6? Or would  
this end up in the same crashing behaviour?
There are some changes/workarounds to do in the source code first,  
right?


Johannes

1)

Process: lyx [850]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:28:16.111 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  2022 sec
Crashes Since Last Report:   2
Per-App Crashes Since Last Report:   2
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…


2)

Process: lyx [904]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:52:05.910 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  1329 sec
Crashes Since Last Report:   1
Per-App Crashes Since Last Report:   1
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…

Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Manveru
2009/9/3 Johannes Knaus knausli...@freenet.de:
[...]
 Application Specific Information:
 USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
 abort() called
[...]
 Exception Type:  EXC_CRASH (SIGABRT)
 Exception Codes: 0x, 0x
 Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 Application Specific Information:
 USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
 abort() called
[...]

For me it seems Apple has changed a security policy about calling
fork(). I cant find any article about that on Google yet.

-- 
Manveru
jabber: manv...@manveru.pl
 gg: 1624001
   http://www.manveru.pl


RE: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Vincent van Ravesteijn - TNW
 So is it useful if I try to compile Lyx on my own on
 10.6? Or would this end up in the same crashing behaviour?

I think it is useful, but I think you'll see the same crashing
behaviour.


There are some changes/workarounds to do in the source
code first, right?


The first thing you might try is to adapt the following code:

194--...@forkedcalls.cpp:

pid_t ForkedProcess::fork() {
#if !defined (HAVE_FORK)
return -1;
#else
pid_t pid = ::fork();
if (pid == 0)
IAmAChild = true;
return pid;
#endif
}


If you undefine HAVE_FORK (or just always return -1), you can see
whether (all) crashes disappear. If so, we have at least a workaround. 

Everything should still work, but you might be interrupted in your
typing when LyX saves the autosave file using the same thread.

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus
I have 1.6.3 and Snow Leopard on my Mac. Unfortunately the same  
problems appear as reported for 1.6.4.


Johannes

Am 03.09.2009 um 16:15 schrieb Julio Rojas:


Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Brayb...@math.umemat.maine.edu 
 wrote:
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release.
(I got the binary from the Lyx server before it was taken off; it  
does have
the problem that Preferences is grayed out as a menu choice, but  
can be
opened using keys CMD + , . I have not noticed any other problems  
with Lyx

1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it  
sit. After
about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My
console report looks alot like the one in the bug report (link  
below).
However, Lyx did not actually crash. After choosing Ignore, Lyx was  
still

running and I could continue to type, save, edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to  
the

autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up  
as yet

(we are about 15 minutes in at this point.

This is just a follow up to the question of Knaus. I am going to  
continue to

use Lyx under Snow Leopard and see where it takes me.

Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent





--

Sometimes I lie awake at night, and ask, Where have I gone wrong?
Then a voice says to me, This is going to take more than one  
night. (Charlie Brown)





Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Julio Rojas
Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Brayb...@math.umemat.maine.edu wrote:
 I am currently testing Lyx 1.6.4 under Snow Leopard, the official release.
 (I got the binary from the Lyx server before it was taken off; it does have
 the problem that Preferences is grayed out as a menu choice, but can be
 opened using keys CMD + , . I have not noticed any other problems with Lyx
 1.6.4?)
 I created a generic Lyx file, typed a bunch of stuff and let it sit. After
 about 5 minutes, a pop up window appeared reporting that Lyx crashed. My
 console report looks alot like the one in the bug report (link below).
 However, Lyx did not actually crash. After choosing Ignore, Lyx was still
 running and I could continue to type, save, edit, etc, the file.
 The crash reoccurs about every 5 minutes, which does correspond to the
 autosave time set in preferences.
 I turned off autosave and Lyx has not sent up another crash pop up as yet
 (we are about 15 minutes in at this point.

 This is just a follow up to the question of Knaus. I am going to continue to
 use Lyx under Snow Leopard and see where it takes me.

 Bill

 On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:

 Hello,

 I ordered the new Mac OS Snowleopard this week and I wonder
 if any of the Lyx-(Mac)-Developers has already tested Lyx
 under a Developer- Version of Snowleopard?

 Will the Lyx-Binary run on Snowleopard?
 Anyway, I'll test it and post it here.

 Johannes.


 We are a bit short on Mac developers, so I doubt that you'll get an
 authorative answer.

 But, the good news is that I've heard of someone running LyX on
 Snowleopard, the bad news is that I heard this by means of a bug report:

 http://www.lyx.org/trac/ticket/6168.

 So, it'll be interesting whether this crash actually has to do something
 with Snowleopard or not.

 Vincent




Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus

Now I found time to install Snow Leopard on my Mac.
I can confirm the behaviour reported here:

Lyx (1.6.3) starts up and as long as I just watch my document it keeps  
running without any errors.
When I type something and wait for the autosave to come into action, a  
pop up window appears with an error message that LyX crashed.
However if I simply click on ignore, I can work with my LyX document,  
as LyX itself still is running. So it might only be some subprocess  
which is crashed.
I can save changes via the save button. Although after pressing the  
button the pop up telling my that LyX crashed appears again.
When I insert a table, the mentioned popup window appears, too. So it  
seems that as soon as you start something which calls up a new menubar  
this process crashes, too.


All these crashes seem to have to with the fork() without exit() thing  
reported on trac, see the crashlog-excerpts below.


So is it useful if I try to compile Lyx on my own on 10.6? Or would  
this end up in the same crashing behaviour?
There are some changes/workarounds to do in the source code first,  
right?


Johannes

1)

Process: lyx [850]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:28:16.111 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  2022 sec
Crashes Since Last Report:   2
Per-App Crashes Since Last Report:   2
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…


2)

Process: lyx [904]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:52:05.910 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  1329 sec
Crashes Since Last Report:   1
Per-App Crashes Since Last Report:   1
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…

Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Manveru
2009/9/3 Johannes Knaus knausli...@freenet.de:
[...]
 Application Specific Information:
 USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
 abort() called
[...]
 Exception Type:  EXC_CRASH (SIGABRT)
 Exception Codes: 0x, 0x
 Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 Application Specific Information:
 USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
 abort() called
[...]

For me it seems Apple has changed a security policy about calling
fork(). I cant find any article about that on Google yet.

-- 
Manveru
jabber: manv...@manveru.pl
 gg: 1624001
   http://www.manveru.pl


RE: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Vincent van Ravesteijn - TNW
 So is it useful if I try to compile Lyx on my own on
 10.6? Or would this end up in the same crashing behaviour?

I think it is useful, but I think you'll see the same crashing
behaviour.


There are some changes/workarounds to do in the source
code first, right?


The first thing you might try is to adapt the following code:

194--...@forkedcalls.cpp:

pid_t ForkedProcess::fork() {
#if !defined (HAVE_FORK)
return -1;
#else
pid_t pid = ::fork();
if (pid == 0)
IAmAChild = true;
return pid;
#endif
}


If you undefine HAVE_FORK (or just always return -1), you can see
whether (all) crashes disappear. If so, we have at least a workaround. 

Everything should still work, but you might be interrupted in your
typing when LyX saves the autosave file using the same thread.

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus
I have 1.6.3 and Snow Leopard on my Mac. Unfortunately the same  
problems appear as reported for 1.6.4.


Johannes

Am 03.09.2009 um 16:15 schrieb Julio Rojas:


Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Bray wrote:
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release.
(I got the binary from the Lyx server before it was taken off; it  
does have
the problem that Preferences is grayed out as a menu choice, but  
can be
opened using keys CMD + , . I have not noticed any other problems  
with Lyx

1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it  
sit. After
about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My
console report looks alot like the one in the bug report (link  
below).
However, Lyx did not actually crash. After choosing Ignore, Lyx was  
still

running and I could continue to type, save, edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to  
the

autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up  
as yet

(we are about 15 minutes in at this point.

This is just a follow up to the question of Knaus. I am going to  
continue to

use Lyx under Snow Leopard and see where it takes me.

Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent





--

Sometimes I lie awake at night, and ask, "Where have I gone wrong?"
Then a voice says to me, "This is going to take more than one  
night." (Charlie Brown)





Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Julio Rojas
Is this problem specifically linked to 1.6.4? Or will 1.6.3 present
it? I have Snow Leopard in my hand and 1.6.3 installed on my wife's
computer. Haven't installed the OS waiting for this problem to solve.
-
Julio Rojas
jcredbe...@gmail.com



On Sun, Aug 30, 2009 at 2:16 AM, William Bray wrote:
> I am currently testing Lyx 1.6.4 under Snow Leopard, the official release.
> (I got the binary from the Lyx server before it was taken off; it does have
> the problem that Preferences is grayed out as a menu choice, but can be
> opened using keys CMD + , . I have not noticed any other problems with Lyx
> 1.6.4?)
> I created a generic Lyx file, typed a bunch of stuff and let it sit. After
> about 5 minutes, a pop up window appeared reporting that Lyx crashed. My
> console report looks alot like the one in the bug report (link below).
> However, Lyx did not actually crash. After choosing Ignore, Lyx was still
> running and I could continue to type, save, edit, etc, the file.
> The crash reoccurs about every 5 minutes, which does correspond to the
> autosave time set in preferences.
> I turned off autosave and Lyx has not sent up another crash pop up as yet
> (we are about 15 minutes in at this point.
>
> This is just a follow up to the question of Knaus. I am going to continue to
> use Lyx under Snow Leopard and see where it takes me.
>
> Bill
>
> On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:
>
>>> Hello,
>>>
>>> I ordered the new Mac OS Snowleopard this week and I wonder
>>> if any of the Lyx-(Mac)-Developers has already tested Lyx
>>> under a Developer- Version of Snowleopard?
>>>
>>> Will the Lyx-Binary run on Snowleopard?
>>> Anyway, I'll test it and post it here.
>>>
>>> Johannes.
>>>
>>
>> We are a bit short on Mac developers, so I doubt that you'll get an
>> authorative answer.
>>
>> But, the good news is that I've heard of someone running LyX on
>> Snowleopard, the bad news is that I heard this by means of a bug report:
>>
>> http://www.lyx.org/trac/ticket/6168.
>>
>> So, it'll be interesting whether this crash actually has to do something
>> with Snowleopard or not.
>>
>> Vincent
>
>


Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Johannes Knaus

Now I found time to install Snow Leopard on my Mac.
I can confirm the behaviour reported here:

Lyx (1.6.3) starts up and as long as I just watch my document it keeps  
running without any errors.
When I type something and wait for the autosave to come into action, a  
pop up window appears with an error message that LyX crashed.
However if I simply click on ignore, I can work with my LyX document,  
as LyX itself still is running. So it might only be some subprocess  
which is crashed.
I can save changes via the save button. Although after pressing the  
button the pop up telling my that LyX crashed appears again.
When I insert a table, the mentioned popup window appears, too. So it  
seems that as soon as you start something which calls up a new menubar  
this process crashes, too.


All these crashes seem to have to with the fork() without exit() thing  
reported on trac, see the crashlog-excerpts below.


So is it useful if I try to compile Lyx on my own on 10.6? Or would  
this end up in the same crashing behaviour?
There are some changes/workarounds to do in the source code first,  
right?


Johannes

1)

Process: lyx [850]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:28:16.111 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  2022 sec
Crashes Since Last Report:   2
Per-App Crashes Since Last Report:   2
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…


2)

Process: lyx [904]
Path:/Applications/LyX.app/Contents/MacOS/lyx
Identifier:  lyx
Version: ??? (???)
Code Type:   X86 (Native)
Parent Process:  lyx [800]

Date/Time:   2009-08-31 23:52:05.910 +0200
OS Version:  Mac OS X 10.6 (10A432)
Report Version:  6

Interval Since Last Report:  1329 sec
Crashes Since Last Report:   1
Per-App Crashes Since Last Report:   1
Anonymous UUID:  D124E21E- 
F546-47A6-9182-5346BDAEE239


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x, 0x
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib   0x92a14972 __kill + 10
1   libSystem.B.dylib   0x92a14964 kill$UNIX2003 + 32
2   libSystem.B.dylib   0x92aa7ba5 raise + 26
3   libSystem.B.dylib   0x92abdc5c abort + 93
…

Re: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Manveru
2009/9/3 Johannes Knaus :
[...]
> Application Specific Information:
> USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
> abort() called
[...]
> Exception Type:  EXC_CRASH (SIGABRT)
> Exception Codes: 0x, 0x
> Crashed Thread:  0  Dispatch queue: com.apple.main-thread
>
> Application Specific Information:
> USING_FORK_WITHOUT_EXEC_IS_NOT_SUPPORTED_BY_FILE_MANAGER
> abort() called
[...]

For me it seems Apple has changed a security policy about calling
fork(). I cant find any article about that on Google yet.

-- 
Manveru
jabber: manv...@manveru.pl
 gg: 1624001
   http://www.manveru.pl


RE: Will Lyx run on Mac OS X 10.6?

2009-09-03 Thread Vincent van Ravesteijn - TNW
> So is it useful if I try to compile Lyx on my own on
> 10.6? Or would this end up in the same crashing behaviour?

I think it is useful, but I think you'll see the same crashing
behaviour.

>
>There are some changes/workarounds to do in the source
>code first, right?
>

The first thing you might try is to adapt the following code:

194--...@forkedcalls.cpp:

pid_t ForkedProcess::fork() {
#if !defined (HAVE_FORK)
return -1;
#else
pid_t pid = ::fork();
if (pid == 0)
IAmAChild = true;
return pid;
#endif
}


If you undefine HAVE_FORK (or just always return -1), you can see
whether (all) crashes disappear. If so, we have at least a workaround. 

Everything should still work, but you might be interrupted in your
typing when LyX saves the autosave file using the same thread.

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Anders Ekberg

Hello Johannes,

Follow the instructions on:
http://www.lyx.org/HowToUseSVN
to download the code (note that you need the code in branches/ 
BRANCH_1_6_X to compile LyX1.6).

Then follow the instructions on:
http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
There are better ways to get universal binaries etc, but the  
instructions should give you something that works on your computer.
(B.t.w. I use QT 4.4.3, I think there was a problem with the latest  
version. Bennet can give you details)


Good luck!
Anders

On 31 aug 2009, at 14.57, Johannes Knaus wrote:


Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps  
on my own. So I would try to build a 10.6-Lyx on my own (well  
slowly, as I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be  
difficult
to fix this as, I guess, we don't have a developer using Snow  
Leopard.

So, if you have any hints, please let us know.


Bill


Vincent






Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread BH
On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberga...@mac.com wrote:
 Hello Johannes,

 Follow the instructions on:
 http://www.lyx.org/HowToUseSVN
 to download the code (note that you need the code in branches/BRANCH_1_6_X
 to compile LyX1.6).
 Then follow the instructions on:
 http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
 There are better ways to get universal binaries etc, but the instructions
 should give you something that works on your computer.
 (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
 Bennet can give you details)

In Qt-4.5, windows aren't properly drawn, often showing a blank white
background where there should be text or toolbar buttons. Clicking in
the window will restore the text.

BH


Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Julio Rojas
Bad news for my wife. We're waiting for the Snow Leopard to arrive. I
guess we will have to wait until some fix for this problem is made,
before installing Snow Leopard. I'll keep following this trend.
-
Julio Rojas
jcredbe...@gmail.com



On Tue, Sep 1, 2009 at 11:26 PM, BHbewih...@gmail.com wrote:
 On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberga...@mac.com wrote:
 Hello Johannes,

 Follow the instructions on:
 http://www.lyx.org/HowToUseSVN
 to download the code (note that you need the code in branches/BRANCH_1_6_X
 to compile LyX1.6).
 Then follow the instructions on:
 http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
 There are better ways to get universal binaries etc, but the instructions
 should give you something that works on your computer.
 (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
 Bennet can give you details)

 In Qt-4.5, windows aren't properly drawn, often showing a blank white
 background where there should be text or toolbar buttons. Clicking in
 the window will restore the text.

 BH



Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Anders Ekberg

Hello Johannes,

Follow the instructions on:
http://www.lyx.org/HowToUseSVN
to download the code (note that you need the code in branches/ 
BRANCH_1_6_X to compile LyX1.6).

Then follow the instructions on:
http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
There are better ways to get universal binaries etc, but the  
instructions should give you something that works on your computer.
(B.t.w. I use QT 4.4.3, I think there was a problem with the latest  
version. Bennet can give you details)


Good luck!
Anders

On 31 aug 2009, at 14.57, Johannes Knaus wrote:


Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps  
on my own. So I would try to build a 10.6-Lyx on my own (well  
slowly, as I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be  
difficult
to fix this as, I guess, we don't have a developer using Snow  
Leopard.

So, if you have any hints, please let us know.


Bill


Vincent






Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread BH
On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberga...@mac.com wrote:
 Hello Johannes,

 Follow the instructions on:
 http://www.lyx.org/HowToUseSVN
 to download the code (note that you need the code in branches/BRANCH_1_6_X
 to compile LyX1.6).
 Then follow the instructions on:
 http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
 There are better ways to get universal binaries etc, but the instructions
 should give you something that works on your computer.
 (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
 Bennet can give you details)

In Qt-4.5, windows aren't properly drawn, often showing a blank white
background where there should be text or toolbar buttons. Clicking in
the window will restore the text.

BH


Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Julio Rojas
Bad news for my wife. We're waiting for the Snow Leopard to arrive. I
guess we will have to wait until some fix for this problem is made,
before installing Snow Leopard. I'll keep following this trend.
-
Julio Rojas
jcredbe...@gmail.com



On Tue, Sep 1, 2009 at 11:26 PM, BHbewih...@gmail.com wrote:
 On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberga...@mac.com wrote:
 Hello Johannes,

 Follow the instructions on:
 http://www.lyx.org/HowToUseSVN
 to download the code (note that you need the code in branches/BRANCH_1_6_X
 to compile LyX1.6).
 Then follow the instructions on:
 http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
 There are better ways to get universal binaries etc, but the instructions
 should give you something that works on your computer.
 (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
 Bennet can give you details)

 In Qt-4.5, windows aren't properly drawn, often showing a blank white
 background where there should be text or toolbar buttons. Clicking in
 the window will restore the text.

 BH



Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Anders Ekberg

Hello Johannes,

Follow the instructions on:
http://www.lyx.org/HowToUseSVN
to download the code (note that you need the code in branches/ 
BRANCH_1_6_X to compile LyX1.6).

Then follow the instructions on:
http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
There are better ways to get universal binaries etc, but the  
instructions should give you something that works on your computer.
(B.t.w. I use QT 4.4.3, I think there was a problem with the latest  
version. Bennet can give you details)


Good luck!
Anders

On 31 aug 2009, at 14.57, Johannes Knaus wrote:


Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps  
on my own. So I would try to build a 10.6-Lyx on my own (well  
slowly, as I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be  
difficult
to fix this as, I guess, we don't have a developer using Snow  
Leopard.

So, if you have any hints, please let us know.


Bill


Vincent






Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread BH
On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberg wrote:
> Hello Johannes,
>
> Follow the instructions on:
> http://www.lyx.org/HowToUseSVN
> to download the code (note that you need the code in branches/BRANCH_1_6_X
> to compile LyX1.6).
> Then follow the instructions on:
> http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
> There are better ways to get universal binaries etc, but the instructions
> should give you something that works on your computer.
> (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
> Bennet can give you details)

In Qt-4.5, windows aren't properly drawn, often showing a blank white
background where there should be text or toolbar buttons. Clicking in
the window will restore the text.

BH


Re: Will Lyx run on Mac OS X 10.6?

2009-09-01 Thread Julio Rojas
Bad news for my wife. We're waiting for the Snow Leopard to arrive. I
guess we will have to wait until some fix for this problem is made,
before installing Snow Leopard. I'll keep following this trend.
-
Julio Rojas
jcredbe...@gmail.com



On Tue, Sep 1, 2009 at 11:26 PM, BH wrote:
> On Tue, Sep 1, 2009 at 1:27 PM, Anders Ekberg wrote:
>> Hello Johannes,
>>
>> Follow the instructions on:
>> http://www.lyx.org/HowToUseSVN
>> to download the code (note that you need the code in branches/BRANCH_1_6_X
>> to compile LyX1.6).
>> Then follow the instructions on:
>> http://www.lyx.org/trac/browser/lyx-devel/branches/BRANCH_1_6_X/INSTALL.MacOSX
>> There are better ways to get universal binaries etc, but the instructions
>> should give you something that works on your computer.
>> (B.t.w. I use QT 4.4.3, I think there was a problem with the latest version.
>> Bennet can give you details)
>
> In Qt-4.5, windows aren't properly drawn, often showing a blank white
> background where there should be text or toolbar buttons. Clicking in
> the window will restore the text.
>
> BH
>


RE: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Vincent van Ravesteijn - TNW
I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below). 

Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.

Bill

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Johannes Knaus

Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps on  
my own. So I would try to build a 10.6-Lyx on my own (well slowly, as  
I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.


Bill


Vincent




RE: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Vincent van Ravesteijn - TNW
I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below). 

Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.

Bill

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Johannes Knaus

Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps on  
my own. So I would try to build a 10.6-Lyx on my own (well slowly, as  
I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.


Bill


Vincent




RE: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Vincent van Ravesteijn - TNW
>I am currently testing Lyx 1.6.4 under Snow Leopard,
>the official release. After about 5 minutes, a pop up
>window appeared reporting that Lyx crashed. My console
>report looks alot like the one in the bug report (link
>below). 

Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.

>Bill

Vincent


Re: Will Lyx run on Mac OS X 10.6?

2009-08-31 Thread Johannes Knaus

Hello again,

My Snow Leopard DVD just arrived, so I'm starting my testing today.
My question now to the developers around:
I'm by far no developer but I successfully compiled some unix apps on  
my own. So I would try to build a 10.6-Lyx on my own (well slowly, as  
I find time).
What prerequisites do I need (QT, which version?) or do you think  
that's by far too complicated?


BTW, I found out that there's a QT-bug within the QT from Macports  
which is not in the original QT, see:

http://trac.macports.org/ticket/20435
http://trac.macports.org/ticket/20937

Johannes

Is this a hard thing to
Am 31.08.2009 um 09:56 schrieb Vincent van Ravesteijn - TNW:


I am currently testing Lyx 1.6.4 under Snow Leopard,
the official release. After about 5 minutes, a pop up
window appeared reporting that Lyx crashed. My console
report looks alot like the one in the bug report (link
below).


Thanks for the info and confirmation of bug 6160. It will be difficult
to fix this as, I guess, we don't have a developer using Snow Leopard.
So, if you have any hints, please let us know.


Bill


Vincent




Re: Will Lyx run on Mac OS X 10.6?

2009-08-29 Thread William Bray
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release. (I got the binary from the Lyx server before it was taken  
off; it does have the problem that Preferences is grayed out as a menu  
choice, but can be opened using keys CMD + , . I have not noticed any  
other problems with Lyx 1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it sit.  
After about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My console report looks alot like the one in the bug report  
(link below). However, Lyx did not actually crash. After choosing  
Ignore, Lyx was still running and I could continue to type, save,  
edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to the  
autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up as  
yet (we are about 15 minutes in at this point.


This is just a follow up to the question of Knaus. I am going to  
continue to use Lyx under Snow Leopard and see where it takes me.


Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent




Re: Will Lyx run on Mac OS X 10.6?

2009-08-29 Thread William Bray
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release. (I got the binary from the Lyx server before it was taken  
off; it does have the problem that Preferences is grayed out as a menu  
choice, but can be opened using keys CMD + , . I have not noticed any  
other problems with Lyx 1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it sit.  
After about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My console report looks alot like the one in the bug report  
(link below). However, Lyx did not actually crash. After choosing  
Ignore, Lyx was still running and I could continue to type, save,  
edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to the  
autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up as  
yet (we are about 15 minutes in at this point.


This is just a follow up to the question of Knaus. I am going to  
continue to use Lyx under Snow Leopard and see where it takes me.


Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent




Re: Will Lyx run on Mac OS X 10.6?

2009-08-29 Thread William Bray
I am currently testing Lyx 1.6.4 under Snow Leopard, the official  
release. (I got the binary from the Lyx server before it was taken  
off; it does have the problem that Preferences is grayed out as a menu  
choice, but can be opened using keys CMD + , . I have not noticed any  
other problems with Lyx 1.6.4?)
I created a generic Lyx file, typed a bunch of stuff and let it sit.  
After about 5 minutes, a pop up window appeared reporting that Lyx  
crashed. My console report looks alot like the one in the bug report  
(link below). However, Lyx did not actually crash. After choosing  
Ignore, Lyx was still running and I could continue to type, save,  
edit, etc, the file.
The crash reoccurs about every 5 minutes, which does correspond to the  
autosave time set in preferences.
I turned off autosave and Lyx has not sent up another crash pop up as  
yet (we are about 15 minutes in at this point.


This is just a follow up to the question of Knaus. I am going to  
continue to use Lyx under Snow Leopard and see where it takes me.


Bill

On Aug 27, 2009, at 8:30 AM, Vincent van Ravesteijn - TNW wrote:


Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer.

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug  
report:


http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do  
something

with Snowleopard or not.

Vincent




Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Johannes Knaus

Hello,

I ordered the new Mac OS Snowleopard this week and I wonder if any of  
the Lyx-(Mac)-Developers has already tested Lyx under a Developer- 
Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



RE: Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Vincent van Ravesteijn - TNW
Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.


We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer. 

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug report:

http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do something
with Snowleopard or not.

Vincent



Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Johannes Knaus

Hello,

I ordered the new Mac OS Snowleopard this week and I wonder if any of  
the Lyx-(Mac)-Developers has already tested Lyx under a Developer- 
Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



RE: Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Vincent van Ravesteijn - TNW
Hello,

I ordered the new Mac OS Snowleopard this week and I wonder
if any of the Lyx-(Mac)-Developers has already tested Lyx
under a Developer- Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.


We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer. 

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug report:

http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do something
with Snowleopard or not.

Vincent



Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Johannes Knaus

Hello,

I ordered the new Mac OS Snowleopard this week and I wonder if any of  
the Lyx-(Mac)-Developers has already tested Lyx under a Developer- 
Version of Snowleopard?

Will the Lyx-Binary run on Snowleopard?
Anyway, I'll test it and post it here.

Johannes.



RE: Will Lyx run on Mac OS X 10.6?

2009-08-27 Thread Vincent van Ravesteijn - TNW
>Hello,
>
>I ordered the new Mac OS Snowleopard this week and I wonder
>if any of the Lyx-(Mac)-Developers has already tested Lyx
>under a Developer- Version of Snowleopard?
>
>Will the Lyx-Binary run on Snowleopard?
>Anyway, I'll test it and post it here.
>
>Johannes.
>

We are a bit short on Mac developers, so I doubt that you'll get an
authorative answer. 

But, the good news is that I've heard of someone running LyX on
Snowleopard, the bad news is that I heard this by means of a bug report:

http://www.lyx.org/trac/ticket/6168.

So, it'll be interesting whether this crash actually has to do something
with Snowleopard or not.

Vincent