Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Georg Baum
Gisbert, Fernando wrote:

 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex,
 the resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:
 
 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}
 
 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone
 know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg



RE: Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Gisbert, Fernando
I tried the layout2layout.py script, and it works well, now the pdf document 
contains the index. Thanks very much for your help.


-Original Message-
From: news on behalf of Georg Baum
Sent: Wed 4/5/2006 8:47 AM
To: lyx-users@lists.lyx.org
Subject:  Re: problem with lyx-1.4.0 and beamer
 
Gisbert, Fernando wrote:

 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex,
 the resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:
 
 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}
 
 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone
 know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg





Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Georg Baum
Gisbert, Fernando wrote:

 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex,
 the resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:
 
 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}
 
 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone
 know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg



RE: Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Gisbert, Fernando
I tried the layout2layout.py script, and it works well, now the pdf document 
contains the index. Thanks very much for your help.


-Original Message-
From: news on behalf of Georg Baum
Sent: Wed 4/5/2006 8:47 AM
To: lyx-users@lists.lyx.org
Subject:  Re: problem with lyx-1.4.0 and beamer
 
Gisbert, Fernando wrote:

 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex,
 the resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:
 
 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}
 
 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone
 know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg





Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Georg Baum
Gisbert, Fernando wrote:

> Hi, I have a problem related with the pdf index generation with the beamer
> class. I write a simple lyx document, and when I view it with pdflatex,
> the resulting pdf leaves the left-side navigation panel empty, even using
> section and subsection environments in the lyx document. When I export the
> file to latex to see what happen, I see two strange lines:
> 
> \setcounter{secnumdepth}{-1000}
> \setcounter{tocdepth}{-1000}
> 
> that in previous beamer documents had a value of 3 instead of -1000. I
> don't know why these two numbers are set to -1000, and I also don't know
> how to reset them to its original value. By setting them to a reasonable
> value, let's say 3, for instance, the index appears again. Does anyone
> know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg



RE: Re: problem with lyx-1.4.0 and beamer

2006-04-05 Thread Gisbert, Fernando
I tried the layout2layout.py script, and it works well, now the pdf document 
contains the index. Thanks very much for your help.


-Original Message-
From: news on behalf of Georg Baum
Sent: Wed 4/5/2006 8:47 AM
To: lyx-users@lists.lyx.org
Subject:  Re: problem with lyx-1.4.0 and beamer
 
Gisbert, Fernando wrote:

> Hi, I have a problem related with the pdf index generation with the beamer
> class. I write a simple lyx document, and when I view it with pdflatex,
> the resulting pdf leaves the left-side navigation panel empty, even using
> section and subsection environments in the lyx document. When I export the
> file to latex to see what happen, I see two strange lines:
> 
> \setcounter{secnumdepth}{-1000}
> \setcounter{tocdepth}{-1000}
> 
> that in previous beamer documents had a value of 3 instead of -1000. I
> don't know why these two numbers are set to -1000, and I also don't know
> how to reset them to its original value. By setting them to a reasonable
> value, let's say 3, for instance, the index appears again. Does anyone
> know how to fix it?

This is a problem in the layout conversion script that converts layout files
from 1.3 format to 1.4 format. Please try the procedure I decsribed at
http://thread.gmane.org/gmane.editors.lyx.general/29518/focus=29518 and
report whether it works.


Georg





problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex, the
 resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:

 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}

 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone know
 how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

 I attach the lyx document.

 Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
http://www.appl-ecosys.com Voice: 503-667-4517  Fax: 503-667-8863


problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
 Hi, I have a problem related with the pdf index generation with the beamer
 class. I write a simple lyx document, and when I view it with pdflatex, the
 resulting pdf leaves the left-side navigation panel empty, even using
 section and subsection environments in the lyx document. When I export the
 file to latex to see what happen, I see two strange lines:

 \setcounter{secnumdepth}{-1000}
 \setcounter{tocdepth}{-1000}

 that in previous beamer documents had a value of 3 instead of -1000. I
 don't know why these two numbers are set to -1000, and I also don't know
 how to reset them to its original value. By setting them to a reasonable
 value, let's say 3, for instance, the index appears again. Does anyone know
 how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

 I attach the lyx document.

 Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
http://www.appl-ecosys.com Voice: 503-667-4517  Fax: 503-667-8863


problem with lyx-1.4.0 and beamer

2006-04-04 Thread Gisbert, Fernando
Title: problem with lyx-1.4.0 and beamer






Hi, I have a problem related with the pdf index generation with the beamer class. I write a simple lyx document, and when I view it with pdflatex, the resulting pdf leaves the left-side navigation panel empty, even using section and subsection environments in the lyx document. When I export the file to latex to see what happen, I see two strange lines:

\setcounter{secnumdepth}{-1000}
\setcounter{tocdepth}{-1000}

that in previous beamer documents had a value of 3 instead of -1000. I don't know why these two numbers are set to -1000, and I also don't know how to reset them to its original value. By setting them to a reasonable value, let's say 3, for instance, the index appears again. Does anyone know how to fix it?

I attach the lyx document.

Thanks.







beamer_wrong.lyx
Description: beamer_wrong.lyx


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Jose' Matos
On Tuesday 04 April 2006 17:30, Gisbert, Fernando wrote:
> Hi, I have a problem related with the pdf index generation with the beamer
> class. I write a simple lyx document, and when I view it with pdflatex, the
> resulting pdf leaves the left-side navigation panel empty, even using
> section and subsection environments in the lyx document. When I export the
> file to latex to see what happen, I see two strange lines:
>
> \setcounter{secnumdepth}{-1000}
> \setcounter{tocdepth}{-1000}
>
> that in previous beamer documents had a value of 3 instead of -1000. I
> don't know why these two numbers are set to -1000, and I also don't know
> how to reset them to its original value. By setting them to a reasonable
> value, let's say 3, for instance, the index appears again. Does anyone know
> how to fix it?

  There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

  Since it is impossible to do this directly from lyx I would expect either 
someone changed this value by hand or your beamer layout file has those 
values there.

  If you want to you can change both values by hand and the file will start to 
behave nicely.

> I attach the lyx document.
>
> Thanks.

-- 
José Abílio


Re: problem with lyx-1.4.0 and beamer

2006-04-04 Thread Rich Shepard

On Tue, 4 Apr 2006, Jose' Matos wrote:


 There are two lines in your file that explain this:

\secnumdepth -1000
\tocdepth -1000

Since it is impossible to do this directly from lyx I would expect either
someone changed this value by hand or your beamer layout file has those
values there.


  I believe that this _is_ related to the change from lyx-1.3.x to -1.4.0. I
noticed this also with a file that I copied from an earlier presentation and
altered. The original had

\secnumdepth 2
\tocdepth 2

but the copied file -- after being opened and saved in lyx-1.4.0 had those
values set to -1000.

  I, too, wondered what happened to the ToC, but in my rush to finish the
presentation I did not explore causes.

Rich

--
Richard B. Shepard, Ph.D. |  Quantifying subjectivity for the
Applied Ecosystem Services, Inc.(TM)  |  benefit of business and society.
 Voice: 503-667-4517  Fax: 503-667-8863