Changing Latex installation used in Lyx

2009-08-14 Thread Antonio Rieser
Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences-TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio


Re: Changing Latex installation used in Lyx

2009-08-14 Thread Paul A. Rubin

Antonio Rieser wrote:

Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences-TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio



If you are keeping the old LaTeX version around as well, you might want 
to check out Ubuntu's update-alternatives command (check the man page or 
google it).  I've only used it for Java, but it should be possible to 
use it to make the new TeXLive install the default choice.  Then run 
latex --version just to confirm the newer LaTeX is being chosen, after 
which try reconfiguring and restarting LyX.


If the new version is already the default choice, you may just need the 
last step (reconfigure/restart LyX).


/Paul



Re: Changing Latex installation used in Lyx

2009-08-14 Thread Ignacio García
Antonio Rieser tonyrie...@... writes:

 I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
 installed a new version of latex (texlive) in a different place from
 where the old one was, but I can't figure out how to get Lyx to
 recognize it.  All of the packages it lists in Preferences-TeX
 Configuration are from the old installation, and it won't compile when
 I use packages from the new configuration.
 
 Thanks in advance for your help.
 
   Antonio

Running on a command line 
   $ tex --version
you get the old version, then possibly the new TeX Live binary directory
isn't in your path.

Assuming a default custom installation (no .deb packages) of texlive 2008,
the directory of the binaries must be added to the search path.
In Ubuntu the default should be 

PATH=/usr/local/texlive/2008/bin/i386-linux:$PATH; export PATH 
MANPATH=/usr/local/texlive/2008/texmf/doc/man:$MANPATH; export MANPATH 
INFOPATH=/usr/local/texlive/2008/texmf/doc/info:$INFOPATH; export INFOPATH

these lines or the relevant ones in your system are added in your
.bashrc (or .profile) file in your HOME directory.

Then reconfigure LyX and try again.

I hope this is a help

Regards
Ignacio Garcia



Changing Latex installation used in Lyx

2009-08-14 Thread Antonio Rieser
Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences-TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio


Re: Changing Latex installation used in Lyx

2009-08-14 Thread Paul A. Rubin

Antonio Rieser wrote:

Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences-TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio



If you are keeping the old LaTeX version around as well, you might want 
to check out Ubuntu's update-alternatives command (check the man page or 
google it).  I've only used it for Java, but it should be possible to 
use it to make the new TeXLive install the default choice.  Then run 
latex --version just to confirm the newer LaTeX is being chosen, after 
which try reconfiguring and restarting LyX.


If the new version is already the default choice, you may just need the 
last step (reconfigure/restart LyX).


/Paul



Re: Changing Latex installation used in Lyx

2009-08-14 Thread Ignacio García
Antonio Rieser tonyrie...@... writes:

 I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
 installed a new version of latex (texlive) in a different place from
 where the old one was, but I can't figure out how to get Lyx to
 recognize it.  All of the packages it lists in Preferences-TeX
 Configuration are from the old installation, and it won't compile when
 I use packages from the new configuration.
 
 Thanks in advance for your help.
 
   Antonio

Running on a command line 
   $ tex --version
you get the old version, then possibly the new TeX Live binary directory
isn't in your path.

Assuming a default custom installation (no .deb packages) of texlive 2008,
the directory of the binaries must be added to the search path.
In Ubuntu the default should be 

PATH=/usr/local/texlive/2008/bin/i386-linux:$PATH; export PATH 
MANPATH=/usr/local/texlive/2008/texmf/doc/man:$MANPATH; export MANPATH 
INFOPATH=/usr/local/texlive/2008/texmf/doc/info:$INFOPATH; export INFOPATH

these lines or the relevant ones in your system are added in your
.bashrc (or .profile) file in your HOME directory.

Then reconfigure LyX and try again.

I hope this is a help

Regards
Ignacio Garcia



Changing Latex installation used in Lyx

2009-08-14 Thread Antonio Rieser
Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences->TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio


Re: Changing Latex installation used in Lyx

2009-08-14 Thread Paul A. Rubin

Antonio Rieser wrote:

Hi,

I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
installed a new version of latex (texlive) in a different place from
where the old one was, but I can't figure out how to get Lyx to
recognize it.  All of the packages it lists in Preferences->TeX
Configuration are from the old installation, and it won't compile when
I use packages from the new configuration.

Thanks in advance for your help.

  Antonio



If you are keeping the old LaTeX version around as well, you might want 
to check out Ubuntu's update-alternatives command (check the man page or 
google it).  I've only used it for Java, but it should be possible to 
use it to make the new TeXLive install the default choice.  Then run 
latex --version just to confirm the newer LaTeX is being chosen, after 
which try reconfiguring and restarting LyX.


If the new version is already the default choice, you may just need the 
last step (reconfigure/restart LyX).


/Paul



Re: Changing Latex installation used in Lyx

2009-08-14 Thread Ignacio García
Antonio Rieser  writes:

> I'm using Lyx 1.6.3, built from source, on Ubuntu 8.04. I recently
> installed a new version of latex (texlive) in a different place from
> where the old one was, but I can't figure out how to get Lyx to
> recognize it.  All of the packages it lists in Preferences->TeX
> Configuration are from the old installation, and it won't compile when
> I use packages from the new configuration.
> 
> Thanks in advance for your help.
> 
>   Antonio

Running on a command line 
   $> tex --version
you get the old version, then possibly the new TeX Live binary directory
isn't in your path.

Assuming a default custom installation (no .deb packages) of texlive 2008,
the directory of the binaries must be added to the search path.
In Ubuntu the default should be 

PATH=/usr/local/texlive/2008/bin/i386-linux:$PATH; export PATH 
MANPATH=/usr/local/texlive/2008/texmf/doc/man:$MANPATH; export MANPATH 
INFOPATH=/usr/local/texlive/2008/texmf/doc/info:$INFOPATH; export INFOPATH

these lines or the relevant ones in your system are added in your
.bashrc (or .profile) file in your HOME directory.

Then reconfigure LyX and try again.

I hope this is a help

Regards
Ignacio Garcia