Re: Adding a custom class template

2011-08-01 Thread Paul Rubin
Maxim Lobovsky maxim.lobovsky at gmail.com writes:

 The relevant files can be found attached to this forum post:
 http://www.latex-community.org/forum/viewtopic.php?f=19t=14360

That link gets me their version of a 404 error (The requested topic does not
exist.).  Did your dog by any chance eat the post?

 Additionally, when the compiled directly
 through pdflatex, it seems to work fine.

Does this mean you export the document from LyX to a .tex file, and that
compiles?  Or do you mean that you created a test file outside LyX (in TeXWorks)
and that file compiled?

 But when viewing the log output by LyX, I don't see that line there
 and I see this instead(C:\Program Files (x86)\MiKTeX
   2.9\tex\latex\base\report.cls

Without access to the layout file, it's hard to say what caused this.  Two
questions: (1) what name did you give to the layout file; and (2) what is the
second line of the layout file (should contain \DeclareLaTeXClass)?

Paul



Re: Adding a custom class template

2011-08-01 Thread Paul Rubin
Maxim Lobovsky maxim.lobovsky at gmail.com writes:

 The relevant files can be found attached to this forum post:
 http://www.latex-community.org/forum/viewtopic.php?f=19t=14360

That link gets me their version of a 404 error (The requested topic does not
exist.).  Did your dog by any chance eat the post?

 Additionally, when the compiled directly
 through pdflatex, it seems to work fine.

Does this mean you export the document from LyX to a .tex file, and that
compiles?  Or do you mean that you created a test file outside LyX (in TeXWorks)
and that file compiled?

 But when viewing the log output by LyX, I don't see that line there
 and I see this instead(C:\Program Files (x86)\MiKTeX
   2.9\tex\latex\base\report.cls

Without access to the layout file, it's hard to say what caused this.  Two
questions: (1) what name did you give to the layout file; and (2) what is the
second line of the layout file (should contain \DeclareLaTeXClass)?

Paul



Re: Adding a custom class template

2011-08-01 Thread Paul Rubin
Maxim Lobovsky  gmail.com> writes:

> The relevant files can be found attached to this forum post:
> http://www.latex-community.org/forum/viewtopic.php?f=19=14360

That link gets me their version of a 404 error ("The requested topic does not
exist.").  Did your dog by any chance eat the post?

> Additionally, when the compiled directly
> through pdflatex, it seems to work fine.

Does this mean you export the document from LyX to a .tex file, and that
compiles?  Or do you mean that you created a test file outside LyX (in TeXWorks)
and that file compiled?

> But when viewing the log output by LyX, I don't see that line there
> and I see this instead("C:\Program Files (x86)\MiKTeX
>   2.9\tex\latex\base\report.cls"

Without access to the layout file, it's hard to say what caused this.  Two
questions: (1) what name did you give to the layout file; and (2) what is the
second line of the layout file (should contain \DeclareLaTeXClass)?

Paul