Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread rgheck

Uwe Stöhr wrote:

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:
I am trying elyxer under the last version of Lyx (1.6.3) . I have 
followed

the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it? What did we decide about the format? Is it 
also html, or is it some other format?


rh


regards Uwe




Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread Uwe Stöhr

rgheck schrieb:

No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it?


If you made a knot into your towel, will the next Tuesday be sunny? ;-)

What did we decide about the format? Is it 
also html, or is it some other format?


I don't understand. It is html because it produces html, for more details, see our current 
configure.py in branch.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread rgheck

Uwe Stöhr wrote:

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:
I am trying elyxer under the last version of Lyx (1.6.3) . I have 
followed

the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it? What did we decide about the format? Is it 
also html, or is it some other format?


rh


regards Uwe




Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread Uwe Stöhr

rgheck schrieb:

No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it?


If you made a knot into your towel, will the next Tuesday be sunny? ;-)

What did we decide about the format? Is it 
also html, or is it some other format?


I don't understand. It is html because it produces html, for more details, see our current 
configure.py in branch.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread rgheck

Uwe Stöhr wrote:

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglu wrote:
I am trying elyxer under the last version of Lyx (1.6.3) . I have 
followed

the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it? What did we decide about the format? Is it 
also html, or is it some other format?


rh


regards Uwe




Re: Elyxer and Lyx 1.6.3

2009-06-14 Thread Uwe Stöhr

rgheck schrieb:

No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX 
to recognize eLyXer, you need to add the path to the eLyXer.py file to 
LyX's PATH in the preferences.


If you've previously done any sort of customization to your preferences, 
will LyX still recognize it?


If you made a knot into your towel, will the next Tuesday be sunny? ;-)

What did we decide about the format? Is it 
also html, or is it some other format?


I don't understand. It is html because it produces html, for more details, see our current 
configure.py in branch.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Olivier Ripoll

Murat Yildizoglu wrote:

Hi,
I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


I managed to get elyxer working by doing the following:

- copy elyxer.py to the script folder (C:\Program Files\LyX
1.6.3\Resources\scripts)
on my machine,- in Preferences - Converters, in the LyX - HTML, modify the
command to be:


python $$s/scripts/elyxer.py $$i $$o


I have installed the last version (0.29) of the elyxer.py script in the
folder indicated by Olivier and changed Lyx-HTML conversion command as
indicated.
I have done a reconfigure, just incase.


Hi,

First, in the same thread, I was indicating that I had a problem with 
reconfigure:


To have it to work, I have to reconfigure, then close lyx, reopen, 
reconfigure, close again, and only at the second restart, I had it to 
work. Try that, and perhaps the problem will be solved.


If it still fails, then you should follow the instructions given by Uwe 
in the same thread, namely:
But even now, LyX will recognize eLyXer when you have it installed. All 
you have to do is to add the path to the file elyxer.py in the PATH 
prefix in LyX's preferences. Then reconfigure LyX and eLyXer should work.


I think that if you install in the lyx resources script folder, you 
should not need to do it, but in case, you may try it.



I actually have a different situation, so if everything still fail, here 
it is: elyxer is installed in Program Files, and this folder was added 
to LyX path. So it's the one seen by reconfigure script (I think). Then 
only, I copy the script in LyX's script folder.


Good luck !

Best regards,

Olivier.




But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
I am probably missing something but I do not know what :-(

Sorry if I am making a stupid mistake but I would appreciate a lot your help
at this point, since I am just blocked...

Regards,

Murat




Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Uwe Stöhr

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:

I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to recognize eLyXer, you need 
to add the path to the eLyXer.py file to LyX's PATH in the preferences.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Alex Fernandez
Hi Uwe,

On Sat, Jun 13, 2009 at 5:16 PM, Uwe Stöhruwesto...@web.de wrote:
 Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
 downloaded it to try, but I was under that impression. Well, maybe
 not.

 No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to
 recognize eLyXer, you need to add the path to the eLyXer.py file to LyX's
 PATH in the preferences.

That is actually what I meant with support: recognize it and use it
if present. Sorry for the confusion.

Alex.


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Olivier Ripoll

Murat Yildizoglu wrote:

Hi,
I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


I managed to get elyxer working by doing the following:

- copy elyxer.py to the script folder (C:\Program Files\LyX
1.6.3\Resources\scripts)
on my machine,- in Preferences - Converters, in the LyX - HTML, modify the
command to be:


python $$s/scripts/elyxer.py $$i $$o


I have installed the last version (0.29) of the elyxer.py script in the
folder indicated by Olivier and changed Lyx-HTML conversion command as
indicated.
I have done a reconfigure, just incase.


Hi,

First, in the same thread, I was indicating that I had a problem with 
reconfigure:


To have it to work, I have to reconfigure, then close lyx, reopen, 
reconfigure, close again, and only at the second restart, I had it to 
work. Try that, and perhaps the problem will be solved.


If it still fails, then you should follow the instructions given by Uwe 
in the same thread, namely:
But even now, LyX will recognize eLyXer when you have it installed. All 
you have to do is to add the path to the file elyxer.py in the PATH 
prefix in LyX's preferences. Then reconfigure LyX and eLyXer should work.


I think that if you install in the lyx resources script folder, you 
should not need to do it, but in case, you may try it.



I actually have a different situation, so if everything still fail, here 
it is: elyxer is installed in Program Files, and this folder was added 
to LyX path. So it's the one seen by reconfigure script (I think). Then 
only, I copy the script in LyX's script folder.


Good luck !

Best regards,

Olivier.




But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
I am probably missing something but I do not know what :-(

Sorry if I am making a stupid mistake but I would appreciate a lot your help
at this point, since I am just blocked...

Regards,

Murat




Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Uwe Stöhr

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:

I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to recognize eLyXer, you need 
to add the path to the eLyXer.py file to LyX's PATH in the preferences.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Alex Fernandez
Hi Uwe,

On Sat, Jun 13, 2009 at 5:16 PM, Uwe Stöhruwesto...@web.de wrote:
 Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
 downloaded it to try, but I was under that impression. Well, maybe
 not.

 No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to
 recognize eLyXer, you need to add the path to the eLyXer.py file to LyX's
 PATH in the preferences.

That is actually what I meant with support: recognize it and use it
if present. Sorry for the confusion.

Alex.


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Olivier Ripoll

Murat Yildizoglu wrote:

Hi,
I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


"I managed to get elyxer working by doing the following:

- copy elyxer.py to the script folder ("C:\Program Files\LyX
1.6.3\Resources\scripts")
on my machine,- in Preferences -> Converters, in the LyX -> HTML, modify the
command to be:


python $$s/scripts/elyxer.py $$i $$o"


I have installed the last version (0.29) of the elyxer.py script in the
folder indicated by Olivier and changed Lyx->HTML conversion command as
indicated.
I have done a reconfigure, just incase.


Hi,

First, in the same thread, I was indicating that I had a problem with 
reconfigure:


To have it to work, I have to reconfigure, then close lyx, reopen, 
reconfigure, close again, and only at the second restart, I had it to 
work. Try that, and perhaps the problem will be solved.


If it still fails, then you should follow the instructions given by Uwe 
in the same thread, namely:
"But even now, LyX will recognize eLyXer when you have it installed. All 
you have to do is to add the path to the file elyxer.py in the PATH 
prefix in LyX's preferences. Then reconfigure LyX and eLyXer should work."


I think that if you install in the lyx resources script folder, you 
should not need to do it, but in case, you may try it.



I actually have a different situation, so if everything still fail, here 
it is: elyxer is installed in "Program Files", and this folder was added 
to LyX path. So it's the one seen by reconfigure script (I think). Then 
only, I copy the script in LyX's script folder.


Good luck !

Best regards,

Olivier.




But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
I am probably missing something but I do not know what :-(

Sorry if I am making a stupid mistake but I would appreciate a lot your help
at this point, since I am just blocked...

Regards,

Murat




Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Uwe Stöhr

Alex Fernandez schrieb:


On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglu wrote:

I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
the instructions in the list given by Olivier:


Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.


No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to recognize eLyXer, you need 
to add the path to the eLyXer.py file to LyX's PATH in the preferences.


regards Uwe


Re: Elyxer and Lyx 1.6.3

2009-06-13 Thread Alex Fernandez
Hi Uwe,

On Sat, Jun 13, 2009 at 5:16 PM, Uwe Stöhr wrote:
>> Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
>> downloaded it to try, but I was under that impression. Well, maybe
>> not.
>
> No, but LyX 1.6.3 recognizes eLyXer when it is installed. To help LyX to
> recognize eLyXer, you need to add the path to the eLyXer.py file to LyX's
> PATH in the preferences.

That is actually what I meant with "support": recognize it and use it
if present. Sorry for the confusion.

Alex.


Re: Elyxer and Lyx 1.6.3

2009-06-12 Thread Alex Fernandez
Hi Murat,

On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:
 I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
 the instructions in the list given by Olivier:

Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.

 But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
 I am probably missing something but I do not know what :-(

I am sorry I can't help you. Surely someone else on the list can help
you. Meanwhile you can try manual conversion on a DOS terminal,
writing:
   Python.exe route_to_elyxer\elyxer.py filein.lyx fileout.html

Let us hope that LyX 1.6.4 comes already preconfigured to use eLyXer
and that the Windows installer optionally installs it. It would solve
a lot of problems for users.

Thanks,

Alex.


Re: Elyxer and Lyx 1.6.3

2009-06-12 Thread Alex Fernandez
Hi Murat,

On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglumurat.yildizo...@univ-cezanne.fr wrote:
 I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
 the instructions in the list given by Olivier:

Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.

 But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
 I am probably missing something but I do not know what :-(

I am sorry I can't help you. Surely someone else on the list can help
you. Meanwhile you can try manual conversion on a DOS terminal,
writing:
   Python.exe route_to_elyxer\elyxer.py filein.lyx fileout.html

Let us hope that LyX 1.6.4 comes already preconfigured to use eLyXer
and that the Windows installer optionally installs it. It would solve
a lot of problems for users.

Thanks,

Alex.


Re: Elyxer and Lyx 1.6.3

2009-06-12 Thread Alex Fernandez
Hi Murat,

On Fri, Jun 12, 2009 at 4:56 PM, Murat
Yildizoglu wrote:
> I am trying elyxer under the last version of Lyx (1.6.3) . I have followed
> the instructions in the list given by Olivier:

Wasn't LyX 1.6.3 supposed to support eLyXer out of the box? I haven't
downloaded it to try, but I was under that impression. Well, maybe
not.

> But, when I do View/HTML or Export/HTML Lyx continues to try to run htlatex.
> I am probably missing something but I do not know what :-(

I am sorry I can't help you. Surely someone else on the list can help
you. Meanwhile you can try manual conversion on a DOS terminal,
writing:
  > Python.exe \elyxer.py filein.lyx fileout.html

Let us hope that LyX 1.6.4 comes already preconfigured to use eLyXer
and that the Windows installer optionally installs it. It would solve
a lot of problems for users.

Thanks,

Alex.