Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
Could you attach a minimal real *.lyx file? I do not understand what
pseudo-html markup means.

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark mark.dalp...@pacificedge.co.nz wrote:
 Hi,

 Running lyx, version 2.0.5, built from source today.
 Host system is (old): kubuntu 8.04

 I am writing an in-house document which shows how to use Sweave. This means 
 I
 want to both show the Sweave code and then the results of the Sweave code
 being run. This has worked in the distant past (lyx version 1.4?) but as I
 update the document now, I am having problems.

 In my example below, I use pseudo-html markup to show the Lyx paragraph types.

 Eg:
 Lyx-code paragraph:
echo=FALSE,results=tex=
 print( toLatex( sessionInfo() ))
 @
 /lyx-code

 chunk paragraph:
 echo=FALSE,results=tex=
 print( toLatex( sessionInfo() ))
 @
 /chunk

 This works fine (as expected) except that the AT-sign, '@', in the lyx-code
 paragraph gets eaten and does not show up in the output. I can circumvent 
 the
 problem by adding a thin-space in front of the '@', however, it implies that I
 need to know when characters will be eaten. I don't know the rules yet.

 If I use the File -- Export -- LaTeX (plain) option, there is no '@' in the
 tex file.

 Cheers,
 Mark



Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Mark Dalphin

I have created and attached a simple example showing the error.

[If this is a double-post, I apologize. I have subscribed to the 
lyx-user maillist as the first posting did not appear to work]


Regards,
Mark

Yihui Xie wrote:

Could you attach a minimal real *.lyx file? I do not understand what
pseudo-html markup means.

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark mark.dalp...@pacificedge.co.nz wrote:
  

Hi,

Running lyx, version 2.0.5, built from source today.
Host system is (old): kubuntu 8.04

I am writing an in-house document which shows how to use Sweave. This means I
want to both show the Sweave code and then the results of the Sweave code
being run. This has worked in the distant past (lyx version 1.4?) but as I
update the document now, I am having problems.

In my example below, I use pseudo-html markup to show the Lyx paragraph types.

Eg:
Lyx-code paragraph:
   echo=FALSE,results=tex=
print( toLatex( sessionInfo() ))
@
/lyx-code

chunk paragraph:
echo=FALSE,results=tex=
print( toLatex( sessionInfo() ))
@
/chunk

This works fine (as expected) except that the AT-sign, '@', in the lyx-code
paragraph gets eaten and does not show up in the output. I can circumvent the
problem by adding a thin-space in front of the '@', however, it implies that I
need to know when characters will be eaten. I don't know the rules yet.

If I use the File -- Export -- LaTeX (plain) option, there is no '@' in the
tex file.

Cheers,
Mark




--



Mark Dalphin Ph.D.

Director of Bioinformatics

mark.dalp...@pacificedge.co.nz mailto:mark.dalp...@pacificedge.co.nz
*Ph:* +64-3-479-5805
*Cell:* +64-21-156-7625
*Skype:* mark.dalphin.pel
http://www.facebook.com/pages/Pacific-Edge/111356775582456
http://twitter.com/#%21/pacificEdgeLtd
http://www.youtube.com/PacificEdgeLtd

87 St David St, PO Box 56, Dunedin, New Zealand 9016www.pacificedge.co.nz




simpleExample.lyx
Description: application/lyx
attachment: mark_dalphin.vcf

Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
[We did receive two posts; your email client may not post your own
email to your own account.]

I can reproduce your problem with the example, but I guess that is
probably due to Sweave instead of LyX -- it interprets @ as the
beginning of text chunks, hence it is removed in the tex output. To
verify this, you can try the knitr module after
install.packages('knitr') in R, and @ will be there as expected. In
case you are not aware of it, knitr is an alternative to Sweave (and
I'm shamelessly advertising here).

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 9:01 PM, Mark Dalphin
mark.dalp...@pacificedge.co.nz wrote:
 I have created and attached a simple example showing the error.

 [If this is a double-post, I apologize. I have subscribed to the lyx-user
 maillist as the first posting did not appear to work]


 Regards,
 Mark



Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Scott Kostyshak
On Mon, Nov 12, 2012 at 10:16 PM, Yihui Xie x...@yihui.name wrote:

 In case you are not aware of it, knitr is an alternative to Sweave (and
 I'm shamelessly advertising here).

As you should be! +1 for knitr over Sweave. knitr can do everything
plus more and it's author/maintainer is extremely responsive.

Scott


Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
Could you attach a minimal real *.lyx file? I do not understand what
pseudo-html markup means.

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark mark.dalp...@pacificedge.co.nz wrote:
 Hi,

 Running lyx, version 2.0.5, built from source today.
 Host system is (old): kubuntu 8.04

 I am writing an in-house document which shows how to use Sweave. This means 
 I
 want to both show the Sweave code and then the results of the Sweave code
 being run. This has worked in the distant past (lyx version 1.4?) but as I
 update the document now, I am having problems.

 In my example below, I use pseudo-html markup to show the Lyx paragraph types.

 Eg:
 Lyx-code paragraph:
echo=FALSE,results=tex=
 print( toLatex( sessionInfo() ))
 @
 /lyx-code

 chunk paragraph:
 echo=FALSE,results=tex=
 print( toLatex( sessionInfo() ))
 @
 /chunk

 This works fine (as expected) except that the AT-sign, '@', in the lyx-code
 paragraph gets eaten and does not show up in the output. I can circumvent 
 the
 problem by adding a thin-space in front of the '@', however, it implies that I
 need to know when characters will be eaten. I don't know the rules yet.

 If I use the File -- Export -- LaTeX (plain) option, there is no '@' in the
 tex file.

 Cheers,
 Mark



Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Mark Dalphin

I have created and attached a simple example showing the error.

[If this is a double-post, I apologize. I have subscribed to the 
lyx-user maillist as the first posting did not appear to work]


Regards,
Mark

Yihui Xie wrote:

Could you attach a minimal real *.lyx file? I do not understand what
pseudo-html markup means.

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark mark.dalp...@pacificedge.co.nz wrote:
  

Hi,

Running lyx, version 2.0.5, built from source today.
Host system is (old): kubuntu 8.04

I am writing an in-house document which shows how to use Sweave. This means I
want to both show the Sweave code and then the results of the Sweave code
being run. This has worked in the distant past (lyx version 1.4?) but as I
update the document now, I am having problems.

In my example below, I use pseudo-html markup to show the Lyx paragraph types.

Eg:
Lyx-code paragraph:
   echo=FALSE,results=tex=
print( toLatex( sessionInfo() ))
@
/lyx-code

chunk paragraph:
echo=FALSE,results=tex=
print( toLatex( sessionInfo() ))
@
/chunk

This works fine (as expected) except that the AT-sign, '@', in the lyx-code
paragraph gets eaten and does not show up in the output. I can circumvent the
problem by adding a thin-space in front of the '@', however, it implies that I
need to know when characters will be eaten. I don't know the rules yet.

If I use the File -- Export -- LaTeX (plain) option, there is no '@' in the
tex file.

Cheers,
Mark




--



Mark Dalphin Ph.D.

Director of Bioinformatics

mark.dalp...@pacificedge.co.nz mailto:mark.dalp...@pacificedge.co.nz
*Ph:* +64-3-479-5805
*Cell:* +64-21-156-7625
*Skype:* mark.dalphin.pel
http://www.facebook.com/pages/Pacific-Edge/111356775582456
http://twitter.com/#%21/pacificEdgeLtd
http://www.youtube.com/PacificEdgeLtd

87 St David St, PO Box 56, Dunedin, New Zealand 9016www.pacificedge.co.nz




simpleExample.lyx
Description: application/lyx
attachment: mark_dalphin.vcf

Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
[We did receive two posts; your email client may not post your own
email to your own account.]

I can reproduce your problem with the example, but I guess that is
probably due to Sweave instead of LyX -- it interprets @ as the
beginning of text chunks, hence it is removed in the tex output. To
verify this, you can try the knitr module after
install.packages('knitr') in R, and @ will be there as expected. In
case you are not aware of it, knitr is an alternative to Sweave (and
I'm shamelessly advertising here).

Regards,
Yihui
--
Yihui Xie xieyi...@gmail.com
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 9:01 PM, Mark Dalphin
mark.dalp...@pacificedge.co.nz wrote:
 I have created and attached a simple example showing the error.

 [If this is a double-post, I apologize. I have subscribed to the lyx-user
 maillist as the first posting did not appear to work]


 Regards,
 Mark



Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Scott Kostyshak
On Mon, Nov 12, 2012 at 10:16 PM, Yihui Xie x...@yihui.name wrote:

 In case you are not aware of it, knitr is an alternative to Sweave (and
 I'm shamelessly advertising here).

As you should be! +1 for knitr over Sweave. knitr can do everything
plus more and it's author/maintainer is extremely responsive.

Scott


Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
Could you attach a minimal real *.lyx file? I do not understand what
"pseudo-html markup" means.

Regards,
Yihui
--
Yihui Xie 
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark  wrote:
> Hi,
>
> Running lyx, version 2.0.5, built from source today.
> Host system is (old): kubuntu 8.04
>
> I am writing an in-house document which shows how to use "Sweave". This means 
> I
> want to both show the "Sweave" code and then the results of the Sweave code
> being run. This has worked in the distant past (lyx version 1.4?) but as I
> update the document now, I am having problems.
>
> In my example below, I use pseudo-html markup to show the Lyx paragraph types.
>
> Eg:
>  paragraph:
>

Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Mark Dalphin

I have created and attached a simple example showing the error.

[If this is a double-post, I apologize. I have subscribed to the 
lyx-user maillist as the first posting did not appear to work]


Regards,
Mark

Yihui Xie wrote:

Could you attach a minimal real *.lyx file? I do not understand what
"pseudo-html markup" means.

Regards,
Yihui
--
Yihui Xie 
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 7:26 PM, Mark  wrote:
  

Hi,

Running lyx, version 2.0.5, built from source today.
Host system is (old): kubuntu 8.04

I am writing an in-house document which shows how to use "Sweave". This means I
want to both show the "Sweave" code and then the results of the Sweave code
being run. This has worked in the distant past (lyx version 1.4?) but as I
update the document now, I am having problems.

In my example below, I use pseudo-html markup to show the Lyx paragraph types.

Eg:
 paragraph:
   

Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Yihui Xie
[We did receive two posts; your email client may not post your own
email to your own account.]

I can reproduce your problem with the example, but I guess that is
probably due to Sweave instead of LyX -- it interprets @ as the
beginning of text chunks, hence it is removed in the tex output. To
verify this, you can try the knitr module after
install.packages('knitr') in R, and @ will be there as expected. In
case you are not aware of it, knitr is an alternative to Sweave (and
I'm shamelessly advertising here).

Regards,
Yihui
--
Yihui Xie 
Phone: 515-294-2465 Web: http://yihui.name
Department of Statistics, Iowa State University
2215 Snedecor Hall, Ames, IA


On Mon, Nov 12, 2012 at 9:01 PM, Mark Dalphin
 wrote:
> I have created and attached a simple example showing the error.
>
> [If this is a double-post, I apologize. I have subscribed to the lyx-user
> maillist as the first posting did not appear to work]
>
>
> Regards,
> Mark
>


Re: Having a problem including an AT, '@', in my output (Document module = Sweave)

2012-11-12 Thread Scott Kostyshak
On Mon, Nov 12, 2012 at 10:16 PM, Yihui Xie  wrote:

> In case you are not aware of it, knitr is an alternative to Sweave (and
> I'm shamelessly advertising here).

As you should be! +1 for knitr over Sweave. knitr can do everything
plus more and it's author/maintainer is extremely responsive.

Scott