Re: Upgrading to Lyx 2.2

2016-06-08 Thread Scott Kostyshak
On Mon, Jun 06, 2016 at 01:57:11PM -0400, Scott Kostyshak wrote:
> On Mon, May 30, 2016 at 12:21:47PM -0400, Scott Kostyshak wrote:
> > On Mon, May 30, 2016 at 02:43:57PM +0200, Charles de Miramon wrote:
> > > Kornel Benko wrote:
> > > 
> > > > Knowing what went wrong, why are you doing it again?
> > > > Simply remove your local copy of cua.bind. Lyx will use the system
> > > > version.
> > > > 
> > > 
> > > Of course.
> > 
> > Glad the issue is solved.
> > 
> > Can you please send your old cua.bind? If it had an older format it
> > should have been updated automatically.
> 
> Hi Charles,
> 
> Would you mind sharing your old cua.bind file? There might be a bug in
> LyX that we should fix.

Charles kindly sent me the file. The problem was that there was a bind
definition before the Format line:

\bind "M-l" "flex-insert Latin"

We could consider moving the Format line to the first line of the file
to avoid future confusion, but I'm not sure it is worth it.

I'm moving this discussion to lyx-devel (if indeed there is future
discussion).

Scott


signature.asc
Description: PGP signature


Re: Upgrading to Lyx 2.2

2016-06-06 Thread Scott Kostyshak
On Mon, May 30, 2016 at 12:21:47PM -0400, Scott Kostyshak wrote:
> On Mon, May 30, 2016 at 02:43:57PM +0200, Charles de Miramon wrote:
> > Kornel Benko wrote:
> > 
> > > Knowing what went wrong, why are you doing it again?
> > > Simply remove your local copy of cua.bind. Lyx will use the system
> > > version.
> > > 
> > 
> > Of course.
> 
> Glad the issue is solved.
> 
> Can you please send your old cua.bind? If it had an older format it
> should have been updated automatically.

Hi Charles,

Would you mind sharing your old cua.bind file? There might be a bug in
LyX that we should fix.

Thanks,

Scott

> 
> Thanks,
> 
> Scott
> > 
> > Charles
> > 




signature.asc
Description: PGP signature


LyX Qt5 PPA (was: Re: Upgrading to Lyx 2.2)

2016-05-31 Thread Liviu Andronic
On Tue, May 31, 2016 at 6:58 PM, Jürgen Spitzmüller  wrote:
> Am Montag, den 30.05.2016, 11:02 +0200 schrieb UD:
>> Thanks a lot--  I have now upgraded to 2.2 without issues.  Now if I
>> could only get the Lyx icons on my Yoga 2 Pro HiDPI to be a little
>> bigger so I could actually see them, I might even be happy!
>
> Try right-click on the toolbar and select "Huge" or "Giant". (This
> should not be needed IMHO, LyX should scale the icons appropriately if
> HiDPI is detected, but this is unfortunately not the case).
>
> Note also that, with Linux, you might need to pass a specific value to
> activate Qt's HiDPI support via .profile
>
> depending on your Qt version it is either
>
> export QT_AUTO_SCREEN_SCALE_FACTOR=1
> (as of Qt 5.6)
>
> or
>
> export QT_DEVICE_PIXEL_RATIO=auto
> (Qt 5.4 and 5.5)
>

I've now prepared a "LyX Qt5 (release)" specifically for packages of
LyX built against Qt5 >=5.5.1 :
https://launchpad.net/~lyx-devel/+archive/ubuntu/release-qt5

For now only Xenial packages are available. Older Qt5 releases have
significant problems with LyX, so older Ubuntu distros are not
supported.

Those who need HiDPI support please check the packages (they will
replace your current Qt4 builds) and report on the list if you
encounter issues.

Regards,
Liviu


> HTH
> (works well for me on the same machine)
>
> Jürgen
>
>
>> Yours,
>> EK
>>
>



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: Upgrading to Lyx 2.2

2016-05-31 Thread Jürgen Spitzmüller
Am Montag, den 30.05.2016, 11:02 +0200 schrieb UD:
> Thanks a lot--  I have now upgraded to 2.2 without issues.  Now if I
> could only get the Lyx icons on my Yoga 2 Pro HiDPI to be a little
> bigger so I could actually see them, I might even be happy!

Try right-click on the toolbar and select "Huge" or "Giant". (This
should not be needed IMHO, LyX should scale the icons appropriately if
HiDPI is detected, but this is unfortunately not the case).

Note also that, with Linux, you might need to pass a specific value to
activate Qt's HiDPI support via .profile

depending on your Qt version it is either

export QT_AUTO_SCREEN_SCALE_FACTOR=1
(as of Qt 5.6)

or

export QT_DEVICE_PIXEL_RATIO=auto
(Qt 5.4 and 5.5)

HTH
(works well for me on the same machine)

Jürgen


> Yours,
> EK
> 



Re: Upgrading to Lyx 2.2

2016-05-31 Thread Helge Hafting



Den 31. mai 2016 01:27, skrev Paul A. Rubin:
"Complete" reinstall actually left my ~/.lyx directory intact, so it 
worked out fine.


This is as expected with Debian/Ubuntu. "apt" and "dpkg" is not supposed 
to touch anything in ~/  (/home/) at all, these utiltites only work with 
system directories. (/etc /usr /bin /var)


Helge Hafting


Re: Upgrading to Lyx 2.2

2016-05-30 Thread Paul A. Rubin



On 05/30/2016 05:02 PM, Liviu Andronic wrote:

> Not sure if it's related, but when I tried to update from Liv's (stable) PPA
> on a Mint Rebecca machine (based on Ubuntu 14.04), the update failed with a
> message that it was attempting to overwrite an icon file. Why that would be
> a problem I have no idea.

Yes, that may happen. I thought I have fixed that, but apparently not.
In any case, either apt-get install -f or uninstalling then
reinstalling should probably take care of this.

"Complete" reinstall actually left my ~/.lyx directory intact, so it 
worked out fine.


Thanks for maintaining the PPAs! Sure beats waiting for Canonical to 
catch up.


Paul


Re: Upgrading to Lyx 2.2

2016-05-30 Thread Liviu Andronic
On Mon, May 30, 2016 at 9:51 PM, Paul A. Rubin  wrote:
> Julio Rojas  gmail.com> writes:
>
>>
>> I am on 14.04 and a problem appear in the automatic updater, asking me to
> apt-get install -f on a console, which apparently run fine. Any idea on what
> happened?
>
> Not sure if it's related, but when I tried to update from Liv's (stable) PPA
> on a Mint Rebecca machine (based on Ubuntu 14.04), the update failed with a
> message that it was attempting to overwrite an icon file. Why that would be
> a problem I have no idea.
>
Yes, that may happen. I thought I have fixed that, but apparently not.
In any case, either apt-get install -f or uninstalling then
reinstalling should probably take care of this.

Regards,
Liviu


> After than, Synaptic wouldn't do anything until I
> fixed broken packages, and the "fix broken packages" menu item in Synaptic
> didn't seem to actually fix them. So I did a complete uninstall of LyX 2.1.4
> (including common) and then a fresh install, and everything worked. On a
> second Rebecca machine, I went straight to a complete uninstall/fresh
> install with no problems.
>
> Paul
>
>



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: Upgrading to Lyx 2.2

2016-05-30 Thread Paul A . Rubin
Julio Rojas  gmail.com> writes:

> 
> I am on 14.04 and a problem appear in the automatic updater, asking me to
apt-get install -f on a console, which apparently run fine. Any idea on what
happened?

Not sure if it's related, but when I tried to update from Liv's (stable) PPA
on a Mint Rebecca machine (based on Ubuntu 14.04), the update failed with a
message that it was attempting to overwrite an icon file. Why that would be
a problem I have no idea. After than, Synaptic wouldn't do anything until I
fixed broken packages, and the "fix broken packages" menu item in Synaptic
didn't seem to actually fix them. So I did a complete uninstall of LyX 2.1.4
(including common) and then a fresh install, and everything worked. On a
second Rebecca machine, I went straight to a complete uninstall/fresh
install with no problems.

Paul




Re: Upgrading to Lyx 2.2

2016-05-30 Thread Scott Kostyshak
On Mon, May 30, 2016 at 02:43:57PM +0200, Charles de Miramon wrote:
> Kornel Benko wrote:
> 
> > Knowing what went wrong, why are you doing it again?
> > Simply remove your local copy of cua.bind. Lyx will use the system
> > version.
> > 
> 
> Of course.

Glad the issue is solved.

Can you please send your old cua.bind? If it had an older format it
should have been updated automatically.

Thanks,

Scott
> 
> Charles
> 


signature.asc
Description: PGP signature


Re: Upgrading to Lyx 2.2

2016-05-30 Thread Charles de Miramon
Kornel Benko wrote:

> Knowing what went wrong, why are you doing it again?
> Simply remove your local copy of cua.bind. Lyx will use the system
> version.
> 

Of course.

Charles



Re: Upgrading to Lyx 2.2

2016-05-30 Thread Kornel Benko
Am Montag, 30. Mai 2016 um 12:12:03, schrieb Charles de Miramon 

> Liviu Andronic wrote:
> 
> 
> > 2.2.0 packages are now available on the PPA, including for 16.04:
> > https://launchpad.net/~lyx-devel/+archive/ubuntu/release
> > 
> > Please report on the list if you encounter any issues with the packaging.
> > 
> 
> Thank you Liviu for the packages !
> 
> I have updated LyX on Ubuntu 14.04 with the apt-get -f install trick.
> 
> It is working but I have lost shortcuts Ctrl-x, Ctrl-c, etc...
> 
> My personal cua.bind was not upgraded by installing the new version. Mine 
> was a format 2 and it seems now it has jumped to format 4.
> 
> I had to go into my lyx directory :
> 
> cd ~./lyx/bind
> 
> and copy the new cua.bind
> 
> cp /usr/share/lyx/bind/cua.bind .
> 
> 
> and restart LyX and now it works. 
> 
> I guess it is something specific to me and I must have copied the cua.bind 
> some times ago in my personal LyX directory and modified it. 

Knowing what went wrong, why are you doing it again?
Simply remove your local copy of cua.bind. Lyx will use the system version.

> I did not see an error message when loading LyX explaining that the bind 
> file was in an obsolete format.
> 
> Cheers,
> Charles
> 

Kornel

signature.asc
Description: This is a digitally signed message part.


Re: Upgrading to Lyx 2.2

2016-05-30 Thread Charles de Miramon
Liviu Andronic wrote:


> 2.2.0 packages are now available on the PPA, including for 16.04:
> https://launchpad.net/~lyx-devel/+archive/ubuntu/release
> 
> Please report on the list if you encounter any issues with the packaging.
> 

Thank you Liviu for the packages !

I have updated LyX on Ubuntu 14.04 with the apt-get -f install trick.

It is working but I have lost shortcuts Ctrl-x, Ctrl-c, etc...

My personal cua.bind was not upgraded by installing the new version. Mine 
was a format 2 and it seems now it has jumped to format 4.

I had to go into my lyx directory :

cd ~./lyx/bind

and copy the new cua.bind

cp /usr/share/lyx/bind/cua.bind .


and restart LyX and now it works. 

I guess it is something specific to me and I must have copied the cua.bind 
some times ago in my personal LyX directory and modified it. 

I did not see an error message when loading LyX explaining that the bind 
file was in an obsolete format.

Cheers,
Charles







Re: Upgrading to Lyx 2.2

2016-05-30 Thread UD

  
  
Thanks a lot--  I have now upgraded to 2.2 without issues.  Now if I
could only get the Lyx icons on my Yoga 2 Pro HiDPI to be a little
bigger so I could actually see them, I might even be happy!
Yours,
EK


On 05/30/2016 12:13 AM, Liviu Andronic
  wrote:


  On Sat, May 28, 2016 at 3:40 PM, UD  wrote:

  
When I try to upgrade to Lyx 2.2 using Liviu's ppa, it seems to recognize
only Ubuntu version 15.10, and not 16.04 (which is what I am running).
Therefore it fails to find the appropriate file, and fails to upgrade.
What am I missing (or am I being too impatient)?


  
  2.2.0 packages are now available on the PPA, including for 16.04:
https://urldefense.proofpoint.com/v2/url?u=https-3A__launchpad.net_-7Elyx-2Ddevel_-2Barchive_ubuntu_release=AwIBaQ=4R1YgkJNMyVWjMjneTwN5tJRn8m8VqTSNCjYLg1wNX4=8TL55ClRBx8qDcu32wK9qq4bzQK7eww9ksMpNtBf_q4=tYAKzofSZ7Q6JlmOeVdKl7MJzUB66NFQLX7uNSgGixI=Qnk06KfyGjlOPLvLaXfXYgC0yptgxTlYGNSNN-WQTNo= 

Please report on the list if you encounter any issues with the packaging.

Regards,
Liviu



  
Thanks
EK


  
  





  



Re: Upgrading to Lyx 2.2

2016-05-29 Thread Scott Kostyshak
On Mon, May 30, 2016 at 11:53:40AM +1200, gordon cooper wrote:
> Many thanks to all those involved with 2.2.0. It has been
> packaged by the team and added to the MX-Linux test repos.
> My own installation on MX-15 went without any issues.
> 
> Have not found any bugs nor backwards compatibility problems,
> Lyx 2.2.0 should soon be upgraded to the main MX repository.

Thanks for the good news.

Scott

> 
> Again thanks,
> Gordon
> 
> NZ.
> 
> 
> 
> 


signature.asc
Description: PGP signature


Re: Upgrading to Lyx 2.2

2016-05-29 Thread Scott Kostyshak
On Sun, May 29, 2016 at 08:25:33PM -0300, Julio Rojas wrote:
> I am on 14.04 and a problem appear in the automatic updater, asking me
> to apt-get
> install -f on a console, which apparently run fine. Any idea on what
> happened?
> 
> Regards,
> 
> -
> Julio Rojas
> jcredbe...@gmail.com

Can you share the output?

Scott

> 
> On Sun, May 29, 2016 at 6:13 PM, Liviu Andronic 
> wrote:
> 
> > On Sat, May 28, 2016 at 3:40 PM, UD  wrote:
> > > When I try to upgrade to Lyx 2.2 using Liviu's ppa, it seems to recognize
> > > only Ubuntu version 15.10, and not 16.04 (which is what I am running).
> > > Therefore it fails to find the appropriate file, and fails to upgrade.
> > > What am I missing (or am I being too impatient)?
> > >
> > 2.2.0 packages are now available on the PPA, including for 16.04:
> > https://launchpad.net/~lyx-devel/+archive/ubuntu/release
> >
> > Please report on the list if you encounter any issues with the packaging.
> >
> > Regards,
> > Liviu
> >
> >
> > > Thanks
> > > EK
> > >
> >
> >
> >
> > --
> > Do you think you know what math is?
> > http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
> > Or what it means to be intelligent?
> > http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
> > Think again:
> > http://www.ideasroadshow.com/library
> >


signature.asc
Description: PGP signature


Re: Upgrading to Lyx 2.2

2016-05-29 Thread gordon cooper

Many thanks to all those involved with 2.2.0. It has been
packaged by the team and added to the MX-Linux test repos.
My own installation on MX-15 went without any issues.

Have not found any bugs nor backwards compatibility problems,
Lyx 2.2.0 should soon be upgraded to the main MX repository.

Again thanks,
Gordon

NZ.






Re: Upgrading to Lyx 2.2

2016-05-29 Thread Julio Rojas
I am on 14.04 and a problem appear in the automatic updater, asking me
to apt-get
install -f on a console, which apparently run fine. Any idea on what
happened?

Regards,

-
Julio Rojas
jcredbe...@gmail.com

On Sun, May 29, 2016 at 6:13 PM, Liviu Andronic 
wrote:

> On Sat, May 28, 2016 at 3:40 PM, UD  wrote:
> > When I try to upgrade to Lyx 2.2 using Liviu's ppa, it seems to recognize
> > only Ubuntu version 15.10, and not 16.04 (which is what I am running).
> > Therefore it fails to find the appropriate file, and fails to upgrade.
> > What am I missing (or am I being too impatient)?
> >
> 2.2.0 packages are now available on the PPA, including for 16.04:
> https://launchpad.net/~lyx-devel/+archive/ubuntu/release
>
> Please report on the list if you encounter any issues with the packaging.
>
> Regards,
> Liviu
>
>
> > Thanks
> > EK
> >
>
>
>
> --
> Do you think you know what math is?
> http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
> Or what it means to be intelligent?
> http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
> Think again:
> http://www.ideasroadshow.com/library
>


Re: Upgrading to Lyx 2.2

2016-05-29 Thread Liviu Andronic
On Sat, May 28, 2016 at 3:40 PM, UD  wrote:
> When I try to upgrade to Lyx 2.2 using Liviu's ppa, it seems to recognize
> only Ubuntu version 15.10, and not 16.04 (which is what I am running).
> Therefore it fails to find the appropriate file, and fails to upgrade.
> What am I missing (or am I being too impatient)?
>
2.2.0 packages are now available on the PPA, including for 16.04:
https://launchpad.net/~lyx-devel/+archive/ubuntu/release

Please report on the list if you encounter any issues with the packaging.

Regards,
Liviu


> Thanks
> EK
>



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library


Re: Upgrading to Lyx 2.2

2016-05-28 Thread Scott Kostyshak
On Sat, May 28, 2016 at 03:40:12PM +0200, UD wrote:
> When I try to upgrade to Lyx 2.2 using Liviu's ppa, it seems to
> recognize only Ubuntu version 15.10, and not 16.04 (which is what I
> am running).  Therefore it fails to find the appropriate file, and
> fails to upgrade.
> What am I missing

I don't think there's anything that you can do.

> (or am I being too impatient)?

Not at all, but it requires some work to implement and that work just
hasn't been done yet. The issue is known though so hopefully soon it
will happen. 

Sorry for the bother,

Scott


signature.asc
Description: PGP signature