Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann


Thanks all who tried to help me with the compiling. I have given up  
for the time being and will wait until my son has time to help me (I  
am too old). I could not find zlib1g-dev under 'All' in synaptics.


I am now using my notebook for completing a paper in lyx. However, the  
lyx file from the pc tells me, the DesmodiumPaperF.lyx is from a newer  
LyX-Version, and the lyx2lyx-Script could not convert the document.  
The Lyx version of the PC was 2.2.2, the version of the notebook  
2.0.0svn. I tried separately in a shell

lyx2lyx DesmodiumPaperF.lyx
bash: lyx2lyx: command not found. What can I do?





Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 8:49 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

 Thanks all who tried to help me with the compiling. I have given up for the
 time being and will wait until my son has time to help me (I am too old). I
 could not find zlib1g-dev under 'All' in synaptics.

 I am now using my notebook for completing a paper in lyx. However, the lyx
 file from the pc tells me, the DesmodiumPaperF.lyx is from a newer
 LyX-Version, and the lyx2lyx-Script could not convert the document. The Lyx
 version of the PC was 2.2.2, the version of the notebook 2.0.0svn. I tried
 separately in a shell
 lyx2lyx DesmodiumPaperF.lyx
 bash: lyx2lyx: command not found. What can I do?

Try one of the following:
- install an unofficial deb
http://www.getdeb.net/updates/Ubuntu/11.04/?q=lyx

- copy lyx2lyx from SVN
http://www.lyx.org/trac/ticket/7121#comment:1

Regards
Liviu


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
 leads to a mail without a reference for the source. Do you know it?

Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu

[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann

Zitat von Liviu Andronic landronim...@gmail.com:


On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
leads to a mail without a reference for the source. Do you know it?


Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu


Got it, thanks, Liviu
Wolfgang


[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz






Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann


Thanks all who tried to help me with the compiling. I have given up  
for the time being and will wait until my son has time to help me (I  
am too old). I could not find zlib1g-dev under 'All' in synaptics.


I am now using my notebook for completing a paper in lyx. However, the  
lyx file from the pc tells me, the DesmodiumPaperF.lyx is from a newer  
LyX-Version, and the lyx2lyx-Script could not convert the document.  
The Lyx version of the PC was 2.2.2, the version of the notebook  
2.0.0svn. I tried separately in a shell

lyx2lyx DesmodiumPaperF.lyx
bash: lyx2lyx: command not found. What can I do?





Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 8:49 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

 Thanks all who tried to help me with the compiling. I have given up for the
 time being and will wait until my son has time to help me (I am too old). I
 could not find zlib1g-dev under 'All' in synaptics.

 I am now using my notebook for completing a paper in lyx. However, the lyx
 file from the pc tells me, the DesmodiumPaperF.lyx is from a newer
 LyX-Version, and the lyx2lyx-Script could not convert the document. The Lyx
 version of the PC was 2.2.2, the version of the notebook 2.0.0svn. I tried
 separately in a shell
 lyx2lyx DesmodiumPaperF.lyx
 bash: lyx2lyx: command not found. What can I do?

Try one of the following:
- install an unofficial deb
http://www.getdeb.net/updates/Ubuntu/11.04/?q=lyx

- copy lyx2lyx from SVN
http://www.lyx.org/trac/ticket/7121#comment:1

Regards
Liviu


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
 leads to a mail without a reference for the source. Do you know it?

Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu

[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann

Zitat von Liviu Andronic landronim...@gmail.com:


On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
leads to a mail without a reference for the source. Do you know it?


Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu


Got it, thanks, Liviu
Wolfgang


[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz






Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann


Thanks all who tried to help me with the compiling. I have given up  
for the time being and will wait until my son has time to help me (I  
am too old). I could not find zlib1g-dev under 'All' in synaptics.


I am now using my notebook for completing a paper in lyx. However, the  
lyx file from the pc tells me, the DesmodiumPaperF.lyx is from a newer  
LyX-Version, and the lyx2lyx-Script could not convert the document.  
The Lyx version of the PC was 2.2.2, the version of the notebook  
2.0.0svn. I tried separately in a shell

lyx2lyx DesmodiumPaperF.lyx
bash: lyx2lyx: command not found. What can I do?





Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 8:49 AM, Wolfgang Engelmann
 wrote:
>
> Thanks all who tried to help me with the compiling. I have given up for the
> time being and will wait until my son has time to help me (I am too old). I
> could not find zlib1g-dev under 'All' in synaptics.
>
> I am now using my notebook for completing a paper in lyx. However, the lyx
> file from the pc tells me, the DesmodiumPaperF.lyx is from a newer
> LyX-Version, and the lyx2lyx-Script could not convert the document. The Lyx
> version of the PC was 2.2.2, the version of the notebook 2.0.0svn. I tried
> separately in a shell
> lyx2lyx DesmodiumPaperF.lyx
> bash: lyx2lyx: command not found. What can I do?
>
Try one of the following:
- install an unofficial deb
http://www.getdeb.net/updates/Ubuntu/11.04/?q=lyx

- copy lyx2lyx from SVN
http://www.lyx.org/trac/ticket/7121#comment:1

Regards
Liviu


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Liviu Andronic
On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
 wrote:
> Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
> leads to a mail without a reference for the source. Do you know it?
>
Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu

[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz


Re: compiling lyx 2.0.1 Now: lyx2lyx

2011-09-15 Thread Wolfgang Engelmann

Zitat von Liviu Andronic :


On Thu, Sep 15, 2011 at 9:59 AM, Wolfgang Engelmann
 wrote:

Thanks, Liviu, but http://www.lyx.org/trac/ticket/7121#comment:1
leads to a mail without a reference for the source. Do you know it?


Yes. Download the src tarball of LyX [1], unpack and navigate to
/lib/lyx2lyx/, then copy this folder (entirely) to the system dir of
your LyX installation. On Linux this would usually be
/usr/share/lyx/lyx2lyx. Make sure to first (re)move the existing
lyx2lyx folder. A word of caution: this is a hackish approach that
should work in many cases, but if you have have issues in the distant
future with opening LyX files this would be your culprit; then you'd
either install latest LyX, or repeat this procedure.
Liviu


Got it, thanks, Liviu
Wolfgang


[1] ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-2.0.1.tar.gz






compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?

** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed

Thanks for help and wish a good day (at least better than mine, see above)

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 In trying to compile the new lyx2.0.1 I encounter the following errors:

 (I am using Debian squeeze)

  The following problems have been detected by configure.
  Please check the messages below before running 'make'.
  (see the section 'Problems' in the INSTALL file)

 ** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
 however, dpkg-dev is installed

 ** Cannot find X window libraries and/or headers.
 under what package do I find these?

You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

and then ./configure  make.

Please report if it worked.
Liviu


 ** moc 4 binary not found !

 ** uic 4 binary not found !

 ** qt 4 library not found !

 libqt4 is installed

 Thanks for help and wish a good day (at least better than mine, see above)

 Wolfgang




-- 
Do you know how to read?
http://www.alienetworks.com/srtest.cfm
http://goodies.xfce.org/projects/applications/xfce4-dict#speed-reader
Do you know how to write?
http://garbl.home.comcast.net/~garbl/stylemanual/e.htm#e-mail


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:36 AM, Liviu Andronic wrote:


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

Ah, that was it

rh



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Liviu Andronic landronim...@gmail.com:


On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'


Thanks, Liviu,
but:


and then ./configure  make.

Please report if it worked.


root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
E: Datei  
/var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht  
gefunden)



Is something wrong with my /etc/apt/sources.list?
-

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.




** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard







Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 5:47 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
 Paketlisten werden gelesen... Fertig
 Abhängigkeitsbaum wird aufgebaut
 Statusinformationen werden eingelesen... Fertig
 E: Datei
 /var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources
 konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht
 gefunden)


 Is something wrong with my /etc/apt/sources.list?

I can hardly understand German, but apt often complains when some
other instance of the package manager is open. Have you closed all
instances of synaptic, aptitute, etc., prior to running the command?
Liviu


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which includes the development support files.

Base packages, like zlib1g, include only the files need to *use* the 
library. So to run LyX, you only need zlib1g, which LyX uses to zip and 
unzip things. The *-dev packages, on the other hand, include what you 
need to link against the library, that is, what you need to *compile* 
programs that use that library. So, to compile LyX, you need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as 
libqt4, you need libqt4-dev.


Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Zitat von Richard Heck rgh...@comcast.net:


On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
 is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which includes the development support files.

Base packages, like zlib1g, include only the files need to *use* the  
library. So to run LyX, you only need zlib1g, which LyX uses to zip  
and unzip things. The *-dev packages, on the other hand, include  
what you need to link against the library, that is, what you need  
to *compile* programs that use that library. So, to compile LyX, you  
need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as  
libqt4, you need libqt4-dev.


Richard



Thanks  Richard for your careful explanation. Will try and report.
Wolfgang




compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?

** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed

Thanks for help and wish a good day (at least better than mine, see above)

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 In trying to compile the new lyx2.0.1 I encounter the following errors:

 (I am using Debian squeeze)

  The following problems have been detected by configure.
  Please check the messages below before running 'make'.
  (see the section 'Problems' in the INSTALL file)

 ** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
 however, dpkg-dev is installed

 ** Cannot find X window libraries and/or headers.
 under what package do I find these?

You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

and then ./configure  make.

Please report if it worked.
Liviu


 ** moc 4 binary not found !

 ** uic 4 binary not found !

 ** qt 4 library not found !

 libqt4 is installed

 Thanks for help and wish a good day (at least better than mine, see above)

 Wolfgang




-- 
Do you know how to read?
http://www.alienetworks.com/srtest.cfm
http://goodies.xfce.org/projects/applications/xfce4-dict#speed-reader
Do you know how to write?
http://garbl.home.comcast.net/~garbl/stylemanual/e.htm#e-mail


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:36 AM, Liviu Andronic wrote:


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

Ah, that was it

rh



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Liviu Andronic landronim...@gmail.com:


On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'


Thanks, Liviu,
but:


and then ./configure  make.

Please report if it worked.


root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
E: Datei  
/var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht  
gefunden)



Is something wrong with my /etc/apt/sources.list?
-

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.




** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard







Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 5:47 PM, Wolfgang Engelmann
engelm...@uni-tuebingen.de wrote:
 root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
 Paketlisten werden gelesen... Fertig
 Abhängigkeitsbaum wird aufgebaut
 Statusinformationen werden eingelesen... Fertig
 E: Datei
 /var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources
 konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht
 gefunden)


 Is something wrong with my /etc/apt/sources.list?

I can hardly understand German, but apt often complains when some
other instance of the package manager is open. Have you closed all
instances of synaptic, aptitute, etc., prior to running the command?
Liviu


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which includes the development support files.

Base packages, like zlib1g, include only the files need to *use* the 
library. So to run LyX, you only need zlib1g, which LyX uses to zip and 
unzip things. The *-dev packages, on the other hand, include what you 
need to link against the library, that is, what you need to *compile* 
programs that use that library. So, to compile LyX, you need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as 
libqt4, you need libqt4-dev.


Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Zitat von Richard Heck rgh...@comcast.net:


On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck rgh...@comcast.net:


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
 is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which includes the development support files.

Base packages, like zlib1g, include only the files need to *use* the  
library. So to run LyX, you only need zlib1g, which LyX uses to zip  
and unzip things. The *-dev packages, on the other hand, include  
what you need to link against the library, that is, what you need  
to *compile* programs that use that library. So, to compile LyX, you  
need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as  
libqt4, you need libqt4-dev.


Richard



Thanks  Richard for your careful explanation. Will try and report.
Wolfgang




compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?

** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed

Thanks for help and wish a good day (at least better than mine, see above)

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
 wrote:
> In trying to compile the new lyx2.0.1 I encounter the following errors:
>
> (I am using Debian squeeze)
>
>  The following problems have been detected by configure.
>  Please check the messages below before running 'make'.
>  (see the section 'Problems' in the INSTALL file)
>
> ** Cannot find zlib.h. Please check that the zlib library
>   is correctly installed on your system.
> however, dpkg-dev is installed
>
> ** Cannot find X window libraries and/or headers.
> under what package do I find these?
>
You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

and then ./configure && make.

Please report if it worked.
Liviu


> ** moc 4 binary not found !
>
> ** uic 4 binary not found !
>
> ** qt 4 library not found !
>
> libqt4 is installed
>
> Thanks for help and wish a good day (at least better than mine, see above)
>
> Wolfgang
>



-- 
Do you know how to read?
http://www.alienetworks.com/srtest.cfm
http://goodies.xfce.org/projects/applications/xfce4-dict#speed-reader
Do you know how to write?
http://garbl.home.comcast.net/~garbl/stylemanual/e.htm#e-mail


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
   is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 10:36 AM, Liviu Andronic wrote:


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'

Ah, that was it

rh



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Liviu Andronic :


On Wed, Sep 14, 2011 at 4:29 PM, Wolfgang Engelmann
 wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed

** Cannot find X window libraries and/or headers.
under what package do I find these?


You're missing most *-dev packages for Qt. Try to run
'apt-get build-dep lyx'


Thanks, Liviu,
but:


and then ./configure && make.

Please report if it worked.


root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
E: Datei  
/var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht  
gefunden)



Is something wrong with my /etc/apt/sources.list?
->

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free

Wolfgang


Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Quoting Richard Heck :


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.




** Cannot find X window libraries and/or headers.
under what package do I find these?


Something like xorg-devel.


** moc 4 binary not found !

** uic 4 binary not found !

** qt 4 library not found !

libqt4 is installed


You need the devel packages, too.

Isn't there a way on Debian of doing something like:
apt-get build-depends lyx
?? I seem to recall such a thing, but it's been a while

Richard







Re: compiling lyx 2.0.1

2011-09-14 Thread Liviu Andronic
On Wed, Sep 14, 2011 at 5:47 PM, Wolfgang Engelmann
 wrote:
> root@wolfgang:/home/wolfgang/Downloads/lyx-2.0.1# apt-get build-dep lyx
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut
> Statusinformationen werden eingelesen... Fertig
> E: Datei
> /var/lib/apt/lists/security.debian.org_dists_squeeze_updates_contrib_source_Sources
> konnte nicht geöffnet werden - open (2: Datei oder Verzeichnis nicht
> gefunden)
>
>
> Is something wrong with my /etc/apt/sources.list?
>
I can hardly understand German, but apt often complains when some
other instance of the package manager is open. Have you closed all
instances of synaptic, aptitute, etc., prior to running the command?
Liviu


Re: compiling lyx 2.0.1

2011-09-14 Thread Richard Heck

On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck :


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
  is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which "includes the development support files".

Base packages, like zlib1g, include only the files need to *use* the 
library. So to run LyX, you only need zlib1g, which LyX uses to zip and 
unzip things. The *-dev packages, on the other hand, include what you 
need to "link against" the library, that is, what you need to *compile* 
programs that use that library. So, to compile LyX, you need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as 
libqt4, you need libqt4-dev.


Richard



Re: compiling lyx 2.0.1

2011-09-14 Thread Wolfgang Engelmann

Zitat von Richard Heck :


On 09/14/2011 12:03 PM, Wolfgang Engelmann wrote:

Quoting Richard Heck :


On 09/14/2011 10:29 AM, Wolfgang Engelmann wrote:

In trying to compile the new lyx2.0.1 I encounter the following errors:

(I am using Debian squeeze)

 The following problems have been detected by configure.
 Please check the messages below before running 'make'.
 (see the section 'Problems' in the INSTALL file)

** Cannot find zlib.h. Please check that the zlib library
 is correctly installed on your system.
however, dpkg-dev is installed


Is zlib.h present?


yes, as zlib1g, and it says:
compression library - runtime
zlib is a library implementing the deflate compression method found
in gzip and PKZIP.  This package includes the shared library.


That package does not include the file zlib.h:
http://packages.debian.org/squeeze/amd64/zlib1g/filelist
You need zlib-dev:
http://packages.debian.org/squeeze/zlib1g-dev
http://packages.debian.org/squeeze/amd64/zlib1g-dev/filelist
which "includes the development support files".

Base packages, like zlib1g, include only the files need to *use* the  
library. So to run LyX, you only need zlib1g, which LyX uses to zip  
and unzip things. The *-dev packages, on the other hand, include  
what you need to "link against" the library, that is, what you need  
to *compile* programs that use that library. So, to compile LyX, you  
need zlib1g-dev.


The same goes for the X packages and Qt packages. E.g., as well as  
libqt4, you need libqt4-dev.


Richard



Thanks  Richard for your careful explanation. Will try and report.
Wolfgang