RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi

I have solved the problem, but I think there probably is a bug in LyX 2.1. The 
answer was to restart lyx (this is important or else xindy will fail). open the 
LyX file and chose texindy and add -L norwegian in the option field. This made 
lyx call texindy with the correct language. There seem to be something going on 
with the encoding as well... 

This with texindy and -L norwegian
Reading indexstyle...
Loading module /tmp/olOnxWlTf7...
Loading module lang/norwegian/latin1-lang.xdy...
Loading module lang/norwegian/latin1.xdy...
Finished loading module lang/norwegian/latin1.xdy.
Finished loading module lang/norwegian/latin1-lang.xdy.
Loading module tex/inputenc/latin.xdy...
Finished loading module tex/inputenc/latin.xdy.
Loading module texindy.xdy...

and this with standard.
Reading indexstyle...
Loading module /tmp/JsqoZC927W...
Loading module lang/general/latin9-lang.xdy...
Loading module lang/general/latin9.xdy...
Finished loading module lang/general/latin9.xdy.
Finished loading module lang/general/latin9-lang.xdy.
Loading module tex/inputenc/latin.xdy...
Finished loading module tex/inputenc/latin.xdy.
Loading module texindy.xdy...

regards,
Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 13:42 GMT+02:00 Ingar Pareliussen:

 I have solved the problem, but I think there probably is a bug in LyX 2.1.
 The answer was to restart lyx (this is important or else xindy will fail).
 open the LyX file and chose texindy and add -L norwegian in the option
 field. This made lyx call texindy with the correct language. There seem to
 be something going on with the encoding as well...


The question is, since your document setting had Standard for the index
processor, which setting you have in Tools  Preferences  Output  LaTeX.
Maybe this settings changed since you used index last time.

Jürgen


RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi
 
The question is, since your document setting had Standard for the index 
processor, 
which setting you have in Tools  Preferences  Output  LaTeX. Maybe this 
settings 
changed since you used index last time.

I do not know what it was in earlier versions of LyX, I have never changed it, 
now it says texindy and no extra options.

Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 15:20 GMT+02:00 Ingar Pareliussen:


 I do not know what it was in earlier versions of LyX, I have never changed
 it, now it says texindy and no extra options.


My point is that it would only be a LyX bug if you had the options (or the
correct settings) in previous LyX versions and lost them during the
upgrade. The general UI did not change.

Jürgen



 Ingar


RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi

I have solved the problem, but I think there probably is a bug in LyX 2.1. The 
answer was to restart lyx (this is important or else xindy will fail). open the 
LyX file and chose texindy and add -L norwegian in the option field. This made 
lyx call texindy with the correct language. There seem to be something going on 
with the encoding as well... 

This with texindy and -L norwegian
Reading indexstyle...
Loading module /tmp/olOnxWlTf7...
Loading module lang/norwegian/latin1-lang.xdy...
Loading module lang/norwegian/latin1.xdy...
Finished loading module lang/norwegian/latin1.xdy.
Finished loading module lang/norwegian/latin1-lang.xdy.
Loading module tex/inputenc/latin.xdy...
Finished loading module tex/inputenc/latin.xdy.
Loading module texindy.xdy...

and this with standard.
Reading indexstyle...
Loading module /tmp/JsqoZC927W...
Loading module lang/general/latin9-lang.xdy...
Loading module lang/general/latin9.xdy...
Finished loading module lang/general/latin9.xdy.
Finished loading module lang/general/latin9-lang.xdy.
Loading module tex/inputenc/latin.xdy...
Finished loading module tex/inputenc/latin.xdy.
Loading module texindy.xdy...

regards,
Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 13:42 GMT+02:00 Ingar Pareliussen:

 I have solved the problem, but I think there probably is a bug in LyX 2.1.
 The answer was to restart lyx (this is important or else xindy will fail).
 open the LyX file and chose texindy and add -L norwegian in the option
 field. This made lyx call texindy with the correct language. There seem to
 be something going on with the encoding as well...


The question is, since your document setting had Standard for the index
processor, which setting you have in Tools  Preferences  Output  LaTeX.
Maybe this settings changed since you used index last time.

Jürgen


RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi
 
The question is, since your document setting had Standard for the index 
processor, 
which setting you have in Tools  Preferences  Output  LaTeX. Maybe this 
settings 
changed since you used index last time.

I do not know what it was in earlier versions of LyX, I have never changed it, 
now it says texindy and no extra options.

Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 15:20 GMT+02:00 Ingar Pareliussen:


 I do not know what it was in earlier versions of LyX, I have never changed
 it, now it says texindy and no extra options.


My point is that it would only be a LyX bug if you had the options (or the
correct settings) in previous LyX versions and lost them during the
upgrade. The general UI did not change.

Jürgen



 Ingar


RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi

I have solved the problem, but I think there probably is a bug in LyX 2.1. The 
answer was to restart lyx (this is important or else xindy will fail). open the 
LyX file and chose texindy and add -L norwegian in the option field. This made 
lyx call texindy with the correct language. There seem to be something going on 
with the encoding as well... 

This with texindy and -L norwegian
Reading indexstyle...
Loading module "/tmp/olOnxWlTf7"...
Loading module "lang/norwegian/latin1-lang.xdy"...
Loading module "lang/norwegian/latin1.xdy"...
Finished loading module "lang/norwegian/latin1.xdy".
Finished loading module "lang/norwegian/latin1-lang.xdy".
Loading module "tex/inputenc/latin.xdy"...
Finished loading module "tex/inputenc/latin.xdy".
Loading module "texindy.xdy"...

and this with standard.
Reading indexstyle...
Loading module "/tmp/JsqoZC927W"...
Loading module "lang/general/latin9-lang.xdy"...
Loading module "lang/general/latin9.xdy"...
Finished loading module "lang/general/latin9.xdy".
Finished loading module "lang/general/latin9-lang.xdy".
Loading module "tex/inputenc/latin.xdy"...
Finished loading module "tex/inputenc/latin.xdy".
Loading module "texindy.xdy"...

regards,
Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 13:42 GMT+02:00 Ingar Pareliussen:

> I have solved the problem, but I think there probably is a bug in LyX 2.1.
> The answer was to restart lyx (this is important or else xindy will fail).
> open the LyX file and chose texindy and add -L norwegian in the option
> field. This made lyx call texindy with the correct language. There seem to
> be something going on with the encoding as well...
>

The question is, since your document setting had "Standard" for the index
processor, which setting you have in Tools > Preferences > Output > LaTeX.
Maybe this settings changed since you used index last time.

Jürgen


RE: indexing in 2.1

2014-05-09 Thread Ingar Pareliussen
Hi
 
>The question is, since your document setting had "Standard" for the index 
>processor, 
>which setting you have in Tools > Preferences > Output > LaTeX. Maybe this 
>settings 
>changed since you used index last time.

I do not know what it was in earlier versions of LyX, I have never changed it, 
now it says texindy and no extra options.

Ingar

Re: indexing in 2.1

2014-05-09 Thread Jürgen Spitzmüller
2014-05-09 15:20 GMT+02:00 Ingar Pareliussen:

>
> I do not know what it was in earlier versions of LyX, I have never changed
> it, now it says texindy and no extra options.
>

My point is that it would only be a LyX bug if you had the options (or the
correct settings) in previous LyX versions and lost them during the
upgrade. The general UI did not change.

Jürgen


>
> Ingar


indexing in 2.1

2014-05-06 Thread Ingar Pareliussen
Hi

I have some problems to get indexing to work in LyX 2.1. The attached lyx file 
should generate the same list as presented (in the same order) in Norwegian, 
however, it seem to be sorted in english in the index. It has been a couple of 
months since I last tried to index somthing, but then it worked flawessly out 
of the box :).

Am I missing something? I see there is a new option field in the 
document-setting but putting -L norwegian for xindy, as a test, gave me no 
index :)

I am on Linux and texlive 2013.

Ingar

index_21.lyx
Description: index_21.lyx


indexing in 2.1

2014-05-06 Thread Ingar Pareliussen
Hi

I have some problems to get indexing to work in LyX 2.1. The attached lyx file 
should generate the same list as presented (in the same order) in Norwegian, 
however, it seem to be sorted in english in the index. It has been a couple of 
months since I last tried to index somthing, but then it worked flawessly out 
of the box :).

Am I missing something? I see there is a new option field in the 
document-setting but putting -L norwegian for xindy, as a test, gave me no 
index :)

I am on Linux and texlive 2013.

Ingar

index_21.lyx
Description: index_21.lyx


indexing in 2.1

2014-05-06 Thread Ingar Pareliussen
Hi

I have some problems to get indexing to work in LyX 2.1. The attached lyx file 
should generate the same list as presented (in the same order) in Norwegian, 
however, it seem to be sorted in english in the index. It has been a couple of 
months since I last tried to index somthing, but then it worked flawessly out 
of the box :).

Am I missing something? I see there is a new option field in the 
document-setting but putting -L norwegian for xindy, as a test, gave me no 
index :)

I am on Linux and texlive 2013.

Ingar

index_21.lyx
Description: index_21.lyx