Re: good practice subroutine coding in web context

2002-04-16 Thread Bill -Sx- Jones
On 4/16/02 1:01 AM, Chris Devers [EMAIL PROTECTED] wrote: I would feel awful if my rudeness made you or anyone else drop off the list. Please accept my deep sincere apologies for what I wrote. You guys are starting to remind me of the '97 Usenet flamewars... To add Perl back to this -

Re: good practice subroutine coding in web context

2002-04-16 Thread Phil Dobbin
On 16/4/02 at 07:52, [EMAIL PROTECTED] (Bill -Sx- Jones) wrote: To add Perl back to this - here: (Attachment is text - BBEdit txt.) Which Mailsmith 1.5.1 is telling me is corrupted and/or archived incorrectly. Any chance of a repost? Regards, Phil.

Re: good practice subroutine coding in web context

2002-04-16 Thread Bill -Sx- Jones
=pod Any chance of a repost? Sure - it was small - it may need to be fixed because of mailing reformatting it; -Sx- :] =cut #!/usr/bin/perl -w require 5.004; use strict; use diagnostics; my $mailAdmin = '[EMAIL PROTECTED]'; # Send Reports to? my $mailProject = '[EMAIL PROTECTED]'; #

Re: good practice subroutine coding in web context

2002-04-16 Thread Bill Stephenson
Geez, What a contrast of views. I was just thinking how very cool it was to see such a wonderful exchange on this list when I see this: this list is becoming nearly useless if os x is supposed to be its focus. snip Funny thing is, this list was started as a result of similar negative

Re: good practice subroutine coding in web context

2002-04-16 Thread Alex S
I agree with Bill. I mean, I'm new to the list, but consider myself a fairly seasoned Perl programmer on a number of platforms. I think most people will agree that Perl is a really cool language, but also a potentially dangerous one. It lends itself quite easily to what is generally

Re: good practice subroutine coding in web context

2002-04-16 Thread Phil Dobbin
On 16/4/02 at 10:18, [EMAIL PROTECTED] (Bill -Sx- Jones) wrote: =pod Any chance of a repost? Sure - it was small - it may need to be fixed because of mailing reformatting it; #!/usr/bin/perl -w [...] Many thanks, Regards, Phil. 1;

good practice subroutine coding in web context

2002-04-15 Thread PK Eidesis
afaiunderstand, a sub should be a closed beast, no? poke it with something, it returns something. That something should be just data (in good MVC tradition (you can tell I have started to read the beginners guide to programming Cocoa) and not any display information about that data. How that

Re: good practice subroutine coding in web context

2002-04-15 Thread Chris Devers
On Mon, 15 Apr 2002, PK Eidesis wrote: afaiunderstand, a sub should be a closed beast, no? poke it with something, it returns something. That something should be just data (in good MVC tradition (you can tell I have started to read the beginners guide to programming Cocoa) and not any

Re: good practice subroutine coding in web context

2002-04-15 Thread Alex S
Chris Devers wrote: afaiunderstand, a sub should be a closed beast, no? poke it with something, it returns something. That something should be just data (in good MVC tradition (you can tell I have started to read the beginners guide to programming Cocoa) and not any display information about

Re: good practice subroutine coding in web context

2002-04-15 Thread Ryan
--At 4/15/02 4:25 PM -0500, PK Eidesis wrote: sub makeCalendar { $type = _; if($type eq month) { print all the code for a monthly calendar; elsif($type eq week) { print all the code for a weekly calendar; elsif($type eq year) { print all the code for a yearly calendar; } }

Re: good practice subroutine coding in web context

2002-04-15 Thread Alex S
I agree with Ryan. I think it's often more useful to have a string returned, giving me the option of what I want to do with it higher up. If you have the makeCalendar() subroutine print, I would rename it to something like outputCalendar() or something to that effect. I like to make sure

Re: good practice subroutine coding in web context

2002-04-15 Thread drieux
On Monday, April 15, 2002, at 02:40 , Ryan wrote: --At 4/15/02 4:25 PM -0500, PK Eidesis wrote: sub makeCalendar { $type = _; if($type eq month) { print all the code for a monthly calendar; elsif($type eq week) { print all the code for a weekly calendar; elsif($type eq year) {

Re: good practice subroutine coding in web context

2002-04-15 Thread Alex S
Since we're giving coding exmaples for ideas... One way to do it with a Template enginer: use Template; my $calOutput = getCalendar('week'); print Content-type: text/html\n\n . $calOutput ; sub getCalendar { my $type = shift _; my $template = Template-new( INCLUDE_PATH =

Re: good practice subroutine coding in web context

2002-04-15 Thread Chris Devers
On Mon, 15 Apr 2002, Alex S wrote: Chris Devers wrote: If yes, how do I accommodate repeated poking of the sub which repeatedly returns data in a predictive display format? iow, do I violate the above premise by making the sub return the display info as well as shown below? Well if the

Re: good practice subroutine coding in web context

2002-04-15 Thread Puneet Kishor
so, everyone is in general agreement that... Separating layout, logic data is a virtue in any programming situation [which is why HTML is such an abomination, but I digress]. I guess I should have clarified that that is what I believe in already (the separating part, not necessarily the

Re: good practice subroutine coding in web context

2002-04-15 Thread ashley
this list is becoming nearly useless if os x is supposed to be its focus. if most of us wanted style guides, coding advice, or the best way to lay out a calendar, we'd have the good grace to seek those answers on lists and locations where they are discussed. a few off topic threads are natural

Re: good practice subroutine coding in web context

2002-04-15 Thread Chris Devers
2002 21:02:20 -0700 From: ashley [EMAIL PROTECTED] To: '[EMAIL PROTECTED]' [EMAIL PROTECTED] X-Mailer: Apple Mail (2.481) Content-Type: text/plain; charset=US-ASCII; format=flowed Subject: Re: good practice subroutine coding in web context this list is becoming nearly useless if os x

Re: good practice subroutine coding in web context

2002-04-15 Thread Puneet Kishor
[..] On Mon, 15 Apr 2002, ashley wrote: Date: Mon, 15 Apr 2002 21:02:20 -0700 From: ashley [EMAIL PROTECTED] To: '[EMAIL PROTECTED]' [EMAIL PROTECTED] X-Mailer: Apple Mail (2.481) Content-Type: text/plain; charset=US-ASCII; format=flowed Subject: Re: good practice subroutine coding in web

Re: good practice subroutine coding in web context

2002-04-15 Thread Chris Devers
On Mon, 15 Apr 2002, Puneet Kishor wrote: sorry guys, maybe I'll lurk, maybe I'll leave, maybe I'll go back to my day job. maybe I'll come back and rejoin this list when I too can write stuff no one can understand. No no no, please don't leave. What I wrote was very rude and very