Re: cdrtools returning error on install

2007-11-21 Thread Bryan Blackburn
On Nov 21, 2007, at 9:11 PM, Ryan Schmidt wrote: On Nov 21, 2007, at 21:33, Tomasz Finc wrote: On Nov 21, 2007 6:17 PM, Ryan Schmidt wrote: On Nov 21, 2007, at 17:19, stuw20 wrote: I was wanting some help with cdrtools. I need it to run turbojet2. When I try and install ports cdrtools

Re: Problems installing Python 2.5.1 on PowerMac G4

2007-12-03 Thread Bryan Blackburn
On Dec 3, 2007, at 6:53 AM, Andre-John Mas wrote: Hi, I am trying to install Python 2.5.1 on my PowerMac G4, but I am running into some problems. Note that I have verified that my ports install is up to date with 'sudo ports selfupdate'. Follows is the output from attempting an install. Any

Re: Apache2 IPv6

2008-01-06 Thread Bryan Blackburn
On Jan 5, 2008, at 11:13 PM, Ryan Schmidt wrote: On Jan 5, 2008, at 23:44, Andre-John Mas wrote: I noticed that there is no variant of Apache2 allowing for IPv6 support. Is there any chance one could be added? If this is not already possible with the standard apache2, then you should

Re: This version of Links does not contain SSL/TLS support

2008-02-02 Thread Bryan Blackburn
On Feb 1, 2008, at 10:42 AM, Charlse Darwin wrote: Hi, I get this error when I try to load some pages. `This version of Links does not contain SSL/TLS support' How did you install links? You need to use the ssl variant: $ sudo port install links +ssl and that should build in support for

Re: error installing cogito

2008-04-20 Thread Bryan Blackburn
On Apr 20, 2008, at 3:28 PM, Ryan Schmidt wrote: On Apr 20, 2008, at 3:42 PM, Guido Soranzio wrote: On Apr 20, 2008, at 10:28 PM, Ryan Schmidt wrote: This (various software packages not finding the programs they need to compile) has happened to many Leopard users for reasons we don't

Re: [help] Writing to /opt/local/var/log/install_setup.log ?

2008-05-02 Thread Bryan Blackburn
On May 2, 2008, at 5:36 PM, Bill Hernandez wrote: I am trying to write a running command log to : /opt/local/var/log/ install_setup.log but doing either below : shell $ sudo echo ${TS} $1 $BASH_CMD_LOG shell $ sudo su -m root echo ${TS} $1 $BASH_CMD_LOG do not work... This fails since

Re: Fetch failed

2008-05-07 Thread Bryan Blackburn
On May 7, 2008, at 1:10 AM, Igor Mikushkin wrote: Hello! When I try to install something I see Error: Target org.macports.fetch returned: fetch failed I think the problem is in my proxy settings. I set http_proxy, FTP_PROXY, HTTPS_PROXY and ALL_PROXY in my ~/.profile and it does not seems to

Re: error installing cogito

2008-05-13 Thread Bryan Blackburn
On May 13, 2008, at 1:54 AM, Ryan Schmidt wrote: On Apr 20, 2008, at 7:09 PM, Bryan Blackburn wrote: [about the Leopard problem where some ports fail to install properly with a seemingly endless variety of bizarre error messages if installing them causes a dependency to be installed first

Re: Failure installing LyX

2008-05-19 Thread Bryan Blackburn
On May 19, 2008, at 3:43 PM, Jerry wrote: (Sorry for the previous post without a subject line.) I go this result with port install LyX: Jerry ... Verifying checksum(s) for ImageMagick Error: Checksum (md5) mismatch for ImageMagick-6.4.1-2.tar.bz2 Error: Checksum (sha1) mismatch for

Re: Cleaning Ports and Apache 2.2.8 installation

2008-05-30 Thread Bryan Blackburn
On May 30, 2008, at 8:53 PM, Thomas Hagedorn wrote: I'm on a MacBookPro, Intel 64-bit, with OS 10.5.2. I had MacPorts installed but then I wanted to test a script to do an automatic installation. To do that, I ran sudo rm -r /opt/local and then ran the script to install MacPorts (via

Re: unable to upgrade wine

2008-05-31 Thread Bryan Blackburn
On May 31, 2008, at 7:40 AM, Michael Thon wrote: Hi all - I get the following error when I try to upgrade the port wine ( :) ) I'm using a macbook with Mac OS 10.5.3. openssl and gcc were both upgraded recently I think. Any idea what the problem is? Cheers Mike [EMAIL PROTECTED] ~]$

Re: Two new HOWTOs available

2008-06-01 Thread Bryan Blackburn
On Jun 1, 2008, at 1:39 PM, Alex Zavatone wrote: This didn't make it back out to the list last night. Nice to see the Howto. I got a boatload of errors starting with the build of SQLlite3. I hope this sheds some light on making the Install bullet/newbie-proof Fetching sqlite3 ---

Re: Two new HOWTOs available

2008-06-01 Thread Bryan Blackburn
On Jun 1, 2008, at 3:10 PM, Zav public wrote: On Jun 1, 2008, at 3:22 PM, Bryan Blackburn wrote: Smells like the tcl environment problem with 10.5: http://trac.macports.org/wiki/LeopardProblems#environmentvariablesbecomeblankbetweenconfigureandbuildphases Just run the command again

Re: Unable to start postgresql server 8.3.1.1

2008-06-02 Thread Bryan Blackburn
On Jun 2, 2008, at 9:48 AM, Vittorio wrote: having always used postgreSQL satisfactorily under FreeBSD I installed postgresql83 postgresql83-server on my leopard Macbook via sudo port install postgresql83 postgresql83-server. The process concluded successfully . I ran as requested: sudo

Re: mtr issues

2008-06-03 Thread Bryan Blackburn
On Jun 3, 2008, at 3:07 PM, Peter Hindrichs wrote: Good Day, I have been using mtr to check the network signal from my wireless ISP, and it has been working fine until the other day when I updated my system to 10.5.3 I did an uninstall of mtr and reinstalled it, with no change here is

Re: New wiki

2008-06-11 Thread Bryan Blackburn
On Jun 11, 2008, at 1:49 PM, paul beard wrote: ... Maybe some docs on how to build from the MacPorts trunk, so we can access all the bug fixes to 1.6, would be a good place to start? You mean something like http://trac.macports.org/wiki/howto/RunningTrunk The howto page at

Re: python2.5 install failed

2008-06-13 Thread Bryan Blackburn
On Jun 13, 2008, at 5:11 AM, Joerg van den Hoff wrote: hi, under 10.4.11 I did a `port upgrade mercurial'. ... /usr/bin/libtool -o libpython2.5.dylib -dynamic \ -all_load libpython2.5.a -single_module \ -install_name /opt/local/lib/libpython2.5.dylib \

Re: Portfile syntax: copying complete directory

2008-06-18 Thread Bryan Blackburn
On Jun 18, 2008, at 7:54 AM, Jochen Küpper wrote: Hi, so in Ticket #15049 I proposed a patch to install man-files and info- pages of gcc-4.3 in a custom location in order to get them installed without conflicts between different gcc version. However, the line file copy

Re: Trying to get a new Scribus to work

2008-06-23 Thread Bryan Blackburn
On Jun 23, 2008, at 7:24 AM, Thorsten Zörner wrote: Hi there, this is Thorsten, stand-in maintainer of the scribus-macport. Scribus has come out with a new version 1.3.3.12 which I've tried to compile locally. It compiles all right, but then one of the next steps fails. Have a look at

Re: noProfile

2008-06-25 Thread Bryan Blackburn
On Jun 25, 2008, at 4:00 PM, Mack wrote: Hi, my install didn't create a .profile for me. Do I create one? how do I do this? See http://trac.macports.org/wiki/ProblemHotlist#a4..profilenotsetup Bryan mack ___ macports-users mailing list

Re: hellanzb

2008-06-25 Thread Bryan Blackburn
On Jun 25, 2008, at 7:29 PM, Mack wrote: Anyone know what I could do to get this installed? 6-2.4/zope/interface/tests running build_ext building '_zope_interface_coptimizations' extension creating build/temp.macosx-10.3-i386-2.4 creating build/temp.macosx-10.3-i386-2.4/src creating

Re: MySQL5 source headers

2008-06-26 Thread Bryan Blackburn
On Jun 26, 2008, at 1:12 AM, Teg Bains wrote: I have looked through the guides, but I cannot figure out where to find the header files. Specifically for mysql5. I have a program (cpgav) that needs the header files :( Thanks, (Dang, first time I didn't send to the list, so resent...)

Re: matplotlib and dap.client

2008-07-03 Thread Bryan Blackburn
On Jul 3, 2008, at 3:01 PM, Dexter Douglas wrote: Hello, I am trying run the plotmap.py script found on matplotlib's web-site: http://matplotlib.sourceforge.net/screenshots.html I am receiving this error [begin] Traceback (most recent call last): File plotmap.py, line 7, in module

Re: Bug with multiple port: dependencies in depends_lib ?

2008-07-03 Thread Bryan Blackburn
On Jul 3, 2008, at 3:21 PM, Olivier Croquette wrote: Hi all While working on my Portfile, I made the following strange observation with depends_lib and multiple ports. If I have: depends_lib port:test-qt4-mac port:git-core Then I get: Error: Dependency 'test-qt4-mac' not

Re: Calls to imagettftext cause fatal error in php

2008-07-07 Thread Bryan Blackburn
On Jul 7, 2008, at 2:56 PM, Ryan Schmidt wrote: On Jul 7, 2008, at 15:08, Chris Janton wrote: On 2008-07-07 , at 11:53 , Ryan Schmidt wrote: The way I read things is that if one turns off quickdraw in freetype then the problem will not occur. What are the implications of turning off

Re: port install php5 fails on Leopard 10.5.4

2008-07-10 Thread Bryan Blackburn
On Jul 10, 2008, at 2:07 AM, [EMAIL PROTECTED] wrote: Hi I just tried to install my first MacPorts using the following command sudo port install php5 +apache2 +mysql5 +mssql ... Command output: /usr/bin/sed \ -e 's!@''AWK''@!!' \ makelist.sh makelist-t /bin/mv makelist-t

Re: skipping non-regular file during selfupdate

2008-07-18 Thread Bryan Blackburn
On Jul 18, 2008, at 6:09 PM, William Davis wrote: On Jul 18, 2008, at 5:19 PM, Ryan Schmidt wrote: On Jul 18, 2008, at 15:11, William Davis wrote: macintosh:~ frstan$ sudo port -d selfupdate ... skipping non-regular file zope/zope-validation/work skipping non-regular file

Re: Installing Mac ports on Leopard

2008-07-22 Thread Bryan Blackburn
On Jul 22, 2008, at 3:48 PM, Philippe B. Laval wrote: I am new to MACs, so my question may be very elementary. I was trying to install Geomview. For this, it was suggested I first installed Mac ports. I followed the links and instructions. Everything seemed to be going fine, I even

Re: libtiff problems?

2008-07-25 Thread Bryan Blackburn
On Jul 25, 2008, at 10:59 AM, Jodi Sekula wrote: Hello, I've recently upgraded to Tiger and installed MacPorts for the first time. I seem to be having difficulties running programs that use libtiff from the terminal. Specifically, I have tried installing both xemacs and ImageMagick

Re: macport libusb install?

2008-07-29 Thread Bryan Blackburn
On Jul 29, 2008, at 12:30 AM, [EMAIL PROTECTED] wrote: Hi - just tried installing libusb and stumbled on some of the instructions at http://libusb.dar...rts.com. Ignore anything and everything at that domain, it's not affiliated with MacPorts in any way... Firstly, it says cd

Re: macport libusb install?

2008-07-29 Thread Bryan Blackburn
On Jul 29, 2008, at 1:45 AM, Ryan Schmidt wrote: On Jul 29, 2008, at 01:52, Bryan Blackburn wrote: your best bet is probably the project's web site (you can use 'port gohome libusb' to open a web browser to it). Now that I didn't know! That's handy. Nor did I until Rainer pointed it out

Re: does exist lsusb under MacPorts ?was(Re: macport libusb install)

2008-07-29 Thread Bryan Blackburn
On Jul 29, 2008, at 11:47 AM, Joshua Root wrote: Yvon Thoraval wrote: is there a way to get lsusb under Mac OS X 10.4.11 ? preferably under MacPorts ;-) The lsusb command is part of the usbutils package[1]. It looks to be pretty Linux-specific. Is there something you need it for that can't

Re: failed hellanzb

2008-07-29 Thread Bryan Blackburn
On Jul 29, 2008, at 11:30 AM, Trenskow wrote: I solved this by creating a nasty little hack, that did the trick. The reason it fails, is that the internal variable set to determine the gcc location is somehow not set, and therefore it tries to execute the first parameter as if it

Re: Portfile cached on repetitive builds??

2008-08-03 Thread Bryan Blackburn
On Aug 3, 2008, at 9:52 AM, Harry van der Wolf wrote: I'm working on the pango Portfile to make it a real two-step Universal compilation. I modified the portfile and did a sudo port clean pango and even checked whether the /opt/local/var/macports/ build/

Re: Problem with MacPorts on OS X Leopard

2008-08-03 Thread Bryan Blackburn
On Aug 3, 2008, at 3:36 PM, Unnsse Khan wrote: Hello there, I am having problems installing ruby and readline using MacPorts 1.600 on OS X Leopard (10.5.4). When I run the following from the command line, this is the error I receive: sudo port install readline Password: --- Activating

Re: Problem with MacPorts on OS X Leopard

2008-08-03 Thread Bryan Blackburn
the output someplace. If you have a database (mysql*, postgresql*, etc) you may have to export from it prior to the upgrade, especially if you will be installing a newer version of the DB when doing the MacPorts reinstall. Bryan Happy programming, Unnsse On Aug 3, 2008, at 3:22 PM, Bryan

Re: Problem with MacPorts on OS X Leopard

2008-08-03 Thread Bryan Blackburn
On Aug 3, 2008, at 6:16 PM, Unnsse Khan wrote: ... sudo install subversion I received this error message: --- Building sqlite3 with target all Error: Target org.macports.build returned: shell command cd /opt/ local/var/macports/build/ _opt_local_var_macports_sources_rsync

Re: ATLAS 3.8.2

2008-08-05 Thread Bryan Blackburn
On Aug 5, 2008, at 12:10 PM, Peter Chen wrote: Is ATLAS 3.8.2 available? I see it on the list, but I can not install it. What happens when you try? If you see Error: Port atlas not found you need to update your MacPorts installation first [1]. If some other error, what is it? Bryan [1]

Re: Having a pretty rough time getting php5 installed

2008-08-08 Thread Bryan Blackburn
On Aug 8, 2008, at 8:31 PM, Scott Haneda wrote: ... And here is what I want to install: sudo port install php5 +apache2 +mysql5 +pear +imap +sqlite +tidy * As a side note, this is a test machine, an identical one is at a colo fascility, and I do not want to run ports on that machine, but

Re: netcat won't install

2008-08-12 Thread Bryan Blackburn
On Aug 12, 2008, at 8:20 AM, myron wrote: I tried installing netcat and the following problems came up. I couldn't find anything in the macports archvies on this issue. I'm new to macports (and really love it), but it looks like the checksum is wrong in Portfile. Should I just change it

Re: netcat won't install

2008-08-12 Thread Bryan Blackburn
On Aug 12, 2008, at 2:00 PM, myron wrote: ... But it doesn't seem to have installed anything in /opt/local/bin myron$ sudo find / -name netcat -print /opt/local/share/doc/netcat /opt/local/var/macports/distfiles/netcat /opt/local/var/macports/receipts/netcat

Re: Nagios/Macports on PowerMac G5

2008-08-12 Thread Bryan Blackburn
On Aug 12, 2008, at 2:14 PM, Dirk H. Schulz wrote: Hi Mark, --On 12. August 2008 09:54:43 -0700 [EMAIL PROTECTED] wrote: ... I don't have a running installation of nagios right now so I couldn't answer any questions they might ask. Do you have any experience with tracing processes on

Re: Building subversion : f: command not found

2008-08-13 Thread Bryan Blackburn
On Aug 13, 2008, at 2:44 PM, Charles Brossollet wrote: Hello, A port install subversion failed with the following message: config: Leopard 10.5.4, Mac mini Intel, MacPorts 1.6 --- Building sqlite3 with target all ... f ./addopcodes.awk parse.h.temp parse.h /bin/sh: f: command not found

Re: Checksum problem with molden

2008-08-14 Thread Bryan Blackburn
On Aug 14, 2008, at 1:29 AM, Angyan Janos wrote: ... I wonder if this is not an inconsistency with the database itself. Although in a somewhat different context, a similar problem was reported in (as far as I understand):

Re: Fetch failing for ntfs-3g port

2008-08-15 Thread Bryan Blackburn
On Aug 14, 2008, at 11:48 PM, William Damon wrote: Hi, ... [Users/wedamon] install ntfs-3g --- Fetching ntfs-3g --- Attempting to fetch ntfs-3g-1.2412.tgz from http://www.ntfs-3g.org/ --- Attempting to fetch ntfs-3g-1.2412.tgz from

Re: py25-libxml2 fails to build

2008-08-16 Thread Bryan Blackburn
On Aug 16, 2008, at 7:00 AM, Brad Allison wrote: --- Building py25-libxml2 with target build Error: Target org.macports.build returned: shell command cd /opt/ local/var/macports/build/ _opt_local_var_macports_sources_rsync .macports.org_release_ports_python_py25-libxml2/work/libxml2-

Re: help with Bzip2

2008-08-19 Thread Bryan Blackburn
On Aug 19, 2008, at 3:35 PM, Gary Law wrote: Hi Got a brand new machine, patched it to latest version of leopard, plus security update. Then downloaded and installed Xcode tools and Macports. And my very first port install blows up! Last login: Sun Aug 17 11:00:43 on console [EMAIL

Re: problem installing Psycopg2

2008-08-24 Thread Bryan Blackburn
On Aug 23, 2008, at 10:43 PM, Nehemiah Dacres wrote: it failed to install after resolving all dependancies. It seems to be an error in the portfile, like a flag being missparsed as a command but I dont know Tcl enough to efficiently deliver a patch. here's the message creating

Re: was there any way to make Psycopg2 compile against python2.5 instead of 2.4?

2008-08-24 Thread Bryan Blackburn
On Aug 24, 2008, at 12:01 AM, Nehemiah Dacres wrote: I ask because its' bad enough that I'll have 2 versions of 2.5 but to have 24 taking up space also is kind of annoying. plus I have a feeling that the program that is using this postgres adaptor is mostly written in 2.5 should I go

Re: cdrtools is not building and installing mkisofs, cdda2wav and various other programs

2008-09-06 Thread Bryan Blackburn
On Sep 6, 2008, at 8:00 AM, David Evans wrote: In cdrtools version 2.01.01a46_0, it does not build and install mkisofs, cdda2wav and various other programs. It does build and install cdrecord I just attached a patch to ticket #15934 [1] which updates cdrtools to the current version

Re: Macports, mri ports problem with AFNI...

2008-09-08 Thread Bryan Blackburn
On Sep 8, 2008, at 12:10 PM, David Perlman wrote: Hello all, I'm new to this list but I've been successfully using afni installed and updated with macports for a couple of years now. However, earlier this year I tried to update afni and ever since then I haven't been able to get any version

Re: p5-perlmagick won't install

2008-09-09 Thread Bryan Blackburn
On Sep 9, 2008, at 1:16 AM, Paul Rauschelbach wrote: I have setup a new machine with OS X 10.5.4, XCode 3.1, and MacPorts 1.6. The MacPorts installer didn't put a .profile in for me, but I added the path and manpath exports myself. I first attempted to install p5-perlmagick. This installed

Re: mutt, ISO-8859-1, and Terminal.app

2008-09-09 Thread Bryan Blackburn
On Sep 9, 2008, at 3:05 PM, Ryan Schmidt wrote: On Sep 9, 2008, at 1:03 PM, Jens Troeger wrote: On Tue, Sep 09, 2008 at 07:49:23AM -1000, Baron Fujimoto wrote: On Tue, 9 Sep 2008, Jens Troeger wrote: I'm running on OS-X 10.4.11 and Terminal version 1.5.1 (133-1). Just recently I

Re: Building sqlite3 fails

2008-09-12 Thread Bryan Blackburn
On Fri, Sep 12, 2008 at 01:54:53PM +0200, Normen Müller said: He all, can anyone help how to build sqlite3? --- # port upgrade outdated --- Building sqlite3 with target all Error: Target org.macports.build returned:

Re: Installing without root privileges: what about /Applications/MacPorts?

2008-09-12 Thread Bryan Blackburn
On Fri, Sep 12, 2008 at 03:13:36PM +0100, Michael Williams said: Hi, I think I've successfully installed MacPorts without root privileges. I installed from source using: ./configure --prefix=$HOME/.macports --with-install-user=$USER --with- install-group=staff

Re: problem building parts of KDE

2008-09-12 Thread Bryan Blackburn
On Fri, Sep 12, 2008 at 12:57:32PM -0600, Glenn English said: I installed MacPorts last night (MacPorts-1.6.0-10.5-Leopard.dmg on a Mac Pro), so I claim n00b :-) [...] maxi:bin root# ./port -v install kmymoney --- Fetching libidn Looks like the fetch location for libidn may have been

Re: problem building parts of KDE

2008-09-12 Thread Bryan Blackburn
On Fri, Sep 12, 2008 at 04:54:01PM -0600, Glenn English said: Still no joy. The build of kdebase3 failed, and I think this is the relevant part of the screen output: gcc -Os -Os -fPIC -D_GNU_SOURCE -DQT_THREAD_SUPPORT -I/opt/local/include/freetype2 -I/opt/local/include -fno-common

Re: Building sqlite3 fails

2008-09-13 Thread Bryan Blackburn
On Sat, Sep 13, 2008 at 09:58:00AM +0200, Normen Müller said: [...] # sudo port clean --work sqlite3 --- Cleaning sqlite3 brain:~ root# sudo port install sqlite3 --- Fetching sqlite3 --- Verifying checksum(s) for sqlite3 ---

Re: MacPorts-1.6.0 Won't Build

2008-09-13 Thread Bryan Blackburn
On Sat, Sep 13, 2008 at 01:34:27PM -0600, Etherous said: Running MacBook: Intel Core Duo with Mac OS 10.5.4 I already tried the DarwinPorts-1.6.0-10.5-Leopard.dmg version. The .pkg SEEMED to run successfully, but whatever it did, it didn't install DarwinPorts. Where did you find a

Re: cdrtools is not building and installing mkisofs, cdda2wav and various other programs

2008-09-16 Thread Bryan Blackburn
On Tue, Sep 16, 2008 at 11:29:33AM +0100, David Evans said: Bryan Blackburn wrote: I just attached a patch to ticket #15934 [1] which updates cdrtools to the current version and switches to using smake; hopefully using smake to do the build will fix these issues you've seen. Bryan

Re: Installing without root privileges: what about /Applications/MacPorts?

2008-09-16 Thread Bryan Blackburn
On Tue, Sep 16, 2008 at 03:39:08PM +0100, Michael Williams said: [...] Forgive my ignorance, but if I installed from 1.6 source and then ran port -v selfupdate am I still running from 1.6 or am I on trunk? selfupdate will keep you on the official release which is 1.6.0 still; it will

Re: cdrtools is not building and installing mkisofs, cdda2wav and various other programs

2008-09-16 Thread Bryan Blackburn
On Tue, Sep 16, 2008 at 10:33:36PM +0100, David Evans said: [...] I hardly ever run port selfupdate. I thought that port sync was sufficient every couple of days. Perhaps that's where I'm going wrong. sync will get updated port information (and is done when you do selfupdate), but

Re: errors encountered while installing Python -- please advise

2008-09-19 Thread Bryan Blackburn
On Fri, Sep 19, 2008 at 03:27:25PM -0400, Richard Rucker said: Here's the installation command being executed: me$ sudo port install py25-gtk py-serial py25-xml py25-hashlib Any particular reason why you're using py-serial instead of py25-serial? py-* ports are usually python 2.4 (some may be

Re: errors encountered while installing Python -- please advise

2008-09-19 Thread Bryan Blackburn
On Fri, Sep 19, 2008 at 05:34:59PM -0400, Richard Rucker said: On Sep 19, 2008, at 4:36 PM, Bryan Blackburn wrote: On Fri, Sep 19, 2008 at 03:27:25PM -0400, Richard Rucker said: Here's the installation command being executed: me$ sudo port install py25-gtk py-serial py25-xml py25

Re: I get the error C compiler cannot create executables when I try to install a port...

2008-09-21 Thread Bryan Blackburn
On Sun, Sep 21, 2008 at 02:34:00PM +0200, Otto Roberson Bertsch said: I get the error C compiler cannot create executables when I try to install a port I had installed first XCode from the Apple 311_2517_developerdvd.dmg. I thought maybe that was the problem since the FAQ states you need XCode

Re: I get the error C compiler cannot create executables when I try to install a port...

2008-09-21 Thread Bryan Blackburn
On Sun, Sep 21, 2008 at 03:28:55PM -0500, Ryan Schmidt said: On Sep 21, 2008, at 7:34 AM, Otto Roberson Bertsch wrote: I had installed first XCode from the Apple 311_2517_developerdvd.dmg. I thought maybe that was the problem since the FAQ states you need XCode 3.0 - so I installed

Re: exlive_base 2007 not working

2008-09-22 Thread Bryan Blackburn
On Tue, Sep 23, 2008 at 02:02:49AM +0200, Florian Kühnlenz said: I just tried to install doxygen. After 10min I recived a failure. After some research I found out i could install texlive_base: any suggestions? --- Building texlive_base with target all Error: Target org.macports.build

Re: taglib won't install (problem with gcc4.0 blacklisted)

2008-09-23 Thread Bryan Blackburn
On Tue, Sep 23, 2008 at 02:59:08PM -0700, rhubbell said: Hello all, I'm new to macports and have run into a problem. I installed macports 1.60 on Tiger and everything went fine after a few fits and starts. But the last package I wanted to install failed. I attempted to install: sudo

Re: taglib won't install (problem with gcc4.0 blacklisted)

2008-09-23 Thread Bryan Blackburn
On Tue, Sep 23, 2008 at 05:18:35PM -0700, rhubbell said: [...] Yes I've already tried this. Thanks. For now I'm not using taglib. Although I'm missing some functionality because I'm not using taglib. Actually I'm building the app now so I'll find out if it can function without taglib. It

Re: taglib won't install (problem with gcc4.0 blacklisted)

2008-09-24 Thread Bryan Blackburn
On Tue, Sep 23, 2008 at 10:25:17PM -0500, Ryan Schmidt said: On Sep 23, 2008, at 10:12 PM, rhubbell wrote: On Tue, 2008-09-23 at 20:22 -0600, Bryan Blackburn wrote: It looks like taglib is only disliking 4.0.0, so I'm guessing if you run gcc --version it'll say 4.0.0 and not 4.0.1

Re: taglib won't install (problem with gcc4.0 blacklisted)

2008-09-24 Thread Bryan Blackburn
On Wed, Sep 24, 2008 at 07:40:10AM -0700, rhubbell said: [...] I don't recall where I got Xcode, I thought it came with the OS. But I'll check that link to see how to upgrade. Yes, the OS DVD does include Xcode, but as time goes on that version goes further out of date...To upgrade you just

Re: audiofile checksum failure

2008-09-24 Thread Bryan Blackburn
On Wed, Sep 24, 2008 at 12:28:49PM -0700, Bill Parducci said: [...] --- Verifying checksum(s) for audiofile Error: No checksum set for audiofile-0.2.6.tar.gz [...] I tried cleaning and repulling with no luck. I also manually pulled the file from a few sites and diff'd the results (all

Re: arpwatch

2008-09-25 Thread Bryan Blackburn
On Fri, Sep 26, 2008 at 01:46:20AM +0100, Mark Hattam said: Is there something amiss with my MacPorts system? I did a sudo port install arpwatch and it installed arpwatch into /opt/local/sbin ... just the executable, no directory. and without making a default (empty) arp.dat and

Re: Gnome won't install

2008-09-29 Thread Bryan Blackburn
On Tue, Sep 30, 2008 at 02:18:38PM +1000, Benedick Miller said: Hello, I am new here. I couldn't find this issue in the archives, in fact I couldn't find a way to effectively search the archives. I have installed Macports mainly so I can install Gnucash 2.2.7 from source, for which I

Re: Gnome won't install

2008-09-30 Thread Bryan Blackburn
On Tue, Sep 30, 2008 at 05:27:31PM +1000, Benedick Miller said: On 30 Sep 2008, at 15:09, Bryan Blackburn wrote: On Tue, Sep 30, 2008 at 02:18:38PM +1000, Benedick Miller said: Hello, I am new here. I couldn't find this issue in the archives, in fact I couldn't find a way

Re: libglade2 fails to install with an xmlcatalog error?

2008-09-30 Thread Bryan Blackburn
On Tue, Sep 30, 2008 at 10:26:16PM -0500, Ryan Schmidt said: On one of my systems I got: Error: Target org.macports.activate returned: shell command xmlcatalog --noout --add system http://glade.gnome.org/ glade-2.0.dtd /mp/share/xml/libglade/glade-2.0.dtd /mp/etc/xml/ catalog returned

Re: Error Message

2008-10-01 Thread Bryan Blackburn
On Wed, Oct 01, 2008 at 07:41:49AM -0700, john wu said: Hi, I tried to install shibboleth to Mac 10.4.11 and got the following error message: Warning: It looks like your PortIndex file may be corrupt. Error: search for portname shibboleth failed: bad argument : should be nonewline Is

Re: Upgrading python25 - python26

2008-10-03 Thread Bryan Blackburn
On Fri, Oct 03, 2008 at 03:38:36PM +0100, Uldis Bojars said: Python 2.6 is now released and a port for it is available on MacPorts. Could you tell me if there is any straightforward way to upgrade Python 2.5 and packages dependent on it (all installed using MacPorts) to the version 2.6?

Re: can't find rsync?

2008-10-04 Thread Bryan Blackburn
On Sat, Oct 04, 2008 at 05:21:30PM -0500, Steven Rogers said: I'm trying to build another package (git-core) which requires rsync, and it seems to be missing from the 10 or places that it tries to download from, such as: --- Attempting to fetch rsync-2.6.9.tar.gz from

Re: Gnome won't install

2008-10-04 Thread Bryan Blackburn
On Sun, Oct 05, 2008 at 11:45:31AM +1000, Benedick Miller said: [...] In fact I tried this: uninstall macports completely. Reinstall Macports. sudo port selfupdate. sudo port install gnucash. Error log below. Sorry I can't work out what I am doing wrong! Does anyone have gnucash

Re: problem with fontconfig

2008-10-05 Thread Bryan Blackburn
On Sun, Oct 05, 2008 at 11:12:11AM +0200, maurizio toncelli said: I have a little problem with fontconfig, macport don' t arrive to download it. What I can do? Perhaps the server was unavailable when you tried, it just downloaded fine here. Otherwise, do you need to use a proxy to

Re: ruby - pg

2008-10-06 Thread Bryan Blackburn
On Mon, Oct 06, 2008 at 05:23:19PM -0400, Tom Allison said: I'm struggling here between the different mailing lists and postings. What I would like to get running is the ruby DBI on postgresql 8.3. macports seems to support 8.1 only. rubygems is mostly DOA every time I try to install and

Re: linking to libssl and libcrypt

2008-10-08 Thread Bryan Blackburn
On Wed, Oct 08, 2008 at 01:44:19PM -0700, Shawn Protsman said: I'm attempting to build a static library that links to both libssl.a and libcrypto.a. When I build it I get these has no symbols messages. Any advice on resolving this? Thanks. Ignore them? Some source files end up, based on

Re: macports and Xcode

2008-10-08 Thread Bryan Blackburn
On Wed, Oct 08, 2008 at 02:16:08PM -0700, rhubbell said: Hello all, Probably a ridiculous question. (never stopped me before) Is macports always and forever dependent upon Xcode? Can it be de-coupled? As long as MacPorts builds ports from source, then Xcode is an absolute requirement (for

Re: linking to libssl and libcrypt

2008-10-08 Thread Bryan Blackburn
On Wed, Oct 08, 2008 at 02:27:07PM -0700, Shawn Protsman said: [...] Thanks for the quick reply. I copied the static lib to /usr/local/lib and then tried to compile my binary which links to liballkeyrtv.a: Building target: keyreq ##gcc -lallkeyrtv -o keyreq keyreq.o gcc -o keyreq keyreq.o

Re: Unable to fetch libxml2

2008-10-09 Thread Bryan Blackburn
On Thu, Oct 09, 2008 at 08:06:11PM -0700, Trevor Robinson said: I've been trying to libxml2 (to install gimp 2.6) for the past few hours, but I've been unable to fetch it from any mirror. xmlsoft.org seems to be down, and other mirrors seem to have older (e.g. 2.6.30) or newer (2.7.2)

Re: cups-headers, gtk2, 10.3 - re-messed up?

2008-10-09 Thread Bryan Blackburn
On Thu, Oct 09, 2008 at 09:53:41PM -0700, Walt Pawley said: I initially attempted to install gimp on my G4 PB, running 10.3.9. It failed, so I started trying to see if I could figure things out (fat chance!). In the process I tried installing gtk2. This failed because it the symbols

Re: New versions of CLISP and ECL

2008-10-10 Thread Bryan Blackburn
On Fri, Oct 10, 2008 at 08:04:37PM -0500, Gabriel Dos Reis said: Hi, Is there a plan to have a port for the latest release of CLisp and ECL? There are tickets for both: http://trac.macports.org/ticket/16255 http://trac.macports.org/ticket/16643 Bryan Thanks, -- Gaby

Re: Error upgrading ffmpeg - running from trunk

2008-10-15 Thread Bryan Blackburn
On Wed, Oct 15, 2008 at 02:09:32PM -0700, Chris Janton said: On 2008-10-15 , at 09:38 , nox wrote: Fixed in r40824. mac 15 # svn info Path: . URL: http://svn.macports.org/repository/macports/trunk/base Repository Root: http://svn.macports.org/repository/macports Repository UUID:

Re: how to detect installed gtk variant

2008-10-15 Thread Bryan Blackburn
On Wed, Oct 15, 2008 at 06:07:04AM -0700, MySchizoBuddy said: For webkit-gtk it has a quartz variant. I want to detect if gtk2 was installed with the quartz variant or not. if not then spit an error and tell the users to uninstall gtk and install it with quartz You might be able to use a

Re: non-root user

2008-10-15 Thread Bryan Blackburn
On Tue, Oct 14, 2008 at 06:49:24PM +0200, Stephan said: Hi all, I am a Macports-newbee and run macports on both my macbook and my desktop computer. Both have Mac OS X 10.4 Tiger. While I am my own admin on the macbook (and installed macports to the standard /opt/local via the .dmg-file) I

Re: Fail to install git-core +svn: Maybe sqlite3 related?

2008-10-16 Thread Bryan Blackburn
On Fri, Oct 17, 2008 at 09:12:52AM +0900, Takaaki Kato said: Hi, I run `sudo port install git-core +svn` and I got the following error. ### Error: Target org.macports.build returned: shell command cd

Re: texlive_base failed to build

2008-10-17 Thread Bryan Blackburn
On Fri, Oct 17, 2008 at 03:06:48AM -0700, Frank J. R. Hanstick said: Hello, I got the following error when installing octave-vrml dependency texlive_base: --- Fetching texlive_base [...] /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I./.. -isystem/opt/ local/include

Re: texlive_base failed to build

2008-10-17 Thread Bryan Blackburn
(Don't forget to reply-all so it gets back to the list, since Apple's mail appears to ignore Mail-Followup-To:) On Fri, Oct 17, 2008 at 02:03:56PM -0700, Frank J. R. Hanstick said: Hello, ~ frank$ gcc_select -l Available versions: mp-gcc43 ~ frank$ which gcc /opt/local/bin/gcc Sounds

Re: grace patch error

2008-10-18 Thread Bryan Blackburn
On Sun, Oct 19, 2008 at 12:05:15AM -0400, William Davis said: DEBUG: Executing org.macports.main (grace) --- Fetching grace DEBUG: Executing org.macports.fetch (grace) --- patch-configure.diff doesn't seem to exist in /opt/local/var/ macports/distfiles/grace --- Attempting to fetch

Re: loader error, uninstall fails

2008-10-19 Thread Bryan Blackburn
On Sun, Oct 19, 2008 at 12:01:07AM -0700, David Epstein said: While trying to install gimp, I had problems with exiv2. So first I did sudo port clean --all exiv2 Is this the correct command for removing all exiv2 files? This worked without complaint. I then tried to install exiv2 on its own,

Re: type S_REGULAR does not match previous objects type S_COALESCED

2008-10-20 Thread Bryan Blackburn
On Mon, Oct 20, 2008 at 08:03:35PM +0200, Anton van Oosten said: I encounter a problem with pdflib when I install octave. At pdflib I encounter the error: type S_REGULAR does not match previous objects type S_COALESCED. Who knows the fix? Regards Anton sudo port install octave

Re: loader error, uninstall fails

2008-10-20 Thread Bryan Blackburn
On Mon, Oct 20, 2008 at 02:26:45PM -0700, David Epstein said: [...] I successfully installed Xcode2.5. Thanks for explaining that I couldn't use Xcode3.x on MacOsX10.4.11. I renamed /usr/local to /usr/local-off sudo port install exiv2 then gave me exactly the same linker/loader errors as

Re: open jpeg build error

2008-10-20 Thread Bryan Blackburn
On Mon, Oct 20, 2008 at 07:59:40PM -0400, William Davis said: [...] ld: malformed version number: 2.1.2.0 Looks like ticket #16931: http://trac.macports.org/ticket/16931 A fix was recently checked in it would appear. Bryan collect2: ld returned 1 exit status make: ***

Re: type S_REGULAR does not match previous objects type S_COALESCED

2008-10-21 Thread Bryan Blackburn
On Tue, Oct 21, 2008 at 11:21:38PM +0200, Anton van Oosten said: If I remove the overloading gcc, so that the /usr/bin/gcc is used, I still get the error. It looks like I have a really old libstdc++.a in usr/local/lib. If I move that I get [...] powerpc-apple-darwin8-g++-4.0.1:

  1   2   3   4   >