On Wed, Nov 5, 2008 at 4:55 PM, Ryan May <[EMAIL PROTECTED]> wrote:
> Hi,
>
> How much freedom would I (and my colleague) have in changing up some of
> the behavior/API of mlab.psd? My current issues with the function:
>
> 1) Returning one-sided or two-sided depends on whether the data is
> comple
Hi,
How much freedom would I (and my colleague) have in changing up some of
the behavior/API of mlab.psd? My current issues with the function:
1) Returning one-sided or two-sided depends on whether the data is
complex. I'd like that to be controlled by a keyword parameter (could
take strings, s
> From: Michael Droettboom [mailto:[EMAIL PROTECTED]
> Sent: Wednesday, November 05, 2008 11:59
>
> David Kaplan wrote:
> > Hi,
> >
> > Actually your question is a good one. One of the reasons I never
> > finished adding an option to text objects to rotate with respect to the
> > plot (is this t
John Hunter wrote:
> On Wed, Oct 29, 2008 at 4:00 PM, Ryan May <[EMAIL PROTECTED]> wrote:
>
>> Here's probably a better question to ask than just to fix the example.
>> Was it intended that the Rectangle.xy attribute disappear? I couldn't
>> find it documented in API_CHANGES. It appears that ther
David Kaplan wrote:
> Hi,
>
> Actually your question is a good one. One of the reasons I never
> finished adding an option to text objects to rotate with respect to the
> plot (is this the correct terminology?), not the screen, is that I
> wasn't sure of the best way to implement this without maki
From: Darren Dale [mailto:[EMAIL PROTECTED]
Sent: Wednesday, November 05, 2008 08:48
On Tuesday 04 November 2008 05:23:19 pm you wrote:
> I attempted to improve the dependency checking in matplotlib.__init__,
> using the subprocess module to silence some deprecation warnings
> encountered wit
Hi,
Actually your question is a good one. One of the reasons I never
finished adding an option to text objects to rotate with respect to the
plot (is this the correct terminology?), not the screen, is that I
wasn't sure of the best way to implement this without making it
hopelessly confusing for
Darn clogged e-mail queue! ;)
I see you've already addressed my question...
Cheers,
Mike
David Kaplan wrote:
> Hi,
>
> I just wanted to send a note saying that I committed an additional
> method to the Transforms class that transforms angles. The basic idea
> is to transform an angle at a point
Hi,
I just wanted to send a note saying that I committed an additional
method to the Transforms class that transforms angles. The basic idea
is to transform an angle at a point to a new angle at the corresponding
point in the transformed coordinate system. The included method is
generic and shou
Thanks, David. That's a much-needed feature.
However, wouldn't it be simpler, API-wise, to add a new kwarg
"rotation_data" (or some better name) which would be an angle in data
space? (Or alternatively a boolean flag "rotation_in_data_coords").
The other advantage of that approach is that si
This looks great to me. I can confirm that this works on Linux as well.
I think from here it's just a matter of applying the same pattern of
changes to collections and images. Once that's done, I'm happy to apply
the patch. And if you plan to make a lot of changes in the future, it
generally
On Tuesday 04 November 2008 05:23:19 pm you wrote:
> I attempted to improve the dependency checking in matplotlib.__init__,
> using the subprocess module to silence some deprecation warnings
> encountered with py2.6. I dont have access to a Windows machine, would
> someone please test the attached
Hi,
I've attached a diff file which implements the basic functionality. It
currently doesn't handle collections or draw_image, but I wanted to
get something simple working first, before expanding the scope. A
simple test program is as follows:
from pylab import *
f = figure()
a,b = bar([1,2], [
13 matches
Mail list logo