Darren Dale wrote:
[...]
> Why do we need a single namespace? It seems unadvisable. There is additional
> overhead with namespace lookups: running numpy.arange(10) a million times
> takes 15% longer than arange(10). I would have thought it best to do more
> of "from w import x, y, z"
I have in
On 7/16/07, Darren Dale <[EMAIL PROTECTED]> wrote:
> This seems a little too cute too me, no offense intended to the clever author.
> Why do we need a single namespace? It seems unadvisable. There is additional
> overhead with namespace lookups: running numpy.arange(10) a million times
> takes 15%
On Friday 13 July 2007 06:29:59 pm Eric Firing wrote:
> Eric Firing wrote:
> > John Hunter wrote:
> >> On 7/13/07, Ted Drain <[EMAIL PROTECTED]> wrote:
> >>> I think he means that the matplotlib/__init__.py file should be
> >>> changed to that those things are imported.
> >>
> >> but if __init__.py
John Hunter wrote:
> On 7/15/07, Eric Firing <[EMAIL PROTECTED]> wrote:
> \> docstring still blathers on about pylab functions, however; I suspect we
>> should change this to something more unique and helpful, such as a
>> directory of matplotlib submodules and/or an intro to the useful things
>> i
On 7/15/07, Eric Firing <[EMAIL PROTECTED]> wrote:
\> docstring still blathers on about pylab functions, however; I suspect we
> should change this to something more unique and helpful, such as a
> directory of matplotlib submodules and/or an intro to the useful things
> in matplotlib.__init__.py l
Tom Holroyd (NIH/NIMH) [E] wrote:
[...]
> If I say
>
import matplotlib
help(matplotlib)
>
> (This is with 0.90.0 by the way)
>
> It basically gives me the help I'd expect for pylab. Oh, and it says
> "the" instead of "to". It's a little weird thinking of a library as the
> top level
John Hunter wrote:
> On 7/13/07, Eric Firing <[EMAIL PROTECTED]> wrote:
>
>> No, it is not your installation. You have identified an area that needs
>> work, after we settle on a possibly new import and namespace strategy.
>
> This is definitely something new -- help(pylab) used to display the
>
On 7/13/07, Eric Firing <[EMAIL PROTECTED]> wrote:
> No, it is not your installation. You have identified an area that needs
> work, after we settle on a possibly new import and namespace strategy.
This is definitely something new -- help(pylab) used to display the
rather extensive pylab doc str
Tom Holroyd (NIH/NIMH) [E] wrote:
[...]
> If I say
>
import matplotlib
help(matplotlib)
>
> (This is with 0.90.0 by the way)
>
> It basically gives me the help I'd expect for pylab. Oh, and it says
> "the" instead of "to". It's a little weird thinking of a library as the
> top level
Christopher Barker wrote:
> John Hunter wrote:
[...]
> I do wish that:
>
import matplotlib as mpl
import mpl.artist
> Traceback (most recent call last):
>File "", line 1, in
> ImportError: No module named mpl.artist
>
> worked.
The way I have it working now (on my machine, not in
John Hunter wrote:
> I don't think this will work in this form. artist is a module, and it
> is not imported simply by importing matplotlib
>
> In [1]: import matplotlib as mpl
>
> In [2]: mpl.artist
however, this seems to work (though it looks perhaps a bit odd)
>>> import matplotlib as mpl
>
Eric Firing wrote:
> John Hunter wrote:
>> On 7/13/07, Ted Drain <[EMAIL PROTECTED]> wrote:
>>> I think he means that the matplotlib/__init__.py file should be
>>> changed to that those things are imported.
>> but if __init__.py imports axes, and axes import matplotlib, don't we
>> still have the p
Eric Firing wrote:
> Tom Holroyd (NIH/NIMH) [E] wrote:
>>
>> Ted Drain wrote:
>>> I think the basic idea is that if I want to use MPL, I should import
>>> it and go and I should not have to import a sub-module out of MPL as
>>> the main API.
>>
>> Yeah, about that, my typical usage is actually "f
Tom Holroyd (NIH/NIMH) [E] wrote:
>
> Ted Drain wrote:
>> I think the basic idea is that if I want to use MPL, I should import
>> it and go and I should not have to import a sub-module out of MPL as
>> the main API.
>
> Yeah, about that, my typical usage is actually "from pylab import *".
> I g
John Hunter wrote:
> On 7/13/07, Ted Drain <[EMAIL PROTECTED]> wrote:
>> I think he means that the matplotlib/__init__.py file should be
>> changed to that those things are imported.
>
> but if __init__.py imports axes, and axes import matplotlib, don't we
> still have the problem of recursive imp
Ted Drain wrote:
> I think the basic idea is that if I want to use MPL, I should import
> it and go and I should not have to import a sub-module out of MPL as
> the main API.
Yeah, about that, my typical usage is actually "from pylab import *".
I guess I am unclear about the relationship betwe
Yes - it doesn't solve or address the recursive import problem. My
impression was that Tom was making a user interface assertion that doing:
import matplotlib as mpl
would be simpler for people than doing:
from matplotlib import mpl
of course I could be complete wrong as well :)
I think the
On Fri, Jul 13, 2007 at 03:06:45PM -0500, John Hunter wrote:
> Because the mpl_ prefix occurs nowhere else, we can easily change this
> to whatever we want with a single search replace.
I haven't sync'd with the repository yet so I can check this assertion:
h123063:~/src/matplotlib$ find . -nam
On 7/13/07, Ted Drain <[EMAIL PROTECTED]> wrote:
> I think he means that the matplotlib/__init__.py file should be
> changed to that those things are imported.
but if __init__.py imports axes, and axes import matplotlib, don't we
still have the problem of recursive imports?
JDH
-
I think he means that the matplotlib/__init__.py file should be
changed to that those things are imported.
At 01:12 PM 7/13/2007, John Hunter wrote:
>On 7/13/07, Tom Holroyd (NIH/NIMH) [E] <[EMAIL PROTECTED]> wrote:
>
> > import matplotlib as mpl
> >
> > and use mpl.artist, etc.
>
>I don't think
On 7/13/07, Tom Holroyd (NIH/NIMH) [E] <[EMAIL PROTECTED]> wrote:
> import matplotlib as mpl
>
> and use mpl.artist, etc.
I don't think this will work in this form. artist is a module, and it
is not imported simply by importing matplotlib
In [1]: import matplotlib as mpl
In [2]: mpl.artist
---
John Hunter wrote:
> from matplotlib import artist as mpl_artist
> from matplotlib import agg as mpl_agg
> from matplotlib import axis as mpl_axis
> from matplotlib import cbook as mpl_cbook
> from matplotlib import collections as mpl_collections
> from matplotlib import colors as mpl_colors
> fr
I just removed the last vestiges of the numerix extension code layer.
The conditional imports are gone from the extension code, the -D flags
are gone from the compile, as is the _ns_ module naming scheme. This
is a fairly major change, so please blow away your install and build
dirs after updating
23 matches
Mail list logo