D750: rebase: move bookmarks with --keep (issue5682)

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz added inline comments. INLINE COMMENTS > quark wrote in rebase.py:1539 > In the future we might want to get the `'rebase'` name from current > transaction (and enforce an active transaction in `cleanupnodes`). In that > case the `name` parameter becomes less necessary and `moves` cou

D750: rebase: move bookmarks with --keep (issue5682)

2017-09-21 Thread quark (Jun Wu)
quark accepted this revision. quark added inline comments. INLINE COMMENTS > rebase.py:1539 > +replacements[oldnode] = succs > +scmutil.cleanupnodes(repo, replacements, 'rebase', moves) > In the future we might want to get the `'rebase'` name from current transaction (and

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread quark (Jun Wu)
quark accepted this revision. quark added inline comments. INLINE COMMENTS > scmutil.py:604 > +# move bookmark backwards > +roots = list(unfi.set('max((::%n) - %ln)', oldnode, > + list(mapping))) I thought this could be `O(changelog)`, but

D674: filemerge: use arbitraryfilectx for backup files

2017-09-21 Thread phillco (Phil Cohen)
phillco updated this revision to Diff 1989. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D674?vs=1874&id=1989 REVISION DETAIL https://phab.mercurial-scm.org/D674 AFFECTED FILES mercurial/context.py mercurial/filemerge.py CHANGE DETAILS diff --git

D727: rebase: move bookmarks with --keep (issue5682)

2017-09-21 Thread quark (Jun Wu)
quark added a subscriber: simonfar. quark added a comment. In https://phab.mercurial-scm.org/D727#12457, @martinvonz wrote: > I'm tired, so I don't think I reviewed this properly, but seemed to make sense. Take your time! Nowadays none of my upstream patches are urgent (for fb) -

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz added a comment. In https://phab.mercurial-scm.org/D748#12953, @quark wrote: > In https://phab.mercurial-scm.org/D748#12948, @martinvonz wrote: > > > Yes, that was necessary because oldnode could be obsolete and that was previously protected by "if not oldbmarks", which I d

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread quark (Jun Wu)
quark added a comment. I think either you or me can update the code. If you're busy with other things, I can update (and split) the original fix directly. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D748 To: martinvonz, #hg-reviewers, quark Cc: quark, mercuri

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread quark (Jun Wu)
quark requested changes to this revision. quark added a comment. This revision now requires changes to proceed. In https://phab.mercurial-scm.org/D748#12948, @martinvonz wrote: > Yes, that was necessary because oldnode could be obsolete and that was previously protected by "if not oldbmar

D750: rebase: move bookmarks with --keep (issue5682)

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz updated this revision to Diff 1987. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D750?vs=1940&id=1987 REVISION DETAIL https://phab.mercurial-scm.org/D750 AFFECTED FILES hgext/rebase.py mercurial/scmutil.py tests/test-rebase-bookmarks.t

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz updated this revision to Diff 1985. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D748?vs=1936&id=1985 REVISION DETAIL https://phab.mercurial-scm.org/D748 AFFECTED FILES mercurial/scmutil.py CHANGE DETAILS diff --git a/mercurial/scmutil.p

D749: cleanupnodes: rename "mapping" to "replacements"

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz updated this revision to Diff 1986. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D749?vs=1937&id=1986 REVISION DETAIL https://phab.mercurial-scm.org/D749 AFFECTED FILES mercurial/scmutil.py CHANGE DETAILS diff --git a/mercurial/scmutil.p

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz marked an inline comment as done. martinvonz added a comment. In https://phab.mercurial-scm.org/D748#12944, @quark wrote: > I noticed the change from `repo` to `unfi`. That actually looks better. Since we are not querying "descendants", it won't cause correctness issues.

D748: cleanupnodes: separate out bookmark destination calculation from actual update

2017-09-21 Thread quark (Jun Wu)
quark accepted this revision. quark added a comment. I noticed the change from `repo` to `unfi`. That actually looks better. Since we are not querying "descendants", it won't cause correctness issues. INLINE COMMENTS > scmutil.py:646 > # Unfiltered repo is needed since nodes in

D768: blackbox: do not prevent 'chg init' from working

2017-09-21 Thread quark (Jun Wu)
quark updated this revision to Diff 1975. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D768?vs=1974&id=1975 REVISION DETAIL https://phab.mercurial-scm.org/D768 AFFECTED FILES hgext/blackbox.py tests/test-blackbox.t CHANGE DETAILS diff --git a/tes

D768: blackbox: do not prevent 'chg init' from working

2017-09-21 Thread quark (Jun Wu)
quark updated this revision to Diff 1974. quark marked an inline comment as done. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D768?vs=1970&id=1974 REVISION DETAIL https://phab.mercurial-scm.org/D768 AFFECTED FILES hgext/blackbox.py tests/test-blac

D768: blackbox: do not prevent 'chg init' from working

2017-09-21 Thread quark (Jun Wu)
quark added inline comments. INLINE COMMENTS > akushner wrote in test-blackbox.t:292 > Is 'repo2' needed here? Nope. Good catch. I was using `hg clone` in test and then simplified it to `init`. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D768 To: quark, #hg-re

D768: blackbox: do not prevent 'chg init' from working

2017-09-21 Thread akushner (Aaron Kushner)
akushner added inline comments. INLINE COMMENTS > test-blackbox.t:292 > + $ hg init repo1 > + $ hg init repo2 > + $ hg --config extensions.a=! -R repo1 log Is 'repo2' needed here? REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D768 To: quark, #hg-reviewers Cc:

D761: test: backout update evolution config

2017-09-21 Thread durin42 (Augie Fackler)
durin42 added a comment. I concur with @quark: if we're going to bother renaming this again, we should just use the `[experimental]` namespace. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D761 To: lothiraldan, #hg-reviewers, pulkit, quark Cc: durin42, quark,

Re: robots.txt for www.mercurial-scm.org

2017-09-21 Thread Gregory Szorc
> On Sep 21, 2017, at 07:40, Augie Fackler wrote: > > >> On Sep 19, 2017, at 12:28, Michael Bolin wrote: >> >> It appears that https://www.mercurial-scm.org/robots.txt disallows indexing >> of /repo. This makes it impossible to Google for Mercurial commits. >> >> Is this an oversight or is

D762: config: backout rename evolution config into stabilization

2017-09-21 Thread quark (Jun Wu)
quark requested changes to this revision. quark added a comment. This revision now requires changes to proceed. -1 as explained in https://phab.mercurial-scm.org/D761. I'll be happy to see a split of the config into: experimental.obsstore experimental.obsexchange experimental.al

D761: test: backout update evolution config

2017-09-21 Thread quark (Jun Wu)
quark requested changes to this revision. quark added a comment. This revision now requires changes to proceed. Although "stabilization" may be controversial, but I don't think "evolution" is a strictly better than that. I think it makes more sense to split the giant config into different

[PATCH] mail: encode long unicode lines in emails properly (issue5687)

2017-09-21 Thread Ippolitov Igor
# HG changeset patch # User Igor Ippolitov # Date 1505982498 0 # Thu Sep 21 08:28:18 2017 + # Node ID 474d0bfc9809032668864cea16026f9b53d24a6d # Parent 05131c963767faaac6a66b2c658659bfbb4db29b mail: encode long unicode lines in emails properly (issue5687) 3e544c074459 introduced a bug:

D768: blackbox: do not prevent 'chg init' from working

2017-09-21 Thread quark (Jun Wu)
quark created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Previously, blackbox always appends to blackbox.log and creates the directory for that file on demand. That could be an issue if: 1. chg starts from `$REPO` dir

D769: blackbox: move _openlogfile to a separate method

2017-09-21 Thread quark (Jun Wu)
quark created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY This removes several `stat` syscalls for accessing `_bbvfs` and makes `ui` object cleaner. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.

Re: [PATCH] patchbomb: add test that shows --to and --cc override matching config item

2017-09-21 Thread Augie Fackler
Ignore this in favor of v2, this one has some missing globs. Sorry. > On Sep 21, 2017, at 10:34, Augie Fackler wrote: > > # HG changeset patch > # User Augie Fackler > # Date 1497453237 14400 > # Wed Jun 14 11:13:57 2017 -0400 > # Node ID bc0dde47a06db5349262b39a7ef20d66fda49fb7 > # Parent

[PATCH v2] patchbomb: add test that shows --to and --cc override matching config item

2017-09-21 Thread Augie Fackler
# HG changeset patch # User Augie Fackler # Date 1497453237 14400 # Wed Jun 14 11:13:57 2017 -0400 # Node ID 5b2c3bd1d58a9d7c7ea6a4739422b516e0baf6ce # Parent 3c96917282376912851e24cd1cf79c93427640f2 patchbomb: add test that shows --to and --cc override matching config item As far as I know

D477: revlog: add option to mmap revlog index

2017-09-21 Thread mbthomas (Mark Thomas)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG3c9691728237: revlog: add option to mmap revlog index (authored by mbthomas, committed by ). CHANGED PRIOR TO COMMIT https://phab.mercurial-scm.org/D477?vs=1786&id=1969#toc REPOSITORY rHG Mercurial

D476: util: add an mmapread method

2017-09-21 Thread mbthomas (Mark Thomas)
This revision was automatically updated to reflect the committed changes. Closed by commit rHG3bb2a9f25fe9: util: add an mmapread method (authored by mbthomas, committed by ). REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D476?vs=1963&id=1968 REVISION DET

D762: config: backout rename evolution config into stabilization

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz added a comment. In https://phab.mercurial-scm.org/D762#12865, @lothiraldan wrote: > In https://phab.mercurial-scm.org/D762#12843, @martinvonz wrote: > > > > The renaming of the evolution related config was a mistake, revert > > > https://phab.mercurial-scm.org/rHGd434a7

D762: config: backout rename evolution config into stabilization

2017-09-21 Thread lothiraldan (Boris Feld)
lothiraldan added a comment. In https://phab.mercurial-scm.org/D762#12843, @martinvonz wrote: > > The renaming of the evolution related config was a mistake, revert > > https://phab.mercurial-scm.org/rHGd434a7f0685c372643a9ae2dda59e65495de95b2 to restore original evolution related con

D763: copytrace: add a a new config to limit the number of drafts in heuristics

2017-09-21 Thread pulkit (Pulkit Goyal)
pulkit updated this revision to Diff 1967. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D763?vs=1961&id=1967 REVISION DETAIL https://phab.mercurial-scm.org/D763 AFFECTED FILES mercurial/copies.py CHANGE DETAILS diff --git a/mercurial/copies.py b/me

D762: config: backout rename evolution config into stabilization

2017-09-21 Thread martinvonz (Martin von Zweigbergk)
martinvonz added a comment. > The renaming of the evolution related config was a mistake, revert > https://phab.mercurial-scm.org/rHGd434a7f0685c372643a9ae2dda59e65495de95b2 to restore original evolution related config keys. Why do you consider it a mistake? REPOSITORY rHG Mercurial

D477: revlog: add option to mmap revlog index

2017-09-21 Thread durin42 (Augie Fackler)
durin42 accepted this revision. durin42 added a comment. I'm landing this, but we should plan to figure out the right tradeoff values and get it on by default or discard the extra complexity at some point. That doesn't have to be before 4.4, but it'd be nice to have that sorted out by 4.5. R

mercurial@34276: 3 new changesets

2017-09-21 Thread Mercurial Commits
3 new changesets in mercurial: https://www.mercurial-scm.org/repo/hg/rev/a37e18b5f055 changeset: 34274:a37e18b5f055 user:Jun Wu date:Mon Sep 18 15:56:08 2017 -0700 summary: blackbox: simplify ui states https://www.mercurial-scm.org/repo/hg/rev/86a5df995880 changeset: 3427

Re: robots.txt for www.mercurial-scm.org

2017-09-21 Thread Augie Fackler
> On Sep 19, 2017, at 12:28, Michael Bolin wrote: > > It appears that https://www.mercurial-scm.org/robots.txt disallows indexing > of /repo. This makes it impossible to Google for Mercurial commits. > > Is this an oversight or is it intentional? (+ some folks) I'm not sure offhand. The robo

[PATCH] patchbomb: add test that shows --to and --cc override matching config item

2017-09-21 Thread Augie Fackler
# HG changeset patch # User Augie Fackler # Date 1497453237 14400 # Wed Jun 14 11:13:57 2017 -0400 # Node ID bc0dde47a06db5349262b39a7ef20d66fda49fb7 # Parent 7cdc8c5a481a4321f2646317dee5454b257c3163 patchbomb: add test that shows --to and --cc override matching config item As far as I know

[PATCH 1 of 2] tests: clean up blackbox test around aliases a little bit

2017-09-21 Thread Augie Fackler
# HG changeset patch # User Augie Fackler # Date 1505174812 14400 # Mon Sep 11 20:06:52 2017 -0400 # Node ID 0878fba873527c814b1ad15d43e89adf62c11d37 # Parent 4f969b9e0cf5d4f2cfb7392cef7f43b74d17c5e4 tests: clean up blackbox test around aliases a little bit diff --git a/tests/test-blackbox.

[PATCH 2 of 2] tests: add a test for blackbox with nested alias configurations

2017-09-21 Thread Augie Fackler
# HG changeset patch # User Augie Fackler # Date 1505174861 14400 # Mon Sep 11 20:07:41 2017 -0400 # Node ID 4aa78b29fd1e14540b0be134297fb84fcf305ec0 # Parent 0878fba873527c814b1ad15d43e89adf62c11d37 tests: add a test for blackbox with nested alias configurations I've observed some weirdnes

Re: [PATCH] convert: parse quoted keys and values in mapfiles

2017-09-21 Thread Yuya Nishihara
On Wed, 20 Sep 2017 22:57:10 +0900, Yuya Nishihara wrote: > And more conservative "wordchars" will minimize the behavior change. > See filemap.filemapper for example. Never mind. wordchars appears not important if whitespace_split is set. ___ Mercurial-d

D476: util: add an mmapread method

2017-09-21 Thread mbthomas (Mark Thomas)
mbthomas added a comment. As it stands, `mmap.mmap` only raises `ValueError` if the arguments are incorrect or if the file is zero-length. But since that's not guaranteed, I've added a check that the reason for the exception is that the file is zero length before returning the empty string.

D476: util: add an mmapread method

2017-09-21 Thread mbthomas (Mark Thomas)
mbthomas updated this revision to Diff 1963. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D476?vs=1785&id=1963 REVISION DETAIL https://phab.mercurial-scm.org/D476 AFFECTED FILES mercurial/util.py CHANGE DETAILS diff --git a/mercurial/util.py b/merc

D763: copytrace: add a a new config to limit the number of drafts in heuristics

2017-09-21 Thread pulkit (Pulkit Goyal)
pulkit created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY The heuristics options tries to the default full copytracing algorithm if both the source and destination branches contains of non-public changesets only. But th

D761: test: backout update evolution config

2017-09-21 Thread pulkit (Pulkit Goyal)
pulkit accepted this revision. pulkit added a comment. The evolution config name makes sense. stabilization was ambiguous. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D761 To: lothiraldan, #hg-reviewers, pulkit Cc: pulkit, mercurial-devel _

D760: cmdutil: move the logic from copy() to a new function copies.copy()

2017-09-21 Thread pulkit (Pulkit Goyal)
pulkit updated this revision to Diff 1959. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D760?vs=1956&id=1959 REVISION DETAIL https://phab.mercurial-scm.org/D760 AFFECTED FILES mercurial/cmdutil.py mercurial/copies.py CHANGE DETAILS diff --git a/m

D761: test: backout update evolution config

2017-09-21 Thread lothiraldan (Boris Feld)
lothiraldan created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY The concept is still call "Changeset Evolution". The "troubles" got renamed to "instability", so the action can be renamed from "evolve troubles" to "stabili

D762: config: backout rename evolution config into stabilization

2017-09-21 Thread lothiraldan (Boris Feld)
lothiraldan created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY The renaming of the evolution related config was a mistake, revert https://phab.mercurial-scm.org/rHGd434a7f0685c372643a9ae2dda59e65495de95b2 to restore origi

D760: cmdutil: move the logic from copy() to a new function copies.copy()

2017-09-21 Thread pulkit (Pulkit Goyal)
pulkit created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY cmdutil.py is still 3647 lines after this change. This patch moves the logic to copy a file from cmdutil.py to copies.py. Now, cmdutil.py just calls copies.py to

[Bug 5687] New: Long unicode lines are encoded incorrectly into email

2017-09-21 Thread mercurial-bugs
https://bz.mercurial-scm.org/show_bug.cgi?id=5687 Bug ID: 5687 Summary: Long unicode lines are encoded incorrectly into email Product: Mercurial Version: stable branch Hardware: PC OS: All Status: UNCONFIRMED